TB auf XP und Ubuntu - Fehler bei Ubuntu

  • Hallo,
    ich nutze Thunderbird plattformübergreifend auf meinem Laptop mit einem gemeinsamen Profil für WinXP SP3 und Ubuntu 2.6.32-24. Unter Windows verwende ich die aktuelle Thunderbirdversion 3.1.2, unter Ubuntu wird die Version ja immer über die Paketverwaltung automatisch aktualisiert.
    Nun zu meinem Problem: Unter Windows läuft Thunderbird problemlos, unter Ubuntu habe ich jedoch einige Fehler in der grafischen Darstellung --> Screenshot 1


    [IMG:http://img267.imageshack.us/img267/1188/forum1l.png]
    Die Fenster werden nicht richtig angezeigt, die Buttons z.B. bei Speichern, Nicht-Speichern oder Abbrechen fehlen völlig.
    Auch wird teilweise bei der oberen Navigation z.B. unter Extras oder Hilfe kein Text im Menü angezeigt. --> Screenshot 2
     
    [IMG:http://img294.imageshack.us/img294/4733/forum3av.jpg]
    Die Listenansicht der einzelnen Emails wird ebenfalls nicht angezeigt.
    Folgende Versuche zur Fehlerbehebung verliefen erfolglos:
    Vollständige Deinstallation von Thunderbird unter Ubuntu + Anlegen eines neuen leeren Profils
    Start im abgesicherten Modus
    Ich habe für Thunderbird keine Add-ons oder Themes installiert.
    Unter Windows läuft hingegen alles fehlerfrei. Bin mir nicht sicher, ob dies ein Ubuntu- oder ein Thunderbirdproblem ist aber ich danke schonmal für eure Hilfe.
    Timi

  • Habe zwar kein Ubuntu im Einsatz (Debian Sid) aber ich tippe mal auf die Version aus den Repositories.
    Themes braucht man keine, es werden die Standardthemes des Systems verwendet, das sieht man z.B. am Adressbuch.
    Um ganz sicher zu sein, würde ich folgendes machen:


    1. Von der Mozillaseite das aktuelle TB herunterladen und in einem temporären Ordner entpacken.
    http://de.www.mozillamessaging.com/de/thunderbird/
    2. Den vorhandenen Ordner .thunderbird in Deinem Homeverzeichnis umbenennen.
    3. Im Temp-Ordner das Script thunderbird starten.


    Nun kann man sehen, ob die Anzeige im Original-TB ok ist und der Fehler eher bei Ubuntu liegt.

  • 1000 Dank an Clio für die Antwort. Jippy!
    Ich habe nun TB wie beschrieben installiert, den Originalordner umbenannt und TB aus dem temporären Ordner heraus gestartet. Alles funktioniert wieder.Auch nach der Änderung der profiles.ini auf den ursprünglichen Pfad kann ich TB wie gewohnt verwenden. Somit scheint es auch kein Problem mit der Profildatei zu sein.


    Nun bleibt aber die Frage, wie ich die alte Version deinstalliere und die neue nun Funktionierende ins System einbinde. Die Deinstallation und erneute Installation über die Synaptic-Paketverwaltung hatte ja bereits nicht funktioniert.


    Hoffe hierbei kann mir noch jemand einen Tip geben.

  • Du kannst so vorgehen:
    Das Ubuntu-Paket über den Paketmanager deinstallieren.
    Jetzt gibt es zwei Möglichkeiten:
    1. Du legst in Deinem Homeverzeichnis einen Ordner Programme an. Dorthin verschiebst Du den entpackten Ordner thunderbird mit allem Inhalt. Dann einen Starter anlegen und den Pfad zum Startscript angeben. Ich nutze kein Gnome sondern Xfce, daher kann ich den genauen Weg nicht beschreiben. Aber das findest Du schon.


    2. Du wirst root und verschiebst den Ordner thunderbird nach /opt. Alle "Fremdsoftware" wird normalerweise dorthin installiert. Der weitere Weg wie zuvor beschrieben.


    Wenn Du alleine den PC nutzt, reicht das Homeverzeichnis, für mehrere User wählt man das globale /opt.
    Automatische Updates funktionieren auch aus dem Homeverzeichnis.
    Daran solltest Du auch denken:
    Thunderbird als Standardmailprogramm festlegen. Die Funktion findest Du unter Einstellungen - Reiter Allgemein
    Firefox mitteilen, dass Thunderbird das Mailprogramm ist. Unter Einstellungen - Anwendungen, dort den Pfad angeben.

  • Ich habe nun TB über den Paketmanager installiert.
    Dann habe ich aber Möglichkeit 3. verwendet.
    Laut der Beschreibung Ubuntuzilla installiert:
    http://sourceforge.net/apps/me…le=Main_Page#Installation
    Dann die deutschen Sprachdateien laut diesem Link runter geladen und installiert:
    http://sourceforge.net/apps/me…e=Main_Page#Localizations
    Nun habe ich aber das gleiche Problem wie hier.
    TB bleibt auf Englisch.
    http://www.thunderbird-mail.de…iewtopic.php?f=32&t=49402
    de.xpi kann wie gewohnt über Tools --> Add-ons --> Extensions --> Install installiert werden. Nach dem Neustart wird jedoch immer nur angezeigt, dass das deutsche Sprachpaket beim nächsten Neustart installiert wird. usw....
    Das zuvor installierte Sprachpaket ist auch unter Add-ons nicht gelistet und TB bleibt auf Englisch.
    general.useragent.locale ist auf de eingestellt.
    Und nun?

  • Wenn das Sprachpaket im Add-on Manager nicht auftaucht, ist es auch nicht installiert bzw. nicht vollständig.
    Vielleicht eine fehlerhafte Version oder nicht passend zur TB-Version. Schau in die install.rdf, vielleicht sieht man da was.
    Ich weiß nicht, was diese Ubuntu-Maintainer da fabrizieren....
    Entweder forscht Du im Ubuntuforum weiter, oder Du entscheidest Dich für einen der von mir vorgeschlagenen Wege.