Thunderbird 2 --> 3.16 ... openpgp geht nicht richtig

  • Hallo,
    wir haben genau einen Bekannten, der darauf besteht, alle seine Emails zu verschlüsseln.
    Irgendwann habe ich also openpgp für Thunderbird 2 installiert; hat auch alles prima funktioniert.


    Heute morgen hat meine Frau beschlossen, ein upgrade auf 3.16 zu machen.
    Sie hat das enigmail 1.1.2 addon installiert ... und eigentlich sieht alles gut aus; aber:
    wenn wir auf eine alte verschlüsselte Mail klicken ... passiert genau gar nichts.


    Kein Inhalt, lediglich eine .msc Attachment wird angezeigt.
    Einfacher Klick auf das attachment - nichts passiert.
    Doppel-Klick oder "Rechtsclick->Entschlüsseln und Öffnen":
    ich werde nach unserer Passphrase gefragt; dann öffnet sich
    ZWEIMAL ein "Anwendung starten" Dialog: "Dieser Link muss mit einer
    Anwendung geöffnet werden". Als Typ steht da nur "file".


    Zuerst habe ich als Anwendung Thunderbird ausgewählt - dann passiert gar nix.
    Dann habe ich Firefox ausgewählt ... und siehe da, er macht einen Link
    ala "file:///C:/DOKUME~1/unserusername/LOKALE~1/Temp/msg-3" auf ...
    und da ist die entschlüsselte Email - leider mit kaputtem Encoding.


    Das ganze unter Windows XP mit gnupgp 1.4.8; ich habe mir die
    Einstellungen angesehen; die sehen soweit "gut" aus.


    Any idea, anyone?

  • Hallo nsw42,


    und willkommen im Forum!


    Zitat von "nsw42"

    wir haben genau einen Bekannten, der darauf besteht, alle seine Emails zu verschlüsseln.


    Das finde ich sehr gut, und ist heutzutage wohl auch notwendig.


    Allerdings nutze ich dazu schon seit vielen Jahren kein GnuPG mehr, kenne ich also damit nicht mehr so gut aus.
    Aber im Forum tauchen zu diesem Thema immer wieder Anfragen auf (=> Forensuche), bei denen es in der Lösung immer wieder darum ging, dass Inkompatibilitäten zwischen dem aktuellen TB, dem dazu kompatiblen Enigmail und auch dem GnuPG ging. Ich kann mich irgendwie an ein inkompatibles GnuPG erinnern, bin mir aber nicht ganz sicher.
    Vielleicht hilft dir der Hinweis mit der Forensuche.
    (Oder du wartest ein wenig, die "GnuPG-Sparte" gibt dir bestimmt noch die richtige Antwort.)


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo,


    ich fange mal mit dem Schluß an:

    Zitat

    ich habe mir die Einstellungen angesehen, die sehen soweit "gut" aus.


    Schön... Nenne doch bitte alle Einstellungen, vor allem unter "Allgemein" und "Erweitert".
    Es sollte zwar nicht passieren, aber vielleicht hat sich ja doch die eine oder andere Einstellung beim Update "verstellt".
    Fehlermeldungen im Log oder der Konsole?
    Die von Peter erwähnten Inkompatibilitäten traten meistens im Zusammenhang mit gpg4win auf. Verwendest du das? Oder woher stammt dein GnuPG?
    Empfehlenswert ist entweder die Minimalversion von http://www.gnupg.org oder das Paket von http://www.gnupt.de. Aktuell ist die 1.4.11 - die 2.0er Versionen kann ich nicht unbedingt empfehlen.


    Werden Anhänge eingebunden angezeigt?


    Gruß, muzel

  • Hallo,


    nun das Problem hat sich scheinbar erledigt.


    BTW: Ich kann muzels Beobachtung / Verdacht bestätigen.
    Auch bei mir hatten sich Veränderungen in den Einstellungen eingestellt. (quasi von Zauberhand :aerger: ).
    So war {plötzlich} bei allen meinen Konten angehackt daß mit GPG signiert werden soll.


    MfG ... Vic

  • Zitat von "muzel"


    Schön... Nenne doch bitte alle Einstellungen, vor allem unter "Allgemein" und "Erweitert".


    Hallo,


    mit etwas Verspätung, gGerade eben habe ich gnupgp 1.4.11 installiert und in openpgp settings aktiviert; leider keine Verbesserung. Also, zu den Einstellungen.


    Ich orientiere mich mal am Wiki und schaue nach allem, was NICHT so aussieht, wie im Wiki ...


    "Alllgemein": 30 min anstatt 10; daran sollte es doch wohl nicht liegen :rolleyes:
    "Senden": senden immer bestätigen ist nicht an
    "Schlüsselauswahl": passt
    "Erweitert": ich habe die ersten beiden Checkboxes an, außerdem keine zusätzlichen
    Parameter für GnuPgp
    Schlüsselserver: steht bei uns
    "pgp.mit.edu, ldap://certserver.pgp.com, random.sks.keyserver.penguin.de, subkeys.pgp.net"


    So, ich habe die beiden zusätzlichen Checkboxes unter "Erweitert" ausgeschaltet, und den
    fehlenden Hacken für "Anhänge nur herunterladen, ..." gesetzt.


    Leider keine Veränderung. Das Verhalten ist immer noch so wie vorher. Einmal logfile ocntent:



    So, ich hoffe dass
    a) ich alle personen-relevanten Infos aus dem log gelöscht
    b) genügend Infos geliefert habe


    Skeptisch macht natürlich diese "Schlüssel wurde widerrufen" Sache. Ist das mein Problem?


    Sonstige Beobachtungen:
    - wenn ich auf den "Entschlüsseln" Button klicke .. passiert genau gar nichts
    - ich habe in der Schlüsselverwaltung nachgesehen - ich "vertraue" dem Schlüssel unseres
    Bekannten
    - meinen eigenen Schlüsseln vertraue ich jetzt auch ... hat aber auch nichts geholfen

  • Hallo,


    Zitat von "nsw42"

    ... Skeptisch macht natürlich diese "Schlüssel wurde widerrufen" Sache. Ist das mein Problem?


    Wurde er denn widerrufen? - Was sagt Dein Bekannter?
    (Da es sich ja um alte mails handelt wäre es ja nicht außergewöhnlich.)
    Wichtige Frage: Klappt denn die Entschlüsselung (ohne TB) nur mittels GPG :?:


    Zitat von "nsw42"

    - wenn ich auf den "Entschlüsseln" Button klicke .. passiert genau gar nichts
    - ich habe in der Schlüsselverwaltung nachgesehen - ich "vertraue" dem Schlüssel unseres Bekannten


    Grübel ... 'eigentlich' solltest Du zumindest eine Meldung erhalten. {Ich teste das mal später.}
    ...
    getestet --> es kommt eine Meldung etwa in dieser Art:


    [IMG:http://s7.directupload.net/images/101129/temp/mttkgnjs.png]


    oder:


    [IMG:http://s3.directupload.net/images/101129/lm3vvyrh.png]


    Ein Entschlüsseln sollte also - bei einer Warnmeldung - möglich sein!
    Ich vermute, daß die mail erst gar nicht bis zum GPG-Programm 'gereicht' wird, sondern schon vorher "Schiffbruch" erleidet. {siehe Frage oben}


    Zitat von "nsw42"

    - meinen eigenen Schlüsseln vertraue ich jetzt auch ... hat aber auch nichts geholfen


    Na da hat das dann doch wenigstens *diesen* Vertrauensakt bewirkt. ;)


    MfG ... Vic

  • Hallo,
    welcher Schlüssel ist widerrufen (-> OpenPGP-Schlüsselverwaltung)?
    Normalerweise sollte es trotzdem möglich sein, die Nachricht zu entschlüsseln, aber zunächst mal sollte sichergestellt werden, daß auf beiden Seiten (Sender/Empfänger) gültige Schlüssel vorhanden sind.
    Einfachster Test ist, sich selbst eine verschlüsselte und signierte Mail zu schicken.

    Zitat

    Ich orientiere mich mal am Wiki ...


    Ich nicht - ich möchte deine Einstellungen wissen, sonst nichts.
    Gruß, muzel

  • Hallo,


    ich hatte das gleiche Problem, dass immer ZWEIMAL ein "Anwendung starten" Dialog mit "Dieser Link muss mit einer
    Anwendung geöffnet werden" kam. Wenn man hier als Anwendung den Windows Explorer (Explorer.exe, unter Win7 unter C:\Windows\Explorer.exe) auswählt, dann funktioniert's. Checkbox "Auswahl für file-Links speichern" setzen nicht vergessen.


    Edit: Es scheint aber trotzdem so, dass der Vorgang trotzdem zweimal aufgerufen wird.


    Gruß, Edu