Thunderbird startet nach Profilumzug nicht mehr

  • Hallo,


    seitdem ich von einem DD-WRT Samba Share mit meinem Thunderbird Profile auf eine NAS von LogiLink umgezogen bin, startet Thunderbird nicht mehr. Hierzu ist zu sagen, dass dieses Verhalten nur auf meinem Ubuntu 10.04 System festzustellen ist. Auf das Thunderbird Profil greife ich auch noch mit einem Windows 7 und einem Windows XP Client zu (nicht gleichzeitig). Die beiden Windows Systeme haben auch Lese und Schreib Berechtigung auf das Share. Somit ergibt sich kein Unterschied zu dem Ubuntu System. Die Windows Rechner können Thunderbird ohne Probleme starten. Wenn ich Thunderbird nun auf dem besagten Ubuntu 10.04 System starten möchte wird folgendene Meldung angezeigt:


    Thunderbird wird bereits ausgeführt, reagiert aber nicht. Um ein neues Fenster öffnen zu können, müssen Sie zuerst den bestehenden Thunderbird-Prozess beenden oder Ihren Computer neu starten.


    Da die Windows Systeme OK sind, schränke ich die Beschreibung auf die Ubuntu Samba Konfiguration ein.


    Hier die Einzelheiten betreffend meiner Einrichtung:


    Habe das Samba Share in der Fstab permanent gemountet und habe auch lese und schreibrechte auf das Thunderbird Verzeichnis. Das Mounten über die FSTAB funktioniert ohne Probleme. Nach dem Booten von Ubuntu habe ich Zugriff auf das gemountete Sharedrive und habe lese und schreibmöglichkeit. Da die das Share in meinem Homeverzeichnis auf den Ordner "thunderbird" eingehängt habe sollte es auch hier kein Rechteproblem geben.


    Hier mein Eintrag in der FSTAB
    //192.168.1.252/public/thunderbird /home/xebr/thunderbird smbfs users,rw,credentials=/home/xebr/.smbcredentials 0 0


    Kopiere ich das Profil aus dem Sambashare local in mein Homeverzeichnis und richte mit dem Thunderbird -ProfileManager ein neues Profil ein mit dem lokalen Thunderbird Verzeichnis funktioniert alles.


    Das deutet eingentlich darauf hin, dass entweder das Share nicht erreichbar ist oder dass die Berechtigung auf das Share nicht in Ordnung ist. Beides ist aber 100% tig auszuschließen, da das Share sofort nach dem Booten gemountet ist und das Verzeichnis gelesen und beschrieben werden kann.


    Wie gesagt zuvor hatte ich genau die gleiche Konstellation über ein Share, dass an einem DD-WRT Samba Server betrieben wurde. Dort hat alles voll funktioniert.


    Habe in dieser neuen Konfiguration auch ein Firefox Profil am laufen. Firefox verhält sich 1 zu 1 genauso.


    Hat vielleicht irgendjemand eine Idee?


    Danke für eure Hilfe.


    Gruß Bernd

  • "lxmobile" schrieb:


    Thunderbird wird bereits ausgeführt, reagiert aber nicht. Um ein neues Fenster öffnen zu können, müssen Sie zuerst den bestehenden Thunderbird-Prozess beenden oder Ihren Computer neu starten.


    Hallo Bernd :)


    ein Klassiker - Profile in use.


    Zitat


    Habe in dieser neuen Konfiguration auch ein Firefox Profil am laufen. Firefox verhält sich 1 zu 1 genauso.


    Erwähnte ich es schon - Profile in use?


    Zitat


    Hat vielleicht irgendjemand eine Idee?


    Danke für eure Hilfe.


    Bitte und HTH
    Gruß Ingo

  • Hi Ingo,


    Sorry, vergaß ich zu erwähnen. "Profil in Use" wurde schon abgarbeitet. In der Tat legt er nach jedem Startversuch die versteckte Datei ".parentlock" an. Diese lösche ich jedesmal. Nach anschließendem Startversuch, das gleiche Spiel. Es wird lediglich die genannte Datei angelegt, dann kommt die beschriebene Fehlermeldung.


    Vielleicht habe ich etwas grobes übersehen, aber das Profil ist nicht durch die .parentlock gesprerrt.


    Gruß Bernd

  • Habe mittlerweile festgestellt, was mein Problem ist. Leider habe ich aber bisher keine Lösung dafür gefunden.


    Mein Problem ist die >>lock<< Datei im Profil Ordner von Thunderbird. Diese war so wie es aussieht im Profilordner vorhanden, als ich diesen auf das Samba Share auf mein NAS kopiert habe. Darum konnte ich zu keiner Zeit Thunderbird starten. Leider kann ich die Datei nicht löschen, da ich dann die Fehlermeldung bekomme, dass die Datei nicht gefunden wurde bzw. nicht vorhanden ist.


    Wenn ich Thunderbird lokal auf die Festplatte kopiere, wird die im >>lock<< Datei nicht mitkopiert, da sie ja nicht vorhanden ist. Somit habe ich einen sauberen Profilordner. Wenn ich nun über den ProfileManager ein neues Profil anlege, dass auch die Kopie des Profilordners auf meiner HD verweist und Thunderbird starte, ist alles OK. Die >>lock<< Datei wird wieder angelegt während der Sitzung. Wenn ich diese beende wird die >>lock<< Datei wieder gelöscht. Somit ist es mir möglich Thunderbird erneut zu starten.


    Wenn ich nun den Profilordner ohne die besagte >>lock<< Datei auf das NAS zurückkopierte kann ich Thunderbird auch starten. Er legt die >>lock<< Datei an. Das Problem ist aber nun, dass diese auf meinen NAS Share nicht mehr gelöscht wird nach dem Beenden. Somit ist es nicht mehr möglich Thunderbird erneut zu starten. Nun bin ich wieder am Ausgangsproblem.


    Hat hierfür jemand eine Lösung. Warum löscht er die Datei auf der HD und nicht auf dem Share??


    Danke für eure Mühe.


    Mfg. Bernd

  • "lxmobile" schrieb:

    Warum löscht er die Datei auf der HD und nicht auf dem Share??


    Hallo Bernd :)


    ich kenne mich mit *nixen nicht sehr gut aus. Aber ich tippe auf die Zugriffsrechte. Hast Du die mal überprüft?


    Zitat


    Danke für eure Mühe.


    Bitte und HTH
    Gruß Ingo

  • Hi Ingo,


    die Zugriffsrechte sind OK. Nach probieren vieler möglicher Konstellationen bin ich zum Schluß gekommen, dass es sich bei dem Problem um ein Problem des NAS Laufwerkes handelt. Möglicherweise um ein Problem der verwendeten Samba Version auf dem NAS. Habe jetzt die Shares wieder umgezogen zum bewährten DD-WRT Samba Share und habe ein Scribt geschrieben, dass mich nach dem Schließen von Thunderbird auffordert eine Sicherung des Profiles vom DD-WRT Share auf das NAS (Raid1) durchführt. Nachdem das Backup durchgeführt wurde wird der Rechner automatisch runtergefahren.


    Weitere Schritte unternehme ich, wenn eine neue Firmware für das NAS Laufwerk rauskommt.


    Danke für deine Hilfe.


    Gruß Bernd