TB 5: Seltsame Filter-Probleme, zeitabhängig!

  • Hallo Leute,


    ich bin ja echt nicht blöd, aber langsam bin ich am verzweifeln...
    Ich nutze TB 5.0, ausschließlich POP Konten und WIN XP (und Antivir Premium, s.u.).
    Außerdem nutze ich noch einige Addons, die jedoch erst nach Auftreten der Probleme installiert wurden, also nicht die Ursache sind.


    Ich habe zwei Probleme:
    1. die Filtereinstellung mit oder ohne Spam funktioniert nicht
    2. nach einiger Zeit kann ich weder Filter nutzen noch Mails manuell verschieben.


    So siehts bei mir aus:
    Mit dem Update auf TB 5 habe ich den Weg meiner Mails (bisher alle Konten einzeln abgerufen und gefiltert) verändert.
    Jetzt laufen sie wie folgt:
    Ich habe mehrere Mailadressen, die alle im Netz auf ein Konto weitergeleitet weden. Dieses Konto (Konto 2) wird von TB abgerufen und die Mails nach empfänger wieder auf die anderen Konten (Konto 1, Konto 3, etc.) verteilt. So sollten die Mails auch wieder in den entsprechenden Posteingängen landen. Führe ich die Filter manuell aus funktioniert das auch(!), ABER:


    1. die Filtereinstellung mit oder ohne Spam funktioniert nicht
    Zunächst einmal gibt es in TB5 bei den Filtern mehrere Möglichkeiten auszuwählen wann der Filter augeführt werden soll, unter anderem kann ich Filter anwenden bei "Nachrichtenabruf oder manuellem Ausführen" ODER "Nachrichtenabruf (nach Junk-Filter) oder manuellem Ausführen" auswählen.
    Der Sinn ist für mich klar: im ersteren Fall werden ALLE Mails auf die verschiedenen Konten verteilt, auch die Junks. Im zweiten Fall werden erst die Junks in den Junk-Ordner von Konto 2 gefiltert und dann der Rest auf die anderen Konten verteilt.


    Da Filterkaskaden nicht wirklich realisierbar sind und es einfacher ist, nur einen Junkordner zu kontrollieren, möchte ich also den zweiten Fall anwenden: erst Spam weg, dann verteilen. Das funktioniert aber nicht, bzw. nur bedingt.


    Bei einem frisch gestarteten TB läuft alles halbwegs - allerdings werden die spams auch mit auf die anderen Konten verteilt. Und wenn ich diese manuell verschiebe bzw. den Junkfilter bzw. das Löschen dieser Mails manuell anstoße , geht auch alles. Nach einiger Zeit jedoch läuft gar nichts mehr: ich kann gar keine Mails mehr verschieben, keine Spams löschen oder irgend ein Filter funktioniert. Ich bekomme keine Fehlermeldung, es regt sich einfach nichts mehr (in der Hinsicht). Starte ich TB neu, dann geht alles wieder für eine gewisse Zeit - einigermaßen.


    Da es in letzter Zeit Probleme mit Antivir gibt (hat ein wenig zu sehr seine Finger auf Prozessen), habe ich den TB-Prozess vom Guard ausgeschlossen.


    Ich habe also zwei Probleme:
    1. die Filtereinstellung mit oder ohne Spam funktioniert nicht
    2. nach einiger Zeit kann ich weder Filter nutzen noch Mails manuell verschieben.


    Ich bin hier echt aufgeschmissen, vor allem, weil ich momentan auf mehreren Accounts zwischen dem ganzen Spam wichtige Mails suchen muß, was irre viel Zeit kostet und was sonst eigentlich von alleine passieren sollte!


    Wäre toll, wenn mich bald jemand aufklären könnte, was da abgeht und wie man das abstelen kann!


    VIELEN DANK! Anja

  • hi!
    willkommen im forum anja!

    Zitat

    ch habe mehrere Mailadressen, die alle im Netz auf ein Konto weitergeleitet weden. Dieses Konto (Konto 2) wird von TB abgerufen und die Mails nach empfänger wieder auf die anderen Konten (Konto 1, Konto 3, etc.) verteilt.


    warum diese änderung? wenn doch vorher alles funktioniert hat? bei so einer verkomplizierung wunderts mich nicht wenn deine filter ins schleudern kommen. abgesehn davon das du unnötigen traffic verursachst.


    edith: den junk kannst du ja sowieso in den konteneinstellungen in einen junkordner filtern!

  • Hallo Anja,


    und willkommen im Forum!
    Ich stelle fest, dass du fast den gleichen Gedanken verfolgst wie ich. Mal sehen, ob wir herausbekommen, warum es bei dir nicht so richtig funktioniert.



    Zitat von "anja-kiel"

    ich bin ja echt nicht blöd, ... , Ich nutze TB 5.0, ausschließlich POP Konten und WIN XP (und Antivir Premium, s.u.). Außerdem nutze ich noch einige Addons, die jedoch erst nach Auftreten der Probleme installiert wurden, also nicht die Ursache sind.


    Ein weniger wichtiger und zwei echt wichtige Hinweise ;-)


    Durch das Zusammenfassen aller Posteingänge auf dem Server hast du also auf dem Client nur ein einziges Mailkonto. Das vereinfacht die Arbeit dort. => gute Lösung. (Bei mir: ggw. 6 IMAP und 4 POP3-Konten. Der kleine "Rest" von rund 80 Weiterleitungsadressen => meine pers. Spamvermeidungsstrategie, wird wie bei dir auf dem Server eingesammelt.)
    Auch das nachträgliche Verteilen auf viele Unterordner unterhalb des Posteinganges ist eine vernünftige Sache und sinnvolle Anwendung der Möglichkeiten des Thunderbird. Und funktioniert auch problemlos, da seit Jahren (bei mir) so Praxis!


    Ich mache es so, vielleicht kannst du einiges als Anregung verwenden:


    Alle eingehenden Mails landen bei mir im zentralen Posteingang (durch vorgeschaltete Filter, die du ja auf dem Server realisierst und hier keine Bedeutung haben). Und sie bleiben dort liegen, bis ich sie entweder gelesen/bearbeitet oder gelöscht habe.
    Das Spamfilter ist so trainiert, dass es den Müll von dort gleich in den lokalen Junkordner verschiebt. Dort werden sie nach zwei Tagen automatisch gelöscht, ich habe also die kaum noch notwendige Möglichkeit, fälschlicherweise als Spam deklarierte Mails zu "entjunken". Manuell als Junk markierte Mails gehen gleich in die Tonne.
    => Fazit: Das Müllproblem betrachte ich als gelöst! (Sind ja eh nur rund 5 Mails pro Woche ... .)


    Jetzt habe ich folgende Filter für den zentralen Posteingang (eines meiner IMAP-Konten) eingerichtet:
    1.) Für Statusmeldungen meiner Serverdienste usw. (haben alle eine eigene Adresse), die sofort und ohne weitere Bearbeitung automatisch in ihre Ordner einsortiert und dort auch gleich auf "gelesen" gesetzt werden => reine Nachweisführung.
    2.) Das Filter "gelesen", welches bei Vorhandensein noch ungelesener Nachrichten alle weiteren Filter stoppt. Wirksam bei Nachrichtenabruf oder manuellem Ausführen.
    3.) Jetzt folgen die vielen Filter für das Einsortieren je nach Absender/Empfänger/Betreff in die entsprechenden Unterordner.


    Ergebnis:
    1.) Im Posteingang liegen alle eingegangenen Nachrichten, egal von wo sie kommen. Gereinigt vom Müll und von den Mails, die ich nur zur Nachweisführung usw. aufhebe.
    2.) dort bleiben sie liegen, so lange ich sie nicht gelesen/bearbeitet/manuell gelöscht habe.
    3.) Jetzt führe ich bewusst manuell die Filter aus (Extras >> Filter auf Ordner anwenden)
    4.) Der Posteingang ist leer (wichtig, auch für die "Gesundheit" des Thunderbird!) und alle Mails sind dort, wo sie hingehören.




    Zitat

    Da Filterkaskaden nicht wirklich realisierbar sind und es einfacher ist, nur einen Junkordner zu kontrollieren, möchte ich also den zweiten Fall anwenden: erst Spam weg, dann verteilen. Das funktioniert aber nicht, bzw. nur bedingt.


    Das mit den Filterkaskaden stimmt so nicht ganz. Es funktioniert schon.


    Zitat

    Bei einem frisch gestarteten TB läuft alles halbwegs - allerdings werden die spams auch mit auf die anderen Konten verteilt.


    Vergleiche mit meiner Lösung. (edit: Und beachte auch den von sjfm gegebenen Hinweis, dass du mehrere Konfigurtionsmöglichkeiten für das Junkfilter hast. Dann muss es eben mehrfach suchen ... .)


    Zitat

    Und wenn ich diese manuell verschiebe bzw. den Junkfilter bzw. das Löschen dieser Mails manuell anstoße , geht auch alles. Nach einiger Zeit jedoch läuft gar nichts mehr: ich kann gar keine Mails mehr verschieben, keine Spams löschen oder irgend ein Filter funktioniert. Ich bekomme keine Fehlermeldung, es regt sich einfach nichts mehr (in der Hinsicht). Starte ich TB neu, dann geht alles wieder für eine gewisse Zeit - einigermaßen.


    Das ist eigentlich ein anderes Problem.
    Was tust du für die oben erwähnte "Gesundheit" deines Thunderbird bzw. seiner mbox-Dateien?
    Du weißt, dass gelöschte Mails nicht wirklich gelöscht, sondern nur als gelöscht markiert werden? Und gerade bei großartigen Verschiebeaktionen werden die mbox-Dateien größer und größer, bis gar nix mehr geht.
    => Komprimieren! (Kennst du nicht? => steht in unserer Anleitung!)


    Hinweis dazu: Ich verwende das ausgezeichnete Add-on "Xpunge". Damit kann ich mit einem Klick ausgewählte oder alle "Mailordner" (in Wirklichkeit mbox-Dateien) komprimieren und vorher noch alle/ausgewählte Mülltonnen leeren.


    Zitat

    Da es in letzter Zeit Probleme mit Antivir gibt (hat ein wenig zu sehr seine Finger auf Prozessen), habe ich den TB-Prozess vom Guard ausgeschlossen.


    Das muss ein Grundsatz sein! AV-Programme dürfen keinerlei Zugriff auf das TB-Userprofil haben!!! Die Gründe dafür habe ich in mehreren Beiträgen genannt. (=> Suchfunktion, nach Beiträgen von mir suchen)


    HTH
    (Und falls nicht, dann bitte weiter fragen ... .)


    MfG Peter (etwas langsamer, aber trotzdem ...)

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo sjfm!


    die Änderung habe ich vorgenommen, weil ich
    1. meine Mails auch mit dem Handy in verschiedenen WLAN-Netzen abrufen möchte, und bei einem Netzwechsel die Einstellungen für jeden Account einzen ändern muß: 1 Account = 1 Änderung
    2. Ich auch häufiger länger unterwegs bin (Urlaub, Tagungen, Eltern, Schwiegereltern, etc.) und es echt nervig ist, 6-8 Accounts per webmail zu prüfen.
    3. ich an einigen Mailadressen sehr hänge (Änderung = verdammt viel Arbeit), diese aber nur alle 16 Minuten abrufen kann, was aber sehr stört und auf dem Handy - warum auch immer - einen automatischen Abruf quasi unmöglich macht. Weitergeleitet werden die Mails aber sofort.


    Klar kann ich den Junk theortisch auch in den einzelnen Inboxen herausfiltern, doch das klappt nicht. In den Inboxen ist für alle Mails, die dorthin gefiltert werden, Endstation. Dort eingerichtete Filter werden nicht automatisch ausgeführt.


    Ich denke, ich werde mir wohl die Arbeit machen müssen... alle Filter löschen und dann neu einrichten, vielleicht ist ja irgendwo der Wurm drin.
    Dennoch bin ich der Meinung, daß das zumindest nicht das Problem löst, daß sich nach einiger Zeit keine Mail mehr bewegen läßt. Aber wir werden sehen.


    Grüße Anja

  • Hallo Peter,


    vielen Dank für Deine ausführliche Antwort!


    Du hast Recht, Im Prinzip habe ich eine ähnliche Idee wie Du.


    Deine Anmerkungen zu Deiner Filterstruktur, den Filtern und die Kommentare von sjfm sagen mir, daß ich tatsächlich den ganzen Filterwust einmal löschen sollte, und von vorne beginnen muß, damit auch Altlasten verschwinden.
    Dann teste ich auch einmal eine Filterkaskade und probiere erneut diese beiden Optionen mit und ohne vorherigem Junkfilteraufruf.


    Komprimieren tu ich die Ordner alle regelmäßig (wöchentlich), da meine täglichen Backups sonst viel zu groß würden. Allerdings habe ich gestern einige große Ordner komplett verschoben bzw umsotiert und eine Riesenmenge Daten "gelöscht". Danke für den Hinweis auf das Addon, das werde ich in diesem Zusammenhang gleich einmal testen.


    So, dann mal fröhliches Probieren!
    Ich melde mich die Tage, was meine Vorhaben gebracht haben.


    Grüße Anja



    PS: Und noch eine Anmerkung zum AV-Programm: meins ist ja noch nicht einmal in der Lage, vernünftig mit eingeschränkten Benutzerkonten zu funktionieren...

  • Hallo,


    hier ein erster Zwischenbericht:


    Das Problem, daß sich die Mails nach einiger Zeit nicht mehr vom Fleck rühren (also weder mit Filtern noch per Drag & Drop), scheint sich mit dem Komprimieren der Ordner erledigt zu haben. TB läuft nun seit heute morgen sauber durch, ohne ein einziges Problem dieser Art.


    Die Filter sind alle gelöscht worden und ich habe begonnen, sie nach und nach wieder einzurichten. Das hat mir die Gelegenheit gegeben, eine Filterkaskade aufzubauen. Zur Definition: damit meine ich, daß Mails automatisch gleich über mehrere Filter von einem Ordner in den nächsten gereicht werden. Leider hat das bei mir nicht funktioniert (Mails bleiben nach dem ersten Filter im ersten Ordner stecken), sodaß ich nun alle Mails, die ich sowieso gleich in bestimmte Ordner sortiere, auch von dem ersten Posteingang aus dorthin filtere. Das wird dann wegen vieler Filter zwar sehr unübersichtlich und ich muß wohl noch etwas daran schrauben, aber es sollte mit ausreichend vielen Kriterien funktionieren.


    Die Funktionen
    - "Filter anwenden bei Nachrichtenabruf oder manuellem Ausführen"
    - "Filter anwenden bei Nachrichtenabruf (nach Junk-Filter) oder manuellem Ausführen"
    konnte ich leider noch nicht ausreichend testen, da ich (glücklicherweise) nicht SO viel Spam bekomme (wenige pro Tag).
    Nur so viel: ich habe zunächst ALLE Filter mit der ersten Option, also OHNE diese Junkfilter-Sache eingestellt. Dabei scheinen die Spam-Mails wie jede andere Mail behandelt zu werden, werden also auch entsprechend gefiltert. Allerdings werden sie als Junk gekennzeichnet, landen aber nicht in dem eingestellten Ordner. Ich habe nun für die Adresse, bei der momentan der meiste Spam kommt, die andere Einstellung MIT Junk-Filter eingestellt. Nun muß ich etwas abwarten, bis ein bißchen Spam ankommt, um eine Aussage treffen zu können, ob das so läuft, wie man es sich vorstellt.


    Grüße Anja