https wird mit falschem (Standardbrowser geöffnet)

  • Wenn ich in Thunderbird 5.0(portable) einen https-link anklicke, öffnet sich FireFox und fragt nach, ob er zum Standardbrowser werden soll.
    Ich habe aber Opera als Standardbrowser eingerichtet und network.protocol-handler.app.https;d:\Tools\Opera11usb\opera.exe eingestellt.
    Wieso öffnet TB trotzdem den Firefox?


    Ich kanns nicht mehr genau sagen, aber ich denke, daß ist erst seit ein paar Tagen so, Windows hat etliche updates gemacht, vielleicht ist da irgendwas schief gelaufen. Der IE war plötzlich Standardbrowser und ich mußte das erst wieder auf Opera zurückstellen.

  • Hallo,
    du hast welches Betriebssystem?
    Mache Firefox zum Standardbrowser und anschließend wieder Opera.
    Klappt es dann?
    Am Besten du nimmst dafür die jeweiligen Einstellungen deines Betriebssystems und nicht die der Browser.
    In XP: Programmzugriffs- und standards.
    In Vista und Win7n heißt das anders (Standardprogramme?).
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Opera nutze ich als USB-Version und im Gegensatz zu FirefoxPortable besitzt Opera in diesem Modus keine Funktion, um sich selbst zum Standardbrowser zu erklären.
    Ich kann das also nur über Dateitypen und Protokolle manuell festlegen. Für http und htm(l) klappt das, nur https irgendwie nicht.

  • Mich wundert, dass das mit einer portablen Version überhaupt geht, wo diese doch kaum Registry Einträge setzt (bzw. die wenigen dann später wieder löschen muss, um keine Spuren auf fremden Computern zu hinterlassen). Außerdem kann ja ein USB-Stick nicht nur einen einzigen Laufwerksnamen haben, es sei denn du weist diesen explizit zu.
    Vermutlich wird dir das nur in einer Desktop-Version gelingen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Tja, es klappt halt. Klar, wenn der Datenträger gerade nicht vorhanden ist, dann geht logischerweise.


    Wenn ich mir die Datei/Protokollzuordnung anschaue, dann bin ich eigentlich kurz vorm Ziel, aber ich finde die Ziellinie nicht.


    Opera ist zwar an sich als Anwendung bekannt und auch für http zugeordnet, aber für https kann ich es eben nicht auswählen.
    Irgendwas unter HKEY_CURRENT_USER\Software\Classes\https ist sicher dafür zuständig, aber ohne zu wissen, welchen schlüssel ich da wie ändern muß...

  • Und warum suchst bei HTTPS nicht den Pfad zur opera.exe als Zieldatei?
    Falls dort noch Zusatzparameter angegeben werden müssen, schau doch einfach, was dort bei HTTP steht.
    In XP ist es dann relativ einfach.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ganz einfach: diese Möglichkeit ist für Protokolle nicht vorgesehen. Nur bei Dateitypen kann man "anderes Programm" wählen und eins angeben. Dort ist Opera aber überall ohnehin schon eingestellt.