HTML-Entität in Subjekt nicht ersetzt

  • Guten Tag,


    ist es normal, dass HTML-Entitäten in Thunderbird (7.0.1) nicht konvertiert werden? Z. B. a ä, o ö, u ü, ß ß, & &, ... …


    Wenn ich mir die gleiche Mail in meinem Web-Account (IMAP) ansehe, werden sie konvertiert. Es macht keinen Unterschied, ob ich die Mail als Text oder HTML sende. Als Zeichensatz hatte ich UTF-8 gewählt.


    Herzlichen Gruß


    Frank

  • Hallo,

    Zitat

    Als Zeichensatz hatte ich UTF-8 gewählt.


    Wo hast du das eingestellt?
    Das Entscheidende ist nämlich, dass du TB nicht diesen Zeichensatz aufzwingen darfst.
    Wenn du auf UTF-8 stellst und die Mail aber ISO-8859-1 deklariert ist, kann der Zeichensatz nicht richtig dargestellt werden.
    Kontrolliere also den Ordner, in dem die Mail ist, mit Rechtsklick, Eigenschaften, Allgemein, ob das untere Kästchen dort angehakt ist.
    Eine weitere Möglichkeit wäre, dass die Mails gar nicht oder falsch deklariert wurde, sie also z.B. in UTF-8 geschrieben, aber als ISO-8859-1 deklariert wurde.
    Das kann man aber nur im Quelltext (Strg+U) erkennen.
    Auch sieht man es, wenn man die Zeichenkodierung unter Ansicht, Zeichenkodierungen, dort den Zeichensatz ändert und dann evtl. Erfolg hat. Diese Änderung ist aber nur temporär und springt bei Neuaufruf wieder zurück.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:

    Hallo,


    Wo hast du das eingestellt?

    Unter Optionen; Zeichenkodierung (natürlich erst, nachdem ich erst ohne getestet hatte).

    "mrb" schrieb:

    Kontrolliere also den Ordner, in dem die Mail ist, mit Rechtsklick, Eigenschaften, Allgemein, ob das untere Kästchen dort angehakt ist.

    Wenn ich eine Mail schreibe, hat die doch gar keinen Ordner. :gruebel:
    Wenn ich sonst Probleme mit der Kodierung sehe, zeigt sich das in einer falschen Darstellung der Zeichen. In diesem Fall werden aber Umlaute korrekt dargestellt und nur die HTML-Entitäten nicht (sie werden einfach als Kode dargestellt). Das ist in meinem Verständnis kein Hinweis auf ein Kodierungsproblem.
    BTW: In einer Version fünf Installation von TB, habe ich inzwischen festgestellt, wird es korrekt umgewandelt ...

  • Könntest du mir bitte erklären, was eine Entität ist, bzw. was du darunter verstehst?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo zusammen,
    kann mich jemand aufklären, worum es geht? Nicht über html-Entitäten, aber was das ganze soll?
    HTML-Entitäten in einer reinen Textmail sind Unfug, und wenn sie angeblich "richtig" dargestellt werden, ist das IMO trotzdem falsch. Ansonsten sollte doch der Zeichensatz die Sonderzeichen hergeben.
    Oder darf ich das "Subjekt" im Subject so deuten, daß es um die Betreffzeile geht - das wäre dann extremer Unfug?
    Gruß, muzel

  • Aber der sagt doch

    Zitat

    to allow for ... (4) textual header information in character sets other than US-ASCII

    Ich verstehe, dass das html-Entitäten eigentlich überflüssig macht, nur nachdem ich trotz Spezifizierung von utf-8 für den Header Umlaute im Betreff nicht richtig dargestellt bekam, hatte ich es mit html-Entitäten versucht, die z. B. von roundcube konvertiert wurden. Der RFC2047 erwähnt html-Entitäten nicht, schließt sie aber auch nicht aus oder habe ich da etwas übersehen?

  • Zitat

    trotz Spezifizierung von utf-8 für den Header Umlaute im Betreff nicht richtig dargestellt


    Wo, im Thunderbird? Bei Webmail ist es ja eher normal, daß Standards nicht eingehalten werden, aber im TB?
    Hast du einen Beispiel-Header?


    RFC2047 Kapitel 3 ist m.E. eindeutig:


    Es gehört also mehr dazu, als mühsam html-Entitäten in den Betreff (oder in den Text, sofern wir von Plaintext sprechen) "hineinzubasteln", die dann kein standardkonformer Mailclient versteht.


    [OT]Im übrigen ist es doch schön, wenn man Spam/Phishing/... schon am kaputten Betreff erkennt - so wird das nix ;)

    Zitat

    Hinweis: Ihre PayLife Kreditkarte vor�bergehend aus Sicherheitsgr�nden begrenzt!

    [/OT]


    Gruß, muzel

  • Ich benutze htmlMimeMail5.php ... Dass in Plain-Text kein HTML gehört versteht sich ... aber dass der Betreff nur Plain-Text sein darf habe ich noch nicht verstanden.