Bilder aus Signaturen werden IMMER in Mail eingefügt?[erl.]

Am 24.09.2018, werden in der Zeit zwischen 21:00 Uhr und 09:00 Uhr des folgenden Tages Wartungsarbeiten am Server durchgeführt. Daher wird die Webseite in dieser Zeit nur eingeschränkt erreichbar sein.
  • Thunderbird-Version: 16.0.2
    Betriebssystem + Version: Win XP
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX):1und1


    Hallo,


    ich habe ein hartnäckiges Problem. Ich verwende in meine HTML Signatur ein Bild von einem anderen Server.


    Der Code dazu sieht so aus:


    Code
    1. <a href="http://www.meineseite.com"><img
    2. alt="MeineSeite Logo"
    3. src="http://www.meineseite.com/images/Logo_RGB_screen.jpg"
    4. width="250" border="0" height="89"></a>


    Alles schön und gut und funktioniert auch, ABER:


    Warum fügt Thunderbird das Bild von dieser URL jeder Mail auch als Anhang bei und vergrößert die Mail (Mulitpart MIME)? Genau das sollte nicht passieren, das Bild sollte beim Empfang der Mail online vom Server kommen (offline wird dann eben keines angezeigt).


    Der Quellcode der erzeugten Nachrichten sieht an der entscheidenden Stelle so aus:


    Code
    1. <a href="http://www.meineseite.com"><img
    2. alt="MeineSeite Logo"
    3. src="cid:part1.00000400.07020803@meineseite.com"
    4. width="250" border="0" height="89"></a><br>


    und dann weiter unten:



    Multipart MIME halt ... ganz normal ... aber nicht nötig und auch nicht gewünscht.


    Das Problem tritt auf bei folgenden Varianten für die Umsetzung einer Signatur:


    - Signaturtext HTML in den Konto-Einstellungen
    - Datei als Signatur anhängen (gleiches HTML nur in Datei)
    - und sogar wenn man die Erweiterung SmartTemplate4 benutzt


    ... gibt es da einen globalen Schalter um Thunderbird zu sagen er möchte das bitte sein lassen?


    Danke schonmal vorab!


    OrganicMan

    2 Mal editiert, zuletzt von graba () aus folgendem Grund: Code-Tags gesetzt

  • Hallo und willkommen im Forum!


    Zitat

    . Ich verwende in meine HTML Signatur ein Bild von einem anderen Server.


    Also remote-Dateien.


    Das funktioniert aber nur, wenn du die Signatur in Thunderbird selbst erstellt hast - also nicht in einem externen Programm - und beim Einfügen der Grafik-URL im Menüpunkt Einfügen/Grafik den oberen Haken entfernt hast. Sonst lädt TB die Datei herunter und hängt sie an die Mail.


    Jeder Anhang einer Grafik- und Textdatei wird aber in Thunderbird unterhalb des Nachrichtentextes sichtbar gemacht, wenn man unter > Ansicht > "Anhänge eingebunden anzeigen" einen Haken gemacht hat.
    Sind die Grafiken aber eingebettet worden, erkennt man die Anhänge erst, wenn man die Nachricht in Reintext anschaut.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Meine Signatur ist Text, einfaches HTML. Dafür brauche ich kein Programm.
    Auch bei manuell in Thunderbird erstellten Signaturen auch unter Verwendung der Bild-Einfügefunktion und Entfernen des betreffenden Hakens habe ich genau das gleiche Ergebnis.

  • Ok ... der Hinweis war doch nicht sooooo schlecht, habe mir nochmal angeschaut, was Thunderbird da tut beim Einfügen eines Bildes und siehe da: Es gibt einen Parameter: moz-do-not-send="true"


    Eingebaut und funktioniert.


    <a href="http://www.meineseite.com"><img
    alt="MeineSeite Logo"
    src="http://www.meineseite.com/images/Logo_RGB_screen.jpg"
    moz-do-not-send="true" width="250" border="0" height="89"></a>

  • Zitat

    Ok ... der Hinweis war doch nicht sooooo schlecht,


    Das ist leicht untertrieben, er war goldrichtig.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw