Umlaute werden im Betreff teilweise als � dargestellt

  • Thunderbird-Version: 17.0.3
    Betriebssystem + Version: Windows 7 Professional
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): eigener Mailserver


    Hallo zusammen.


    Ich hoffe, das Thema ist hier im richtigen Unterforum. Es war das, das am ehesten passend erschien ;)


    Ich arbeite in einem Verlag und wir versenden regelmäßig über einen Dienstleister Newsletter per Mail. Jetzt kommt und kam es immer wieder vor, dass bei mir im Betreff Sonderzeichen nicht korrekt dargestellt wurden, sondern nur als � und der Betreff danach auch abgebrochen wird/wurde. Bei den Kollegen, die Outlook nutzen, ist alles in bester Ordnung (zumindest in der Hinsicht :D ) und auch bei mir kommt es nur alle naselang vor. Die übrige Zeit werden alle Umlaute im Betreff völlig korrekt dargestellt.


    Jetzt hab ich mir heute mal zwei Quellcodes vorgenommen – einmal mit korrekt dargestelltem Umlaut und einmal mit fehlerhaft dargestelltem Umlaut (beides mal das Wörtchen "für") und bin auf folgendes gestoßen:
    Der Betreff wird im Quellcode mit einer festen Zeilenlänge ausgegeben. Ist der Betreff länger als die Zeile wird er in der nächsten Zeile weiter geschrieben und so weiter. Fällt jetzt dieser Umbruch genau in die Zeichenkette, die dem "ü" entspricht und wird diese teilweise in die nächste Zeile verschoben, so kommt es zu der fehlerhaften Darstellung des Umlauts.


    Hier die beiden Betreffzeilen aus dem Quellcode:


    Korrekte Umlautdarstellung:


    Subject: =?utf-8?Q?Hochenergie-Traktionsbatterien_f=C3=BCr_Elektrofahrzeuge_-_Univ?=
    =?utf-8?Q?erselles_Sensorinterface_-_Java-Umgebung_f=C3=BCr_STM32-MCUs?=


    (Betreff lautet: Hochenergie-Traktionsbatterien für Elektrofahrzeuge - Universelles Sensorinterface - Java-Umgebung für STM32-MCUs
    Betreff wird so dargestellt: Hochenergie-Traktionsbatterien für Elektrofahrzeuge - Universelles Sensorinterface - Java-Umgebung für STM32-MCUs)


    Falsche Darstellung:


    Subject: =?utf-8?Q?Winzige_bipolare_A/D-Wandler_-_MCU_mit_Kryptographiemodul_f=C3?=
    =?utf-8?Q?=BCr
    _Kfz-Kombiinstrumente?=


    (Betreff lautet: Winzige bipolare A/D-Wandler - MCU mit Kryptographiemodul für Kfz-Kombiinstrumente
    Betreff wird so dargestellt: Winzige bipolare A/D-Wandler - MCU mit Kryptographiemodul f�)


    Ist es möglich da in einer der nächsten Versionen von Thunderbird Abhilfe zu schaffen?


    Lieben Gruß
    Miggi

  • Hallo und willkommen im Forum!


    Ich hatte deine Frage schon früher gesehen und mir lange überlegt, ob ich antworte.
    Das Problem ist nämlich dein eigener Server. Würdest du einen der gängigen Mailanbieter benutzen, könnte ich das problemlos testen, da ich von den meisten selbst ein Konto habe.
    Das zweite: Newsletter halten sich oft nicht immer an die gängigen Regeln was die Deklarierung der Mails angeht.
    Ein kleiner Fehler und Thunderbird bekommt Probleme. Outlook und Co. dagegen können diese oft korrekt darstellen, da Newsletter und viele Webseiten auf MS-Produkte optimiert sind.
    Weiter: ist schon der Quelltext falsch darstellt, kann TB überhaupt nichts mehr machen.


    Code
    1. ?utf-8?Q?


    das "Q?" steht für "quoted printable"
    und

    Code
    1. _f=C3=BCr


    das ist "quoted printable"
    Aber hier

    Code
    1. f=C3?=
    2. =?utf-8?Q?=BC

    muss ein Fehler vorliegen, da das "=" nicht am Ende stehen kann also vor dem "?" von "?utf-8?Q?", außer es handelt sich um das gleichlautende "=" , welches das Zeilenende darstellt.
    Ich glaube, du hast die Zusammenhänge analytisch richtig erkannt.


    Lies mal hier:
    http://www.usenet-abc.de/wiki/Team/Quoted-Printable
    Machen kannst du als Empfänger nichts dagegen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw