Enigmail: Keine Schlüssel sichtbar [erl.]

  • Hallo, ich habe das Problem, dass in der Schlüsselverwaltung von Enigmail keine Schlüssel sichtbar sind. Einmal habe ich auf "Standardmäßig alle Schlüssel anzeigen" geklickt und dann waren die Schlüssel plötzlich da. Aber das hat nur ein einziges mal geklappt. Ich habe auch schon versucht, Enigmail neu zu installieren. Ich wollte mal meinen privaten Key sichern, weiß aber nicht wie ich ihn finden soll.


    Thunderbird-Version: 24.2.0
    Betriebssystem + Version: Windows 7 Ultimate
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): Yahoo
    S/MIME oder PGP: PGP
    Enigmail: 1.6

  • Hallo winterschwert,


    Zitat von "winterschwert"

    Ich wollte mal meinen privaten Key sichern, ...


    Gute Idee! Fast schon mutig, dass Du damit gewartet hast.


    Hast Du die Schlüssel vielleicht aus Versehen gelöscht? Kannst Du gegenwärtig verschlüsselte E-Mails senden und empfangen? Teste ggf. mit Adele.


    Hast Du Kleopatra installiert? Kennt sie die Schlüssel? Ansonsten, führe mal


    Code
    1. gpg --list-keys
    2. gpg --list-secret-keys


    im Terminal aus.


    Gruß


    Susanne

  • Also ich habe Enigmail erst heute installiert, hatte es vor ein paar Jahren schon mal, aber der Schlüssel ist natürlich mittlerweile weg. Deshalb wollte ich ihn gleich nach dem Installieren sichern.


    Das Senden und Empfangen von verschlüsselten Mails funktioniert. Ich habe mir selbst eine Mail geschickt und habe es mit Adele ausprobiert. Die Schlüssel sind auch in der Schlüsselverwaltung vorhanden. Wenn ich nämlich die Schlüssel vom Schlüsselserver aktualisiere, wird mir angezeigt, dass sie erfolgreich aktualisiert wurden. Aber in der Verwaltung sind sie nicht sichtbar. Vielleicht liegt es an der aktuellen Thunderbird-Version. Andere Addons habe ich schon testweise deaktiviert, damit hat es wohl nichts zu tun. Es scheint wohl nur eine Art Anzeigefehler oder Fehler in der GUI zu sein.
    Mit Kleopatra kenne ich mich nicht aus, wo kann man das finden?


    Mit CMD lassen sich die Keys mit Verfallsdatum auflisten, danke für den Befehl. Habe nur noch das Problem, dass die Verwaltung und solche Sachen wie Exportieren nicht gehen, weil die Keys nicht im Programm sichtbar sind. Könnte es mit einem Virenscanner zu tun haben?

  • Hallo winterschwert,


    ich weiß nicht, warum Dir die Schlüssel unter Enigmail nicht angezeigt werden. Bei mir hat das schon immer funktioniert. An der TB-Version liegt es daher eher nicht. Wenn Du dem weiter nachgehen möchtest, warte, bis ein Windows/gpg/Enigmail-Benutzer sich meldet.


    Kleopatra ist ein Zertifikatsmanager, der meines Wissens ab GPG 2 unter Windows mitinstalliert werden kann. Den benötigst Du aber nicht. In GPG geht alles wunderbar per Kommandozeile. Zum Exportieren eines privaten Schlüssels:


    Code
    1. gpg -a --output secret-key.asc --export-secret-keys Schlüssel-ID


    Damit exportierst Du den privaten Schlüssel mit der ID Schlüssel-ID im ASCII-Format in eine Datei secret-key.asc. Ansonsten kann ich Dir noch die Anleitungen zu gpg sehr empfehlen ;-)


    Gruß


    Susanne

  • Thunderbird deinstalliert, Profilordner gelöscht, GPG4win deinstalliert, Benutzerdaten von GPG gelöscht.
    Dann Thunderbird neu installiert und neue Mail-Profile angelegt, Enigmail neu installiert, Schlüssel importiert. Leider immer noch keine Schlüssel sichtbar.

  • Es gab wohl mal ein ähnliches Problem: http://sourceforge.net/p/enigmail/bugs/62/


    Da lag es wohl an der Sprache. Ich habe jetzt die US-amerikanische Version von Thunderbird 24.2.0 installiert und auch Enigmail mit GnuPG neu installiert. Wie erwartet war dann alles auf Englisch, aber es wurden immer noch keine Schlüssel angezeigt, obwohl sie importiert worden sind.
    Was vielleicht noch interessant ist: Wenn ich vorhandene Schlüssel neu importieren will, öffnet sich ein Fenster "OpenPGP Alert", in dem steht:


    ---
    Importing the keys failed


    gpg: Schlüssel [zensiert]: Ist bereits im geheimen Schlüsselbund
    gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
    gpg: gelesene geheime Schlüssel: 1
    gpg: unveränderte geh. Schl.: 1
    ---

  • Hallo winterschwert,


    wie schon geschrieben weiß ich nicht, warum bei Dir die Schlüssel nicht über das GUI angezeigt werden. Vielleicht ist es ein bug in Enigmail, vielleicht der von Dir erwähnte bug in gpg, vielleicht spielen Dir auch nur Reste einer vorherigen Installation einen Streich. Das wäre dann ein Thema für die Windowsfraktion.


    Da es aber über die Konsole geht, ist doch das Problem nur kosmetischer Natur, oder?


    Was überrascht Dich denn an der Fehlermeldung? Sie ist doch korrekt, denn der Schlüssel war ja bereits vorhanden.


    Gruß


    Susanne

  • Ich habe die Fehlermeldung nur deshalb noch mal reingeschrieben, damit andere genau wissen, worum es geht. Vielleicht findet dadurch ja jemand über eine Suchmaschine hierher. Auch das Anhängen von Public Keys läuft nicht in der GUI, da ja keine angezeigt werden. Außerdem bin ich mit Konsolenbefehlen nicht so gewandt, wie es beispielsweise viele Linuxbenutzer zwangsweise sind. Die werden das wahrscheinlich Faulheit nennen, oder typisch Windowianer. Aber ich habe das Addon natürlich nicht installiert, um mir das Leben schwer zu machen. Ich hoffe darauf, dass es irgendwann nach einem Update besser funktioniert. Ansonsten muss ich halt eine Alternative suchen. Das ist wieder das Grundsatzproblem: Die Leute wollen Sicherheit, aber nur wenn damit kein Komfort-Verlust verbunden ist. Ich bin schon bereit, etwas dafür zu tun. Aber wenn der Aufwand für mich unverhältnismäßig wird, dann lass ich es vorerst auf sich beruhen, bis sich eine bessere Lösung findet.
    Danke trotzdem dass du mir geantwortet hast, da fühlt man sich als Neuer nicht so allein gelassen. ;)

  • Hallo winterschwert,



    Zitat von "winterschwert"

    Auch das Anh\ängen von Public Keys läuft nicht in der GUI, da ja keine angezeigt werden.


    Das ist ein guter Punkt. Den hatte ich nicht bedacht. Insofern würrde es sich lohnen, hartnäckig zu bleiben und die Ursache des Problems weiter zu untersuchen. Mir fällt allerdings nur wenig dazu ein. Ich habe von diesem Problem zuvor noch nicht gehört. Wie oben geschrieben, kann das durchaus ein bug sein, ich vermute aber, dass er in irgendeiner Weise mit Deiner spezielle Umgebung zu hat. Sonst hätten wir hier sicher schon mal davon gelesen.
    Es gibt hier im Forum noch weitere Helfer, die gpg und Enigmail verwenden. Vielleicht habe die ja noch eine Idee. Ansonsten könntest Du Dich auch direkt an den Enigmail-Support wenden. Dort gibt es auch einen Link zum Entwicklerteam.


    Zitat von "winterschwert"

    Das ist wieder das Grundsatzproblem: Die Leute wollen Sicherheit, aber nur wenn damit kein Komfort-Verlust verbunden ist.


    Ja, da stimme ich Dir zu. Das Dumme daran ist, dass sich viele erst gar nicht damit auseinandersetzen. Ich halte es weder für übermäßig kompliziert noch für sehr aufwendig. Es braucht aber wohl eine kritsche Masse, um das Thema wirklich unters Volk zu bringen.


    Zitat von "winterschwert"

    Ansonsten muss ich halt eine Alternative suchen.


    Die Alternative wäre S/MIME. Beides hat seine Vor- und Nachteile. Leider sind die Verfahren nicht zueinander kompatibel. Auch so ein Problem auf dem Weg zur kritischen Masse ... .



    Gruß


    Susanne

  • Eine komplette Neuinstallation des Systems hat das Problem wie erwartet behoben. Ich habe danach Thunderbird frisch installiert und den alten Profilordner reinkopiert, was einwandfrei funktioniert hat. Danach musste ich nur noch GnuPG mit dem OpenPGP-Assistenten neu installieren. Das bedeutet, das Problem lag wohl tatsächlich nicht an Thunderbird oder Enigmail.