.xml Dateiendung beim direkten Öffnen eines Anhangs

  • Thunderbird-Version: 17.0.6
    Betriebssystem + Version: Win7 64bit
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): privat


    Hallo Ihr Lieben,


    folgende Situation:
    Im Anhang einer Mail befindet sich eine Datei namens "Auftrag68009.fpsl". Speichere ich sie auf dem Desktop und öffne sie dann, funktioniert also so wie es soll. Versuche ich sie direkt aus der Mail zu öffnen, dann lädt TB sie ja in den %temp% Bereich des Betriebssystems herunter und öffnet sie dort.


    Hier das Problem: Beim Herunterladen hängt TB die Dateiendung .xml an die Datei. Damit wird sie für mich unbrauchbar, denn statt dem Filemaker geht jetzt ein XML-Editor auf!


    Frage: Wie gewöhne ich dem TB ab, diese Dateiendung an meine Datei zu hängen?


    Beste Grüße

    Einmal editiert, zuletzt von m.pfeiffer ()

  • Hallo,
    darf man wissen, mit welchem Programm du die Datei öffnest? Etwa mit "FileMaker Pro Snapshot Link"?
    Thunderbird entnimmt die mimetypes aus der Windows-Registry, schau mal, ob du sie dort findest.
    Alternativ > Systemsteuerung\Alle Systemsteuerungselemente\Standardprogramme\Dateizuordnungen festlegen.
    Ist sie dort nicht vorhanden, kann sie Thunderbird auch icht kennen.
    Evtl. muss das dafür zuständige Programm neu installiert werden, damit diese Einträge neu erstellt werden.
    Du kannst auch versuchen in Thunderbird unter Extras > Einstellungen > Sicherheit > Anhänge - falls der Dateityp zu finden ist - das Öffnungsprogramm dort zu fixieren.
    Besser wäre es aber, einen evtl. Eintrag zu entfernen und beim erneuten Versuch den Anhang zu öffnen, die entspr. Angaben im aufpoppenden Eingabefenster machst und dauerhaft speicherst.
    Alternativ: Thunderbird beenden und im Thunderbird-Profil die Datei mimetypes.rdf löschen.
    Profile verwalten (Anleitungen)
    Dateien im Profil kurz erklärt.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    vielen Dank für Deine schnelle Antwort! :)
    Allerdings habe ich mich vlt. nicht ganz klar ausgedrückt, oder Du hast mich nicht verstanden.


    Alles was Du schreibst hatte ich vorher schon ausprobiert bzw. überprüft! Aber das hilft mir nicht weiter. Warum? Weil das Programm "Filemaker Pro v11" in der Registry zwar eine Dateiendung verknüpft - weshalb ich die .fpsl-Datei über den Windows-Explorer ja auch öffnen kann -, aber keinen Content-Type! Daher bekommt die Datei in der Mail fälschlicherweise den Content-Type: text/xml; und nicht application/fpsl; oder so :rolleyes:


    Und deswegen möchte ich nur wissen: Wie gewöhne ich dem TB ab, die Dateiendung .xml an meine Datei zu hängen?


    Beste Grüße

  • Hallo,


    weiß denn keiner, wieso der TB beim Öffnen mancher Anhänge ein Textdatei daraus macht?


    P.S.: Verwende ich Windows Live Mail, wird besagte Datei einwandfrei mit dem Filemaker geöffnet, auch ohne dass ich sie vorher irgendwo speichern muss!


    Beste Grüße