Datei in HTML Signatur geht nicht, obwohl Link funktioniert

  • Thunderbird-Version: 24.4
    Betriebssystem + Version: 7 64 Bit
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): 1und1
    Speicherdienst (z.B. Dropbox): eigener FTP Server



    Das Phänomen war schon einmal.
    Ich habe in meinem Thunderbird mehrere Konten (alle bei 1und1 - verschiedene Firmenaccounts).
    Die Signatur beinhaltet ein Logo, welches per Browser ohne Probleme aufzurufen ist.
    http://www.badeloft.de/Badeloft_Signature.jpg


    Auf einmal wird dieses Bild nicht mehr mit in der Signatur mit angehanden (Problem beim einbinden des Bildes).
    Jedoch nur bei den E-Mails des einen 1und1 Accounts. Alle Bilder der anderen E-Mails vom anderen 1und1 Account gehen einwandfrei.


    Woran kann das liegen?

  • Hallo,

    Zitat

    Auf einmal wird dieses Bild nicht mehr mit in der Signatur mit angehanden


    Wenn du das Bild aber im Browser öffnest, ist das ja eine remote-Datei und die wird ja nicht eingebunden und steht im Quelltext (Strg+U) nur als Link. Vielleicht solltest du den Quelltext mal vergleichen und überprüfen.


    Wie fügst du die Signatur ein, per Eingabe in den Konteneinstellungen oder ebenfalls dort als externe *.html Datei?
    Überprüfe zunächst das Verhalten im safe-mode:
    In TB > Hilfe > "Mit deaktivierten Add-ons neu starten" und den Button "Im abgesicherten Modus weiterarbeiten" verwenden oder Start mit gedrückter Umschalt-Taste.
    Oder über Win+R --> thunderbird -safe-mode --> OK.
    Falls es dort genau so ist, lege ein zusätzlichen Profil an und teste es dort.4 Ein neues Profil erstellen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    das witzige ist, dass ich das schon einmal hatte und wie von Zauberhand ging es nach einigen Monatebn wieder.
    Ich füge Die Signatur direkt in den Konteneinstellungen als HTML Signaturtext ein.


    Es ist auch exakt der gleiche Code, wie bei meinem anderen E-Mail Account, wo alles funktioniert.
    Ich möchte die Signatur ungern hier öffentlich zeigen, kann sie dir aber gern als PN schicken.

  • Hallo,

    Zitat

    Die Signatur direkt in den Konteneinstellungen als HTML Signaturtext ein.


    Den Code hast du woher? Aus einem externen Programm, in Thunderbird erstellt oder selbst geschrieben.?


    Du kannst mir gern den HTML-Code per PN zusenden.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    Danke für die PN. Um den Code in Thunderbird zu testen, habe ich ihn in ein Verfassenfenster über > Einfügen > HTML..
    dort eingefügt und er wurde normal angezeigt.
    Für Thunderbird allerdings ist der Code fehlerhaft, weil ihm gesagt werden muss, ob die Datei angehängt werden muss oder dort ein remote-Link steht. Im entsprechende Menü beim Einfügen muss dort nämlich ein Haken herausgenommen werden, dann fügt Thunderbird der Mail den Code "moz-do-not-send" mit dem Wert "true" hinzu (wenn nicht eben "false"):



    Und wenn der fehlt, möchte er die Grafik als eingebundene Datei also als Anhang versenden, was natürlich nicht geht, weil es keine Datei auf der Festplatte dafür gibt. Das Verhalten ist nachvollziebar.


    Ich empfehle dir daher, die Signatur entspr. zu bearbeiten oder sie komplett neu in einem Thunderbird -Verfassenfenster zu erstellen und als *.html abzuspeichern und den Pfad zu dieser Datei gibt du nach Anhaken der richtigen Option in den Konteneinstellung an.
    Damit dürfte das Problem gelöst sein.


    Edit: habe den geändert und das Versenden klappt.
    Ich schicke dir den korrigierten heute Abend zu.

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    wow, da denkt man HTML ist HTML und jedes Programm liest diese Sprache gleich aber nix da. Wieder was gelernt.
    Ich danke dir vielmals für die Aufklärung und bin auf deinen Code gespannt, den ich mit meinem vergleichen und dann testen kann.


    Vielen lieben Dank,
    Sabine :)

  • Zitat

    ...da denkt man HTML ist HTML und jedes Programm liest diese Sprache


    Du wirst es nicht glauben: du täuschst dich total, es gibt keinen Standard für HTML in Emails, jedes Programm werkelt mit seinem eigenen Code, wie es dem Entwickler passt und bringt zumindest Thunderbird regelmäßig zu Darstellungsfehlern. Skripte funktionieren überhaupt nicht.
    Aber eigentlich spielt in deinem Fall der HTML-Code an sich ja keine Rolle, es geht ja nur um die Versendemodalitäten.
    Für den Empfänger ist dieser Eintrag unwichtig und wird von dem betr. Programm ignoriert.
    Sicherlich hätte man in Thunderbird dieses Prozedere eleganter lösen können. Thunderbird ist eben free source und kostenlos.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw