Beim Unterschreiben wir Zertifikats-Datei nicht mit versendet

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 31.3.0
    * Betriebssystem + Version: Windows 8.1 64 bit
    * Kontenart (POP / IMAP): Exchange 2010
    * Postfachanbieter (z.B. GMX): Telekom
    * S/MIME oder PGP:S/MIME



    Beim Unterschreiben wir
    Zertifikats-Datei nicht mit versendet


    Hallo Zusammen,


    wenn ich ein Mail über mein Exchange
    Postfach versende und es digital unterschreibe, wird die
    Zertifikats-Datei nicht mit versendet. Ich habe das Zertifikat wie im
    Internet beschrieben in Thunderbird importiert. In anderen
    Mailprogrammen (EM Clint, Outlook) funktioniert es.


    Kann mir jemand helfen?

  • Hallo chschneider,


    und willkommen im Forum!
    Zwei Fragen:
    1.) Möchtest du nur signieren oder auch an den Adressaten verschlüsseln?
    2.) Woher weißt du, dass dein Zertifikat nicht mit versandt wird. Was steht im Quellcode?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter_Lehmann,


    vielen Dank für Deine Antwort.


    Zu Deinen Fragen habe ich folgende Antwort:


    1. Nein. Ich möchte nur unterschreiben!
    2. Bei einem Test habe ich ein unterschriebens Mail an verschiedene Adresen, die mir gehören, verschickt. Bei keinen der Adressen wurde das Zertifikat mitgesendet.


    Gruß


    Chschneider

  • Bitte die Fragen beantworten.

    • Das Herausgeberzertifikat des ausstellenden TrustCenters ist importiert und ihm ist auch das Vertrauen ausgesprochen? (Von dir importiert bzw. vorher schon vorhanden gewesen)
    • Deine eigene Schlüsseldatei (importiert als .p12 oder .pfx) ist unter "eigene ..." zu sehen? (und nicht etwa noch unter "andere" importiert!)
    • Unter Konteneinstellungen > S/MIME ist dein Schlüssel 2x dem entsprechenden Mailkonto zugeordnet?
    • Du kannst erfolgreich eine Testmail an dich selbst verschlüsselt senden?
    • Diese wird dann auch beim Empfang als verschlüsselt empfangen?
    • Und noch einmal meine Frage aus dem letzten Posting: Was steht im Quellcode der empfangenen Mail (bitte den Quellcode dieser Mail in der nächsten Antwort in Codetags gesetzt posten. Mailadressen bitte etwas anonymisieren.)

    edit vom 26.12.14: Ich habe die Fragen durchnummeriert. Du kannst auf die Nummern antworten ... .

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

    Einmal editiert, zuletzt von Peter_Lehmann ()

  • Hallo


    Das Zertifikat wurde importiert und das Herausgeberzertifikat ist auch richtig vorhanden.


    Beiliegend übersende ich Dir den Quellcode:


  • Ich habe dir wegen der besseren Lesbarkeit den Quellcode in die gewünschten Codetags gesetzt.
    Weitere Hinweise gebe ich dir aber erst dann, wenn du alle meine Fragen beantwortet hast. Ein wenig Mitwirken ist schon erforderlich ... .


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo!


    Folgende Antworten kann ich Dir zu Deinen Fragen geben:


    Zu 1. Ja! Das Herausgeberzertifikat des ausstellenden TrustCenters wurde
    importiert und ihm wurde das Vertrauen ausgesprochen.


    Zu 2. Meine eigene Schlüsseldatei wurde als p12-Datei in "eigene ..." importiert.


    Zu 3. Ja!


    Zu 4. Nein!


    Zu 5. Nein


    Zu 6.


    Test

    Einmal editiert, zuletzt von graba () aus folgendem Grund: Code-Tags gesetzt

  • Wir bleiben bei einer Testmail an dich selbst.
    Ich möchte versuchen herauszufinden, warum du keine Mail an dich selbst verschlüsseln kannst. Auf jeden Fall ist in dem geposteten Screenshot absolut nichts von S/MIME zu sehen. Und das kann ich beim besten Willen nicht nachvollziehen.

    • Wenn du bei einer solchen an dich adressierten Mail (also im Editorfenster) auf den Button "S/MIME" klickst, wird dir da angezeigt, dass für deine eigene Adresse ein gültiges Zertifikat (= öffentlicher Schlüssel) vorliegt?
    • Wenn du jetzt nach dem Schließen dieser Anzeige auf das kleine Dreick neben dem Button "S/MIME" klickst, kannst du da die Verschlüsselung und die Signatur dieser Mail aktivieren?
    • Oder kommt da irgend eine Fehlermeldung? (Evtl. erst beim Senden)
    • Wenn ja welche? (Bitte im Wortlaut oder als Screenshot posten.)


    Zu deiner Kontenart (POP / IMAP):
    Du schreibst, dass deine Kontenart "Exchange 2010" ist. Nun, ich kenne "Exchange 2010" nur als Bezeichnung eines Servers aus dem Hause M$. Und dieser kann, wenn es serverseitig so administriert wurde, auch die im Internet üblichen Protokolle POP3, IMAP und SMTP bedienen.
    Bitte schaue in deinen Konteneinstellungen nach, ob du deine Mails per POP3 abholst oder mit IMAP verwaltest.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter!


    Vielen Dank für Deine Nachricht. Ich
    habe mich über die Feiertage etwas rar im Netz gemacht, deshalb erst
    jetzt meine Antwort.


    Den Fehler habe ich mittlerweile selbst
    gefunden! Aber ohne Deine Fragen wäre ich auf den Fehler
    wahrscheinlich nicht aufmerksam geworden.


    Fehlerbeschreibung:


    Die Mails wurde über den
    Standardserver von Thunderbird verschickt.


    Lösung:


    Habe für das Exchange-Postfach den
    Postfachserver meines Postfachs als SMTP-Server eingetragen.


    Jetzt funktioniert sowohl das
    Unterschreiben, wie auch das Verschlüsseln!!


    Vielen Dank für Deine Hilfe!!!!