Problem bei PDF-Versand

  • Hallo,


    ich habe seit ca. 4 Monaten bei bestimmten Personen Probleme beim Versand von PDFs über Thunderbird. Diese Personen melden mir bei PDFs immer als Fehlermeldung zurück, die Datei sei beschädigt oder leer. Die meisten anderen Personen - ich sage jetzt mal 95% - haben keine Probleme, selbst wenn sie exakt die gleiche Datei in exakt der gleichen Mail erhalten haben. Das Problem tritt bei verschiedenen Programmen zur Erstellung von PDFs auf (getestet: Adobe Acrobat X Pro, PDF-Creator) und egal, ob ich die PDFs in diesen Programmen selbst erstelle oder über Microsoft Office.


    Was ich bisher nicht weiß: Was diese Personen gemeinsam haben könnten (sie nutzen jeweils unterschiedliche Mailprogramme und Betriebssysteme).


    Was ich inzwischen weiß: Es scheint an Thunderbird selbst zu liegen, denn bei der Nutzung anderer Mailprogramme über den Browser habe ich das Problem NICHT. Auch die Versandmailadresse scheint nicht das Problem zu sein, denn auch dort funktioniert der Versand, wenn ich den Zugang über den Browser wähle.


    Ich nutze Thunderbird sowohl privat als auch beruflich auf dem selben Rechner - deshalb scheue ich mich im Moment vor der Radikallösung, die Profile zu killen und Thunderbird komplett neu aufzusetzen. Eine "sanfte" Neuinstallation, d.h. Thunderbird neu installiert ohne die Profile gekillt zu haben, hat nichts bewirkt.
    Deshalb hoffe ich auf Ideen..... (oder wenigstens gute Hinweise, wie ich solch eine Neuinstallation glimpflich über die Bühne bringen kann...)


    Ich nutze Thunderbird 31.4.0, bisherige Updates haben das Problem leider nicht behoben.
    Kontenart: IMAP (es sind 2 verschiedene IMAP-Konten betroffen: ein Webmail- und ein Googlemail-Account)
    Betriebbsystem: Windows 7 Home Premium


    Danke im Voraus für´s Mitgrübeln...
    Casa

  • Hallo Casa,


    und willkommen im Forum!
    Da dann will ich mal mitgrübeln ;-)


    Gleich vorab eine Feststellung: Ich habe in den vielen Jahren, in denen ich TB als Mailclient benutze, bestimmt Zehntausende von Mails verschickt, auch sehr viele mit Anhang und selbstverständlich auch pdf. Und ich versende (bis auf ganz wenige) alle meine Mails mit einer elektronischen Signatur. Bei dieser elektronischen Signatur wird beim Empfänger bei jeder einzelnen Mail sofort angezeigt, ob die gesendete Datei auch wirklich bitgenau übertragen wurde. Ein einziges "gekipptes" Bit würde sofort Alarm schlagen und die Mail als manipuliert klassifizieren.
    Ergebnis: ich habe noch nie (!!) von einem Mailpartner erfahren, dass ich eine "maipulierte" Mail verschickt habe (die würden es mir garantiert mitteilen!).
    Fazit: Ich habe gute Argumente zu behaupten, dass der TB grundsätzlich Anhänge bitgenau überträgt.


    Nun müssen wir bei dir die Ursachen für dieses Verhalten herausarbeiten. (Ich möchte mit meiner obigen Aussage die bei dir auftretenden Effekte keinesfalls wegdiskutieren!)

    • Lässt du etwa deine gesendeten Mails sinnfreierweise durch deinen sicherlich vorhandenen AV-Scanner überwachen?
      Die Überwachung des eingehenden Mailtraffics (also der Verbindung zum IMAP- oder POP3-Server) ist für den Benutzer eines Windows-Rechners schon sehr wichtig. Aber bei der Verbindung zum SMTP-Server sinnfrei und problembehaftet. => deaktivieren! Wer nicht sicher ist, dass die von ihm gesendeten Mailanhänge "Schadstoffrei" sind, der sollte keine Anhänge versenden oder überhaupt nicht mailen! Zum Versand vorgesehene Dateien sind vor dem Anhängen an eine Mail zuerst mit einem aktualisierten AV-Scanner zu scannen und erst dann zu versenden! Sehr oft führt die Überwachung des ausgehenden Mailtroffics zu derartigen von dir beschriebenen Effekten.


    • Wenn damit das Problem noch nicht gelöst wurde (oder überhaupt als eine sehr gute Lösung!), empfehle ich dir, sämtliche von dir gesendete Mails auch noch einmal automatisch an eine eigene Adresse zu senden.
      In den Konteneinstellungen findest du unter "Kopien & Ordner" die Option, "Blindcopie (BCC) an ...". Hier trägst du eine deine eigenen Adressen (am besten eine spezielle dafür vorgesehene Adresse) ein. Im Ergebnis bekommst du jede gesendete Mail nach ein paar Sekunden an dich zurück. Mit einem dafür speziell angelegten Filter kannst du sogar diese erhaltenen Mails in deinen Gesendet-Ordner kopieren und hast automatisch damit auch noch die (einzige mögliche!) ultimative Sendebestätigung.
      Wenn in der erhaltenen Mail der Anhang korrekt vorhanden ist, hast du die absolute Sicherheit, dass zumindest dein Mailclient diese Mail auch völlig korrekt gesendet hat (wovon ich ausgehe!). Damit scheidet dein eigener Rechner als Ursache des Fehlers aus.


    Ja, mach das mal, und dann sehen wir weiter.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo,


    sorry für die verspätete Reaktion. Mir ist leider nicht klar, wo ich die Einstellung finden würde, ob meine ausgehenden Mails auf Viren gescannt werden. Weder bei Thunderbird noch bei Avira habe ich eine entsprechende Einstellung gefunden. Wo müsste ich nachgucken?



    Wie gesagt: Die meisten Personen hatten nie Probleme mit meinen PDF-Anhängen, aber bestimmte Personen konnten sie seit ca. 7 Monaten nicht mehr öffnen, wenn ich sie über Thunderbird versendet habe. Ich habe nun einen eher verzweifelten Lösungsversuch gestartet. Erst habe ich Avira gelöscht, was das Problem nicht behoben hat. Nun bin ich von Thunderbird auf den eM Client umgestiegen und siehe da: Nun können wieder alle problemlos meine PDFs öffnen. Lieber wäre es mir aber, wieder Thunderbird nutzen zu können. Also: Falls jemand eine Idee hat, was das Problem sein könnte, wäre ich absolut dankbar!


    Herzliche Grüße
    Casa