Ständig Timeout beim Versenden von Anhängen über GMX

  • * Thunderbird-Version: 31.4.0
    * Betriebssystem + Version: Windows 7 Home Premium
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX): GMX


    Hallo zusammen!
    Vielleicht weiß jemand von euch Rat! Ich habe nach einer google Suche meines Problems zwar das Gefühl, dass ich damit nicht alleine, trotzdem konnte ich (bisher) keine Lösung finden.


    Mein Problem:
    Ich kann über mein GMX Konto bei Thunderbord keine Mails mit Anhang verschicken.


    Symptome:
    Bei einem Anhang von ca. 5 MB läuft das Versenden bis ca. 12 %. Nach ca. einer Minute Stillstand kommt dann die Fehlermeldung:

    Zitat

    Senden der Nachricht fehlgeschlagen.
    Die Nachricht konnte nicht gesendet werden, weil die Verbindung mit dem SMTP-Server mail.gmx.net ihre Ablaufzeit (Timeout) überschritten hat. Versuchen Sie es nochmals oder kontaktieren Sie Ihren Netzwerkadministrator.


    Bei einem Anhang von ca. 2 MB läuft das Versenden bis ca. 30 %. Danach siehe oben.
    Bei einem Anhang von ca. 600 KB äuft das Versenden bis ca. 95 %. Danach siehe oben.
    Mails ohne Anhang können problemlos versandt werden.


    Weiteres:
    Versenden über mein Gmail Konto in Thunderbird läuft mit den selben Anhängern problemlos.
    Versenden über mein GMX Konto im Firefox läuft mit den selben Anhängen problemlos.


    Jetzt werden einige von euch vielleicht erstmal annehmen, dass meine SMTP Einstellungen falsch sind. Zugegeben, ich bin sicher kein Fachmann! Aber ich würde vermuten, dass ich (fast) alle möglichen Einstellungen probiert habe. Ich versende über den Server mail.gmx.net. Ich habe sowohl STARTTLS als auch SLL/TLS probiert. Mit jewels den Standard Ports als auch viele weitere Ports, welche im Internet vorgeschlagen werden. Außerdem habe ich sogar keine Verbindungssicherheit und verschiedene Authentifizierungsmethoden ausprobiert.


    Letztlich habe ich gelesen, dass es am Antivirusprogramm oder der Firewall liegen könnte. AUch das denke ich ausschließen zu können. Ich habe Free Version von Antivir und die normale Windows Firewall, also nichts wildes. Ich habe das Versenden auch schon probiert, während ich Antivir ausgeschaltet hatte, leider erfolglos. Und, wie gesagt, es funktioniert ja über Gmail.


    Ich denke, dass das Problem seit ca. einem Monat bestehen dürfte. Ende 2014 habe ich auf jeden Fall noch Mails mit sehr großen Anhängen verschickt.


    Weiß vielleicht jemand Rat? Das wäre eine sehr große Hilfe!


    Vielen lieben Dank für eure Mühen schon mal im Voraus!!


    Noch ein kleiner Nachtrag:
    Aufgrund meiner Prozentangaben könntet ihr vielleicht vermuten, dass mein Timeout zu früh kommt. Das würde ich auch nicht denken, da die Prozentangaben direkt nach einer Sekunde kommen. Also direkt z.B. 12 % oder 80 % und dann sich eine Minute nichts tut, bis dann der Timeout-Fehler kommt. Bei Gmail mit dem selben 5 MB Anhang kommt direkt 12 % und dann läuft das Versenden langsam aber sicher bis 100 %, wie es sein sollte.

  • Hallo Holden,


    und willkommen im Forum!
    Zuerst einmal ein großes Lob für deine Fehlerbeschreibung und vor allem für die vielen Untersuchungen, die du schon selbst durchgeführt hast! Wenn das mal alle anfragenden User so machen würden ... .
    Allerdings - bei dem, was ich da alles gelesen habe, fällt mir wirklich keine "Blitzantwort" ein.
    Trotzdem einige Bemerkungen, vlt. ist was ja was hilfreiches dabei.

    • Das so oft gescholtene (weil nicht verstandene) Timeout ist die Zeit, nach welcher dich das Programm vor weiterem sinnlosen Warten befreit, wenn keine Daten fließen. Das bedeutet, dass selbst wenn du (sinnloserweise) einen Riesenanhang von 20MB verschicken würdest, und die Daten fließen, du niemals ins Timeout laufen würdest! Sei froh, dass es dieses Timeout gibt, sonst würdest du "ewig" warten!
    • Die Ursache ist also, dass - warum auch immer - keine Daten fließen.
    • Zuerst solltest du mal bei deinem Provider nachsehen, wie groß dort per SMTP versandte Dateianhänge maximal sein dürfen. Die Mailprotokolle sind nämlich niemals dafür entwickelt worden, um zum Transport von Monsteranhängen missbraucht zu werden! Für Datentransporte (also Dateien mit nennenswerter Größe) gibt es bessere Protokolle (ftp und neuerdings WebDAV) und die Mailprotokolle sind dafür denkbar ungeeignet, da diese nur reine ASCII-Zeichen (also Reintext mit internationalen Sonderzeichen) übertragen können. Binäre Anhänge müssen immer in dieses Format umcodiert werden, was sie noch einmal zusätzlich um ca. 1/3 aufbläht.
      Also: Was lässt dein Provider zu?
    • Das Verwalten eines E-Mailkontos "mit dem Firefox" nennt man "Webmail". Und dieses IMHO gruselige Verfahren hat absolut nichts mit der Funktion eines richtigen Mailclients zu tun. Auch wenn letztendlich providerseitig die gleichen Datenbanken verwendet werden. Hier läuft alles über http oder https.
    • Zu deinen SMTP-Einstellungen: Wirklich noch einmal mit den Daten vergleichen, welche der Provider auf seiner Webseite aktuell veröffentlicht hat. Penibel überprüfen! Auch wenn du das ja schon gemacht hast. Meine Empfehlung ist, bei GMX deine Kundennummer als Benutzername einzutragen.
    • Wer ist denn überhaupt dein Internetprovider? Nicht etwa der magentafarbene? Und der Router ist auch kein Speedport der neueren Bauart? Ich frage ja nur ... .
    • Mein Hauptverdächtiger ist und bleibt die zusätzlich installierte "Sicherheits-" Software! Deshalb solltest du diese entweder zumindest testweise komplett deinstallieren (die für den Test bessere Lösung) oder zumindest so konfigurieren, dass sie beim Start des Betriebssystems NICHT mit startet. Neustart des Rechners, Überprüfung, ob dieses Programm wirklich nicht mit gestartet wurde, nochmalige Überprüfung der SMTP-Einstellungen und Test mit dem Thunderbird. Ausschalten des "Sicherheits-"Programms bei laufendem Betriebssystem bringt nichts!
      Wichtig: Das AV-Programm darf NIEMALS das TB-Userprofil überwachen. Die Überwachung der Verbindung zum IMAP/POP3-Server ist möglich, aber die Verbindung zum SMTP-Server sollte unbedingt von der Überwachung ausgenommen sein.


    OK?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

    2 Mal editiert, zuletzt von Peter_Lehmann ()

  • Hallo Peter,

    vielen lieben Dank für die vielen Lösungsansätze!!

    Ich gehe mal auf direkt auf deine Punkte ein.

    2. „Jein“. Mails ohne Anhang kann ich immer verschicken. Mails mit Anhang kann ich außerdem wirklich immer über Gmail in TB verschicken. Aber ja, man kann annehmen, dass (in den meisten Fällen – dazu komme ich gleich noch) keine großen Datenpakete (so stelle ich mir das als Laie vor) an den GMX Server fließen.

    3. Laut eigenen Angaben lässt GMX bei Freemail 20 MB Anhänge zu. Ich hatte es aber ja nur mit Anhängen von ca. 1 bis 5 MB versucht.

    5. Habe schon alle möglichen Einstellungen probiert. Du hast Recht, dass man tatsächlich auch die Kundennummer angeben kann. Bei der Lösung meines Problems hat es leider nicht geholfen.

    6. Mein Internetprovider ist unitymedia, welcher ja besonders in NRW sehr groß ist. Ich habe einen relativ neuen WLAN-Router. Habe ihn auf Werkseinstellung zurückgesetzt. Ohne Effekt auf mein Problem.

    7. Ich kann die AV-Programme /Firewall wohl jetzt definitiv ausschließen. Habe Antivir komplett gelöscht. Außerdem habe ich noch mal extra eingestellt, dass TB von der Windowsfirewall nicht überwacht wird. Alles ohne Effekt.

    Außerdem habe meinen GMX-Account aufgeräumt, sodass ich nur noch die hälfte des möglichen Speichers verbrauche, und ich habe TB komplett deinstalliert. Inkl. meines Profils, also der in %AppData% gespeicherten Daten.

    Ich kann nicht genau sagen, ob die Neuinstallation den Ausschlag gegeben hat, ich denke eher nicht, aber jetzt funktioniert es teilweise! Darum schrieb ich oben auch „in den meisten Fällen“. Tatsächlich klappt das Versenden von Anhängen jetzt auch über GMX, allerdings nur bei ca. 30 % der Versuche. Das ist natürlich noch nicht so richtig befriedigend!

    Außerdem muss ich sagen, dass ich sowieso auch außerhalb von TB ein paar Probleme mit dem Internet habe. Upload von Bildern (z.B. auf Dropbox) dauert oft lange oder funktioniert erst nach mehreren Versuchen. Außerdem eine weitere Kuriosität: Bei viel Traffic (z.B. das laden eines Streams) bricht die Internetverbindung des PCs manchmal ab. Dann trenne ich am PC die WLAN Verbindung zum Router und stelle sie direkt im Anschluss wieder her. Dann ist die Verbindung wieder da.

    Ich habe jetzt festgestellt, dass dieses Trennen und Wiederherstellen der WLAN Verbindung auch auf mein Problem einen positiven Effekt hat.

    Ich vermute, dass das Problem entweder mein PC ist, und von einem Laien wie mir nur durch komplettes Neuaufsetzen gelöst werden kann, oder mein Internetprovider (oder doch der Router) das Problem verursacht.

    Noch mal, ich finde es allerdings sehr sehr merkwürdig, dass ich immer die selben Mails mit großem Anhang sehr wohl in TB über Gmail versenden kann. Dort sind die SMTP Einstellungen übrigens die gleichen.

    Also wenn du, oder jemand anderes, keine zündende Idee mehr hat, werde ich wohl meinen PC neu aufsetzen.


    So oder so, vielen Dank für die Hilfe!


    Nachtrag: Ich habe noch einen (alten) PC mit Ubuntu 12.04. Auch dort habe ich TB installiert und siehe da: Kein Problem beim Versenden von Anhängen über GMX. Habe es drei mal getrestet mit bis zu 15 MB großen Anhängen. Ich werde es die Tage noch weiter probieren. Wenn es dabei bleibt, dass es auf dem alten PC funktioniert und auf dem normalen nicht, werde ich den normalen neu aufsetzen! Das Problem liegt wohl wirklich am PC, allerdings außerhalb von TB.

    Einmal editiert, zuletzt von Holden ()

  • Hi Holden,


    ich bewundere dich wirklich, was du als "Laie" (wie du dich selbst einstufst) alles zur Fehlersuche unternimmst. Das ist vorbildlich und ich möchte dich wirklich nicht als Laie bezeichnen!


    Ich bin bewusst nicht auf evtl. mögliche Probleme außerhalb des TB eingegangen, weil du ja geschrieben hast, dass du über gmail problemlos senden kannst. Aber da du jetzt meldest, dass du auch andere Probleme ("Upload von Bildern (z.B. auf Dropbox) dauert oft lange oder funktioniert erst nach mehreren Versuchen.") hast, tendiere ich jetzt auch dazu, das Betriebssystem selbst zu untersuchen.


    Problem: Ich kenne zwar viele "Stellschrauben" an welchen man sein Netzwerk optimieren kann, aber ich lebe schon viele Jahre in einer "Windowsfreien Welt" und kann dich leider nicht aus dem Gedächtnis dorthin führen. Einziger Tipp: deaktiviere mal (testweise) in den Netzwerkeinstellungen IPv6. Manchmal reicht das schon.


    Vorschlag: Warte mal einen Tag, bevor du deine WinDOSe neu aufsetzt. Vielleicht springt einer der hier vorhandenen Windows-Auskenner auf und gibt dir ein paar Tipps. Die Richtung dürfte ja jetzt schon deutlich sein.



    Viel Erfolg und weiter so!


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Mein Problem hat sich durch kompletter Neuinstallation des Systems gelöst!


    Vielen Dank für die Hilfe!