Enigmail und gmx bzw. web.de Verschlüsselung

  • Hallo!
    Ich habe ein Problem mit der verschlüsselten Kommunikation via Enigmail. Eigentlich klappt es auch alles ganz gut, doch nun nutzen einige meiner Bekannten die Verschlüsselung über gmx.de bzw. web de. Der Austausch der Schlüssel funktionierte auch problemlos und meine Mails kommen wohl auch verschlüsselt an. Allerdings erhalte ich lediglich "leere" Emails als Antwort. Es wird mir zwar angezeigt, dass die Mail verschlüsselt ist, aber selbst nach dem Entschlüsseln bleibt die Mail leer, lediglich die übliche Meldung im grünen Feld (entschlüsselte Nachricht, Absender, Datum ect.) erscheint.
    Kennt jemand das Problem und hat einen Lösungsvorschlag?


    Angaben zum System:
    Thunderbird-Version: 38.3.0
    Betriebssystem: Win7 64
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): gmx.de

  • Hallo,


    das liegt vielleicht einfach nur daran, dass die E-Mails in HTML verfasst (und per PGP/MIME verschlüsselt wurden) und die Ansicht in Deinem TB auf "reiner Text" steht.


    Gruß


    Susanne

    Einmal editiert, zuletzt von SusiTux () aus folgendem Grund: + in

  • Wo kann man das Einstellen? Das könnte auch die Lösung für mein Problem sein.
    Angeloo

  • Rate mal, wo man die Ansicht des Inhalts von Nachrichten wohl einstellt? Unter Ansicht -> Nachrichteninhalt. :)

  • das liegt vielleicht einfach nur daran, dass die E-Mails in HTML verfasst (und per PGP/MIME verschlüsselt wurden) und die Ansicht Deinem TB auf "reiner Text" steht.

    Danke für den Tipp, aber das ändert nichts. Zumal die reine PGP-Nachricht, also der verschlüsselt Text doch ohneghin nicht formatiert wäre, oder? Und Bei Absendern von GMX/Web wird der bei mir nicht angezeigt.

    Wo kann man das Einstellen? Das könnte auch die Lösung für mein Problem sein.
    Angeloo

    Ansicht -> Nachrichteninhalt

  • Zumal die reine PGP-Nachricht, also der verschlüsselt Text doch ohneghin nicht formatiert wäre, oder?

    Im Gegensatz zu PGP/INLINE bleibt bei PGP/MIME bleibt die HTML-Formatierung erhalten.
    Probiere folgendes: Speichere eine dieser leeren, verschlüsselten E-Mails einmal entschlüsselt ab. Dann schau in den Quelltext dieser entschlüsselten E-Mail.

  • Man lernt nie aus, das wusste ich nicht.
    Den Quelltext habe ich mir schon bei den verschlüsselten Mails angeschaut, er enthält tatsächlich die entsprechende Nachricht, habe die mal testweise über den GNU Privacy Assistant entschlüsselt. Bis auf die Umlaute keine Probleme.
    Und auf die Gefahr hin mich jetzt völlig zum Drops zu machen - was meinst du mit speichern? Also auf entschlüsseln gehen und dann die Mail einfach "Speichern unter" als eml-Datei ablegen? Die so gespeicherte Datei ist dann weiterhin verschlüsselt, der Quelltext ändert sich auch nicht. Aber vielleicht stehe ich auch gerade nur total auf dem Schlauch...

  • Den Quelltext habe ich mir schon bei den verschlüsselten Mails angeschaut, er enthält tatsächlich die entsprechende Nachricht, habe die mal testweise über den GNU Privacy Assistant entschlüsselt. Bis auf die Umlaute keine Probleme.

    Damit erübrigt sich vorgeschlagene der Test schon fast. Er sollte dazu dienen, festzustellen ob die E-Mail einen Inhalt hat. Die Frage ist nun, ist dieser Inhalt ein reiner Text, oder handelt es sich um HTML?


    was meinst du mit speichern?

    Enigmail bietet die Möglichkeit, verschlüsselte E-Mails entschlüsselt zu speichern. In der aktuellen Version 1.8.x geht das (nur) über ein Filter, ab der Version 1.9. und deren Pre-Release auch direkt über das Kontextmemü. Ich nehme an, Du benutzt die aktuelle 1.8.x. Dann musst Du dazu ein Filter einrichten.
    Auch wenn wir nun bereits wissen, dass die E-Mail nicht leer bei Dir ankommt, solltest Du diesen Test dennoch einmal durchführen. Du kannst dann über Strg + U erkennen, ob Enigmail in die E-Mail korrekt entschlüsselt hat.

  • So, habe das jetzt mal ausgeführt. Im Quelltext sind die Nachrichten, bis auf die Umlaute, tatsächlich korrekt entschlüsselt.
    Enigmail nutze ich übrigens in der Version 1.8.2.

  • Im Quelltext sind die Nachrichten, bis auf die Umlaute, tatsächlich korrekt entschlüsselt.

    Gut, damit weißt Du, dass die Entschlüsselung korrekt funktioniert hat. Die wichtige Frage

    Die Frage ist nun, ist dieser Inhalt ein reiner Text, oder handelt es sich um HTML?

    hast Du leider nicht beantwortet.
    Auch ohne Verschlüsselung kommt es manchmal vor, dass E-Mail-Inhalte nicht angezeigt werden. Entweder weil die Ansicht auf Text gestellt ist oder weil die Deklarationen (z.B. der Content-Type) nicht korrekt ist. Letzteres kann ich nicht beurteilen, aber dazu gibt es hier andere Experten.
    Könntest Du den lesbaren Quelltext dieser E-Mail hier einmal posten? Den Inhalt und die Adressen solltest Du natürlich zuvor verfremden. Auch evtl. vorhanden Anhänge (die wilden ASCII-Zeichen am Ende) bitte zuvor entfernen. Es soll nur darum gehen, festzustellen, ob es sich um HTML handelt, ob die E-Mail zuvor PGP-MIME verschlüsselt wurde und ob die Deklarationen darin korrekt sind.

  • Die Textansicht habe ich auch schon mehrfach umgestellt, das hat leider nichts gebracht. Aber hier mal der Quelltext, hoffe ich habe alles sicherheitsrelevantes eliminiert:



    2 Mal editiert, zuletzt von graba () aus folgendem Grund: Code-Tags gesetzt

  • Gut, oder auch nicht. Der Quelltext sieht auf den ersten Blick bis auf ein paar Kleinigkeiten eigentlich ok aus. Eine der Kleinigkeiten ist die, dass der Content-Type als multipart/mixed festgelegt ist. Das ist aber absolut nicht meine Baustelle. Dazu müsste sich jemand anderes hier äußern, der sich mit den internen Strukturen von E-Mails besser auskennt.


    In der Zwischenzeit könntest Du aber noch ein paar Tests durchführen, die vielleicht helfen, der Ursache näher zu kommen. Zunächst teste einmal, ob das Problem nur auftritt, wenn per gmx/web.de auf eine bereits verschlüsselte E-Mail geantwortet wurde.
    Sollte das so sein, wäre als nächstes herauszufinden, ob die E-Mails jeweils nach der gleichen Methode verschlüsselt wurden, also ob PGP/INLINE, PGP/MIME oder ein Mix benutzt wurde.
    Damit verknüpft ist die Frage, ob durchgängig reiner Text verwendet wurde, oder die ursprüngliche E-Mail vielleicht in PGP/MIME und HTML erstellt wurde. Vielleicht erklärt das das multipart/mixed.

  • Schade, aber trotzdem natürlich erst mal Danke.
    Der Fehler tritt nicht nur bei beantworteten Mails auf. Werde mir mal bei gmx- oder web.de einen Account anlegen und dort die Verschlüsselung die Tage mal überprüfen und mich dann hier wieder melden.

  • Werde mir mal bei gmx- oder web.de einen Account anlegen und dort die Verschlüsselung die Tage mal überprüfen

    Ich hatte mir die Verschlüsselung gleich nach Bekanntwerden dieser Initiative testweise aktiviert. In meinem Fall hat das Ver- und Entschlüsseln und das Zusammenspiel mit dem TB ohne Probleme funktioniert. Wirklich gut!


    Falls Du nicht nur Testen sondern bestehende Schlüssel verwenden willst, so kannst Du sie importieren. Achte aber beim Einrichten auf gmx/web.de darauf, dass Du die dabei neu erstellten (aber dann gar nicht mehr benötigten Schlüssel) nur deaktivierst aber nicht löschst. Das ist eine Eigenart zumindest bei gmx. Auch wenn Du eigene Schlüssel importierst, musst bei der ersten Konfiguration zunächst neue anlegen. Wenn Du diese dann dann aber löschst, funktioniert der Webmail-Client nicht mehr richtig.


    P.S.: Was den Content-Type usw. betrifft, hab' einfach etwas Geduld. Einer derjenigen ( mrb ) war heute schon im Forum. Vielleicht schaut er oder jemand anders ja hier rein.

  • So, habe Thunderbird jetzt mal komplett neu installiert, ohne Ergebnis. Jetzt bin ich tatsächlich ratlos, bei einer "jungfräulichen" Version von Thunderbird hätte es doch eigentlich klappen müssen?!
    Hatte auch mal meine entsprechenden Schlüssel bei gmx importiert, dann ging es zwar - wie auch erwartet - über den Browser/ Mailvelope, aber bei Thunderbird kam immer noch nichts an.

  • Hallo stollentrollo,


    So, habe Thunderbird jetzt mal komplett neu installiert, ohne Ergebnis. Jetzt bin ich tatsächlich ratlos, bei einer "jungfräulichen" Version von Thunderbird hätte es doch eigentlich klappen müssen?!


    Thunderbird trennt, wie jedes gute Software-Programm, strikt zwischen Programm- und Datenbereich (= Dein Thunderbird-Profil [sieht in der Regel so aus: yt47ztzu.default]).


    Die Neu-Installation des Programmes hilft in der Regel überhaupt nicht.


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Schon klar, ich habe Profil ect. auch seperat gelöscht, registry bereinigt ect. Es sollte also eigentlich restlos beseitigt gewesen sein.

  • Ich habe mir jetzt die Verschlüsslung bei gmx erneut eingerichtet. Es funktioniert bei mir einwandfrei. Ich kann Dir daher nicht sagen, weshalb es bei Dir zu diesem Phänomen kommt. Es bleiben drei Auffälligkeiten:

    • Der merkwürdige Content-Type
    • Die nicht korrekt dargestellten Umlaute
    • Die Tatsache, dass der Fehler nur beim Antworten auftritt

    Das deutet m.E. darauf hin, dass etwas mit der originalen E-Mail nicht stimmt. Das genauer Festzustellen, bräuchte einen der hiesigen Content-Type- und Charakter-Set-Experten. Auf diesem Gebiet kenne ich mich nicht aus.


    Gruß


    Susanne

    • Die Tatsache, dass der Fehler nur beim Antworten auftritt

    Das stimmt so nicht, ich habe das mittlerweile mal getestet, die Probleme kommen auch bei einzelnen Mails vor.
    Und auch wenn das jetzt vielleicht nicht an diese Stelle gehört - auf meinen Smartphone habe ich jetzt K9 mit OpenKeyhain eingerichtet. Auch hier fallen die Mails von GMX bzw. WEB aus dem Rahmen.


    • Sie werden als "leer" ähnlich wie in Thunderbird angezeigt, allerdings weisen sie jeweils zwei Anhänge auf. In einem dieser Anhänge befindet sich dann die verschlüsselte Nachricht.
    • OpenKeychain kann die Nachricht dann zwar entschlüsseln, allerdings nicht in K-9 direkt, wie es sonst üblich wäre, sondern nur unmittelbar im OpenKeychain.
    • Umlaute werden ebenfalls nicht korrekt dargestellt.

    Ist schon klar, dass es hier vorrangig um Thunderbird geht, aber scheinbar tritt das Problem nicht nur bei Thunderbird auf. Sollte es tatsächlich in den originalen E-Mails begründet liegen, kann man natürlich nur wenig Einfluss darauf nehmen. So wirklich kompatibel ist der Verschlüsselungsdienst von GMX/WEB dann wohl doch nicht, zumal ich dort auch nicht wirklich viele Einstellungsmöglichkeiten finden konnte.

  • Hallo stollentrollo,

    Der Fehler tritt nicht nur bei beantworteten Mails auf.

    Sorry, das "nicht" hatte ich nicht mehr in Erinnerung.



    So wirklich kompatibel ist der Verschlüsselungsdienst von GMX/WEB dann wohl doch nicht, zumal ich dort auch nicht wirklich viele Einstellungsmöglichkeiten finden konnte.

    GMX hat sich nach eigenen Angaben sehr genau an den RFC gehalten und zuvor auch Kompatibiltätstests mit Enigmail duchgeführt. Ich kann zumindest bestätigen, dass bei mir alles ordnungsgemäß funktioniert.


    Ich habe aber einen Verdacht und zwar immer noch den alten:

    auf meinen Smartphone habe ich jetzt K9 mit OpenKeyhain eingerichtet. Auch hier fallen die Mails von GMX bzw. WEB aus dem Rahmen.

    Das sieht mir sehr danach aus, als hättest Du Enigmail nach wie vor auf PGP/INLINE eingestellt. Das klappt nicht mit GMX, denn die verwenden das modernere PGP/MIME, u.a. damit HTML-E-Mails verschlüsselt werden können.


    Meines Wissens unterstützt K9 PGP/MIME nicht - im Gegensatz zu Enigmail.


    Gruß


    Susanne

    Einmal editiert, zuletzt von SusiTux () aus folgendem Grund: Hatte den Trollo versehentlich zum Troll gemacht. Hab' ihm nun noch ein o spendiert.