Thunderbird findet plötzlich Pfad nicht mehr

  • Guten Morgen,


    ich habe ein merkwürdiges Problem: bis gestern abend funktionierte mein Thunderbird einwandfrei.


    Über Nacht hat sich mein Windows 7 (Prof.) mal wieder aktualisiert. Nachdem alles ohnehin sowieso neu gestartet war, habe ich Veracrypt auch gleich erneuert auf 1.17.


    Thunderbird ist Portable installiert und wird in einer mit Veracrypt verschlüsselten Datei gestartet. Ich starte das Thunderbird mit Admin-Rechten.


    Nachdem ich fertig war, wollte ich ThunderbirdPortable.exe starten. Die Datei startet, fragt, ob das mit den Veränderungen am Rechner zulässig ist, und nach Bestätigung teilt sie mir mit, das der Pfad, in dem sie liegt, nicht existiert.


    Weil ich dachte, dass da irgendwo was fehlt, habe dann auf Thunderbird 45.1.1 upgedatet. Null Erfolg.


    Einer eine Idee, wo sich das Vögelchen verschluckt hat ?


    Viele Grüße



    Blue Raven

  • NAchtrag: Wenn ich Thunderbird.exe starte, fängt er irgendwo im Urschleim an mit Anlegen eines neuen Accounts, d.h. er findet mein Profil nicht. Da es nur eines gibt, befürchte ich natürlich, dass, wenn ich weiter mache, mir alles zerschiesse ...

  • Guten Tag Blue Raven!


    Das ist doch ganz einfach: Du nimmst deine gestrige Datensicherung und spielst dein Profil zurück.



    Ich hoffe mal, dass du jemandem, der sich die letzten fast 30 Jahre seines Berufslebens mit IT-Sicherheit befasst hat, einige persönliche Bemerkungen gestattest:

    • Ich kann beim besten Willen nicht verstehen, warum du auf einem Rechner eine portable Version des Thunderbird installierst. Diese portablen Versionen (es gibt mehrere) werden dazu entwickelt, um nomadisch mit dem USB-Stick auf verschiedenen Rechnern den Thunderbird zu starten. Ein derartiges Verhalten (Anschließen eines USB-Sticks an mehreren - nicht eigenen - Rechnern gilt heutzutage sicherheitsmäßig als sehr bedenklich und sollte besser unterbleiben.
      Wenn du (wie fast jeder von uns) gute Gründe hast, den TB auf mehreren Rechnern zu betreiben, dann installiere den Thunderbird auf allen Rechnern und nutze IMAP. Adressbücher und Kalender kannst du bei einem vertrauenswürdigen Hoster speichern und mit allen Installationen darauf zugreifen.
    • Ich kann nicht verstehen, wieso du auf deinem Rechner als Administrator arbeitest. Zum "Nutzen" ist ein eingeschränktes Nutzerkonto anzulegen und zu verwenden. Das vorhandene Adminkonto ist ausschließlich zum Administrieren zu verwenden. Und mit Adminrechten ins Internet zu gehen, geht schon gar nicht.
    • Wieso packst du ausgerechnet deinen Thunderbird in einen Kryptocontainer? Werden alle deine Mails mit S/MIME oder GnuPG end2end verschlüsselt? Dann könnte ich es ja verstehen. Falls du "Geheimnisse" in deinen Mails transportierst, dann sind diese (wenn die Mail nicht verschlüsselt war), sobald sie einen der beteiligten Rechner verlassen haben, keine Geheimnisse mehr. Hinsichtlich der Vertraulichkeit gilt eine unverschlüsselt gesendete Mail als "verbrannt". Und das einzige echte "Geheimnis" in jedem TB-Userprofil ist die Datenbank mit den (hoffentlich starken und immer unterschiedlichen!) Passwörtern für die Mailkonten. Und dieses wird durch die Nutzung eines (merkbaren) Master-PW verschlüsselt.
      JA, auch für mich ist es selbstverständlich, dass die SSD meiner beiden Notebooks vollverschlüsselt sind. Das macht Sinn, falls eines davon in fremde Hände gerät. Aber nur das TB-Userprofil?
    • Und dann solltest du dir merken, dass du gerade bei verschlüsselten Daten IMMER eine tagesaktuelle Sicherung auf einem externen Medium hast. Normale, unverschlüsselte Daten können in sehr vielen Fällen rekonstruiert werden. Du wirst staunen, was da möglich ist. Aber verschlüsselte Daten stellt dir "keiner" wieder her. (Oder nur mit einem kaum gerechtfertigten Aufwand - aber diesen wird sich für deine Mails niemand aufbürden.)



    fängt er irgendwo im Urschleim an mit Anlegen eines neuen Accounts,

    Und, hast du denn schon mal selbst nach deinem "Profil" in dem gemounteten Container gesucht?
    Wenn du es findest, kannst du es doch in wenigen Minuten wieder einbinden.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,


    nur mal so als Kurzfassung zu Deinem langen und ausführlichen Begründung:


    - Das System ist ein privater alter Laptop, den ich hin und wieder in der Deutschen Bahn nutze. Jetzt könnte man sicher auch eine bootable Systemplatte mit Veracrypt und Co. herstellen (weiß ich), allerdings habe ich mich wegen des damit verbundenen Aufwandes darum gedrückt. :whistling:


    Sprich: Was passiert, wenn das Laptop geklaut wird ? Man kann (PW Knacken mal nicht unterstellt) die Platte ausbauen. Dort findet man 2 Partitionen - die Systempartition und die Datenpartition. Erstere offen, zweitere, mit allen persönlichen Daten, im Crypto Safe. Darum geht es mir. Deshalb Portable Version (nicht nur von Thunderbird). Und nein - es ist nicht nur Thunderbird im Crypto Container.


    - Das Insider wie Du sicherlich viele gute Gründe haben und dieses Konzept als halbherzig oder was auch immer bezeichnen - geschenkt. Ich bin nur ein "dummer" User und versuche ein für mich handelbares System zu bauen, bei dem ich mich wohl fühle. :thumbup:


    - Warum TB mit Admin-Rechte (nicht generell !!!) ? Muss irgendwie an den Einstellungen von meinem Windows liegen, denn ich hatte irgendwann mal Probleme, die sich mit Admin-Rechten lösen ließen. Auch hier weiß ich - optimal geht anders ... ;)


    - Gestriges Backup - Nette Idee. Professionelle Nutzer haben das sicherlich mit NAS-Systemen und Co. - nächtlichem Backup-Lauf vielleicht per UCL oder was weiß ich. Otto Normalverbraucher wie ich nur mit einem Laptop und einer mobilen Platte - der macht das einmal wöchentlich mit Kopie von Platte zu Platte - wenn der zeitliche Rahmen es her gibt. :saint:


    Ich wollte hier jetzt aber keine Sicherheitsdiskussion anstoßen oder führen, nehme Kritik an meinem System auch nicht persönlich - ich weiß ja, dass es besser geht. Aber trotzdem bitte ich darum, diesen Aspekt meines Systemaufbaus mal hinten anzustellen.


    Tja, das mit dem Profil muss ich zu Hause mal versuchen, ob das System dann wieder fliegt. Wenn nicht - ein 1-Woche altes Backup habe ich ja - theoretisch ... biggrin.png


    Für mich bleibt die Frage - wo ist die Pfad-Information, die er plötzlich warum verloren hat ? Die ThunderbirdPortable.exe ist ja auch nur ein verkappter Link - und seit Anno Tobak (2009) nicht geändert ... Wieso scheint das aktuelle Windows- und Veracrypt-Update den TB zu verbiegen ? Alle anderen (auch portablen :rolleyes: ) Programme laufen einwandfrei ... ?(


    Viele Grüße



    Ein ratloser Blue Raven

  • Noch ein Thema in den Zusammenhang: Ich habe jetzt ein altes Backup gefunden, überarbeitet und aktualisert - läuft am Backup-Platz einwandfrei.


    Nur wenn ich das ganze Verzeichnis woanders hin kopiere, um es von seinem neuen Platz aus laufen zu lassen, findet er schon wieder das Profil nicht und beginnt mal wieder ganz von vorne. Im Backup-Verzeichnis läuft aber alles perfekt ...


    Dann verstehe ich irgendwo das System von Portable nicht ...


    Viele Grüße



    Blue Raven

  • Dann verstehe ich irgendwo das System von Portable nicht ...

    Dann weißt du wenigstens, warum wir das keinesfalls für eine Installation empfehlen!
    Außerdem gibt es mehrere Hersteller des portablen Thunderbird. Und jeder macht es anders ... . (Empfehlenswert: die Version von Caschy)


    Nachdem du (endlich) in deiner Antwort etwas klarer wurdest (HD in System und Daten partitioniert => sehr gut, Datenpartition verschlüsselt => sehr gut!) und auch mitgeteilt hast, dass du ja doch eine Datensicherung hast, mache ich dir wieder Hoffnung.


    Zuerst solltest du das gesicherte Profil hinsichtlich seines Aufbaus und Inhalts genau mit dem Vergleichen, was du in unserer Hilfe findest. Also beginnend vom Ordner <acht_Zufallszeichen>.default und allem, was darunter folgt. Du musst nicht alles dort finden, aber bestimmte Grundbestandteile.


    Dann löschst du mit einem mutigen Druck auf die [Entf]-Taste die Kopie deines port. TB von deiner Datenpartition, legst dir unter D:\<Benutzername> einen Ordner für das TB-Profil an. Meinetwegen ..\TB-Profil. Und in dieses kopierst du dein vollständiges Profil, beginnend mit o.g. Ordner rein.


    Nun installierst du - so wie man eben ein Programm installiert, also auf die Systempartition - den von unserer Seite heruntergeladenen aktuellen Thunderbird.
    Du startest diesen aber gleich mit dem Profilmanager (!!). Wie das geht, findest du - du ahnst es schon.
    Im Profilmanager legst du ein neues Profil an, nutzt aber als Speicherort des Profils genau den, den du vorhin angelegt hast, also D:\...\TB-Profil\<acht_Zufallszeichen>.default <==.
    Wenn du nun den TB startest, müsste er das Profil über den mit Hilfe des Profilmanagers neu angegten Eintrag in der profiles.ini (die darf niemals verlegt werden, muss also an ihrem Platz verbleiben!).



    OK?



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Dann weißt du wenigstens, warum wir das keinesfalls für eine Installation empfehlen!Außerdem gibt es mehrere Hersteller des portablen Thunderbird. Und jeder macht es anders ... . (Empfehlenswert: die Version von Caschy)

    Hallo Peter,


    Danke für die Info. Ich habe so einen Verdacht, woran das liegt. Werde ich heute abend mal ausprobieren und testen ...

    Einmal editiert, zuletzt von Blue Raven ()

  • Guten Morgen,


    So, inzwischen bin ich etwas weiter - aber meine Verwirrung ist umso größer - es scheint an Veracrypt zu liegen.


    Es scheint so, dass einige Programme die mit Veracrypt gemappten LW und Pfade nicht finden. Was merkwürdig ist - der Explorer findet sie ohne Probleme. Und Programme, die NUR in dieser Umgebung laufen, gehen problemlos.


    Aber in dem Moment, wo auf irgendeine Datei ausserhalb des Containers zugegriffen wird, gehen die Probleme los. Am krassesten: Wenn ich in Winamp auf Dateien in diesen WL zugreifen will (z. B. indem ich LW überwachen lasse, um neue Songs automatisch zur Wiedergabeliste hinzuzufügen, zeigt er mir KEINES meiner gemappten LW an).


    Eine portable Version des TB, die auf einem der LW liegt, geht ohne Probleme. Die andere (s.o.) nicht. Wo der Unterschied zwischen den beiden Versionen liegt - keine Ahnung. Peter würde wahrscheinlich auf unterschiedliche Quellen tippen ;-)


    Bin inzwischen völlig ratlos ...

  • Hallo Blue Raven,

    Peter würde wahrscheinlich ...

    ... nach konkreten überprüfbaren Fehlermeldungen fragen.



    Fakt ist, dass sich ein korrekt erzeugter und mit den richtigen Parametern aufgerufener (gemounteter) True- oder Veracrypt-Container genau so wie ein reelles Laufwerk verhält.
    Es ist eben die Frage, wie du den Container mountest. Am besten, du legst dir ein Script an, welches den Container immer an exakt den gleichen Ort einbindet. Auf der WinDOSe also auf einen sonst freien Lw-Buchstaben. Und dann testest du, ob dieses auch immer so erfolgt und ob dieses virtuelle Lw auch immer von dir beschrieben werden kann.
    Ich empfehle auch, immer eine normale FAT-Formatierung zu nehmen. Damit umgehst du Probleme durch die Rechtevergabe bei NTFS.
    (BTW: ich nutze ebenfalls diverse VC-Container, so zum Bsp. auf meinem Linux-Desktop - ohne verschlüsselte System-SSD - wo ich (nur!) die Daten meines Banking-Programms "Moneyplex" in den Container gepackt habe. Auch mit anderen Programmen greife ich - dort wo ich es für notwendig betrachte - auf Daten zu, welche sich im ungemounteten Zustand in einem Container befinden. Weder ich noch die Programme haben jemals damit ein Problem gehabt.)


    Ein Problem tritt immer auf, wenn der Thunderbird gestartet wird, bevor der Container gemountet ist. Der in der profiles.ini genannte Pfad für das Profil muss immer vor dem Start des TB beschreibbar vorhanden sein. Und bis ein Container gemountet ist, kann es einige Sekunden dauern! Gerade bei VC, wo dieser Vorgang aus gutem Grund bewusst etwas verlangsamt wurde.


    Dann habe ich wohl auch geschrieben, dass du zur Einrichtung des TB (beim dessen erstem Start) den Profilmanager benutzen sollst. Wenn du das gemacht hast, dann ist in der profiles.ini automatisch der richtige Pfad eingetragen und du spartst dir die "Frickelei" mit dem Editieren dieser Datei.


    Der einzige "Vorteil" der portablen Version ist, dass durch den festen Zusammenhang zwischen Programm und Profil letzteres immer an einem fest definierten Ort relativ zum Programm liegt. Also, egal, wo du das Programm hinkopierst, ist sein Profil mit ihm fest verbunden.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,


    Danke für Deine Antworten.


    > konkreten überprüfbaren Fehlermeldungen fragen


    Tja, wenn ich die hätte ... - ich kenne nur die Symptome.


    Mal zu der Art wie ich arbeite:


    1. Sowohl die Datendatei als auch das externe LW haben IMMER die selben LW-Buchstaben. Sonst funktionieren die Links auf meinem Desktop nicht. Und manche Programme wie Mediamonkey und Winamp sind da etwas sensibel,wenn man den LW-Bustaben ändert. Dann fängt das gesamte Bibliothek-Einlesen wieder von vorne an und der Überblick für mich, was abgearbeitet ist, ist für die Tonne.


    2. Da ich mit der portablen Version von TB gearbeitet habe, kann ich TB nicht starten, bevor VC oben ist. Gilt (für mich) logischerweise auch für die neue Installation, da mein Profil ja im Container liegen soll.


    3. Den Profilmanager des TB hatte ich genutzt. Geht trotzdem nicht er scheint den Pfad nicht zu finden (ini hatte ich ja schon gepostet).


    4. Völlig merkwürdig ist, dass, wenn ich die (inzwischen wieder komplett aktuelle und einzig funktionierende) Backup-Version (auf meinem Datencontainer Daten-LW Y:) auf den Datencontainer (LW G:) kopiere und dort starte, funkt es ebenfalls nicht.


    5. Völlig unklar ist für mich die Tatsache, dass Winamp (funktionierte bis letzte Woche Mittwoch oder Donnerstag einwandfrei gegen Y:) auf einmal kein einziges (!!!) gemountetes LW mehr erkennt. Sprich: Obwohl die LW einwandfrei im Windows-Explorer erkannt werden, die Mediamonkey-Version (Portable, komplett auf Y:) fröhlich vor sich hindudelt, TB lokal dort läuft, man kopieren und was weiß ich kann, weigert sich Winamp auf einmal, jegliches dieser LW zu erkennen. Hier sehe ich den Ansatzpunkt für das Problem: Es scheint so, dass (z. B. auch die normale Version) TB die gemounteten LW nicht mehr erkennt - was aber über meinen geistigen (IT-) Horizont geht.


    Ich habe versucht, durch Deinstallation von VC 1.17 und Neuinstallation von VC 1.16 das Problem zu lösen - weil damit hatte es ja bis letzte Woche einwandfrei geklappt. Leider funktioniert das auch nicht mehr.


    > Weder ich noch die Programme haben jemals damit ein Problem gehabt.


    Genau das selbe hätte ich bis letzte Woche Freitag auch so unterschrieben - und ich arbeite damit auch schon ein paar Jährchen (mindestens 6-7). Deshalb ist mir das ja zu hoch ...


    Als letzte Ursache könnte es eines dieser Windows-Patches von letzter Woche sein ... - was ich mir auch nicht wirklich vorstellen kann. Obwohl: das Nichterkennen der gemounteten LW ist doch sehr merkwürdig ...


    Viele Grüße



    Blue Raven