Emailversand mit Anhang erzeugt Timeout - Mails werden aber gesendet

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 45.3.0
    * Betriebssystem + Version: Windows 7 Professional SP 1 64 bit
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX): diverse (z.B. Allinkl, 1und1)
    * Speicherdienst (z.B. Dropbox):
    * Eingesetzte Antivirensoftware: Avast - ausgehender Mailversand wird nicht überprüft
    * Firewall (Betriebssystem-intern/Externe Software): Avast


    Hallo liebes Forum,


    seit einigen Tagen habe ich beim Senden von Emails mit Anhängen >100Kb folgendes Verhalten:
    Ich klicke auf "senden", dann "rennt" der Ladebalken direkt auf 100% (also sehr schnell - egal wie groß der Anhang ist) und bleibt so stehen.
    Dann nach einiger Zeit wenn ich nichts weiter mache kommt die Meldung:
    Senden der Nachricht fehlgeschlagen. Die Nachricht konnte nicht gesendet werden, weil die Verbindung mit dem SMTP-Server smtp.web.de ihre Ablaufzeit (Timeout) überschritten hat. Versuchen Sie es nochmals.


    Die Mail wird allerdings dennoch gesendet! Habe ich mehrfach getestet. Jedoch kommt immer die Fehlermeldung und auch ein Kopieren in den Ordner gesendet passiert nur selten.


    Alles andere funktioniert perfekt. Ich kann Emails abrufen und auch größere Datenmengen empfangen.



    Router ist schonmal ausgeschlossen ... habe über mein Iphone einen Hotspot aufgemacht und da passiert das gleiche.
    Avast Internet Security hatte ich zeitweise komplett ausgeschaltet - bringt nichts. Steht jetzt auf Mailversand ausgehend nicht überwachen.


    Sonst habe ich noch winpatrol (free edition) und spybot laufen. Sonst keine Defender.


    Es ist zum Verzweifeln. Ich habe gegoogled und vieles ausprobiert (STARTLS anstatt SSL/TLS, Thunderbird deinstalliert und neu installert mit altem gesicherten Profil genommen, Globalen Index ausgeschaltet).


    Woran kann das liegen?
    Wäre sehr dankbar für eine Lösung. So kann ich nicht wirklich arbeiten.


    Viele Grüße
    Sepp

  • Guten Tag Sepp, und willkommen im Forum!


    Wenn du bestätigen kannst, dass die gesendeten Mails wirklich alle beim Empfänger ankommen (*), dann gehe ich ganz einfach mal von dem altbekannten Problem beim Kopieren in den auf dem IMAP-Server liegenden "Gesendet"-Ordner aus. (Dazu gibt es gefühlte 168 Beiträge hier im Forum ;-))


    Das reine Senden einer Mail erfolgt ja über das "SimpleMailTransportProtocol" an den gleichnamigen Server deines Providers. Das funktioniert bei richtiger Konfiguration (richtig ist, so wie es auf der Webseite deines Providers steht) auch fast immer problemlos. Zumindest, wenn du die Überwachung der Verbindung zum SMTP-Server deaktiviert hast. Die Überwachung dieser Verbindung ist IMHO so wie so sinnfrei.


    Wenn eine Mail gesendet wurde, erfolgt das nachträgliche Kopieren in den festgelegten "Gesendet"-Ordner. Dieses ist ein reiner plumper Kopiervorgang und erfolgt bei einem mit IMAP eingerichteten Konto auch per IMAP und in den bewussten Ordner auf dem Server. Und genau dabei treten sehr häufig die beschriebenen Fehler auf. (Vermutlich hat das etwas mit der Anzahl der Verbindungen zum Server zu tun.)


    Lösungen:

    • Manche User berichten, dass es ausreicht in den Konten-Einstellungen für die Ablage die "zweite Variante", also "anderer Ordner" und dann den "Gesendet"-Ordner auf dem IMAP-Server zu wählen. Von den Einstellungen her ist das zwar der gleiche Ordner, wie in der ersten Variante, aber es soll so funktionieren. Wer weiß, warum ... .
    • Du wählst nicht den "Gesendet"-Ordner auf dem Server, sondern den gleichnamigen Ordner in den "Lokalen Ordnern". Damit ist das ein rein lokaler Kopiervorgang - und der funktioniert immer! Wenn du keinen Zwang hast, von mehreren Clients aus auf die gesendeten Mails zuzugreifen, dann ist das das Mittel der Wahl. Selbstverständlich kannst du die lokal gespeicherten gesendeten Mails auch mit der Maus in den "Gesendet"-Ordner auf dem Server verschieben. Auch das funktioniert (außerhalb des Sendevorgangs) immer.
    • (*) Diese Variante ist für mich die optimale Variante. Ich nenne sie die "ultimative Sendebestätigung".
      Wie schon gesagt, handelt es sich normalerweise um einen plumpen Kopiervorgang. Dieser gibt dir keinerlei Gewähr, dass wirklich gesendet wurde! Also dieses Kopieren zuerst deaktivieren!
      In den Einstellungen gibt es aber die Option, jede von dir gesendete Mail zusätzlich und vom Empfänger unbemerkt per BCC an eine deiner eigenen Adressen zu senden. Wenn du dann diese Mail wenige Sekunden später erhältst, hast du die ultimative Bestätigung, dass dein Client diese Mail deinem SMTP-Server erfolgreich übergeben und dieser sie auch weitergeleitet hat. Mehr ist mit dem alten Protokoll nicht möglich. Aber durch bestimmte Einträge in den Headerzeilen ist schon deutlich zu sehen, dass diese Mail von deinem SMTP weitergeleitet wurde.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hi Peter,


    erstmal vielen Dank für deine ausführlichen Ausführungen, die alle sehr gut nachvollziehbar und verständlich sind.


    Ich fürchte nur, dass die Sachen, die du vorgeschlagen hast, das Problem und dieses komische Verhalten mit dem Ladebalken nicht beheben werden. Das ist ja eigentlich das, was nicht funktioniert. Scheinbar bekommt Thunderbird keinerlei Info vom Server wieviel hochgeladen wurde und wieviel nicht (oder warum "zischt" der Ladebalken auch bei Emails mit 5 Megabyte superschnell auf 100% obwohl das nicht den wahren Ladegrad widerspiegelt?). Und es bekommt auch nicht mitgeteilt, dass die Mail gesendet wurde - sonst würde es doch nicht "Senden fehlgeschlagen" melden. Oder irre ich mich? Sprich die Kommunikation mit den Servern über den Status der Email scheint irgendwie defekt.


    Was du schreibst bezieht sich nur auf das kopieren in den gesendet Ordner, (was, wenn ich es recht bedenke, nur in den Fällen klappt in denen die Mail auch erfolgreich gesendet wurde - dieser Kopiervorgang also überhaupt angestoßen wird). Jedoch wird, wenn ich mit größerem Anhang sende, ja noch nichtmal der Kopiervorgang angestossen, da ja "Senden nicht möglich." Ich habe dann ja lediglich die Möglichkeit abzubrechen oder neu zu versuchen. Ein Speichern als Entwurf ist dann auch nicht möglich bzw. bekommt ein timeout.


    Ich hoffe es ist verständlich ausgedrückt. Nicht der Kopiervorgang ist das Problem, sondern nach wie vor das Senden (welches zwar klappt, Thunderbird aber weder merkt noch richtig darstellt (siehe Ladebalken und Meldung).
    Was mich wundert ist, wieso das jahrelang klappt, man dann den Rechner einschaltet und es plötzlich nicht mehr geht? Woran kann das denn liegen?


    Vielen dank im voraus! Entschuldige mein Kauderwelsch. :)

  • Hallo Sepp,

    (oder warum "zischt" der Ladebalken auch bei Emails mit 5 Megabyte superschnell auf 100% obwohl das nicht den wahren Ladegrad widerspiegelt?).

    Es wird angezeigt, wie die Daten den Thunderbird verlassen. Wenn diese Daten später gecached werden, verlassen sie "blitzschnell" den TB und landen im Cache. Dies kann beispielsweise auch der AV-.Scanner sein, welcher vielleicht doch noch im Spiel ist? Empfehlung: diesen testweise komplett deinstallieren, Neustart und bis zur Neuinstallation etwas Vorsicht walten lassen.


    Wie sieht es jetzt aus?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hi Peter,


    nachdem sich nun auch andere Uploads irgendwie komisch verhalten haben, habe ich einfach ein altes (Februar) Systembackup eingespielt. Das war einfacher ... Ich danke dir trotzdem sehr herzlich für deine Mühen Peter! Das Thema kann geschlossen werden.


    Viele Grüße
    Sepp