Passwörter geändert - Start extrem langsam

  • Ah - ja. danke für den Hinweis...


    Das ist ganz neue Materie zum Reinarbeiten für mich


    Jetzt dann mit Timestamp.


    Sieht aus, als würde wirklich jedes Konto plötzlich 3 Sekunden brauchen - aber kann man aus dem Log erkennen, warum auf einmal?

    Files

    Gruß Thomas

  • aber kann man aus dem Log erkennen, warum auf einmal?

    Man vielleicht schon. Ich nicht. Ohne Dokumentation kann ich mir nur zusammenreimen, was die einzelnen Einträge bedeuten könnten. Bei einigen ist das einfach, bei anderen nicht.


    Dadurch, dass die Konten parallel abgerufen werden, ist es außerdem sehr mühsam, einem bestimmten Vorgang zu verfolgen.

    Außerdem hast du 6 Konten eingerichtet, obwohl doch der "Fehler" schon mit zweien auftritt. Das macht es nicht leichter, den Überblick über das Log zu behalten.


    Was mir beim Überfliegen aufgefallen ist:


    Die größte Verzögerung liegt zwischen diesen beiden Events:

    Code
    1. 2018-03-29 09:17:13.843000 UTC - 1332[19d7d210]: 124b9000:imap.gmail.com:S-INBOX:CreateNewLineFromSocket: + idling
    2. 2018-03-29 09:17:21.797000 UTC - 5752[3812140]: POP3: [this=1a836bc0] ~nsPop3Protocol()


    Dazwischen liegen rund 8 Sekunden, in denen zumindest keine Kommunikation mit den Mailprovidern stattfindet. Wenn ich mal annehme, dass die Zahlen, wie 1332[19d7d210] sozusagen einen Mail-Thread identifizieren, dann steckt hinter 1332 dein Konto5.

    Jetzt wird es interessant: 5752[3812140] scheint auf den ersten Blick dein POP-Konto zu sein. Unter dieser Nummer findet sich aber auch eine IMAP-Verbindung.

    Also entweder stimmt meine Annahme nicht, oder du hast dieses Konto sowohl als POP wie auch als IMAP eingerichtet.


    Dazu ist noch etwas aufgefallen: unter 5752[3812140] gibt es später Kommunikation mit einem SMTP. Da wurde eine Mail an dein Konto3 gesendet. Auch das ist natürlich kontraproduktiv, wenn man sich durch die Logs wühlt, und schon echt ärgerlich.


    Ebenfalls zu diesem Konto gibt es mehrer Fehlermeldungen:

    Code
    1. 2018-03-29 09:17:10.484000 UTC - 5752[3812140]: POP3: [this=1a836bc0] RECV: -ERR Unknown command: AUTH
    2. 2018-03-29 09:17:30.353000 UTC - 5752[3812140]: SMTP connection error quitting 804b0002, ignoring
    3. 2018-03-29 09:17:31.369000 UTC - 5752[3812140]: failed creating protocol instance to play queued url:imap://Konto3@gmx.de@imap.gmx.net:993/fetch>UID>/INBOX>31


    Weiter geht's. Du synchronisierst neben den IMAP-Posteingängen noch eine ganze Menge weiterer Ordner. Einer davon heißt treffenderweise auch noch "Synchronisierungsprobleme" und hat selbst wiederum ebenfalls synchronisierte Unterordner. Das betrifft wohl dein Outlook-Konto. Kann man aus der Tatsache, dass du solche Ordner hast, schließen, dass es hier schon vorher Probleme gab?


    Mehr Zeit werde ich jetzt nicht investieren, zumal das recht aufwendig ist und ich durch die Logs den Eindruck gewonnen habe, dass du bisher so einiges vergessen hast zu erwähnen. Da darst du dich schon schön selbst durchwühlen.

    Edited once, last by Drehmoment ().

  • Hallo Drehmoment und vielen Dank für's "Durchwühlen"


    Dieser Log zeigt jetzt das voll aufgesetzte TB mit allen Erweiterungen, also auch Synchronisationen mit Kalendern und Adressbüchern.


    Die eingefrorene Verzögerung am Start ist aber identisch, wenn ich die 6 Konten frisch angelegt habe und keine Termine und Adressen synchronisiere.

    Danach läufts ja flüssig...


    Es ist sicher kein Konto als POP und IMAP gleichzeitig angelegt (zumindest nicht von mir).


    Einen Ordner Synchronisierungsprobleme gibt es auch nicht, da werde ich mal weiter suchen müssen.


    Nochmal danke für deine Zeit und deine Anregungen


    Falls ich irgendwas finde, gebe ich Bescheid, falls nicht, bleibt es wohl so wie es ist - TB anwerfen und erst mal ein paar Sekunden warten.

    Wie gesagt, jetzt ist es mehr Neugierde, wieso die plötzliche Änderung auftrat.

    Gruß Thomas

  • Einen Ordner Synchronisierungsprobleme gibt es auch nicht, da werde ich mal weiter suchen müssen.

    Laut dem Log gibt es die:



    Sind das vielleicht Ordner, die bei outlook.com standardmäßig angelegt werden? Ich habe dort kein Konto und kann es deshalb nicht überprüfen.

  • Ich habe jetzt mal die nicht Gmail Konten entfernt und in Opera Mail angelegt, da die nur für Logins etc sind.


    Pro Gmail Konto braucht TB 2-3 Sekunden beim ersten Start, das ist für mich OK


    Die Outlook Ordner gibt’s tatsächlich...

    Gruß Thomas

  • Die Outlook Ordner gibt’s tatsächlich...

    Ja, die Logs lügen nicht. Die spannende Fragen wären: Wenn du sie nicht angelegt hast, wo kommen sie dann her? Haben sie einen Inhalt? Vielleicht sogar einen, der auf Probleme hinweist? Die Namen lassen ja so etwas vermuten.

  • Hallo Drehmoment


    Habe ich auch nicht behauptet :D


    Nein, sie haben keinen Inhalt und - das ist interessant - im Outlook Konto per Web Interface existieren sie auch nicht.


    Allerdings sind sie jetzt weg, da ich diese Konten - wie schon geschrieben - ausgelagert habe.

    Wenn ich Zeit habe, lege ich noch mal ein nacktes Profil mit den drei Gmail Konten an und logge den Start.

    Gruß Thomas

  • So, neues Profil mit meinen drei Gmail Konten angelegt, Log siehe Anhang


    Interessant sind diese Zeilen:


    2018-04-03 09:51:32.850000 UTC - 8340[3412140]: 17e83000:imap.gmail.com:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN

    2018-04-03 09:51:35.897000 UTC - 8340[3412140]: 17e8e800:imap.gmail.com:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN

    2018-04-03 09:51:38.897000 UTC - 8340[3412140]: 1234d000:imap.gmail.com:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN


    Nach diesen ist immer eine 3 Sekunden Pause, die es so vor den neuen Passwörtern nicht gab - leider habe ich da nichts geloggt - gab ja auch keinen Grund.


    Die Suche nach dem String:

    imap.gmail.com:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN

    hat mich auch nicht weiter gebracht, alles, was ich dazu fand, bezog sich darauf, das gar keine Verbindung mehr ging.


    Evtl. sollte mal den Gmail Support fragen bzw. da in ein Forum gehen...

    Files

    Gruß Thomas

  • Interessant sind diese Zeilen:

    Wie gesagt, ich kann die Logs auch nicht lesen. Die Texte in den Logs sind ist ja nichts, was in einem RFC genormt wurde. Die wurden von den Entwicklern des Thunderbirds so festgelegt. Ohne Doku ist es für einen Außenstehenden schwer, genau nachzuvollziehen, was die Zeilen besagen sollen.

    Mit etwas gesundem Menscheverstand kann man sich trotzdem einiges zusammenreimen. Es bleibt aber immer ein wenig spekulativ.


    Ich verstehe die Logs anders als du. Die Zeilen mit dem clearing IMAP_CONNECTION_IS_OPEN besagen meiner Meinung nach nur, dass hier eine Statusvariable gelöscht wurde. Mit der eigentlichen Verbindung hat das noch nichts zu tun. Das erfolgr erst danach.

    Die interessanten Zeilen sind für mich deshalb die nächsten. Die, die du ausgelassen hast.


    Ich verstehe es so:

    mit dem Entering bzw. dem Select beginnt der initiale Verbindungsaufbau. Der ist erst beendet, wenn der IMAP-Server mit OK geantwortet und seine Fähigkeiten mitgeteilt hat. Dann erst erfolgen der Login und das Abrufen der Mails


    Bei dir:


    Code
    1. 2018-04-03 09:51:35.850000 UTC - 8404[17d6cde0]: 17e83000:imap.gmail.com:NA:ProcessCurrentURL: entering
    2. 2018-04-03 09:51:35.850000 UTC - 8404[17d6cde0]: 17e83000:imap.gmail.com:NA:ProcessCurrentURL:imap://xxxgmail%2Ecom@imap.gmail.com:993/select%3E/INBOX: = currentUrl
    3. 018-04-03 09:51:42.273000 UTC - 8404[17d6cde0]: 17e83000:imap.gmail.com:NA:CreateNewLineFromSocket: * CAPABILITY IMAP4rev1 UNSELECT IDLE NAMESPACE QUOTA ID XLIST CHILDREN X-GM-EXT-1 XYZZY SASL-IR AUTH=XOAUTH2 AUTH=PLAIN AUTH=PLAIN-CLIENTTOKEN AUTH=OAUTHBEARER AUTH=XOAUTH
    4. 2018-04-03 09:51:42.305000 UTC - 8404[17d6cde0]: 17e83000:imap.gmail.com:NA:CreateNewLineFromSocket: 1 OK Thats all she wrote! p25mb93082861lji


    Zwischen der Anfrage des Thunderbird und der Antwort mit den Capabilities vergehen 6,5 Sekunden. Das scheint mir das Problem zu sein. Weshalb das so lange dauert, kann man an den Logs nicht erkennen. Vielleicht müssen die bei Google erst einen Thread in ihrer Überwachungs-, ich meine natürlich Analyse- , software starten. ;-)

  • OK, danke für die Rückmeldung... wenn's mich zu sehr nervt, werde ich mal Google anfunken

    Gruß Thomas