Problem beim Import des privaten pgp-Schlüssels nach Neuinstallation TB 78.5.0 auf W10 x64 und Raspi 3

  • Hallo zusammen,


    ich bin neu hier und muss gleich mit einem Problem nerven:)

    Auf W10 (x64, Version 1903) hat das Upgrade auf die 78.x mit Migration von Enigmail geklappt.

    Jetzt habe ich TB 78.5.0 neu installiert und beim Import des privaten PGP-Schlüssels werde ich nach einem Passwort gefragt.

    Das Passwort ist wohl nicht das normale Passwort das bei PGP und Enigmail zum Schutz des privaten Schlüssels abgefragt wurde.

    Und ein anderes Passwort habe ich nicht für PGP.


    Das Problem betrifft wohl nicht nur W10, sondern auch auf meinem Raspi 3 habe ich das gleiche Problem...


    Ich hoffe auf die Weisheit des Forums


    Liebe Grüße


    Zinn40

  • graba

    Approved the thread.
  • Beim Import fragt Thunderbird für jeden geheimen Schlüssel zwei Mal nach der zugehörigen Passphrase. Da diese Passphrase von da ab im Passwortspeicher des Thunderbird gespeichert wird, wird zu dessen Schutz ein Masterpassword benötigt. Damit wird der Passwortspeicher verschlüsselt.

    Dieses Passwort ist frei wählbar und hat nichts mit den Passphrasen der Schlüssel zu tun.

    Ich weiß nicht mehr aus dem Kopf, ob die Einrichtung dieses Masterpasswords beim Import gleich angefordert wird. Aber vermutlich ist dies das Passwort, das dich gerade verwundert.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Beim Import fragt Thunderbird für jeden geheimen Schlüssel zwei Mal nach der zugehörigen Passphrase. Da diese Passphrase von da ab im Passwortspeicher des Thunderbird gespeichert wird, wird zu dessen Schutz ein Masterpassword benötigt. Damit wird der Passwortspeicher verschlüsselt.

    Dieses Passwort ist frei wählbar und hat nichts mit den Passphrasen der Schlüssel zu tun.

    Ich weiß nicht mehr aus dem Kopf, ob die Einrichtung dieses Masterpasswords beim Import gleich angefordert wird. Aber vermutlich ist dies das Passwort, das dich gerade verwundert.

    Hallo Susi to visit,


    das ist wohl nicht des Rätsels Lösung...

    Zweispältiges Verhalten:

    Win10: nichts gemacht, Schlüssel wurde importiert.

    Raspi: Schlüsselimport funktioniert nicht:

    Meldung:

    "Bitte Passwort eingeben, um folgenden Schlüssel zu entsperren:

    <Schlüssel-ID, E-Mail-Addr, Datum der Erzeugung>

    Wenn ich jetzt ein beliebiges Passwort eingebe kommt keineswegs die Bitte das Passwort nochmal einzugeben, es kommt ein das Pop Up "Ihr Schlüssel wird importiert", dann plopt das erste PopUp wieder auf, da kann ich das PW so oft wiederholen wie ich möchte. Und die Passphrase des Schlüssels funktioniert auch nicht.


    Ich bin ratlos, zumal ich am TB unter W10 nichts verändert habe.


    Liebe Grüße


    Zinn40

  • Win10: nichts gemacht, Schlüssel wurde importiert.

    Ein Schlüssel, der eine Passphrase hat, kann ohne diese nicht benutzt werden. Er kann nicht mal gelesen werden, denn schließlich ist er damit verschlüsselt.


    Ups, sorry, war grad zu schnell mit dem Absenden. Weiter geht's.


    Wenn Win10 keine Passphrase verlangt, dann war entweder keine vorhanden (ich weiß gar nicht, ob das überhaupt möglich ist) oder der Schlüssel war zum Zeitpunkt des Imports bereits entsperrt.


    Meldung:

    "Bitte Passwort eingeben, um folgenden Schlüssel zu entsperren:

    <Schlüssel-ID, E-Mail-Addr, Datum der Erzeugung>

    Wenn ich jetzt ein beliebiges Passwort eingebe

    Die Meldung zeigt an, dass es hier um die Passphrase des Schlüssels geht, nicht um das Masterpassword. Somit sollte klar sein, dass du hier mit einem beliebigen Passwort nicht nicht weiterkommst.


    Ansonsten hast du bisher zu wenig Information gegeben. Es ist z.B. nicht klar, ob die Schlüssel Besonderheiten haben (Off Line Key, Sub Key, besonderer Algorithmus, etc. etc. ...)

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hallo Susi to visit,


    Der Schlüssel ist ein 1024 Bit DSA-Schlüssel, keine Besonderheiten. Einfach plain PGP.

    Und mit Enigmail hat immer die Passphrase abgefragt, da gibt es keine Irrtümer oder Vertipper...


    Liebe Grüße


    Zinn40

  • Wenn das mit DSA kein Tippfehler ist, dann meinst du vermutlich DSA + Elgamal. Das wäre zumindest eine kleine Besonderheit. Enigmail hat das zwar angeboten, standardmäßig war aber RSA 2048 gesetzt. Ob die aktuelle Implementierung im Thunderbird mit DSA + Elgamal umgehen kann, weiß ich nicht. Das habe ich nicht ausprobiert.

    Ebenso weiß ich nicht, ob im Falle von RSA 1024 Bit noch akzeptiert werden.


    Du kannst bis auf weiteres die Version 78 auch mit GnuPG und dem Schlüsselbund des Systems nutzen. Dazu ist ein Aufrufparameter anzugeben (-> Suchfunktion nutzen).

    Und mit Enigmail hat immer die Passphrase abgefragt, da gibt es keine Irrtümer oder Vertipper...

    Sag ich doch. Siehe #4.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hallo Susi to visit,


    laut Schlüsselvewaltung (GPA) 1024 bit DSA (+4096 bit Elgamal).


    Enigmail habe ich installiert, ist aber nicht im Menü sichtbar. Und die grooße Weisheit des Internets hat mir auch keinen Hinweis gegeben, mit welchem Parameter ich TB starten muss, damit Enigmail aktiviert wird...


    Ich muss jetzt aber erstmal TB updaten...


    Liebe Grüße


    Zinn40

  • Enigmail benötigst du dazu nicht mehr, lediglich die Schlüsselverwaltung, je nach Betriebssystem. Näheres dazu und auch den Konfigparameter findest unter dem Thema der Smartcards hier.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hallo Susanne,


    ich bin momentan etwas genervt, dass ich nicht dahinterkomme was, wie und warum es passiert ist :(

    Ich erwäge momentan drei Optionen:


    1. Ich nehme das Profil von w10 und schiebe es dem Raspi TB unter - Problem: Ist die Profilstruktur die gleiche und wo finde ich das Profil unter nix .

    2. Ich deinstalliere W10 TB 78.5.1 und installiere TB 68.x - Das aktuelle Profil soll ja nicht mehr passen, aber das kann man angeblich anpassen?

    3. Neuinstallation W10 (neue SSD, die aktuelle ist rappelvoll) und TB 68.x, gleiches Problem wie unter 2.


    Wenn ich viel Glück habe, habe ich noch ein Backup vom Profil vor TB 78.x


    Bei 2. und 3. käme anschließend das Update auf 78.5.x, in der Hoffnung, das dann alles wieder funktioniert...


    Liebe Grüße


    Zinn40

    1. Den Punkt verstehe ich nicht. Du hast oben geschrieben, du hättest am Raspi das gleiche Problem. Jetzt klingt es so, als wüsstest du gar nicht, wo das Profil hingehört.
    2. Ein Profil der Version 78 ist nicht rückwärtskompatibel. Es lässt sich aber wieder herrichten. Die Informationen, was dazu nötig ist, findest du in anderen Beiträgen hier im Forum. -> Suchfunktion
    3. Eine volle SSD ist nicht gut. Ob du deshalb Windows neu installieren musst, kann ich aus der Ferne nicht sagen. Vermutlich eher nicht, es sei denn, du hast es verwurschtelt. Das Windows selbst wird kaum die Ursache sein. Soviel Platz braucht es nun auch wieder nicht. Vielleicht genügt es, wenn du etwas aufräumst, auslagerst, löscht.

    Du hast diesen Thread wegen eines Problems beim Import der Schlüssel eröffnet. Nun scheint es so, als wäre eine Rundumhilfe gefragt. Das ist schon ok, aber an dieser Stelle steige ich dann aus. So viel Zeit habe ich trotz Lockdown Light beim besten Willen nicht. Sorry.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

    1. Den Punkt verstehe ich nicht. Du hast oben geschrieben, du hättest am Raspi das gleiche Problem. Jetzt klingt es so, als wüsstest du gar nicht, wo das Profil hingehört.
    2. Ein Profil der Version 78 ist nicht rückwärtskompatibel. Es lässt sich aber wieder herrichten. Die Informationen, was dazu nötig ist, findest du in anderen Beiträgen hier im Forum. -> Suchfunktion
    3. Eine volle SSD ist nicht gut. Ob du deshalb Windows neu installieren musst, kann ich aus der Ferne nicht sagen. Vermutlich eher nicht, es sei denn, du hast es verwurschtelt. Das Windows selbst wird kaum die Ursache sein. Soviel Platz braucht es nun auch wieder nicht. Vielleicht genügt es, wenn du etwas aufräumst, auslagerst, löscht.

    Du hast diesen Thread wegen eines Problems beim Import der Schlüssel eröffnet. Nun scheint es so, als wäre eine Rundumhilfe gefragt. Das ist schon ok, aber an dieser Stelle steige ich dann aus. So viel Zeit habe ich trotz Lockdown Light beim besten Willen nicht. Sorry.

    Hallo Susanne,


    dass eine volle SSD schlecht ist, weiß ich selber ;-). Und dass Sie voll ist liegt u.a. an Windows (Updates).

    Aber das ist nicht Deine Baustelle, und eher ein Nebenkriegsschauplatz...


    Wie ich schrieb irgendwie hat TB unter W10 den Schlüssel importiert, warum wieso weiß ich nicht und das nervt, da ich normalerweise Anderen bei Computerproblemen helfe und jetzt kann ich mir nicht mal selber helfen :-(.


    Ich hätte es ganz gerne genauso auf dem Raspi, aber da ich nicht weiß, was unter Windows passiert ist, bleibt nur die Hoffnung, dass ein kopiertes Profil den gewünschten Erfolg bringt, das Profil habe ich gefunden.


    Morgen ist ein neuer Tag und vielleicht geht dann irgendwas besser. Mindestens ein Workaround findet sich dann (hoffentlich!).


    Bis hierhin vielen Dank für Deine Hilfe und ich hoffe ich muss dich nicht noch mal wegen dieses Problems beanspruchen!


    Liebe Grüße


    Oliver

  • Also, um das für mich zu einem Abschluss zu bringen. Die meisten Linux-Distris sind immer noch auf der 68. Ich kann das gut nachvollziehen und werde mich hüten, die 78 manuell zu installieren. Ich kann eh beide Versionen (78 in Windows, 68 in Linux) nebeneinander benutzen. Es eilt nicht. Was dich dazu drängt, auf dem Raspi unbedingt die 78 zu installieren, ist für mich ein wenig unverständlich.


    Windows allein benötigt keinesfalls eine komplette SSD. Wenn du natürlich die Wiederherstellungspunkte seit Rames II aufbewahrst oder große Datenmengen auf der Systempartition/SSD liegen hast, dann überrascht es nicht. Daten lassen sich auslagern, die Wiederherstellungspunkte auf die letzten reduzieren. Da ist also vielleicht noch eine Menge Luft. Deshalb macht man seinen Rechner nicht platt. Dein Importproblem jedenfalls liegt gewiss nicht am Windows.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hallo Susanne,


    das Windows per se nicht das Problem für meine Probleme mit TB ist, ist schon klar.

    Aber das Windows hat schon ein paar Versionsupgrades hinter sich und den Schrott von wieder deinstallierten Programmen.

    Wiederherstellungspunkte gibt es keine - aber einen Thunderbird mit drei E-Mail-Konten. Auf zwei ist richtig Traffic und ich archiviere und lösche nicht, also sind da nahezu alle E-Mail-Korrespondenzen seit ca. 20 Jahren und viele logs drin...

    Ein Umzugsversuch für das Profil von der SSD auf die HDD ist - warum auch immer - gescheitert, obwohl ich Profile schon von einer Maschine auf eine neue umgezogen habe.


    Aber back to topic:

    W10 hat irgendwie den Schlüssel als privaten Schlüssel akzeptiert, ohne dass ich weiß was da geschah. Es wäre halt schön das Vorgehen zu reproduzieren, das möchte ich mit dem Pi machen, der eignet sich sehr zum experimentieren.

    TB ist 78.5.0 einfach mit sudo-install thunderbird installiert, da war nix mit Experiment meinerseits.

    FF hingegen ist 78er ESR, neuer geht nicht.


    Liebe Grüße


    Oliver