Posts by strzata

    Leider ist alles wieder wie vorher. Wenn der Hintergrundtask läuft (und das immer dann, wenn TB beendet wird), stürzt TB beim nächsten Starten ab und öffnet den Absturzmelder. Dann sind auch viele Kalendereinträge nicht mehr da.

    Mann oh Mann - welche Odyssee. Ich hab euch den ganzen Sonntag geklaut. Ich weiss nicht, wie ich mich so richtig bedanken kann.

    Dass ihr so uneigennützig euer Wissen anderen öffnet, ist bewundernswert und verdient grosse Hochachtung!


    Nun zum Eigentlichen: der Tipp von Sehvornix traf genau ins Schwarze. Die .json entfernt (hat TB neu angelegt) und die Sache war geritzt. Bin ich froh, dass ich die ganze Arbeit mit dem Neueinrichten nicht machen muss.


    Ich wünsche euch allen einen guten Start in die neue Woche (ohne Corona) ;-)

    Viele Grüße

    Norbert


    P.S. Wenn jemand von euch mal gaaaanz viel Zeit hat - es gibt noch eine offene Frage zu einem Problem, dass uns bei unserer täglichen Arbeit sehr belastet. TB 68.4.2 (aber auch schon die Vorgänger) zicken auf 4 Rechnern rum. Starten nicht richtig und Kalendereinträge fehlen. Vielleicht kommt jemand zufällig am Beitrag "TB unerklärlicher Hintergrund Task" vom 18.01.20 vorbei ...

    So, geschafft. Neues Profil erstellt. Und - funktioniert!

    Aber jetzt kommt bestimmt noch eine Hürde, oder?

    In meinem alten Profil gab es 6 Konten und 8 Kalender. Jeder mit Anbindung an unseren SAMBA-Server (sabredav) und auch an einen Google-Kalender. Die Kalender hatten unterschiedliche Farben für jeden Kalender und zig unterschiedliche Kategorien. Sollte so bleiben, denn ist nicht bedeutungslos. Das alles in das neue Profil zu übernehmen würde viele Stunden kosten. Wie soll ich jetzt also vorgehen?

    Quote

    kannst Du es einmal testweise in einem zusätzlichen, neuen Profil versuchen?

    Das hat mich auf die Idee gebracht, dass wir ja hier noch 5 weitere Rechner stehen haben. Auf einem anderen Rechner (auch mit 68.4.2) gibt es absolut kein Problem. Das Fenster "Öffnen mit" erscheint!

    Lässt sich das auf meinem Entwicklungsrechner (dieser hier) irgendwie reparieren? Für die Zertifizierung meiner Praxissoftware muss es hier laufen. Kann ich im Profilordner irgendwas löschen, damit der Fehler raus ist? Musste im FF mal sowas machen, weil hier der Zertifikatsspeicher defekt war. Oder sollte ich TB neu installieren? Nur erfahrungsgemäss wird dabei eh das alte Profil wieder übernommen.

    Schade. Ich muss für eine Online Prüfung ein Video abliefern, wo ich nachweisen kann, dass ich Mails mit ldt im Anhang verarbeiten kann. Ich weiss nicht, ob der Prüfer es akzeptiert, wenn ich das Attachment erst speichere und dann öffne. Könnte ich Dir eine solche Mail mal zum Testen zuschicken? Ist nur reiner Plaintext. Vielleicht liegts an der Mail und nicht an Windows. Oder wollen wir mal eine Teamviewersitzung machen?

    Schöne Grüße

    Norbert

    Vielen Dank!

    Hab Deine Anleitung befolgt. Hab die Datei aus TB in ein temp. Verzeichnis gespeichert. Ein Doppelklick darauf öffnet nun das File sofort im Editor. Klicke ich jedoch den Anhang in TB, öffnet sich das "Verfassen" Fenster. Wie ich schon gesagt hatte: die Mail liegt nicht in einem Ordner von TB, sondern als *.eml File auf der Festplatte. Dieses öffne ich mit Doppelklick. Ich habe nun auch mal diese Mail an mich selbst gesendet. Sie erscheint in meinem Posteingang mit dem Anhang. Auch hier: wenn ich den Anhang klicke, geht "Verfassen" auf. Speichern kann ich sie wiederum nach C:\temp und hier öffnet sie sich im Editor mit Doppelklick.

    Hast Du noch eine Idee?

    Danke Ingo,

    hab alles versucht. Die Extension ".ldt" z.B. finde ich gar nicht in "Standard-Apps". Wie man eine neue Zuordnung eines unbekannten Dateityps hinzufügt hab ich nicht gefunden. Hab dann alles zurückgesetzt. Grossputz kann nicht schaden. Dennoch kann ich keinen der Maschine unbekannten Dateityp öffnen. Es erscheint nur ein neues "Verfassen" Fenster. Rechte Maustaste (egal ob mit Shift, Ctrl oder Alt) bringt mir keine zusätzlichen Möglichkeiten. Hast Du noch einen Tipp? Kann ich Dir mal ne Mail mit einem Anhang (ist nur PlainText) zusenden?

    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 68.4.2
    • Wurde gerade auf eine neue Versionsreihe aktualisiert (bspw. von 60.* auf 68.*): nein
    • Betriebssystem + Version: WIN 10 Pro
    • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX):
    • Eingesetzte Antiviren-Software: ESET
    • Firewall (Betriebssystem-intern/Externe Software): ESET
    • Router-Modellbezeichnung (bei Sende-Problemen): FB 7490


    Hallo,

    auf der Festplatte sind Mails im eml-Format abgespeichert, die ich mit Doppelklick in TB öffnen kann. Teilweise haben die Anhänge spezielle Namen haben (z.B. *.ldt, *.oze und andere). Ich möchte diese Dateien mit dem Editor öffnen, da es eigentlich reine ASCII Dateien sind. Doch wenn ich sie anklicke, geht nur ein neues "Verfassen" Fenster auf. Mit Rechtsklick kann ich kein "Öffnen mit" auswählen. Haben die Anhänge ein bekanntes Format (z.B. *.pdf), dann geht sofort mein PDF-Viewer auf und zeigt sie an. Ich bilde mir ein, vor einigen Wochen noch kam bei unbekannten Dateitypen auch das Fenster "Öffnen mit". Hat sich das durch ein Update geändert? Wie kann ich es wiederherstellen?


    Danke für eine Antwort

    und freundliche Grüße

    Norbert

    Vielen Dank für die Antworten. Hab gestern auch noch gefunden, dass es in den Kalendereinstellungen die Möglichkeit gibt, "immer im Online Modus" zu starten. Wir werden das in den nächsten Tagen testen bevor wir TbSync ausprobieren. Hat jemand etwas gelesen, dass der Sync Button nicht synct?


    Dabei hab ich auch gemerkt, dass man den Absturzmelder abhaken kann. Ist im Moment auf allen Rechnern an. Könnte das der Hintergrundprozess sein? Auch dies werden wir im Verlauf dieser Woche testen.


    Grüße Norbert

    Das Problem mit Lightning ist gelöst. Ich darf bei den einzelnen Konten nicht die Offline Unterstützung einschalten. Sobald ich den Haken rausmache, synchronisiert sich der Kalender sofort. Es wird so sein, dass Lightning nicht merkt, dass man Termine direkt in der Datenbank eingegeben hat. Wahrscheinlich war es früher so, dass beim Starten von TB immer in die DB geschaut wurde. Vielleicht ist das nicht mehr so? Aber wenigstens der "Synchronisieren" Button müsste doch die Daten erneut aus der DB holen? Kann man da in about:config etwas einstellen? Oder wie könnte man mit dem Programmierer in Kontakt kommen?


    Das Absturzproblem ist leider immer noch vorhanden. Kann man in einem Log nachsehen? Wo finde ich das?

    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version:68.4
    • Wurde gerade auf eine neue Versionsreihe aktualisiert (bspw. von 60.* auf 68.*):ja
    • Betriebssystem + Version:WIN 10 Pro
    • Kontenart (POP / IMAP):
    • Postfach-Anbieter (z.B. GMX):
    • Eingesetzte Antiviren-SoftwareESET:
    • Firewall (Betriebssystem-intern/Externe Software):
    • Router-Modellbezeichnung (bei Sende-Problemen):


    Hallo,

    seit der TB 68.3 und jetzt auch mit der 68.4 haben wir nur noch Probleme. Eben habe ich den letzten von 6 Rechnern auf die 68.4 umgestellt (verlief automatisch). Hier läuft jetzt TB prima. Das war auf den anderen 5 Rechnern anfangs auch so. Mittlerweile gibt es dort immer wieder Abstürze und Lightning synchronisiert nicht richtig. Zwei Dinge sind dabei zu beobachten:


    Wenn TB beendet wird, trägt sich im Taskmanager ein Hintergrundtask ein, der ca. 150 MB Speicher beansprucht. Nachdem dieser ein bis drei Minuten gelaufen ist, wird er geschlossen und sofort erscheint der Absturzmelder. Das ist bei jedem User (es gibt auf jedem Rechner 4) gleich.


    Lightning ist an eine Sabredav Datenbank auf unserem Samba-Server angebunden. Wir schreiben meist Termine aus unserem Praxisprogramm mit SQL-Befehlen direkt in die DB. Das hat jahrlang gut funktioniert. Und wenn ich als Admin über den Browser in die DB schaue (http://server_xyz/sabredav/calendarserver.php/calendars/admin), sind die Termine auch alle ordnungsgemäss in den Tabellen eingetragen.


    Wenn dann in einem Kalender Termine fehlen, muss ich alle Kalender löschen (abbestellen) und neu anlegen. Ist eine aufwändige Arbeit, da für jeden der 4 User jeweils 6 Kalender neu angelegt werden müssen, und das mit verschiedenen Farben für die User und für die Kategorien. Bin ich damit mit einem Konto fertig, sind die Termine bei diesem User wieder da. Bei den anderen Usern erst, wenn ich auch hier die Kalender neu angelegt habe. Wenn ich mit allen 5 Rechnern durch bin, ist der Tag rum.


    Nachdem alles neu eingerichtet ist (habe ich in der letzten Woche drei Mal durch), funktioniert es ein paar Tage lang gut, abgesehen von dem Absturzverhalten. Dann treten wieder Störungen auf. TB habe ich schon mehrmals völlig neu installiert.


    Es ist jetzt 1 Stunde vergangen, seitdem ich auf diesem Rechner TB auf 68.4 gezogen habe. Anfangs erschien der Hintergrundtask beim Beenden von TB gar nicht. Jetzt eben habe ich das nochmal getestet: er scheint wieder, schliesst sich aber nach 1 Sekunde sofort wieder und eine Absturzmeldung erscheint nicht. Wie gesagt: das war bei den anderen Rechern gnauso und nach ein paar Tagen schloss sich der Task erst nach ein paar Minuten und TB stürzte ab.


    Wir hoffen sehr, dass es hier im Forum eine Hilfe zur Lösung des Problems geben wird. Danke.


    Gruß Norbert

    Also: wir haben überall die 32 Bit Version. Und auf dem zickenden Rechner habe ich festgestellt, dass nur auf dem Konto von Margitta (Kontowechsel erfolgt durch Ab-/Anmelden unter Windows, immer nur eins ist aktiv!) alles reibungslos funktioniert. Die drei anderen Konten sind beeinträchtigt.


    Mit offenem Taskmanager (TM) kann ich folgendes beobachten:

    Starten TB

    im TM erscheint der Task

    Beenden TB

    der Task im TM verschwindet oben, aber sofort erscheint er wieder unten als Hintergrundprozess

    wenn man ihn jetzt killt, ist alles okay

    nach ca. 1 Minute verschwindet er aber auch von selbst und dann kommt sofort der Absturzmelder


    Das ist aber nicht reproduzierbar. Manchmal erscheint der Absturzmelder auch nicht und man merkt erst dann, dass etwas nicht stimmt, wenn man TB startet und die Meldung kommt, dass er schon läuft.

    Danke! Jetzt gehts wohl ans Eingemachte. Und durch Deine vielen Fragen merke ich erstmal, dass ich selbst nicht so richtig in die Tiefe gegangen bin. Ich muss also dringend nachsehen, ob alle vier Profile betroffen sind. Dann muss ich auch noch die Versionen 32-64 vergleichen.

    wieso dann eigentlich Google?

    Weil wir es nicht hinbekommen haben, von der Aussenstelle über den bestehenden VPN-Tunnel Fritzbox zu Fritzbox auf die sabredav-Datenbank zuzugreifen. Es war für uns leichter: Hauptstelle-Kalender synchronisiert Google und Aussenstelle benutzt Google-Kalender.


    Die Profile befinden sich auf jedem PC nur lokal - es handelt sich nicht um einen Netzwerkspeicher.

    Genauso isses.


    Eine Synchronisation wird "lediglich" über einen Online-Kalender vorgenommen. Es werden nur Kalender mit Hilfe von SabreDAV synchronisiert

    Ja. Auf die Datenbank auf dem zentralen SAMBA-Server haben alle Zugriff.


    Es werden keine E-Mails synchronisiert.

    Mailkonten auf allen Rechnern gleich. Jeder holt direkt bei der Telekom ab (secureimap).

    Am Anfang hattest Du gesagt, dass man im Task-Manager keinen Prozess mehr laufen sieht. Später sagst Du, dass man immer den Hintergrund-Prozess sieht.

    Da lag ein Tag dazwischen. Habe zuerst keinen TB-Prozess gesehen. Dann aber gründlicher gesucht und den Hintergrundprozess entdeckt. Wenn ich den kille, dann startet TB ohne Probleme (siehe #5).


    Ich werde mich jetzt aufmachen, die noch offenen Fragen zu klären und mich mit dem "Update-Prozess" zu beschäftigen. Ich habe große Hoffnung, dass Du das dann "knacken" kannst. Ich bin Dir wirklich sehr dankbar!


    Viele Grüße Norbert

    Es gibt keine weiteren AddOns! TB ist jungfräulich. Der Kalender ist das einzige. Und der ist für uns absolut lebenswichtig. Sonst könnten wir unsere Praxis dicht machen (oder mit einem dicken Buch durch die Gegend rennen). Da ist Google eingebunden und hierüber wird eine AVM Steckdose in unserer Aussenstelle geschaltet (Technik hochfahren wenn wir auf dem Weg dorthin sind). Jede Mitarbeiterin hat den Kalender auf ihrem Handy und kann Termine einsehen, vergeben und löschen. Die sabredav Tabellen liegen auf einem SAMBA-Server in unserem Praxisnetz. Wir machen da mit TB keine Experimente. Wir hatten bis zur 60er Version noch ein Purge drauf, damit die Datenbank auf dem Server nicht voll läuft. Aber das haben wir mittlerweile auch deinstalliert, da zu lesen war, dass es mit der 68er nicht mehr geht (weiss da jemand Ersatz?).


    Irgendwas im Profil auf dem einem Rechner ist korrupt. Die 68 haben wir noch auf drei weiteren Rechnern unter WIN 10. UInd hier gibt es keine Probleme. Wie gehe ich nun vor, um mir die wenigste Arbeit zu machen? Alle Mailadressen und Kalender möchte ich nicht neu eingeben müssen. Sonst hätte ich schon alles von TB vom Rechner geworfen und eine Neuinstallation gemacht. Den Inhalt der Profile (es sind auf diesem Rechner 4 Stück für 4 Mitarbeiterinnen) könnte ich ja eventuell von den funktionierenden Rechnern rüberkopieren. Aber wie hier im Forum zu lesen ist, hat das ja auch seine Tücken. Welche "kleineren" Schritte könnte ich nun erstmal unternehmen?

    Nachdem ich Lightning deinstalliert hatte, läuft TB ohne Probleme. Hab es heute neu installiert. Ist ja glücklicherweise eine Sache von wenigen Sekunden. Aber sofort ist das Problem wieder da: TB meldet, dass er erst beendet werden muss, damit er neu gestartet werden kann. Das kommt jedesmal beim Start. Und ab und zu kommt auch der Absturzmelder dazwischen. Schuld ist ein Hintergrundtask (zu sehen im Taskmanager), der nach dem Schliessen von TB weiter läuft.


    Habe jetzt Lightning mehrere Male de- und wieder installiert. Das oben beschriebene ist reproduzierbar.

    Okay, Danke. Werde es am Wochenande in Angriff nehmen.

    Und nein - diese roten "Text-Zeilen" erscheinen nicht. Und ich habe Ähnliches auch bis jetzt nicht gesehen. Deshalb weiss ich tatsächlich nicht, was sie bedeuten. Fest steht, dass TB auf diesem Rechner nicht korrekt beendet wird und ein Hintergrundprozess aktiv bleibt, der das Neustarten beeinträchtigt. Ob das tatsächlich an Lightning liegt werde ich wissen, wenn ich es deinstalliert habe.

    Viele Grüße

    Norbert

    Danke!

    Na so ganz gleich ist es wohl doch nicht. Ein Quelltext geht nicht auf. Eine Profilübernahme hat nicht stattgefunden. Sprachpakete sind nicht installiert. Soll ich dennoch mal versuchen, Lightning neu zu installieren? Ich scheue mich ein bisschen davor, da wir 8 Kalender (für jede Mitarbeiterin einen eigenen mit eigenen Farben und eigenen Kategorien) haben und das alles genauso wieder hinzubekommen ist schon aufwändig. Die Kalender liegen in einer Sabredav MySql Datenbank auf einem Samba-Server. Oder kann ich die Kalender irgendwie sichern und nach Lightning-Neuinstallation wieder einspielen?