Gibts was neues zum Thema Mails verschlucken?

  • Hallo Forum,


    es gibt ja schon einige Mails zum Thema "Thunderbird verschluckt eMails", leider alle ohne nennenswerte Ergebnisse (von einigen Flames mal abgesehen)..


    Ich ziehe also meine Asbestunterwäsche an, und versuche es mal aufs neue..


    Was tut sich zu dem Thema? Ich hab jetzt lange Zeit Thunderbird getestet, und es ist tatsächlich so. Einige mails werden einfach verschluckt. Es liegt nicht an Junk-Einstellungen, nicht an Filtern, und auch nicht daran, dass ich zu blöd sein könnte, TB einzurichten bzw. zu bedienen.


    Ich hab nen serverseitigen Spam-Filter am laufen, darum ist mir das auch erst aufgefallen. Seitdem hab ich TheBat nebenher zur Sicherheit am laufen, und da geht immer mal wieder eine Mail ein, die Thunderbird einfach nicht anzeigt.


    Hab auch alle nicht soo wichtigen Erweiterungen gelöscht, aber das bringt auch nix.


    Irgendwas neues? Ein spezielles Muster, welche Mails "verschluckt" werden, kann ich nicht erkennen..


    Wäre über ein Statusupdate echt dankbar..


    Wem geht es eigentlich noch so??


    Gruß
    Herrmann

  • Hallo Herrmann,


    eigentlich ist das auch ein Problem, das mich brennend interessiert.
    Nicht nur, daß Mails nicht abgeholt werden, sondern auch doppelt und
    mehrfach. Ich gehe mal davon aus, daß Du POP3 verwendest, aber die Mails
    auf dem Server läßt, sonst könntest Du kaum parallel einen anderen
    Client benutzen.
    Das Problem ist IMO die Art und Weise, wie sich Thunderbird die
    abgeholten Mails merkt, in der Datei popstate.dat. TheBat hat den
    Postfachinspektor, wo man Mails jederzeit manuell als gelesen oder
    ungelesen markieren, löschen oder abholen kann. Inzwischen benutze ich
    auch separate Tools wie kshowmail zur Überwachung meiner Postfächer,
    weil ich in dieser Beziehung zu wenig Vertrauen zum TB habe -
    leider. Es liegt nicht am TB allein, offenbar tritt das Problem bei
    bestimmten Providern verstärkt auf, es gab dazu einige Beiträge. Es
    kann passieren, daß sich die normalerweise eindeutige Mail-ID ändert,
    dann gerät der TB durcheinander. Das ist jetzt eine mögliche Ursache -
    eher für mehrfach abgeholte Mails. Eine andere sind Timeouts bei
    "großen" Mails.
    Eine Lösung wäre der Umstieg auf IMAP, soweit möglich, oder eine bessere
    Synchronisation zwischen Client und Server bei POP3 - aber damit ist
    vorerst wohl nicht zu rechnen - vielleicht in der 2.0 ?


    Gruß, muzel

  • Moin miteinander,


    1. Es gab lange Zeit ein Problem in Verbindung mit "nur Kopfzeilen abholen". Dabei gingen tatsächlich Mails verloren.
    Dieses Problem existiert nicht mehr.
    2. POP-Timeout: Auch ich hasse die Einführung der Timeouts...
    Man kann aber den Timeout beliebig hoch einstellen:
    http://www.thunderbird-mail.de/hilfe/faq/#allgemein_timeout
    In TB-1.5 wird es dafür eine Möglichkeit in der GUI geben.
    3. popstate.dat: Hier gibt es ein Problem mit einigen Providern, deren Server die UID öfters mal ändern (was so eigentlich nicht vorgesehen ist, da es dadurch ja keine eindeutige ID mehr ist). - AFAIK sind v.a. die Provider von United Internet betroffen.
    Abhilfe: Keine, außer Providerwechsel oder auf IMAP umsteigen, wenn man die Mails von verschiedenen Rechner aus verwalten will.
    Generell sind dadurch die doppelt heruntergeladenen Mails zu erklären, aber auch nicht heruntergeladene Mails wären denkbar, wenn eine neue Mail eine UID erhält, die TB als schon heruntergeladen in der popstate.dat vermerkt hat.
    4. "Verlorene Mails" generell: Es kommt/kam desöfteren vor, dass TB manche Mails nur nicht anzeigt. Um zu überprüfen, ob dieser Fall vorliegt, kann man den entspr Posteingang komprimieren, TB schließen, die entspr. INBOX.msf löschen, TB starten.
    Nun sollten in jedem Falle alle vorhandenen Mails angezeigt werden.
    Generell wird dieses Problem und auch andere plötzlich verschwundenen Mails von Drittprogrammen (z.B. Virenscanner...) hervorgerufen, die TB beim Zugriff auf Dateien im TB-Profil behindern oder eigenständig in Dateien im TB-Profil herumschreiben.



    Ein darüber hinausgehendes generelles Problem mit dem POP3-Abruf kenne ich nicht.


    Gruß,
    Michael

  • Ich habe das oben beschriebene Problem und das Problem soll in version 1.5.0.9 gefixt sein, wann kommt die denn raus?

  • Einen exakten Termin kenne ich nicht. Doch haben die oben genannten Probleme (aus 2005 und davor) nichts mit dem aktuellen bug zu tun, der in 1.5.0.9 behoben sein wird.
    Laut der Kommentare der Entwickler tritt letzterer nur unter recht seltenen Bedingungen auf (identische message ID für zwei oder mehr E-Mails) und betrifft daher fast auschließlich Spam. Näheres dazu in bugzilla und einigen Threads hier im Forum.

  • Nein das stimmt nicht
    Mails von Boards mit Benachrichtigungen verschwinden auch sowie mails von golem

  • "Flanagan" schrieb:

    Nein das stimmt nicht ...


    Ich habe ja nicht Ihrer Aussage widersprochen, dass Ihnen Mails verloren gegangen sind. Ich stelle nur fest, dass die oben beschriebenen, möglichen Ursachen aus dem Jahr 2005 nichts mit dem aktuellen bug zu tun haben, der in 1.5.0.9 gefixed sein wird. Und das stimmt sehr wohl.
    Ferner hat David B. in dem bug recht genau beschrieben, unter welchen Umständen genau dieser Fehler zum Tragen kommt, und dazu gehört die identische Message-ID, die bei regulären E-Mails nicht vorkommen sollte.


    Sie sollten nicht den Fehler machen, das offensichtliche Verschwinden Ihrer E-Mails auf diesen Bug zu schieben, ohne dafür klare Hinweise zu haben. Vielleicht treffen die Bedingungen des Bugs ja in Ihrem Fall zu, aber dann haben Sie nicht das gleiche Problem, wie oben beschrieben.


    Sie sind nicht der/die erste, dem/der Mails verloren gehen. Solche Fälle hat es leider schon lange vor der 1.5.0.8 gegeben. Nach der Bekanngabe des erwähnten Fehlers glauben nun natürlich viele, dass Sie Opfer dieses bugs in der 1.5.0.8 seien. Aber ist das sicher oft nicht zutreffend.


    In der Vergangenheit waren in vielen Fällen die Mails übrigens nicht wirklich verloren sondern wurden nur nicht angezeigt. Es gab verschiedene Ursachen, z.B. die oben von nixblicker beschriebenen. Virenscanner sowie die genannte "Nur-Kopfzeilen-Option" (insbesondere in Verbindung mit Web.de) gehören zu den Top-Kandidaten. Dazu gibt es hier hinreichend Threads.


    Welche Ursache bei Ihnen vorliegt, kann Ihnen zur Zeit niemand definitiv sagen. Dazu bräuchte es nämlich deutlich mehr Hinweise Ihrerseits oder die berühmte Glaskugel. Sie können aber folgendes tun:


    - Falls die E-Mails, die bei Ihnen verschwinden, den Kriterien des Bugs entsprechen, können Sie auf die 1.5.0.7 zurückgehen. Die hatte diesen Bug nicht.
    - Sie können die Empfehlungen von oben beachten und sich (per Suchfunktion) über weitere mögliche Ursachen und Maßnahmen informieren. (z.B. Virenscanner richtig konfigurieren, die Nur-Kopfzeilen-Option ausschalten, ein neues und sauberes Profil anlegen, etc. , siehe oben).