Ordner sind weg oder werden nicht mehr angezeigt!

  • Hallo zusammen,
    ich benutze seit ca. drei Wochen Thunderbird. Unteranderem hole ich auch meine Geschäftlichen Nachrichten damit ab. Ich hatte einige Ordner unter diesem Account angelegt, die seit dem Wochenende nicht mehr vorhanden sind oder nicht angezeigt werden. Denn im lokalen Verzeichnis sind die Ordner mit den dazu gehörigen Datein zu finden. Es ist immer eine Datei ohne Endung und eine mit .msf vorhanden. Ich hatte einen Trjaner auf meinem Laptop den habe ich aber entfernt bekommen. Ich weiß nicht ob es vielleicht in Zusammenhang stehen könnte. Es wäre wirklich freundlich, falls mir jemand auf die Sprünge helfen könnte bei diesem Problem.


    OS: WINXP Home SP2.

  • Hallo dcelli,


    kann sein das die mbox-Datei, die die Mails enthält, vom Virenscanner gelöscht wurde. Als erstes würde ich aber einmal die msf-Dateien löschen.
    Lösche alle Dateien mit der Erweiterung msf in deinem Profil.
    Du kannst dafür auch mein Programm BereinigungTB von meiner Webseite (siehe www-link) benutzen.
    Falls das nichts helfen sollte, melde dich noch mal - evtl. lassen sich die noch vorhandenen Ordner wieder importieren.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Auch wenn es jetzt für dich unter Umständen zu spät ist:


    Gerade, wenn du deinen Rechner geschäftlich nutzt, sollte für dich eine regelmäßige (tägliche!) Datensicherung zur Selbstverständlichkeit werden.
    Und vielleicht auch mal darüber nachdenken, deine Mails per imap abzuholen. Dann kümmert sich der Provider um die Sicherung der Mails. Du hast also zumindest dieses Problem nicht mehr (in dem Umfange). Und die blanken Mailprofile sind im Fall des Falles schnell wieder eingerichtet.


    MfG "Peter"

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Danke erst einmal für die schnelle Antwort.
    Toolman: Was für Dateien sind denn das mit der Endung .msf? Diese sind nämlich auch in den noch vorhanden Ordnern meiner anderen Accounts. Kann ich diese dann auch gleich löschen, haben sie keine weitere Funktion?


    Peter_Lehmann: Du hast natürchlich vollkommen recht. In dieser Hinsicht war ich unvorsichtig. Allerdings läuft noch ein Rechner im Büro, der auch die Mails abholt. Hast Du vielleicht eine gute Quelle wo ich mich über IMAP-Konten informieren kann?


    Gruß und nochmals vielen Dank!

  • Hallo Toolman,


    ich habe schon etwas üner . msf-Dateien gefunden. Scheinen nur Index-Dateien zu sein (Sortierung, gelöscht oder nicht gelöscht..). Sie werden wohl beim nächsten Start TB wieder erstellt. Habe sie jedenfalls alle gelöscht, aber die Ordner sind nicht wieder aufgetaucht.


    Gruß Marco

  • Hallo dcelli,


    auch in der mbox-Datei steht ein Hinweis ob diese Nachricht gelöscht wurde, da erst bei der Komprimierung die Mail tatsächlich gelöscht wird. Da aber warscheinlich die gesamte mbox-Datei selbst gelöscht wurde, vermute ich mal das das dir nicht besonders weiterhilft - du hast die Mail ja nicht selbst gelöscht, sondern der Virenscanner hat die Datei gelöscht (warscheinlich).
    Falls du mal mein Tool DateianalyseTB (www-Link) ausführst und mir die damit erstellte Textdatei per PN schickst, kann ich dir sagen was noch da ist und wie man das wieder einbindet.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Ich hänge mich hier mal ran, um keinen neuen Thread eröffnen zu müssen.


    Also. Ich habe TB 1.5.0.7 und Windows XP Home.
    Heute habe ich ein wenig aufgeräumt und Programme gelöscht, temporäe Dateien löschen lassen usw. Zum Schluss habe ich dann das Brico Vista Inspirate Pack installiert.


    Nun habe ich TB gestartet und es fehlen eine Menge Ordner. Ich lasse alle Mails im Posteingang ankommen und hatte unter "Local" Ordner angelegt, in die die Filter die Mails reinsortieren. Nun meldet ein Filter nach dem anderen, dass der dazugehörige Ordner nicht existiert. Ganz nebenbei bleiben die eingehenden Mails (habe zum Glück schnell in den Offlinemodus geschaltet) nicht im Posteingang, sondern verschwinden einfach. Sie sind dann nicht im Papierkorb und nicht im Spamordner. Angezeigt werden sollten alle Mails. Drei genauso wie die anderen angelegten Ordner sind nicht verschwunden und in ihnen sind auch alle E-Mails drin, die gestern auch drin waren. Es handelt sich um die Order "BILLING" "FAX" und "INFOCITY Sammelkonto". Außerdem gibt es zwei Ordner, die ich nicht angelegt habe und die "nstmp" und "nstmp-1" heißen, ganz unten in der Liste auftauchen und nur mit Spammails gefüllt sind.


    Im Thunderbird-Ordner bei den Anwendungsdaten sieht alles ganz normal aus. Alle Ordner sind da und die Dateien sind auch drin. Auch der Thunderbird-Ordner unter "Programme" kommt mir so wie er ist bekannt vor.


    Thunderbird hat irgendwie seit Anbeginn die Angewohnheit, versandte und eingegangene Mails einfach so auf C:\ abzulegen. Dadurch sind die Mails in eml-Form da und ich konnte von TB auch problemlos drauf zugreifen. Wäre mir bloß lieb, wenn die Mails wenigstens in einem Ordner landen würden. Aber das erste Problem hat Vorrang.


    Ich habe da schonmal was vorbereitet. Und zwar habe ich hier ein Analyse-Tool gefunden und die Analyse einfach mal auf meinen Webspace geladen:


    http://www.city-gate.net/public/tbprofile.txt


    Dann habe ich mal das Bereinigungstool probiert aber es bleibt beim Neustart von TB alles beim Alten. Bevor ich das getan habe, habe ich die beiden kompletten Thunderbird-Ordner aus den Anwendungsdaten und dem Programmordner auf eine andere Platte gesichert. Nu bin ich denn doch ratlos. Es ist ja irgendwie alles da aber wie bringe ich dem Vogel das bei?


    Übrigens: Das komplette TB-Verzeichnis unter "Anwendungsdaten" wird von meinen F-Secure-AV übersprungen. Daran liegt es also wohl auch nicht. Das hatte ich schonmal. Was mir vielleicht noch einleuchten würde ist, dass beim Bereinigen vielleicht 0-MB- und temporäre Dateien gelöscht worden sind. Aber ob das damit zusammenhängen kann, weiß ich nicht.


    So denn. Ich danke schonmal für die Mühe - das File ist doch sehr umfangreich aber es ist ein tolles Tool.


    MfG Martin

  • Hallo dossi,


    es sieht tatsächlich so aus wie es Werner schon schreibt.... wenn unterhalb von .\mail ein Ordner wie z.b. bei dir (3) PROJEKTE.sbd existiert muss es auch eine Datei geben die in diesem Speziellen Fall dann (3) PROJEKTE heist.


    Beispiel:


    in C:\Dokumente und Einstellungen\d.media\Anwendungsdaten\Thunderbird\Profiles\ux4thue1.default\Mail\Local Folders


    ist dieses unterverzeichnis (3) PROJEKTE.sbd aber in
    C:\Dokumente und Einstellungen\d.media\Anwendungsdaten\Thunderbird\Profiles\ux4thue1.default\Mail\Local Folders


    gibt es keine datei mit dem Namen (3) PROJEKTE, dafür aber eine msf mit dem Namen... es muss also mal eine existiert haben. Lege einfach eine leere Datei an, wenn du die alte Datei nicht wieder herstellen kannst.
    Um zu vermeiden dass dir dein Windows einen Streich spielt, empfehle ich, eine Datei auf folgenden Weg anzulegen:
    starte die Eingabeaufforderung und gebe folgenden Befehl ein:


    echo. >>"C:\Dokumente und Einstellungen\d.media\Anwendungsdaten\Thunderbird\Profiles\ux4thue1.default\Mail\Local Folders\(3) PROJEKTE"


    und für die Zukunft würde ich Sonderzeichen in Verzeichnisnamen vermeiden (die Klammern im Verzeichnisnamen)- das ist immer eine Quelle für Fehler aller Art.


    schöne Grüße


    Toolman


    P.S. Ich habe eigentlich auf meiner Seite darauf hingewiesen, man sollte die Informationen in der tbprofile.txt nicht in öffentliche Foren packen.... die Gefahr von Spambots erfasst zu werden ist dafür zu groß. Ich würde daher den Link auf deiner Webseite zumindest mit einem Verzeichnisschutz versehen bevor deine Postfächer aus allen Näten platzen.

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Upps, hab die Datei erstmal wieder heruntergenommen. Ich hatte sie mir angesehen und so auf Anhieb zumindest keine E-Mail-Adressen darin entdeckt. Aber danke für den Hinweis. Sieben Tage habe ich den Webspace noch und da könnte es schon zu spät sein.


    Wenn ich das richtig verstanden habe, hat die Person im anderen Thread einfach in Thunderbird die Ordner wieder neu erstellt? Oder im Verzeichnis?

  • Zitat von "dossi"

    Wenn ich das richtig verstanden habe, hat die Person im anderen Thread einfach in Thunderbird die Ordner wieder neu erstellt? Oder im Verzeichnis?


    Beide Möglichkeiten sollten funktionieren, einfacher ist es natürlich die Ordner im Thunderbird neu anzulegen.


    Gruß
    Werner

  • Hm, die Order sind wieder da. Weil ich sie alle nochmal erstellt habe. Aber sie sind leer.


    Gibt es irgendwie eine Möglichkeit, die bisher gespeicherten und nicht mehr sichtbaren Mails wieder in die Ordner zu bekommen? Wenn sie das Format EML hätten, ginge das ja aber scheinbar befinden sich die Mails in einer Datei zusammengefasst (?)


    Ich habe mal im Forum umhergestöbert aber ich glaube, mir fällt nicht der zutreffende Suchbegriff ein. Ich finde da alles Mögliche aber nicht das was ich brauche.

  • Hallo dossi,


    Zitat von "dossi"

    Hm, die Order sind wieder da. Weil ich sie alle nochmal erstellt habe. Aber sie sind leer.


    Nun das wundert mich eigentlich nicht.
    Da du die ja neu erstellt hast kann da ja auch nichts drin sein.



    Zitat von "dossi"


    Gibt es irgendwie eine Möglichkeit, die bisher gespeicherten und nicht mehr sichtbaren Mails wieder in die Ordner zu bekommen? Wenn sie das Format EML hätten, ginge das ja aber scheinbar befinden sich die Mails in einer Datei zusammengefasst (?)


    Das musst du mir mal genau erklären... in welcher Datei vermutest du denn noch deine jetzt nicht mehr sichtbaren Mails? Wenn die Mails noch in irgendeiner Mbox-Datei drin sind, lassen sie sich auch wieder sichtbar machen...



    Zitat von "dossi"


    Ich habe mal im Forum umhergestöbert aber ich glaube, mir fällt nicht der zutreffende Suchbegriff ein. Ich finde da alles Mögliche aber nicht das was ich brauche.


    Na ja, das glaub ich jetzt aber nicht, wir hatten das Thema leider schon sehr oft.... such einfach mal nach gelöschten Mails ("gelöschte Mails". - bei mir ergibt das alleine schon 74 Treffer!)


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hm, in den msf-Dateien befindet sich nichts. Aber bevor ich gestern etwas geändert hatte, hatte ich die kompletten Verzeichnisse gesichert. Und da sind die msf-Dateien bis zu 40.000 kb groß und es befindet sich Code drin. Allerdings keine Mails. Spiele ich die Dateien zurück, passiert aber nichts. Ich habe hier aber auch mehrere Megabyte und auch über 100 MB große Dateien. Leider kriegt der Editor die natürlich nicht geladen. Da sind wohl die Mails drin? Dann mache ich mich mal auf die Suche nach "gelöschte Mails". Mein Denkfehler war, dass ich gleich bis in die Tiefe gedacht hatte: "Speicherplatz Mails" z.B. war der letzte Versuch. Vielleicht sollte ich einfacher denken ;-)


    Danke jedenfalls erst einmal.

  • Vergiss mal dem ganzen Quatsch mit den *.msf-Dateien. Wenn sie Probleme machen sollten, dann einfach weg damit (bedenkenlos löschen).


    Dateien, die man mit seinem Editor (welcher das auch sei) nicht öffnen kann, kann man sich mit jedem beliebigen Textprogramm (Word...) ansehen und auch bearbeiten. Ich kenne keine aktuelle Textverarbeitung, die nicht sogar GigaBytes verarbeiten kann.


    Gruß, Sünndogskind_2

  • Hallo dossi,


    die Dateien mit den Mails haben keine Endung... die bekommst du auch mit dem Editor auf...allerdings solltest du bei größeren Dateien als 10 MB kein Notepad mehr nehmen - es gibt genügend Alternativen... ich verwende den guten alten Proton.


    Ohne jetzt die genaue Dateistruktur zu kennen wird es schwierig... guck mal in deinen Profilordner nach .\mail\local folders.


    hier kannst du eigentlich alle deine Dateien ohne Endung hineinkopieren, vorausgesetzt es gibt nicht bereits eine Datei mit dem gleichen Namen. Dann musst du diese umbenenen. Sollten sich in deinem Backup noch verzeichnisse mit sbd-Endung befinden so sind dort meistens auch noch maildateien drin. Willst du diese Verzeichnisse komplett so kopieren, so musst du wenn du das sbd-Verzeichnis direkt nach local Folders kopierst in Local Folders entweder schon eine Datei mit dem gleichen Namen (ohne sbd-Endung) haben oder eine solche anlegen.



    und wenn dir das jetzt alles zu kompliziert war, kannst du auch mbox-Import verwenden.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Ah, eine Überschneidung.
    Jetzt weiß ich endlich, wozu dieses Tool gut ist.
    Und möglicherweise hätte ich damit von Anfang an das Problem lösen können. Er erstellt jetzt mit jeder importierten Datei einen neuen Ordner. Die brauche ich ja eigentlich nur noch umbenennen und an ihren alten Platz schieben (unter Local statt unter Posteingang).


    Danke Leute. Mein Supportanfragenmarathon (vorgestern 1&1, gestern TB, heute McAfee) ist einmal erfolgreich. Während die anderen beiden noch nicht einmal geantwortet haben. OpenSource ist eben einfach das Beste - wer was weiß, sagt es auch weiter.


    Dossi

  • Zitat von "dossi"

    Mein Supportanfragenmarathon (vorgestern 1&1, gestern TB, heute McAfee) ist einmal erfolgreich.


    War da nicht noch ein Problem? :wink:


    Zitat von "dossi"

    Thunderbird hat irgendwie seit Anbeginn die Angewohnheit, versandte und eingegangene Mails einfach so auf C:\ abzulegen. Dadurch sind die Mails in eml-Form da und ich konnte von TB auch problemlos drauf zugreifen. Wäre mir bloß lieb, wenn die Mails wenigstens in einem Ordner landen würden.


    Ich nehme an du hast die Erweiterung Tb AutoSave Extension installiert, in den Einstellungen der Erweiterung kannst du den Speicherort der EML-Datein festlegen.


    Gruß
    Werner

  • Oh ja, das Problem. Ich hatte es schon aufgegeben. ;-)


    Hab ich. Und das DAS die Ursache sein könnte, da wäre ich nie drauf gekommen. Habe ich geändert.


    So, nun läuft auch alles wieder. Dankeschön!!


    Dossi

  • Zitat von "dossi"

    Und das DAS die Ursache sein könnte, da wäre ich nie drauf gekommen.


    Da installieren die Leute eine Erweiterung und dann wundern sie sich wenn sie arbeitet. :lol:


    Gruß
    Werner