Fehler: UTF Code im Betreff

  • Hallo,


    wir betreiben einen Webshop (iWay von Press-Sense) zur Abwicklung von Druckerei-Aufträgen. Das System erstellt E-Mails zur Benachrichtigung von Einkäufen (Bestellstatus, Lieferstatus usw.)


    Seit einem Update von iWay sehen die Betreff- und Absender der Mails so aus:
    =?UTF-8?B?QSBuZXcgSm9iICMzNDE5IGhhcyBhcnJpdmVkIHRvIHRoZSBBcHByb3ZhbCBRdWV1ZS4==?=


    In Outlook oder anderen Mailclients (nicht Mozilla) ist der Betreff OK.


    Ich habe schon mit den Einstellungen des Zeichencodes herumgespielt, das ändert aber höchstens den Inhalt der Mail, nicht die Betreff-Zeile. Der Inhalt wird aber korrekt dargestellt.
    Gibt es da noch weitere Einstellungen?

  • Hallo, willkommen im Forum.


    Du meinst aber die Betreffs der empfangenen Mails?


    Bevor wir hier auf Fehlersuche gehen und wir das Thema gerade hatten,
    überprüfe an Hand dieses Threads, deine Einstellungen, die den Zeichensatz betreffen.
    Bitte beachte dort meine Kommentare zu bestimmten Einstellungen. Nicht alle in den geposteten Snaps sind empfehlenswert.


    http://www.thunderbird-mail.de/forum/viewtopic.php?t=23645


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    danke für die schnelle Antwort.


    Im angegebene Thread geht es um den Inhalt nicht um den Betreff. Das hilft mir nicht weiter.


    Blöderweise steht das schon so im Quelltext:



    Zitat

    From-Addr: it@...
    Subject: =?UTF-8?B?QSBuZXcgSm9iICMzNDI4IGhhcyBhcnJpdmVkIHRvIHRoZSBBcHByb3ZhbCBRdWV1ZS4==?=
    To: fellhauer@...

  • Hallo,
    erstens schreibst du in deinem Anfangsposting

    Zitat

    Seit einem Update von iWay sehen die Betreff- und Absender der Mails so aus:


    zum Zweiten, was meinst du wohl, was "subject" im Deutschen heißt? "Betreff"!!
    Der Nachrichtentext heißt im Englischen "body".


    Du hast die Einstellungen für die Zeichensätze überprüft?


    Lies außerdem, wenn es sich um Mails mit Anhängen handelt, dazu:


    http://www.thunderbird-mail.de…ht=pdf+anh%E4nge&start=15
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Sorry wenn ich mich falsch ausdrücke, aber nochmal:


    das Darstellungsproblem betrifft NUR den Betreff (Subject:) und die Absenderadresse (From:), die werden beide so unleserlich dargestellt.


  • Dann poste mir mal den Header einer dieserMails und zwar diesen Teil:


    Mime-Version: 1.0
    Content-Type: text/html; charset="ISO-8859-1"
    Content-Transfer-Encoding: quoted-printable


    Der kann auch öfter im body vorkommen.

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hier ist es:



  • Dann stell mal unter Ansicht, Zeichencodierung auf Unicode UTF-8. ZUvor aber die betr. Mail auswählen.
    Ich warte immer noch auf deine Einstellungen.
    Sonst werde ich nicht weiter antworten.
    Ixe deine Mailadresse aus, wenn sie echt ist, sonst erlebst du bald eine Spamschwemme.

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat

    Dann stell mal unter Ansicht, Zeichencodierung auf Unicode UTF-8. ZUvor aber die betr. Mail auswählen.


    Wie in meinem ersten Posting geschrieben habe ich das schon gemacht. Das bezieht sich ausschließlich auf den Inhalt, nicht auf die Betreff-Zeile. Außerdem erkennt TB das korrekt und steht schon auf UTF-8

    Zitat

    Ich warte immer noch auf deine Einstellungen.


    Du hast keine von mir verlangt. Was soll ich dir schicken?

    Zitat

    Ixe deine Mailadresse aus, wenn sie echt ist, sonst erlebst du bald eine Spamschwemme.


    Das ist nicht meine, sondern die vom Entwickler des Linux-Mailservers SndMail

  • Ich schrieb:

    Zitat

    Bevor wir hier auf Fehlersuche gehen und wir das Thema gerade hatten,
    überprüfe an Hand dieses Threads, deine Einstellungen, die den Zeichensatz betreffen.
    Bitte beachte dort meine Kommentare zu bestimmten Einstellungen. Nicht alle in den geposteten Snaps sind empfehlenswert.


    http://www.thunderbird-mail.de/forum/viewtopic.php?t=23645


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ja klar Mann, hab ich auch gelesen und erkenne darin, dass du offenbar mein Problem nicht verstehst. Hat sonst jemand einen Tipp für mich?