Kombiniertes Profil unter Linux & Windows

  • Hallo,


    ich weiß nicht, ob das hier das richtige Forum für meine Frage ist, aber ich probiere es einfach mal (es ist nicht eine reine Thunderbird-Frage) :wink:
    Ich habe vor unter Linux und Windows mit Thunderbird auf das gleiche Profil zuzugrifen -> unter beiden Systemen die selben Bedingungen.
    (Frage 1 wäre erst einaml, ob das prinzipiell funktioniert...)
    Ich habe bisher dazu eine eigene, kleine FAT32-Partition für Profile etc. angelegt. Dahin habe ich mein Profil aus dem standard Windowsverzeichnis migriet und im Profilmanager erfolgreich unter Windows eingebunden.
    Der Teil der mir noch Probleme bereitet ist unter Linux (Suse 10.1) ebenfalls darauf zuzugreifen:
    Bisher habe ich es nicht geschafft, die Zugriffsrechte so anzupassen, dass ich mit meinem normalen User darauf zugreifen kann (funktioniert nur als root). In /etc/fstab habe ich die Partition mit
    /dev/hda11 /Profile vfat users,gid=users,umask=0007,uid=1000,utf8=true 0 0
    eingebunden, trotzdem kann ich nicht mit meinem User (ID=1000) darauf zugreifen (oder als root die Rechte ändern (sollte auch nicht nachträglich mit FAT32 funktionieren)).


    Hat jemand vielleicht schon mal eine ähnliche (funktionierende) Konfiguration angelegt und könnte mir weiter helfen?


    Vielen Dank,
    Thomas


    BTW: Gibt es relistisch eine andere Möglichkeit als FAT, um eine Partition für Windows und Linux anzulegen und dabei eine Rechteverwaltung zu haben? Bisher habe ich nur Windowstreiber gefunden, die keine Zugriffsrechte unterstüzen...

  • Danke für den Link,


    das scheint genau das zu sein, was ich mir vorgestellt habe :)


    Grüße,
    Thomas

  • Hi,


    hat soweit alles geklappt (der fstab-Eintag war anscheinend auch schon richtig, nur hatte ich die fstab wohl nicht korrekt neu geladen...)
    Allerdings fällt mir beim Starten von Thunderbird auf, das Ordnernamen mit Umlauten einen Augenblick lang nicht korrekt dargestellt werden und erst beim Abruf der Konten mit den richtigen Zeichen erscheinen.
    Ich vemute mal, dass es daran liegen könnte, dass sich die Windows und Unix-Textformate unterscheiden.
    Weiß eventuell jemand, ob das irgenwann mal zu Problemen füren könnte? (In der man zu mount gibt es auch eine Option zur automatischen Konversion zwischen beiden Zeichensätzen "conv=b[inary] / conv=t[ext] / conv=a[uto]" für FAT-Partitionen, allerdings mit einer Warnung versehen...)


    Grüße,
    Thomas