Anhänge abtrennen

  • Hallo,
    nachdem ich festgestellt habe, dass man Anhänge am besten abtrennen oder löschen kann, wenn man keine Nachrichtenvorschau und bloß keine Anhänge eingebunden anzeigen lässt (bei IMAP) ist mir folgendes aufgefallen.


    Ich habe Anhänge von einem Kunden (6 x jpg gesamt 6mb) abgetrennt und in meinem Kundenordner gespeichert. Nachdem ich gefragt wurde ob ich dass auch wirklich will (ja) wurde die Mail mit erfreulichen 12kb angezeigt. Erstaunlicherweise wurden die Anhänge aber noch angezeigt...+ sogar bei doppelklick ausgeführt.
    Dann habe ich die Anhänge aus dem Kundenordner wegverschoben und siehe da... die Anhänge wurden zwar noch in der Mail angezeigt, konnten aber nicht mehr ausgeführt werden. Es gab sogar eine Meldung mit dem Verweis auf meinen Kundenordner und dass da nix mehr ist...
    Nachdem ich die Anhänge wieder zurück geschoben hatte konnte ich die Anhänge wieder aus dem thunderbird heraus anzeigen...
    soweit so glücklich, +ich dachte ich hätte ein event entdeckt.
    Leider klappte das beim 2ten mal nicht. die Anhänge wurden zwar abgetrennt und sauber weggespeichert aber es gab keinen Verweis in der Mail, so als ob es in der Mail nie Anhänge gegeben hätte...


    kennt jemand das?
    weiß jemand wie oder wo ich das einstellen kann?
    Ich würde gerne das erste verhalten als default einstellen.


    viele grüße
    holzwurm

  • Das von dir anfänglich geschilderte Verhalten ist normal. Es ist nicht konfigurierbar, jedenfalls ist es mir nicht bekannt.


    Hintergrund:
    Nach dem Abtrennen ändert Thunderbird die Angaben zum Anhang in der Mail.

    Code
    1. X-Mozilla-External-Attachment-URL: file:///C:/pfad/zum/anhang
    2. X-Mozilla-Altered: AttachmentDetached; date="Wed Jan 31 21:52:45 2007"


    Solange also der Anhang an dem gespeicherten Platz ist, kann er auch aus TB heraus gefunden werden. Wird er dagegen verschoben oder gelöscht, "merkt" TB das natürlich nicht und kann den Anhang nicht finden.


    Dass das beim zweiten Mal nicht klappen soll, kann ich nicht nachvollziehen. Oder versuchst du, einen bereits abgetrennten Anhang nochmals abzutrennen? Das kann logischerweise nicht gehen!

  • hi wpu,
    danke für deine Antwort. Mir ist es bis jetzt nicht gelungen meinen Fehler zu wiederholen, ich werde das aber weiter beobachten.
    Normalerweise sehe wenn ein Anhang abgerennt ist weil dann die Dateigröße fehlt. Es könnte nur sein, dass ich versucht habe doppelt abzutrennen wenn es beim ersten mal nicht geklappt hat.


    Weist du ob das Abtrennen von Anhängen Einfluss auf die Geschwindigkeit von TB hat ? immerhin muss er sich ja die ganzen verknüpfungen merken.

  • "holzwurm" schrieb:

    Weist du ob das Abtrennen von Anhängen Einfluss auf die Geschwindigkeit von TB hat ? immerhin muss er sich ja die ganzen verknüpfungen merken.


    Ich habe es nicht gemessen, aber nach meiner Logik kann es keinen Einfluss auf die Geschwindigkeit haben. Um Mails wiederzufinden benutzt TB einen Index. Wenn die Mail dann angezeigt wird, wird der Anhang nicht angezeigt, es sei denn, TB kann ihn selbst darstellen, z. B. ein Bild. Ist letzteres der Fall, wird natürlich die Anzeige länger dauern, da je erst gerändert werden muss.


    Die "Verknüpfung" zum abgetrennten Anhang steht nur in der Mail selbst. Sie wird also erst aktiv, wenn man drauf klickt. Also wieder Performance-unabhängig.