Probleme mit utf-8-Mails

  • Einen wunderschönen guten Tag


    Ich habe ein Problem bei utf-8-Mails, von denen ich nicht weiß, ob das ein Thunderbird-Problme ist oder eines des Mailservers.


    Da ich auf meinem PC die einige Sonderzeichenunterstützungen geladen habe, zeige ich zunächst einmal ein "Bild des php-Scriptes":


    [IMG:http://applikationssoftware.de/pictures/phpMail/Script.jpg]


    Mit diesem Script kann ich mir eine Standardmail senden und die sieht in einem Imap-Konto folgendermaßen aus:


    [IMG:http://applikationssoftware.de/pictures/phpMail/Mail_Imap.jpg]


    Die gleiche Mail wird kopiert und an in ein Pop-3-Konto eingefügt


    [IMG:http://applikationssoftware.de/pictures/phpMail/Mail_Pop3.jpg]


    Ich weiß zur Zeit nicht, ob es sich um ein TB-Problem handelt oder um ein Problem meines Mailservers.


    Wenn ich mir die Quelltexte der Mails ansehe, dann habe ich einmal die Imap-Quelle


    [IMG:http://applikationssoftware.de/pictures/phpMail/Mail_Source_Imap.jpg]


    und einmal die Pop-3-Quelle


    [IMG:http://applikationssoftware.de/pictures/phpMail/Mail_Source_Pop3.jpg]


    Kann mir hier jemand weiterhelfen?


    Herzliche Grüße
    Wolfgang

  • Was meinst du mit

    Zitat

    Die gleiche Mail wird kopiert und an in ein Pop-3-Konto eingefügt

    ? Die Zeile

    Code
    1. Mime-Version: 1.0


    ist doch sicher auch im Header, oder?

  • Hallo


    "wpu" schrieb:

    Was meinst du mit


    Na ich meine dass die Mail in zwei Postfächer einsortiert wird.


    Code
    1. if ($ADR eq "richtige.adresse@irgendwo.tld")
    2. {
    3. cc "$MDIR/imap"
    4. to "$MDIR/pop_3"
    5. }


    "wpu" schrieb:

    Die Zeile

    Code
    1. Mime-Version: 1.0


    ist doch sicher auch im Header, oder?


    Ups - danke, die stand nicht drin. Das ändert aber nichts am Ergebnis.


    Also: Jetzt steht es drin, ich habe es ausprobiert und das gleiche Ergebnis bekommen.


    Herzliche Grüße
    Wolfgang]

  • Nun versteh ich gar nichts mehr. (Sollte wohl ins Bett gehen. ;-) )
    Das Skript vom Ausgangsposting verschickt doch eine Mail! Wieso soll die jetzt in zwei verschiedene Postfächer einsortiert werden? Das ist doch eine Empfangsfilterung!


    Außerdem lese ich im PHP-Handbuch:

    Zitat

    Sie müssen die Header mit \r\n trennen, auch wenn einige Unix-MTAs automatisch \n durch \r\n ersetzen (was zu doppeltem \r führt, wenn \r\n verwendet wird).

  • Hallo


    "wpu" schrieb:

    Das Skript vom Ausgangsposting verschickt doch eine Mail! Wieso soll die jetzt in zwei verschiedene Postfächer einsortiert werden? Das ist doch eine Empfangsfilterung!


    Aus Testgründen. Ich will wissen, dass es funktioniert und zwar eben sowohl beim Imap als auch bei Pop3.


    "wpu" schrieb:

    Außerdem lese ich im PHP-Handbuch:


    Ich bin mir im Augenblick gar nicht so sicher, ob ich das wirklich will. Was du siehst ist die Mail in der normalen Textansicht.


    [IMG:http://applikationssoftware.de/pictures/phpMail/Mail_Sl_r_Sl_r.jpg]


    Aber ich habe die Mail mal in ein Outlook-Konto laufen lassen. Da sieht es ähnlich aus.


    [IMG:http://applikationssoftware.de/pictures/phpMail/Mail_Outlook.jpg]


    Es könnte also auch am Mailserver liegen.


    Herzliche Grüße
    Wolfgang

  • "Wolfgang_1" schrieb:


    Es könnte also auch am Mailserver liegen.


    Um das festzustellen oder auszuschließen, wollte ich den Weg in Erfahrung bringen, den die Mail nimmt. Aber leider bekomme ich auf meine Fragen keine Antworten, die eine Diagnose möglich machen.


    Bisher ist noch nicht einmal klar, welche Server überhaupt an dem gesamten Transfer beteiligt sind. Wird die Mail wirklich verschickt, oder nur auf dem eigenen Mailserver in ein anderes Verzeichnis kopiert?


    Sorry, aber mit den Angaben kann ich dir nicht helfen.


    Zitat

    Ich bin mir im Augenblick gar nicht so sicher, ob ich das wirklich will.


    Die Erfinder von PHP und Schreiber des Handbuches haben sicher mehr Ahnung von PHP als du und ich.

  • Hallo


    "wpu" schrieb:

    Um das festzustellen oder auszuschließen, wollte ich den Weg in Erfahrung bringen, den die Mail nimmt. Aber leider bekomme ich auf meine Fragen keine Antworten, die eine Diagnose möglich machen.


    Ich bitte vielmals um Entschuldigung, dass hier war das Thunderbird-Forum und ich hatte dieses Problem zuerst dem TB zugerechnet.


    Ich bin Mitglied in einer kleinen Servergemeinschaft (http://centershock.net/admin/wiki/index.php/Hauptseite). Das Script läuft auf dem Server, und es wird wirklich eine Mail abgeschickt, die dann eben von dem Server auch ganz normal zugestellt wird.


    Der Mailserver ist Courier-MTA.


    Da ich eine kleine Verlagsseite laufen habe unter http://www.grieser-verlag.com/ und hier in der Tat auch Bestellungen aus dem Ausland kommen, möchte ich eine funktionsfähige Bestellabwicklung integrieren und zwar eben auch dann, wenn der Besteller auf einen unüblichen Zeichensatz zurückgreift.


    Ich hatte darüber hinaus in [url]http://groups.google.de/group/…=2&hl=de#1a6d49e83d257719[url] den Rat bekommen, dass man auf diese Kodierung setzen sollte - aus Sicherheitsgründen.


    "wpu" schrieb:

    Die Erfinder von PHP und Schreiber des Handbuches haben sicher mehr Ahnung von PHP als du und ich.


    Davon bin ich überzeug aber die sitzen in Amiland. Und glaube mir: Die Probleme mit den Zeichensätzen, die haben wir Europäer und die nicht! Verschick mal eine Mail in hebräisch oder russisch mit 1und1 und du wirst verstehen, was ich meine.


    Herzliche Grüße
    Wolfgang Uhr