PGP/Mime nicht mit 'nur Kopfzeilen'

  • Guten Abend


    beim benutzen von OpenPGP haben wir folgendes Problem:
    PGP/Mime funktioniert nur, wenn man in den optionen "nur Kopfzeilen herunterladen" deaktiviert.
    Da wir aber vermeiden möchten das spam und viren auf die festplatte gelangen, suchen wir nach einer lösung.
    kennt vielleicht jemand eine?
    oder gibt es eine erweiterung, mit der man einstellen kann, das bei bestimmten email-adressen die nachricht komplett runtergeladen wird, normal aber nicht?


    ty


    Malte

  • Hier noch ein paar Details (gilt für Sender und Empfänger)


    Thunderbird: 1.5.0.10
    Enigmail[de]: 0.94.2
    GPG: 1.4.6


    Server: t-online.de
    Konto: pop3


    Server-Einstellungen: Nur die Kopfzeilen herunterladen = ja


    Ist eine eMail im Eingang werden die Kopfzeilen heruntergeladen, der gesamte Header ist verfügbar.


    Im Nachrichtenfeld steht:
    ---------------------
    Nicht heruntergeladen
    Nur die Kopfzeilen wurden vom Server heruntergeladen.
    Klicken Sie hier, um die ganze Nachricht vom Server herunterzuladen.
    ---------------------


    Ein Klick und die Mail ist komplett da. Das funktioniert auch mit verschlüsselten Mails.


    Anders bei verschlüsselte Mails mit PGP/MIME.


    Bsp.: Eine eMail verschlüsselt, signiert, PGP/MIME an meine Adresse.
    Ergebnis bei Format "html" oder "Reintext" ist gleich.


    Nach Abruf kommt wieder die Mitteilung "Lokaler Ordner hat 1 neue Nachricht".


    Alle Kopfzeilen sind da.
    Das Nachrichtenfeld ist leer, also "blank", KEIN link/button zum Herunterladen, kein Anhang.


    Geh ich über das web in mein Postfach auf dem t-online-Server ist die Mail dort komplett. Das Nachrichtetextfenster ist dort leer aber zwei Anhänge sind herunterladbar. Eine Textdatei und eine verschlüsselte Datei, die manuell dechiffrierbar ist.


    application-1.pgp-encrypted 1K (Inhalt: "Version: 1")
    encrypted.asc xK (halt so groß wie die Nachricht)


    Schaltet ich nun meine Thunderbird Einstellung um auf:


    Server-Einstellungen: Nur die Kopfzeilen herunterladen = nein


    Kommen (neue) verschlüsselte, signierte, PGP/MIME eMails problemlos in meinem Donnervogel an.


    Aus persönlichen Gründen wollen wir aber grundsätzlich zunächst nur die Kopfzeilen herunterladen. Wo liegt unser Fehler?


    MfG Jürgen

  • Hallo Malte,
    das ist ein uraltes Problem und derzeit nicht lösbar (soweit ich weiß). Eines geht nur, PGP/Mime oder nur Kopfzeilen herunterladen. Nicht einmal Deaktivieren von OpenPGP hilft, nur gezielte "Falschkonfiguration" und Neustart. Dann kann man die Mails herunterladen und OpenPGP wieder aktivieren.
    Da ich keine Angst vor Viren und Spam habe und die Bandbreite auch keine Rolle mehr spielt, habe ich die Option "nur Kopfzeilen herunterladen" zu den Akten gelegt, zumal es damit auch ohne OpenPGP gelegentlich Probleme bis hin zu Datenverlust gab.
    Ein Fall für Bugzilla, oder für einen Bug-Report an den Autor von Enigmail.


    Gruß, muzel

  • Äh, hallo...?
    Es geht darum, daß man keine Chance hat, PGP/Mime verschlüsselte Nachrichten vollständig herunterzuladen, wenn "nur Kopfzeilen herunterladen" aktiviert ist. Und das ist ein Bug, über den ich mich auch schon geärgert habe.
    Es reicht nicht, Enigmail zu deaktivieren, man muß "nur Kopfzeilen herunterladen" ausschalten, und bekommt dann sämtliche Megabytes von Müll, den man nicht haben will.
    m.

  • Nein, keine Fehlermeldung. Wie schon im zweiten Beitrag beschrieben:

    Zitat


    Alle Kopfzeilen sind da.
    Das Nachrichtenfeld ist leer, also "blank", KEIN link/button zum Herunterladen, kein Anhang.


    Keine Chance...

  • "muzel" schrieb:


    das ist ein uraltes Problem und derzeit nicht lösbar (soweit ich weiß). Eines geht nur, PGP/Mime oder nur Kopfzeilen herunterladen.


    Hallo muzel,
    danke für die Antwort, wir konnten bisher keine Infos zu diesem uralten Problem finden.


    Merkwürdig ist auch, dass ein Weiterleiten der eMail aus dem web-Interface von t-online fehlschlägt. Die weitergeleitete eMail ist leer und ohne Anhänge. Die sind aber -wie oben beschrieben- vorhanden und sogar abspeicherbar.


    MfG Jürgen

  • Hallo muzel


    Vielen Dank auch von meiner Seite!


    Dieses Problem hat uns doch eine gewisse Zeit beschäftigt, danke für deine schnelle und präzise Antwort. :)


    Dass das runterladen nicht nur mit Kopfzeilen funktioniert, ist schade. Vielleicht werde ich jetzt auch vorläufig die Funktion deaktivieren, da mir ja ein gewisser Virenschutz durch T-Online und meinen Virenscanner garantiert wird.


    Thx
    Mfg, Malte

  • Trifft dieses Problem nur auf Enigmail zu oder auch auf andere zertifikate (thawte, cacert).
    Ich habe fuer folgende Email nur die Kopfzeilen heruntergeladen:


    Content-Type: application/x-pkcs7-mime; name="smime.p7m"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename="smime.p7m"
    Content-Description: S/MIME Encrypted Message


    In der Druckvorschau bekomme ich einen Link zu sehen, aber ich weiss noch nicht, wie ich durch falsch-konfiguration den email-inhalt auf meinen rechner bekommen kann.

  • Hallo nochmal,


    also ich finde es gut, daß hier höflich und freundlich miteinander umgegangen wird, man sollte aber auch nicht überempfindlich reagieren, besonders bei offensichtlichen Mißverständnissen.


    Von S/MIME habe ich keine Ahnung, das wäre mal wieder ein Fall für Peter ;-).


    Und was "altbekannt" betrifft, ich habe genau diesen Bug hier im Forum mal beschrieben, vor Jahren, aber wahrscheinlich ist er nicht mehr auffindbar. In Bugzilla habe ich ihn nicht gefunden, aber das will nichts heißen.


    Gruß, muzel

  • Workaround


    Nach Update auf die aktuellen Versionen konnten wir folgende Notlösung, bzw. Umgehungslösung für das Problem finden.


    Neue Versionen (gilt für Sender und Empfänger)
    Thunderbird: 2.0.0.6
    Enigmail[de]: 0.95.3
    GPG: 1.4.7


    Server: t-online.de
    Konto: pop3


    Server-Einstellungen: Nur die Kopfzeilen herunterladen = ja


    eMail: verschlüsselt, signiert, PGP/MIME.
    Format "html"


    Nach "Abrufen" kommt die Mitteilung "Lokaler Ordner hat 1 neue Nachricht".


    Alle Kopfzeilen sind da.
    Das Nachrichtenfeld ist leer, also "blank", KEIN link/button zum Herunterladen, kein Anhang.


    Also bis dahin alles unverändert wie in Version 1.5


    Workaround

    • PGP/MIME-eMail im Posteingang markieren
    • mit rechter Maustaste Kontextmenü aufklappen
    • unterster Eintrag "Ausgewählte Nachrichten herunterladen" ist grau, nicht anwählbar
    • einen Eintrag mit Untermenü anwählen
    • nach 1-2sec wird dann der unterste Eintrag schwarz
    • Eintrag "Ausgewählte Nachrichten herunterladen" auswählen


    Voilà, bingo, da ist sie, die PGP/MIME-eMail im html-Format,
    trotz der Option "Nur die Kopfzeilen herunterladen = ja".


    MfG Jürgen

  • Stimmt, funktioniert (auch ohne html und bei anderen Providern), danke für den Tipp.


    Gruß, m.