Langes Warten beim ersten Öffnen des Adressbuchs

  • Hallo,


    hab ein Problem, das immer nur beim ersten Öffnen des Adresbuchs nach einem Neustart von Thunderbird auftritt: Das Programm friert dann für 20 Sekunden ein und man kann erst mal nichts mehr machen.
    Nach dieser einmaligen Wartezeit kann man das Programm dann ohne weitere Verzögerungen nutzen.


    Wäre wunderbar, wenn mir jemand einen kleinen Hinweis geben könnte...


    danke schon mal.


    der marco

  • Hallo eddyedfred,


    das Problem ist noch ein Relikt aus 1.5.0.7. Ich habe dafür ein kleines Tool geschrieben, dass deine Prefs.js säubert. Denke vor Benutzung des Programms an ein Backup - das Programm erstellt eine bereinigte prefs.js in %homedrive% (auf Privat-Pc's normalerweise C:\) weil ich das Überschreiben und das Backup nicht im Programm integrieren wollte (daher selbst daran denken). Da vbscript benutzt wird, muss Win98 oder höher oder eine VB-Script5-Engine installiert sein.


    und hier gibt es das Tool zum Download (auf die Überschrift klicken um es herunter zu laden):
    http://agsm.de/thunderbird/prefsclean.htm


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • vielen vielen dank für deine schnelle antwort. werde das so bald wie möglich testen.


    grüße, marco

  • sorry, klappt nicht.
    also ich bekomme das programm nicht ausgeführt. starte es unter einem adminaccount, bekomme aber die meldung, nach der eingabe des pfades, daß der zugriff verweigert wurde.
    von den berechtigungen her dürfte es eigentlich kein problem geben.


    die fehlermeldeung kommt vom winows scripting host.


    gruß, marco

  • hallo eddyedfred,


    TB war aber geschlossen, oder? Bei geöffnetem TB ist die Prefs.js u.U. wirklich gesperrt.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Ich habe dieses Tool mal angewendet und die Datei von bisher 82KB auf ca. 44KB reduzieren können. Was hat es nun wirklich weggeworfen?


    Beim ersten Aufschalten habe ich nichst gemerkt.

  • Arran ,


    bei der geringen Verkleinerung wirst du auch nichts merken... das Tool entfernt überflüssige nonascii-Zeilen aus der Prefs.js.


    eddyedfred ,


    kopier die Prefs.js mal aus dem Profil nach C:\test\prefs.js (C:\test ggf. vorher anlegen). Lass dann das Tool noch mal laufen... kann sein das der Pfad zu lang ist oder du hast dich beim eintippen des Pfades vertippt. Evtl. hast du den Pfad ja auch gar nicht verändert? Ach was, das steht ja auf meiner Seite das das nur ein Beispiel ist, das hast du bestimmt gemacht...
    :wink: :wink:
    schöne Grüße


    Toolman


    Edit: es könnte auch sein dass bei dir mit hilfe eines "Tools" der WSH deaktiviert wurde (XP-Antispy schlägt so etwas glaub ich auch mitlerweile vor)


    du kannst das ja relativ einfach testen ob wsh überhaupt geht...
    lade dir von meiner Webseite die Datei version.vbs herunter


    (bitte mit rechter maustaste und Ziel speichern unter...)


    die führst du aus... die zeigt nur die gerade aktuelle VB-Script-Version an. Kommt der Fehler schon dann, ist mit dem WSH etwas nicht in Ordnung und du musst die nonascii-Zeilen manuell aus der Prefs.js werfen.

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • wunderbar!
    hat geklappt!
    lag aber einfach ein bißchen an meiner dummheit.
    man muß in dem feld natürlich nicht nur den pfad angeben, sondern auch noch "prefs.js" anhängen. das hatte ich nach dem kopieren des pfades aus dem explorer natürlich nichtmehr gemacht.


    und nicht nur toll, daß das programm durchlief, nein, es hat auch noch genau das gemacht, was ich brauchte...


    vielen vielen dank für die schnelle hilfe!


    der marco

  • "Toolman" schrieb:

    Arran ,


    bei der geringen Verkleinerung wirst du auch nichts merken...


    Das war eine Reduktion von immerhin fast 50%. Was ist denn eine "grosse" prefs?

  • "Arran" schrieb:

    Was ist denn eine "grosse" prefs?


    na ja eine die 400KB überschreitet würde ich jetzt mal sagen.


    aber evtl. hast du ja die bereinigte noch gar nicht von %Homedrive% in dein Profil kopiert? :wink:


    schöne Grüße


    Toolman


    Edit: ich habe hier noch eine alte die ich aufgehoben habe - die hatte 307 KB - aktuell habe ich eine mit 32KB

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro