Umlaute in eingehenden Mails werden zu "Hyroglyphen&quo

  • Hallo Th-Fachleute (zu Th 1.5.0.12),
    Umlaute in eingehenden Mails werden v e r e i n z e l t (je nach Absender) in unpassende Großbuchstaben und Anführungszeichen durch Fragezeichen ersetzt. Wenn ich mir selbst eine Mail zur Prüfung schicke, ist alles in Ordnung. Ich gehe daher davon aus, dass der Absender eine "besondere" Einstellung gewählt hat, Kann ich die "knacken".
    Die Zeichenkodierung steht bei mir auf "westlich" für ausgehende Mails; versuchsweise habe ich für eingehende Mails "Unicode" (UTF8) eingesetzt - keine Änderung mit den Hyroglyphen. HTML ist eingeschaltet.
    Danke für Hilfen
    Willibald :? :?

  • Für einzelne Nachricht änderst du Kodierung in Ansicht / Zeichenkodierung.
    Welche passt?

  • Hallo,
    nicht immer klappt es mit dem richtigen Zeichensatz, das hängt vom Absender ab.
    Vorausgesetzt, deine Einstellungen sind richtig.
    Extras, Einstellungen, Ansicht, Schriftarten und Kodierung ist kein Haken gesetzt bei den unteren beiden Kästchen.
    Haken bei "Nachrichten erlauben, andere Schriftarten zu verwenden", sollte dagegen angehakt sein.
    Außerdem sollte unter Ansicht, Zeichenkodierung, "Automatisch bestimmen" auf "universell" stehen.


    Ist alles richtig, sollte jetzt TB die richtigen Zeichensätze automatisch richtig erkennen. Was du auch unter Ansicht, Zeichenkodierung erkennen kannst. Wurde eine Mail in UTF-8 gesendet, müsste dann bei dir auch UTF-8 dort angehakt sein. Probiere das mal selbst aus.
    Ist aber eine Mail falsch deklariert, was man oft (nicht immer) im Quelltext erkennen kann, hilft nur das Raten des richtigen Zeichensatzes und das manuelle Umstellen. Aber auch das klappt dann nicht, wenn den betr. richtigen Zeichensatz Windows nicht kennt.


    Der unter Ansicht, Zeichenkodierung angezeigte Zeichensatz, richtet sich nach der Deklarierung in der Mail.
    Wurde sie in UTF-8 deklariert, ist dieses auf dort angehakt. Ist die nächste Mail mit ISO-8895-15 deklariert, wird dieses bzw. Westeuropäisch angezeigt.
    Die Deklarierung im Quelltext (strg+U) sieht bspw. so aus:


    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: 8bit
    oder
    Content-Type: text/plain;
    charset="us-ascii"
    Content-Transfer-Encoding: 7bit
    oder
    Content-Type: text/plain; charset="ISO-8859-1"
    Content-Transfer-Encoding: 8bit


    Sie kann auch mehrfach auftreten bei Anhängen und HTML.
    Ist aber die Mail als UTF-8 kodiert und es wurde ein anderer Zeichensatz deklariert, steht TB auf dem Schlau. Mit Glück findet man aber dann trotzdem den richtigen Zeichensatz manuell.

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo allerseits,


    ich hab mir nun den halben Wolf gesucht, komme nicht weiter und hänge dies mal an dieses uralte Thema an, da es exakt mein Problem beschreibt. Ich bin kürzlich von einer eher alten Version von TheBat auf Thunderbird 2.0.0.21 umgestiegen, weil mich u.a. genervt hat, daß theBat mails von geocaching.com und opencaching.de nicht umbrechen kann und die Links nicht klickbar sind.
    Prima, Thunderbird kann das - nur leider scheitert der Vogel an der Zeichenkodierung dieser Absender auf seine - hier geschilderte Weise.


    Praktischerweise hat mrb hier schon die korrekten Einstellungen beschrieben, und genau so habe ich sie auch gesetzt.

    Zitat

    Ist alles richtig, sollte jetzt TB die richtigen Zeichensätze automatisch richtig erkennen. Was du auch unter Ansicht, Zeichenkodierung erkennen kannst. Wurde eine Mail in UTF-8 gesendet, müsste dann bei dir auch UTF-8 dort angehakt sein

    Genau dies funktioniert bei den genannten Absendern nicht, es zeigt immer Westlich-15 an. Bei beiden Absendern finde ich im Quelltext:
    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: BASE64


    Soweit ich das überblicke, passiert das wirklich nur, wenn dort BASE64 steht. Wenn ich später händisch auf UTF-8 klicke, kann man den Text vernünftig lesen.
    Ist das Problem bekannt und ich habe es nur doch nicht gefunden? Oder gibt es irgendwie doch eine Lösung? Und sei es nur ein Button zum Schnellumschalten auf UTF-8 - so ähnlich wie das HTML-Plugin, das ich sehr nett finde, da mein Standard die reine Textansicht ist.


    danke schon mal und VG,
    Karin

  • Hallo und willkommen im Forum!
    Du hast das schon richtig erkannt, dass der Grund die falsche Deklarierung ist.
    Aussehen müsste sie so:


    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: 7bit


    Hatte die Mail einen Anhang?
    Dann müsste eine zusätzliche Deklarierung dieser Art stehen:


    Content-Type: application/x-msdownload;
    name="Uninstall.exe"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
    filename="Uninstall.exe"


    Der Content-Type kann je nach Dateityp auch anders lauten.


    Durch die falsche Deklarierung ändert sich der vorhandene Zeichensatz - also der, der vorhergehenden Mail -nicht und bleibt auf ISO-8955 stehen.


    Die Schuld liegt also beim Absender, der einen nicht konformen Mailklienten bzw. ein nicht aktuelles Betriebssystem hat.
    Wenn du nur wenige Mails von diesem Absender bekommst, kannst du mit ein wenig Aufwand, die Mail so abändern, dass der Zeichensatz richtig angezeigt wird. Das geht sehr schnell, wenn man weiß wie.
    Sollte dich das Vorgehen interessieren, poste es hier.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,

    Zitat

    Hatte die Mail einen Anhang?


    Nein, von den genannten Absendern erhalte ich ich nur Logmitteilungen ohne Anhänge (beides große online-Portale), ähnlich wie die Benachrichtigung in einem Forum. Und damit sind wir beim Thema: auch die Benachrichtigung über deinen neuen Beitrag zeigt mir Thunderbird nicht richtig an - also doch nicht nur bei BASE64, das macht echt irgendwie keinen Spaß :( Hier heißt es:
    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: 8bit
    Aber auch nach dem Neustart von TB, wenn ich als erste Mail auf diese Benachrichtigung gehe, zeigt es mir die Umlaute nicht korrekt an und wird als Westlich...15 interpretiert.

    Zitat

    Wenn du nur wenige Mails von diesem Absender bekommst, kannst du mit ein wenig Aufwand, die Mail so abändern, dass der Zeichensatz richtig angezeigt wird. Das geht sehr schnell, wenn man weiß wie.
    Sollte dich das Vorgehen interessieren, poste es hier.


    Etwas, das schneller geht als auf Ansicht-Zeichenkodierung-UTF8 zu klicken? ;) Dann ja. Ansonsten lohnt der Aufwand kaum. Mit privaten Mails habe ich zum Glück keine Probleme, das betrifft eher Werbung oder eben solche kurzen Foren-/Logmitteilungen. Man kann die ja lesen, ist eh nicht so wichtig, aber deprimierend shice sieht es trotzdem aus :mrgreen:


    Gruß, Karin

  • Mist, es liegt an einem Bock in meiner Installation bzw. meinem Profil: habe TB eben auf dem 2. OS installiert und Nachrichten von dem Konto abgeholt, über das immer die vermurksten Mails reinkommen. Da hat TB noch nicht mal ein Problem mit den zuerst genannten Mails - wird alles brav als UTF-8 interpretiert und angezeigt... Vor dem Abholen hatte ich die Einstellungen noch exakt so gesetzt, wie ich sie im "kaputten" Profil habe.
    Gibt es eine Möglichkeit, irgendwie die Defaults wieder herzustellen? Oder eine andere Idee, wie ich das wieder hinkriege?
    Das Dumme ist, in der Fledermaus hatte sich über die Jahre eine ganz schön umfangreiche Ordnerstruktur angesammelt, die ich mühselig Ordner für Ordner übertragen hatte.


    Gruß, Karin

  • Hallo,
    du ahnst sicher schon, wie die Antwort lautet?
    Ein neues Profil einrichten.
    Wie ist deine Ordnerstruktur in TB, alle Ordner/Unterordner in "lokale Ordner" oder in verschiedenen Kontoordnern?
    Ah noch etwas: sind deine Posteingangsordner leer und werden diese regelmäßig komprimiert und auch der Index zurückgesetzt?
    Vor einem neuen Profil kann man natürlich noch etwas experimentieren
    Wo genau die Einstellungen f+ür die Zeichensätze sind, ist mir leider nicht bekannt, ich vermute aber in der prefs.js. Da diese aber die Steuerzentrale für TB ist und dort alle Konten vermerkt sind, kann das Zurücksetzen mehr Schaden als nützen. Du kannst ja versuchsweise mal die Datei panacea.dat verschieben und TB eine neue anlegen lassen. /(B vorher beenden).
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für deine Antwort. Mir langt's grad erst mal. Hab versucht, ein neues Profil anzulegen, Nachrichten sauber importiert - da erstellt er mir keinen Junk-Ordner, obwohl in den Einstellungen so angegeben. Das darf doch nicht wahr sein! Und weiß der Geier was dann sonst noch nicht funktioniert und sich später erst zeigt.
    Mal sehen, ob ich Ostern dazu komme, die vielen Stunden, die mich der shice schon gekostet hat, hab ich eigentlich gar nicht übrig...


    Gruß, Karin

  • Hallo,
    TB erstellt Ordner oft erst dann, wenn sie gebraucht werden. Also einen Ordner Entwürfe, Vorlagen, Gesendet erst in dem Moment, in dem auch eine Mail dorthingebracht werden soll.
    Du hattest "neue Junk-Nachrichten verschieben in" aktiviert und ein Konto bzw. den lokalen Ordner ausgewählt?
    Eigentlich müsste in diesem Fall sofort nach Klick auf OK der Junk-Ordner erstellt werden. Selbst wenn diese Option nicht angehakt ist. Es reicht also das Aktivieren der Junkfunktion.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi,


    gut, daß du noch mal nachgehakt hast :mrgreen: Ich hatte übersehen, daß man in den Konten die Junk-Funktion aktivieren muß... Hatte dies nur unter Extras Einstellungen getan. Naja, kommt vor, wenn man schon so abgefressen ist ;)
    Aber JETZT sieht es endlich so aus, als ob alles in Ordnung wäre!


    Gruß, Karin