IMAP: Anzeige neuer Mails im Ordnerbaum fehlerhaft

  • Hallo,


    folgendes seltsames Problem mit 2.0.0.6 unter Windows:


    Bei der laufenden Synchronisierung mit IMAP werden schon gelesene (angeklickte und dadurch von Fettdruck in Normaldruck gewandelte) Mails mit der nächsten Synchronisierung durch IMAP im Ordnerbaum links wieder als fett (neu) markiert. Es sind immer nur ein paar Mails, es lässt sich auch keine Logik erkennen. Auf jeden Fall sind es immer ein paar der zuletzt reingekommenen Mails. Es sieht auch so aus, als ob es irgendwie ein alter Stand wäre, der sich nicht schnell genug synchronisiert.


    Ein Wechseln in den Ordner durch Klick links lässt die Fett-neu-Markierung sofort wieder verschwinden, im Ordner selbst sind die Mails nicht neu markiert.


    Es scheint wohl ein Bug des Ordnerbaums zu sein?! Wer hat damit Erfahrungen und weiss wie man's abstellt?


    Systemzeit des IMAP-Servers und des Client-Rechners sind absolut synchron, als IMAP-Server verwende ich Cyrus/imapd unter Linux.


    Danke schonmal....:)

  • Hallo Tachy und willkommen im Thunderbird-Forum!




    Klick mal per Rechtsklick auf den betroffenen Ordner und wähle Eigenschaften>Index wiederherstellen.
    Und in den Konten-Einstellungen>Server-Einstellungen den Haken bei Bereinigen "Expunge" beim Verlassen setzen.

  • Hallo rum,


    Zitat von "rum"


    Klick mal per Rechtsklick auf den betroffenen Ordner und wähle Eigenschaften>Index wiederherstellen.


    Perfekt, das tut !!! danke!
    Der Ordner, den ich händisch so bearbeitet habe, schluckt das auch ohne Mucken.


    Zitat von "rum"


    Und in den Konten-Einstellungen>Server-Einstellungen den Haken bei Bereinigen "Expunge" beim Verlassen setzen.


    Aber alleine mit diesem Haken, den ich bisher auch schon gesetzt habe, macht er es nicht. Er stellt damit allein den Index nicht wieder her....


    Viele Grüße,
    Tachy

  • ....und zu früh gefreut,... auch den Ordner, den ich mit "Index wiederherstellen" bearbeitet hatte, zeigt nach Beenden und neu hochfahren des Thunderbird links wieder das falsche an.

  • Hi,

    Zitat

    Aber alleine mit diesem Haken, den ich bisher auch schon gesetzt habe, macht er es nicht. Er stellt damit allein den Index nicht wieder her....

    soll er auch nicht. Aber eigentlich soll er damit die Änderungen mit dem Server "abgleichen"
    Versuch mal folgendes: beende TB und gehe in den Profilordner und dort in den Ordner IMAP:


    [IMG:http://img214.imageshack.us/img214/816/003testbildhz3.jpg]


    [IMG:http://img111.imageshack.us/img111/2221/004testbildjr4.jpg]




    lösche die IMAP.%Konto%.msf (im Beispl. imap.1und1.de.msf) und dann klicke auf den Ordner und lösche die darin enthaltene *.msf (im Bild inbox.msf)

  • ....nix zu machen, auch nach dem Löschen der msf-Files baut er den selben Käse beim Synchronisieren wieder falsch auf.


    Ich glaube fast, das hängt am Cyrus.

  • Interessant:


    ich habe wieder etwas herumprobiert, weder mit Expunge, noch mit Löschen der lokalen Files oder der Index wiederherstellen-Funktion war etwas zu machen.


    Dann habe ich mal im IMAP-Serververzeichnis des betreffenden Ordners geschaut, was los ist. Dort lagen noch Mails herum, die gar nicht mehr aktiv sind. Auch einmal den "squatter" drüberlaufen brachte nix.


    Im Verzeichnis-Baum mit rechter Maustaste auf den Ordner und "Komprimieren" brachte die Lösung! Das Serververzeichnis enthielt fortan nur noch die aktiven Mails. Damit wird dem Server wohl gesagt, dass er den Ordner RICHTIG aufräumen soll. Seither tritt dieser Fehler in diesem Ordner nicht mehr auf (bis zur nächsten nötigen Komprimierung, nehme ich mal an ;) ).


    Vorher:


    drwxr-x--- 2 cyrus mail 4096 2007-08-22 19:34 .
    drwxr-x--- 4 cyrus mail 4096 2007-08-22 19:34 ..
    -rw-r----- 1 cyrus mail 17590 2007-06-08 18:15 20.
    -rw-r----- 1 cyrus mail 6932 2007-06-25 13:42 23.
    -rw-r----- 2 cyrus mail 4934 2007-08-01 14:26 46.
    -rw-r----- 4 cyrus mail 219433 2007-08-01 14:31 47.
    -rw-r----- 2 cyrus mail 4927 2007-08-08 16:27 52.
    -rw-r----- 2 cyrus mail 5468 2007-08-08 16:20 53.
    -rw-r----- 4 cyrus mail 219433 2007-08-01 14:31 54.
    -rw-r----- 2 cyrus mail 4383 2007-08-16 15:25 55.
    -rw-r----- 2 cyrus mail 4750 2007-08-21 12:52 56.
    -rw-r----- 2 cyrus mail 5077 2007-08-21 12:50 57.
    -rw-r----- 2 cyrus mail 5523 2007-08-21 12:57 58.
    -rw-r----- 2 cyrus mail 4749 2007-08-21 12:58 59.
    -rw-r----- 1 cyrus mail 4454 2007-08-21 13:00 60.
    -rw-r----- 1 cyrus mail 16684 2007-08-21 14:59 cyrus.cache
    -rw-r----- 1 cyrus mail 199 2007-06-14 05:57 cyrus.header
    -rw-r----- 1 cyrus mail 856 2007-08-21 15:38 cyrus.index
    -rw------- 1 cyrus mail 62617 2007-08-22 19:34 cyrus.squat


    nach "Komprimieren":


    drwxr-x--- 2 cyrus mail 4096 2007-08-22 19:48 .
    drwxr-x--- 4 cyrus mail 4096 2007-08-22 19:34 ..
    -rw-r----- 1 cyrus mail 17590 2007-06-08 18:15 20.
    -rw-r----- 1 cyrus mail 6932 2007-06-25 13:42 23.
    -rw-r----- 1 cyrus mail 4454 2007-08-21 13:00 60.
    -rw-r----- 1 cyrus mail 3688 2007-08-22 19:48 cyrus.cache
    -rw-r----- 1 cyrus mail 199 2007-06-14 05:57 cyrus.header
    -rw-r----- 1 cyrus mail 256 2007-08-22 19:48 cyrus.index
    -rw------- 1 cyrus mail 62617 2007-08-22 19:34 cyrus.squat


    Gibt es dafür eine Einstellung beim Thunderbird, dass er automatisch komprimiert?


    Unter Einstellungen -> Erweitert -> Netzwerk&Speicherplatz Haken bei "Ordner komprimieren, wenn dies mehr Platz spart als ___ KB" und da eine 0 eintragen, geht wohl auch nicht so recht.

  • Und wenn du eine "1" statt "0" einträgst?
    "0" bedeutet in der Regel "kein Limit", daher die Vermutung...


    Grüße,
    Michael

  • Hallo Michael,


    auch nix.... Ich bin gerade in den erweiterten Einstellungen und schau mir die dazugehörigen Variablen an, da gibts noch mehr als ein/aus und die KBs:


    mail.prompt_purge_threshhold: true
    mail.purge_threshhold: 0


    ^^^^^ das sind die übers GUI gesteuerten beiden , der haken und die 0 KB in meinem Fall,...


    mail.purge.min_delay: 480
    mail.purge.timer_interval: 5


    ^^^^^ und die hier gilt es noch herauszufinden,...;)

  • Vielleicht liegts doch am Cyrus:

    Zitat von "cyrus-doc zu imapd.conf"

    expunge_mode: immediate
    The mode in which messages (and their corresponding cache entries) are expunged. "Immediate" mode is the default behavior in which the message files and cache entries are purged at the time of the EXPUNGE. In "delayed" mode, the messages are removed from the mailbox index at the time of the EXPUNGE (hiding them from the client), but the message files and cache entries are left behind, to be purged at a later time by "cyr_expire". This reduces the amount of I/O that takes place at the time of EXPUNGE and should result in greater responsiveness for the client, especially when expunging a large number of messages.
    Allowed values: immediate, delayed

    flushseenstate: 0
    If enabled, changes to the seen state will be flushed to disk immediately, otherwise changes will be cached and flushed when the mailbox is closed. This option may be used to fix the problem of previously read messages being marked as unread in Microsoft Outlook, at the expense of a loss of performance/scalability.


    Vor allem würde ich die zweite Option mal aktivieren.
    Falls das nichts bringt, solltest Du sicherstellen, dass die erste Option auf "immediate" steht und im TB das automatische Expungen beim Verlassen des Ordners aktivieren.


    hth,
    Michael

  • Hallo Michael,


    vielen Dank für den Tipp...! Ich habe es eben mal im imapd.conf eingestellt, werde die Lage beobachten und berichten :)


    Gruß,
    Tachy