Nachrichten, die älter sind als X Tage löschen: Will nicht..

  • Hallo,


    ich arbeite seit über 2 Jahren schon mit Thunderbird, aber ich habs nie geschafft meinen IMAP-Ordnern via Thunderbird beizubringen, dass nur die letzten 30 Mails behalten werden sollen, oder alternativ, Mails die älter als X Tage sind, gelöscht werden. Aber egal was ich einstelle: TB scheint das zu ignorieren. Es wird einfach nix gelöscht, egal wie ich es drehe und wende.


    Das hier ist das Fenster in dem ich die Einstellung vornehme:
    Imap_speicher.png


    Ich benutze TB 2.0.0.6
    IMAP-Server ist ein Courier-Server unter Debian Sarge (eigene Kiste)


    Ich hab hier im Forum und auch mit Google schon gesucht, konnte aber nix finden was darauf hindeutet dass es mit dieser Funktion Probleme gibt, ergo hab ich auch keine Lösung gefunden.


    Wär klasse wenn mir da jemand unter die Arme greifen könnte.


    Gruß
    Alex


    P.S. Ich möchte das ganzer Client-Seitig gelöst haben, und nicht Server-Seitig.

  • Hi, keine Ahnung, was da nicht funktioniert.


    Klappt es denn mit einer eigenen Filterregel?

  • Ähm, vielleicht bin ich ja etwas "doof", aber wie erstell ich denn eine Filterregel für einen speziellen Ordner, die besagt: nur die 30 neusten drin lassen, oder alternativ: alle Mails älter X Tage löschen ...


    Hab keine Möglichkeit gefunden dem Filter zu sagen dass er mit Ordner ABC assoziiert ist.


    Gibts ne Möglichkeit TB irgendwie zu debuggen oder ein Logging einzuschalten? Wenn die Speicherplatz-Funktion nicht geht muss das ja irgendwo zu Tage treten... oder nicht?


    - Alex

  • Zitat von "alex0801"

    Ähm, vielleicht bin ich ja etwas "doof", aber wie erstell ich denn eine Filterregel für einen speziellen Ordner, die besagt: nur die 30 neusten drin lassen, oder alternativ: alle Mails älter X Tage löschen ...


    War nicht ganz so gemeint ;).


    Du kannst eine Filterregel erstellen. Später kannst du per - nicht automatisch - die Regel für einen Ordner anwenden lassen, mit einer Erweiterung auch schnell per Rechtsklick. Automatisch geht es nur im Posteingang des Kontos.


    Das ist nicht das, was du eigentlich willst, aber besser als nix. Und du kannst testen, ob das zumindest funktioniert. Hierfür gibt es ja auch eine Log-Funktion.

  • Hmm, ja, dass es SO geht wusste ich. Dachte es gibt da einen schicken WorkAround.. auch ohne Erweiterung.


    Mich stört's schon, dass die Funktion da ist, aber mir nichts, dir nichts, ohne eine Mucks zu machen, einfach nicht geht. Und das quasi schon seit Jahren (sicher schon seit 2005).


    Weiß jemand ob TB das löschen selbst macht, oder wird da nur ein "Kommando" an den IMAP-Server abgegeben, der das dann selbst "managen" soll?
    Bei letzterem wäre dann ja quasi mein Courier-IMAP-Daemon die Problemstelle, und nicht TB.


    Any ideas?


    - Alex

  • Zitat von "alex0801"

    Hmm, ja, dass es SO geht wusste ich


    Das wiederum kann ich ja nicht wissen. ;)

    Zitat

    .Weiß jemand ob TB das löschen selbst macht, oder wird da nur ein "Kommando" an den IMAP-Server abgegeben, der das dann selbst "managen" soll?


    BIn kein IMAP-Profi, aber ich meine letzteres. Aber ich meine, dass z.B. übliche E-Mail-Provider da unterschiedliche Angaben machen, welches Kommando ihr Server benötigt.


    Spiel deshalb mal in deinen Kontoeinstellungen in TB herum, was dein Server möchte:


  • Ich versteh nicht so ganz was ich da "rumspielen" soll. Die Drop-Down-Box zeigt bei mir exakt das gleiche an wie im Screenshot.


    Hmm.

  • Zitat von "alex0801"

    Ich versteh nicht so ganz was ich da "rumspielen" soll. Die Drop-Down-Box zeigt bei mir exakt das gleiche an wie im Screenshot.


    Du sollst die drei Einstellungen nacheinander mal austesten, ob es zu deinem Problem etwas bewirkt. (Sieh an, hier bin ICH davon ausgegangen, dass du das bereits probiert hast ;))


    Es gibt drei verschiedene Einstellungen fürs Löschen, drei verschiedene Arten zu löschen bei IMAP. Schlimm genug, teste aus, ob es mit einer Einstellung davon klappt.

  • Ähm, ich hab das deshalb nicht probiert, weil ich das schlicht und einfach nicht in Verbindung gebracht habe.


    Im englisch-sprachigen Client wird das noch deutlicher als im deutsch-sprachigen:


    Zitat


    When I delete a message: Move it to the Trash folder / Mark it as deleted / Remove it immediately


    Wenn ich die Sache mit dem markieren einstelle, und eine Nachricht lösche, dann wird sie nur als gelöscht markiert.
    Das hat also offensichtlich wirklich nix mit der Speicherplatzeinstellung, oder wie's im englischen client heisst, "Retention Policy", zu tun, leider.


    - Alex

  • Zitat von "alex0801"

    Wenn ich die Sache mit dem markieren einstelle, und eine Nachricht lösche, dann wird sie nur als gelöscht markiert.


    Als gelöscht markiert bezieht sich jetzt darauf, dass die Markierung bei der nächsten Verbindung/Synchronisation dem Server übermittelt wird und der Server die tatsächliche Löschung durchführt.


    Du kannst ja auch testen, was bei sofortigem Löschen passiert "Remove it immediately". Und wenn das nicht klappt, dann halt in den Papierkorb, auch wenn das nicht dein eigentliches Ziel ist.

  • Naja, war ja nicht anders zu erwarten: Beim sofort löschen macht er was? Sofort löschen.
    Wie gesagt: Der zusammenhang zu der Funktion fehlt gänzlich. Wenn die Funktion annähernd funktionieren würde, müsste ja eines der 3 Phänomene aus der Drop-Down-Box in den KOntoeinstellungen auftreten. Aber es tut sich gar nix.


    Ich such jetzt mal weiter auf IMAP-Server-Seite. Vielleicht find ich da was, vielleicht muss ich da noch irgend eine Option einschalten oder so.


    - Alex

  • Zitat von "alex0801"

    Naja, war ja nicht anders zu erwarten: Beim sofort löschen macht er was? Sofort löschen.


    Nochmal, ich war wohl nicht deutlich genug (oder du hast es bereits probiert und ich kapiere es nicht)


    1. Stelle ein "Sofort löschen" / "Remove it immediately". Danach teste, ob das Löschen so auf deinem IMAP-Server (!!!) funktioniert und dann, ob deine Einstellungen im Ordner nun funtkionieren mit "älter als 30 tage" o.ä.


    2. Wenn es nicht klappt, dann probiere die Einstellung "Als gelöscht markieren / "Mark it as deleted". Dann wieder wir oben testen.


    3. Wenn das auch nicht klappr, dann die dritte Option testen.


    Mir scheint, du verstehst nicht die verschiedenen Möglichkeiten für den Begriff "löschen" - ist aber auch nicht einfach. ;)

  • Also,
    ich hab alles 3 getestet, und alles 3 funktioniert an sich prima. Nur fühlt sich dadurch die im 1. Post angesprochene Funktion davon nicht angesprochen. Der ist es "wurscht" was ich da einstelle. Der Mailserver kann aber offensichtlch alle 3 Lösch-Varianten. Nur die Funktion Nachrichten, die älter sind als X Tage löschen, bzw. Alle außer den neusten X Nachrichten wehrt sich wehement. Soll heißen: Die Funktion unternimmt keinen Löschversucht. Für mich sieht's so aus als ob der Aufruf der Funktion gar nicht bis zum löschen kommt, und es deshalb egal ist was ich aus den 3 Alternativen einstelle.
    Wenn es wirklich serverseitig gelöst ist, dann ist es sowieso wurscht was ich da einstelle.


    - Alex

  • Zitat von "alex0801"

    Wenn es wirklich serverseitig gelöst ist, dann ist es sowieso wurscht was ich da einstelle.


    Das kommt drauf an. Wenn du Mails lokal heruntergeladen hast, kannst die auch lokal löschen. Wenn du hingegen normal in deinem IMAP-Konto löschst, liegen die Mails ja auf dem Server. Hier kann nun TB quasi nur das Kommando zum Löschen geben.


    Vielleicht hat ja noch jemand anders eine Idee ...

  • Deine Beiträge sind noch etwas zu stark auf Newbies getrimmt.


    Ich sagte ja: Ich arbeite seit 2 Jahren mit Thunderbird und betreibe einen eigenen IMAP-Server. Mit IMAP an sich bin ich schon ziemlich gut vertraut. Wie IMAP funktioniert weiß ich ebenfalls.
    Und dass ein Löschvorgang auch auf dem Server ausgeführt werden muss, bin ich mir auch bewusst.


    Mir geht's jetzt nur um die besagte Funktion aus dem 1. Post:


    Triggert TB die Löschaktion der einzelnen Mails auf dem Server wenn sich TB mit dem IMAP-Server verbindet selbst, oder setzt TB nur ein Kommando beim Server ab, das dem Server mitteilt, dass er auch ohne weiteres Client-Zutun die Mails die älter als X Tage sind löscht.


    Ist ersteres der Fall, würde das heißen, dass TB nicht korrekt funktioniert. Ist letzteres der Fall würde das heißen, dass mein Courier-IMAP-Daemon das Kommando von Thunderbird nicht versteht oder unterstützt.


    HIER liegt der Hund begraben.


    - Alex

  • Zitat von "alex0801"

    Deine Beiträge sind noch etwas zu stark auf newbies getrimmt.


    Mag sein. Das liegt zum einen daran, dass mir in deinen Beiträgen oben deine bisherigen Versuche nicht klar geworden sind, zum andern daran, dass meine Kenntnisse hier auch lückenhaft sind.

    Zitat

    Mir geht's jetzt nur um die besagte Funktion aus dem 1. Post:


    Ja, und es war zunächst nicht klar, ob TB das nicht ausführt oder ob die Kommansoübermittlung ins Leere läuft. Jetzt ist es ja klar: Es läuft in TB nicht.


    Die Filterfunktion (30 Tage und so) wird in TB ausgeführt, übermittelt wird AFAIK die Löschung der einzelnen Mails. Aber letzteres ist ja nicht das Problem, wie jetzt nun klar ist.

  • Hmm, gibts hier vielleicht einen spezialist der sich mit den IMAP-Kommandos auskennt? Ich würd ja auf die Suche gehen, aber ich hab keinen Anhaltspunkt. "retention policy imap courier" bringt mich bei google auch nicht weiter.



    - Alex

  • Nochmal Nachschub:


    Bist du sicher, dass du den Ordner beim Testen komprimiert hast (Rechtsklick)? Erst dann werden die Nachrichten ja tatsächlich gelöscht (Speicherplatz freigegeben).

  • Jepp, ich hab die Komprimierungsoption zum Speicherplatzsparen eingeschaltet und ich hab in dem Ordner fast megabyteweise Textmails (ohne Anhang) der letzten 5 Tage (hab die Löschaktion zum testen auf 3 Tage gestellt).


    - Alex

  • Zitat von "alex0801"

    Jepp, ich hab die Komprimierungsoption zum Speicherplatzsparen eingeschaltet und ich hab in dem Ordner fast megabyteweise Textmails (ohne An


    Das meine ich nicht. Diese Einstellung bietet dir nur ab und an das Komprimieren an bzw. macht es je nach deiner Einstellung ab und an automatisch.


    Zudem ist es irrelevant, wie viel MB Textmails der Ordner enthält.


    Entscheidend ist, ob du tatsächlich (!) MANUELL komprimiert hast beim Test.