Umlaute im Absender und Betreff

  • Hallo zusammen.


    Ich verwende hier Icedove 2.0.0.9 auf Debian Sid / Sidux, und habe Probleme mit der Anzeige von Betreff und Absender, wenn da Umlaute enthalten sind. Schaut dann z.B. so aus:

    Zitat

    Neuer Eintrag im G��������


    Das G... sollte eigentlich "Gästebuch" heißen.


    Die Mail kommt als text/html und ISO-8859-1, so steht es zumindest im Header:

    Code
    1. Content-Type: text/html; charset=iso-8859-1


    Im Quelltext werden die Umlaute korrekt angezeigt, und auch im Mail-Body enthaltene Umlaute machen keine Probleme.


    Als Default habe ich ISO-8859-15 eigerichtet, verwende auf Betriebssystem-Ebene allerdings UTF-8 (Default-Einstellung)


    Von andere Stelle versandte Mails in UTF-8 zeigen die Umlaute an, da finde im Quelltext aber auch ein einleitendes "=?UTF-8?Q?" und abschließendes "?=" beim Betreff, die Umlaute selber sind dann codiert: "=C3=B6" soll in diesem Fall ein ö sein. (Diese Mail wurde von der Blogsoftware WordPress gesendet, als text/plain und UTF-8)


    Wo muss ich nach dem Fehler suchen? Es hat ja schließlich irgendwann, bevor ich Sidux installiert habe, auch korrekt funftioniert.

  • Hallo,
    es fehlt bei deinem Auszug aber die Kodierung. Wenn die nicht dasteht, kann TB nur raten.


    Also Content-Transfer-Encoding: quoted-printable
    oder
    Content-Transfer-Encoding: 8bit


    Nur: der Header wird immer mit quoted printable kodiert.
    Erkennbar am "Q?".


    Auch heute trotz aller Protokolle und Kompatibilitäten gilt immer noch die Regel, keine Umlaute in Mails zu benutzen. Warum?
    Weil z.B. quoted printable nicht alle Programme und Systeme lesen können. Manchmal liegt es auch an den Servern.
    Aber bitte lies selbst:
    http://www.rhusmann.de/kuerzel/kuer20j2.htm


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • OK, die Header habe ich mal ergänzt. Es handelt sich um um Mails, die PHP versendet, wenn sich jemand in's Gästebuch einträgt, und da kann ich die Header beeinflussen. Hier aus dem Quelltext der empfangenen Mail:

    Code
    1. Subject: Neuer Eintrag im Gästebuch
    2. From: xxxxxx's Gästebuch <automailer@xxxxxx.xx>
    3. Mime-Version: 1.0
    4. Content-Type: text/html; charset=iso-8859-1
    5. Content-Transfer-Encoding: 8bit


    In der Thunderbird-Listenanzeige ist's jedoch unverändert. Bis zum ersten Umlaut passt's, ab da nur noch Fragezeichen.

  • Sonst niemand eine Idee?


    Auch, wenn ich das Encoding von 8bit auf quoted-printable setze, schauts unverändert aus. Der Fehler liegt also wohl nicht an der Mail, sondern doch an Thunderbird bzw. Icedove.

  • Hallo,
    wenn jemand eine Idee hätte, stände sie schon hier.
    Das Problem ist deine spezielle Umgebung. Die kann man nicht so einfach simulieren, wenn man Windows hat.
    Deswegen kann ich auch nichts mehr dazu sagen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi


    Ich kann, wie mrb, auch nur dazu sagen, verwende (mindestens) in Mailadressen und Betreffszeilen keine Umlaute. Das gibt zu oft Probleme.
    Ist "Gaestebuch" so schlimm? ;-)


    Bruno

  • Natürlich geht Gaestebuch auch. Für das konkrete Beispiel habe ich das auch entsprechend umgestellt. In der Adresse kommt kein Umlaut vor, nur im realname des Absenders, auch geändert.


    Soweit zu diesem Beispiel. Aber ich erhalte auch andere Mails, die Umlaute um Absendernamen (z.B. Jörg) oder im Betreff verwenden. Da habe ich natürlich auf die Schreibung keinen Einfluss, und bekomme dann die Fragezeichen angezeigt. Und der Fehler tritt unabhängig davon auf, ob ich den original Donnervogel oder die Debian-Variante Icedove starte. Und beide verwenden unterschiedliche Profilverzeichnisse (.mozilla-thunderbird für icedove, .thunderbird für Thunderbird), so dass ich einen Konfigurationsfehler entweder zweimal gemacht habe, oder ausschließen kann :confused:

  • Wenn ich unter Windows, oder ubuntu (virtuell) im Thunderbird in "Ansicht/Zeichencodierung" einstelle:


    Automatisch bestimmen: Aus
    UTF-8: Umlaute haben Fragezeichen (Adresse, Betreff, Mailtext)
    8859-1/-15: Umlaute werden angezeigt (Adresse, Betreff, Mailtext)


    In "Extras (oder Bearbeiten)/Einstellungen/Ansicht/Schriftarten" habe ich ISO 8859-15 gewählt.


    Bei dir kann alles wieder anders sein...

  • Ok, Ubuntu ist ja Debian-basiert. Ich habe festgestellt, dass die Codierung da nicht die große Rolle spielt. Denn unter Ansicht ist die Codierung eingestellt, die ich im Header der Mail wiederfinde. Und eine Änderung der Einstellung wirkt sich nur auf den Mailtext aus, nicht aber auf Betreff und Absender. Aber im Text habe ich mit Umlauten auch keine Probleme...


    In Bearbeiten -> Einstellungen habe ich auch als ISO 8859-15 sowohl für eingehende, als auch für ausgehende Nachrichten eingestellt. Aber auch eine vorübergehende Änderung nach UTF-8 für eingehende Mails brachte keine Besserung.

  • Jetzt bin ich im "echten" ubuntu 7.10. Hier habe ich auch überall ISO 8859-15 eingestellt. Änderungen wie ich oben beschrieben habe, sind gleich.


    Da muss es zwischen Debian und ubuntu doch grössere Unterschiede geben...


    Edit:
    Von den Linux-Innereien habe ich nicht gross Ahnung, aber: Könnte es vielleicht an den Spracheinstellungen von Debian liegen?

  • Moderne Linux-Systeme laufen für gewöhnlich mir UTF-8, so auch mein Debian. Sollte bei Deinem Ubuntu ebenso sein, wenn Du da nichts verstellt hast.


    Mögliche System-Sprachen sind bei mir:
    * de_DE
    * de_DE@euro
    * de_DE.UTF-8


    Die erste Option ist ISO-8859-1, die zweite ISO-8859-15.

  • Hallo,


    ich benutze Windows (noch ;)) und habe da selbiges Problem. Ich wollte TB von Grund auf neu konfigurieren und habe deshalb ein frisches Profil genommen. Das lustige ist nun, das mein altes TB es richtig anzeigt und mein neues falsch, ich muss nochmal nachsehen woran es genau liegt bzw. was ich für Unterschiede gemacht habe.


    Ich melde mich mal, wenn ich komplett verglichen habe (falls ich dazu lust habe) bzw. wenn ich das Problem gelöst habe.


    //edit
    Welche Erweiterungen hast du den installiert, vll. liegt es mit daran und ich benutze nun die gleiche.

  • Hallo,
    deine Frage gehört eigentlich nicht hier her, weil du Windows hast.
    Wie bist du denn beim Erstellen des neuen Profil vorgegangen?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    ich finde sie gehört gerade hier her, da es sich um das gleiche Problem handelt und "nur" das OS verschieden ist. Oben hat ja jemand geschrieben das es bei Windows nicht auftritt oder "schade" ist das er kein Windows benutzt. Und ich nutze Windows und habe genau auch dieses Phänomen.


    Mhmm, wie eingerichtet? Na so wie ich es für mich als gut erachte, plaintext Nachrichten, UTF-8.


    Weil dieses Problem bei mir ebenfalls auftriit unter Windows fragte ich ja auch eventuellen Erweiterungen die für dieses Verhalten verantwortlich sein könnten.

  • TB in Windows und Linux ist nicht gleich und ist dem Betriebssystem angepasst.


    Ich meinte aebr wie du beim erstellen des TB-Profils vorgegangen biest oder haben wird uns da missverstanden?
    Zur Kontrolle lies mal in der Dokumentation zum Thema "Profile".


    Post mal deine Einstellungen unter Extras, Einstellungen, Ansichten, Schriftarten und Kodierungen, vor allen die gemachten Haken, die Schriftarten sind ohne Belang.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Mir ist schon klar das Windows nicht Linux ist, fakt ist aber das es sich um das gleiche Anzeigeproblem handelt.


    Ich habe nicht exakt ein neues Profil erstellt sondern die Portable Version genutzt um ein frisches Profil zu haben (da ich gern alles in einem Ordner habe).
    ---
    [x] Nachrichten erlauben, andere Schriftarten zu verwenden


    Ausgehende Nachrichten: UTF-8
    Eingehende Nachrichten: UTF-8


    darunter die 2 Kästchen haben keinen Hacken.
    ---
    Benutze IMAP und habe mal bei dem Ordner auf ISO-8859-1 umgestellt und da funktioniert es.
    Standard-Zeichenkodierung: UTF-8 (ISO-8859-1 geht)
    Sonst sind keine weiteren Haken gesetzt.


    Habe gerade altes Profil mit neuem verglichen und da auch an der Ordner-Kodierung rumgespielt und daran liegt es auch, bei dem einen war UTF-8 (neues Profil) bei dem anderen ISO-8859-1 (altes Profil) eingestellt. Die Frage ist nur warum funktioniert das nicht mit beidem? Habe doch den Haken für Zeichenkodierung ignorieren nicht gesetzt.

  • Hallo,

    Zitat

    Benutze IMAP und habe mal bei dem Ordner auf ISO-8859-1 umgestellt und da funktioniert es.


    Ich würde das im Ordner nicht machen, bei vielen Konten kommt man da schnell durcheinander und darum den Haken dort immer weglassen.
    Aber wie ist denn deine Einstellung unter Ansicht, Zeichenkodierung?
    Ein weiterer Pferdefuß, wenn nicht automatisch der richtige Zeichensatz angezeigt wird.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo mrb,


    also unter Ansicht folgende Einstellungen:


    [x] Nachrichten erlauben, andere Schriftarten zu verwenden


    Ausgehende Nachrichten: UTF-8
    Eingehende Nachrichten: UTF-8


    darunter die 2 Kästchen haben keinen Hacken.


    // hatte das schon im letzten Beitrag aber nicht nochmal deutlicher hervorgehoben ;) möchtest du da noch paar Einstellungen wissen? Denke aber das sind die wichtigen die dich interessieren.


    Zu IMAP:
    ich habe bei dem Ordner keinen Haken gesetzt sondern nur die Kodierungen im Ordner geändert von UTF-8 zu ISO-8859-1 so wie ich es im alten Profil hatte und es funktionierte. Die Frage ist nur, warum hat das überhaupt Auswirkung? Wie gesagt ich habe da ja keinen Haken gesetzt das es alles ingnorieren soll und zwingend UTF-8 benutzen soll, dass finde ich unlogisch.


    Ich hoffe du verstehst jetzt was ich meine ;) falls nein muss ich Screenshots posten. Aber danke dir für deine Zeit und Hilfe, vll kommen wir ja noch dem Problem auf die Spur oder es geht nicht so wie ich mir das denke.

  • Hallo,
    du hast mich wohl falsch verstanden.
    Ich meinte Ansicht, Zeichenkodierung und nicht Extras, Einstellungen, Ansicht.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    mist hast recht, habe dich falsch verstanden.


    Also unter Ansicht hab ich folgendes:


    Normal UTF-8, wenn ich aber die eine Mail auswähle wird ISO-8859-1 daraus. (ist ja auch richtig so)
    Automatisch Bestimmen -> Universell


    soll ich dir noch was posten, oder ist da noch was wichtig?