E-Mail Signieren / Falscher Passphrase

  • Hallo zusammen.


    Nun muss ich mich doch mal an die Community wenden da ich selbst nicht weiterkomme.


    Zuerst an die Technischen details.
    Thunderbird 2.0.0.12
    PGPShell 3.6.4
    Aktuelle GPG Version.


    Nun zu dem Problem.
    Zuvor hab ich mich ein wenig mit PGP/GPG gespielt um dort mal richtig einzusteigen. Da bis dahin Symetrische verschlüsselungen ein großes fragezeichen dargestellt haben. Nun bin ich auch dahinter gestiegen, recht einfach sowie auch genial. :D


    Habe wie gesagt zuvor auch immer Key's erstellt mit dem Passwort: test und diese erst mal hin und her geschickt etc. und dabei hat alles funktioniert. Das Signieren/Verschlüsseln von Thunderbird etc.


    Nun dachte ich mir, erstelle ich mir gestern einen richtigen Key, mit einem richtigem Passwort und lade dies auch auf die Key-Server hoch. Soweit so gut. Nun wollte ich heute auch die erste Signierte Mail verschicken bis dann folgendes Problem auftauchte.
    Jedesmall gibt Thunderbird aus, das ich das Falsche Passwort angegeben habe.


    Kleiner auszug aus der Log.

    Code
    1. enigmail> C:\Programme\GNU\GnuPG\gpg.exe --charset utf8 --batch --no-tty --stat
    2. us-fd 2 -t --clearsign -u 0xXXXXXXXX --passphrase-fd 0 --no-use-agent
    3. gpg: übersprungen "0xXXXXXXXX": Falsche Passphrase
    4. gpg: [stdin]: clearsign failed: Falsche Passphrase
    5. enigmail.js: Enigmail.encryptMessageEnd: Error in command execution


    So, dann began das grübeln, hab ich vielleicht wirklich ein falsches Passwort angegeben, manuell und per Copy&Paste versucht dies einzutragen nichts half.
    Da dachte ich zuerst ich hätte schon beim erstellen einen Falsches Passwort eingegeben. Bis ich auf die Idee gekommen bin über das Frontend GPGShell etwas zu Signieren, und siehe da, dort akzeptiert er mein Key und Signiert eine Datei.


    Nun die frage an was dies liegt.
    Mein Passwort enthält unter anderem Sonderzeichen sowie auch ausgeschriebene umlaute.


    Kann es sein das Thunderbirg, bzw. das Plugin OpenPGP dies nicht richtig verarbeitet bzw. weitergibt?


    Code
    1. gpg: übersprungen "0xXXXXXXXX": Falsche Passphrase


    Dies muss zwar nichts heißen, aber selbst in der Log kann er die Umlaute nicht richtig anzeigen. Weiß nicht ob dies im zusammenhang steht. Aber weiter weiß ich nicht.



    Eine frage noch, obwohl dies eine allgemeine PGP/GPG frage ist, sollte ich mein Passphrase ändern, und diesen auf die Key-Server hochladen, bleibt alles beim alten? Die Schlüssel ID, etc? Ich will nicht unnötige "Dateileichen" dort anlegen.
    Vielleicht nur mal zum testen ob es evtl. wirklich am Passphrase liegt.



    Ich hoffe, ich habe alles gründlich niedergeschrieben, so das man diesen fehler nachvollziehen kann.


    Viele Grüße
    Rara

    Einmal editiert, zuletzt von Rara ()

  • Hallo Rara,


    und Willkommen im Forum!


    Schön, daß Du Dich für open-PGP interessierst. :)
    Zunächst Du sprichst von symmetrischer Verschlüsselung - das kann open-PGP ( = GPG, GnuPG, ...) *auch* - jedoch der wirkliche Sinn & Zweck liegt in der asymmetrischen Verschlüsselung ~ sprich im *Schlüsseltausch*! --> siehe Link unten!


    Dann, wenn es mit dem "test" Passwort geklappt hat, dann geht es ja prinzipiell!
    Sprich Du hast JETZT einfach nur einen Konfigurationsfehler begangen.
    Ich vermute, Du hast in Thunderbird nicht den *richtigen* key ( = Schlüssel) ausgewählt. Dort solltest Du es überprüfen. ;)
    (Ich schließe jetzt mal aus, daß Du durch Tippfehler etc. einen Lapsus begangen hast!)
    Mit Sonderzeichen kommt enigmail / GPG gut zurecht; Umlaute auszuschreiben war ein kluges Vorgehen von Dir.
    Versuche doch mal etwas bei Dir auf dem Computer mittels des neuen keys zu verschlüsseln und dann wieder zu entschlüsseln (das geht schneller als ein Hin- & Hersenden!)


    Den hoch geladenen key würde ich - zunächst - belassen. Ändern kannst Du ihn NICHT! Sollte er tatsächlich unbrauchbar sein, so kannst Du ihn widerrufen, d.h. "revoken"!


    Lies Dir doch mal *hier klicken* diese Hilfen zu GPG aus diesem Thread durch. Du wirst sehen es ist nicht nur hoch interessant, sondern auch ein wirklicher Gewinn in puncto Internetverständnis! [ich habe extra nochmal alle Links überprüft!]


    MfG ... Viktor :cool:

  • Hallo Vic~,


    natürlich meinte ich bei PGP eine aysmetrische verschlüsselung, da bin ich wohl selber nur mal ins stauchen gekommen. :D


    Wie auch das Signieren zuvor klappt das Ver-, und Entschlüsseln mit hilfe von PGPshell wunderbar, erstellt mir die Verschlüsselte Datei, die ich mithilfe meines Keys wieder entschlüsseln kann.


    Stimmt, das mit dem richtigen Schlüssel auswählen, war mein erster fehler. Also wo ich dies zu anfang ausprobiert habe, dort waren noch meine alten schlüssel vorhanden, diese hab ich dann auch mal, um mögliche fehlerquellen zu vermeinden gelöscht. Nun ist nur noch einer bzw. meiner priv. key vorhanden. Und auf diesen ist er auch wirklich eingestellt. Dies sehe ich auch in der Fehler Log, da er dort auch die richtige Schlüssel ID anzeigt.


    Da dies auch mein erster "manuell" erstellter Key ist. Also kein misch key aus DSA und RSA sondern nur einen reinen RSA Key erstellt habe.
    Erstelle ich diesen nocheinmal, genau so, aber wieder mal mit einem einfachen Passwort, einfach mal wieder Test. So schliesse ich einen passwort fehler aus.
    Aber vielleicht mag Thunderbird mein eigenes Pass nicht.
    Aber das kann es einfach nicht sein, da das Signieren/Verschlüsseln über die PGPshell wunderbar klapt.


    Nun teste ich mal ein wenig und gib hier auskunft was esgebracht hat.


    Viele Grüße
    Rara


    Zitat

    Update


    So, mal einen neuen schlüssel erstellt, Passwort war dieses mal das berümt berüchtigte test, und siehe da. Die Mail geht wunderbar raus.
    Hmm, also das der vorherige Key ohne Thunderbird wunderbar funktioniert, kann es nur an dem Plugin bzw. Thunderbird selber liegen, das er das Passwort nicht korrekt weitergibt.


    Nun bin ich erst mal ratlos.
    Jetzt kann ich mir höchstens den Spass machen, alle sonderzeichen einzeln als Passwort zu benutzen, um rauszufinden welches probleme macht. ^^"
    Das mach ich glaub ich mal und Upate ich hier auch.

  • Hallo zusammen,


    Zitat

    Update 2


    So, diese mal geb ich dies als neue antwort aus, da der fehler eingegrenzt wurde.
    Weiß nicht warum ich nicht schon vorher darauf gekommen bin, aber nun hab ich es ausprobiert.
    Jeweils einen Key mit einem Sonderzeichen/Umlaut als Passwort erstellt.
    Als umlaut hab ich nun irgend ein Vokal genommen, jetzt das "ü" und siehe da, Thunderbird gibt wieder an das es das falsche Passwort ist.


    Wäre nett, wenn dies jemand mal bei sich ausprobieren könnte. Ob es an meiner Rechner konfiguration liegt, das keine umlaute richtig übertragen werden, oder ob Thunderbird damit ein allgemeines problem hat.


    Viele Grüße
    Rara

  • Hallo,


    Zitat von "Rara"

    Eine frage noch, obwohl dies eine allgemeine PGP/GPG frage ist, sollte ich mein Passphrase ändern, und diesen auf die Key-Server hochladen, bleibt alles beim alten? Die Schlüssel ID, etc? Ich will nicht unnötige "Dateileichen" dort anlegen.


    Du musst deinen Schlüssel nicht nochmals auf einen Server laden, wenn Du nur die Passphrase geändert hast. Ich versuche kurz und leicht vereinfacht zu erklären, warum das unnötig ist.
    Eigentlich ist das "Passwort" zum Entschlüsseln von Emails der private Schlüssel, also eine Datei. Damit jetzt aber nicht jeder, der einmal an diesen privaten Schlüssel gekommen ist, gleich alle deine verschlüsselten Mails lesen kann, wird als zusätzliche Schutzmaßnahme der private Key verschlüsselt gespeichert und dafür gibst Du auch das Passwort ein (man kann auch Schlüsselpaare ohne Passwort erstellen, sollte man aber natürlich auf gar keine Fall tun).
    Beim Entschlüsseln einer Mail passiert folgendes: Du gibst ein Passwort ein, damit wird der geheime Schlüssel entschlüsselt und mit diesem wiederum wird die Nachricht entschlüsselt. Änderst Du also die Passphrase, bleibt der geheime Schlüssel derselbe, er wird nur neu verschlüsselt gespeichert. Leute, die Dir verschlüsselte Nachrichten schicken oder signierte Nachrichten von Dir bekommen, kriegen davon gar nichts mit.


    Grüße
    Karla

  • Hallo Karla,


    na dann sieht die ganze sache schon wieder ganz anders aus, dachte Passphrase == priv. Key. Das der Passphrase den "verschlüsselten" privaten Key erst freigibt und dieser somit die eigentliche nachricht entschlüsselt, war mir nicht bewusst.
    Damit wurde nun ein großes problem aus dem weg geräumt, einfach nur noch den Passphrase abändern und meine ganzen probleme sind beseitigt.


    Vielen dank für diese erklährung. Nun hat es sogar ein :gruebel: , wie ich, die funktionsweisse verstanden. :D


    Man lernt immer was dazu, und gleich diesen Text einem bekannten weitergereicht, den ich auch mit dem GPG Fieber angesteckt habe. Mit einem schlag sind gleich mehrere leute klüger geworden.


    Thx :zustimm:


    Viele Grüße
    Rara

  • Zitat von "Rara"

    ...dachte Passphrase == priv. Key. Das der Passphrase den "verschlüsselten" privaten Key erst freigibt und dieser somit die eigentliche nachricht entschlüsselt, war mir nicht bewusst.


    Hallo Rara,


    OH Nein! ~ Da hast Du Dir aber die angebotenen Hilfen nicht sehr aufmerksam durchgelesen. ;)

    Zitat von "Rara"

    ... Wäre nett, wenn dies jemand mal bei sich ausprobieren könnte. Ob es an meiner Rechner konfiguration liegt, das keine umlaute richtig übertragen werden, oder ob Thunderbird damit ein allgemeines problem hat.


    Also ich verwende Umlaute in meinen Passphrasen und es funktioniert auch mit TB.


    MfG ... Vic

  • Zitat von "Vic~"


    OH Nein! ~ Da hast Du Dir aber die angebotenen Hilfen nicht sehr aufmerksam durchgelesen. ;)


    Also ich verwende Umlaute in meinen Passphrasen und es funktioniert auch mit TB.


    MfG ... Vic


    Srrrrry :D Habe, wie ich gestehen muss, nur kurz reingeschaut. Und bin davon ausgegangen das es die gleichen dinge sind, mit denen ich mich schon vorher beschäftigt hatte. Waren es dann auch. Nur ich hab eine sehr lange Leitung. Und dabei geht die hälfte meist immer verloren. ^^"
    Erst mit dieser, für Kinder unter 6 Jahren, Anleitung, habe ich es auch erst selbst richtig begreifen können.
    Nun machen auch die Bilder, zu der funktionsweiße der Verschlüsselung, Session Key etc. für mich auch nun mehr Sinn, bzw. konnte diese erst jetzt richtig verarbeiten/verstehen.



    Da es aber nicht ein allgemeines Problem ist, und das Umlautweiterreichen an GPG eher nur meinem Thunderbird/Rechnerkonfiguration zuzuschreiben ist, hat sich das Thema nun vollends erklärt/geklärt.


    Nun kann auch dieser Thread von mir aus geschlossen/gekenzeichnet werden.


    Viele Grüße
    Rara

  • Hi,


    Tolle Lösung des Problems. :rolleyes:


    Ich habe genau das Problem seit ich Enigmail installiert habe.


    Ein Umlaut in meiner Passphrase und das Ding will nicht mehr.


    Meinen Schlüssel oder Passphrase will ich nicht ändern.


    Kann mir jemand verraten, was ich tun muss?


    ( Win XP, Thunderbird Version 2.0.0.12 (20080213), Enigmail Version 0.95.6 (20080101), GNUPG 1.4.8 )


    Danke für die Hilfe

  • Das Thema wurde auf Wunsch von Leto89 wieder von "erledigt" zu unerledigt geändert.


    Willkommen im Forum Leto89!

  • Hallo,


    du könntest uns mit den relevanten Stellen aus dem Log beglücken, so wie rara das im ersten Beitrag auch gemacht hat.
    Ich vermute das Problem darin, dass GnuPG und das Betriebssystem verschiedene character sets erwarten. Das ist schön in raras Log zu sehen, wo zB ü statt einem Ü zu sehen ist. Probiere mal als Zusätzlichen Parameter für GnuPG folgende Zeilen durch (eine nach der anderen):

    Code
    1. --charset iso--8859-1
    2. --charset iso--8859-2
    3. --charset koi8-r


    Ich muss allerdings gestehen, dass ich weder dieses Problem jemals hatte, noch ich mich mit Windows in Bezug auf solche Dinge auskenne. Aber vielleicht konnte ich dir trotzdem helfen oder zumindestens für einen Windowsexperten hier im Forum den nötigen Denkanstoss liefern.


    Karla

  • Also meiner Meinung nach ist jemand, der Umlaute in Passwörtern/Passphrasen verwendet, selbst schuld, wenn das schiefgeht. Der ASCII-Zeichensatz, der auf allen Computern und Betriebssystemen verstanden wird, beinhaltet genug Groß- und Kleinbuchstaben, Zahlen und Sonderzeichen für Passwörter mit jeder gewünschten Sicherheit und Länge.
    m.

  • Hallo Leto89,


    ich hatte Dein posting damals schon registriert, nur war ich ob dieses Kommentars (zumal als ersten Beitrag)

    Zitat von "Leto89"


    Tolle Lösung des Problems. :rolleyes:


    doch eher nicht in meiner Hilfsbereitschaft motiviert!
    Du & Dein Problem wurde gar nicht besprochen.
    [Bei Gefallen und Interesse lesen ]


    Zunächst verweise ich auf das Posting von Karla. ;)
    Hierzu fehlt uns noch die "Beglückung" - ist Dein Interesse doch nicht so groß?.


    Dann: Du brauchst den key ja auch gar nicht zu ändern.


    Wenn es denn *wirklich* nicht bei Dir klappt {und Du Dir die Mühe nicht machen willst}, dann ändere halt einfach doch die Passphrase entsprechend um.
    (und zwar nur diese!) Und schon klappt's.


    (Warum Du die Passphrase par tout nicht ändern willst bleibt wohl unverständlich!)


    [Ich kann nur nochmals betonen, daß es bei mir diese Probleme nicht gibt!
    Sprich: Sonderzeichen klappt! Umlaute klappt! ]


    Und ... öhhmm BTW ... muzel hat nicht ganz unrecht. :cool:


    MfG ... Vic

  • Erstens: Danke an Karla die konstruktiv an die Sache herangeht.


    Zweitens: Ich war zum Zeitpunkt des ersten Posting ziemlich genervt, weil ich meine Passphrase erstellt habe und es ganz normal funktioniert hat (auf der Arbeitsstelle mit der PGP.com-Software). Es funktioniert weiter ganz normal auf der Arbeit. Aber zu Hause benutze ich Thunderbird und wollte deswegen etwas Passendes haben. Nur leider funktionierte es nicht.


    Drittens: Der Beitrag scheint mein Problem doch recht passend zu beschreiben. Sogar die Logeinträge zeigen das gleiche Verhalten. Nur bin ich nicht bereit meine Passphrase zu ändern (aus beruflicher Sicht; es gibt Leute, die sich mehrfach absichern).


    Übrigens zu ASCII: Schön und gut, aber dann sollten doch alle Menschen am besten die gleiche Sprache sprechen, wir könnten auch die Kultur auslöschen und Individualismus ist doch auch für die Katz. ;)
    Ich verstehe encoding-Problem sowieso nicht. Das sollte man doch in Griff bekommen. Ich schaffe das bei meinen Programmen doch auch.


    Viertens: Mein Internet-Provider hatte mir zwischenzeitlich die Leitung gekappt und leider hat ja auch die Antwort gemessen an der Rara-Problem-Beantwortung lange auf sich warten lassen (was wohl auch auf meine rüde Aussage zurückzuführen ist), so dass ich nicht mehr so oft nachschaute.


    Leider sagt er zu Karlas Vorschlag:

    Code
    1. D:\GnuPG\gpg.exe --charset utf8 --charset iso--8859-1 --charset iso--
    2. 8859-2 --charset koi8-r --batch --no-tty --status-fd 2 --with-fingerprint --fixe
    3. d-list-mode --with-colons --list-keys
    4. gpg: conversion from `utf-8' to `iso--8859-1' not available
    5. gpg: `iso--8859-1' ist kein gültiger Zeichensatz
    6. gpg: `iso--8859-2' ist kein gültiger Zeichensatz


    Was nun?

  • Da darf ich Karla zitieren:

    Zitat

    Probiere mal als Zusätzlichen Parameter für GnuPG folgende Zeilen durch (eine nach der anderen):


    Und nicht alle auf einmal.
    Vermutlich hat sie sich verschrieben, aber wie die Zeichensätze richtig heißen, bekommst du sicher heraus (ich weiß es nicht, aber

    Zitat

    gpg: `iso--8859-1' ist kein gültiger Zeichensatz
    gpg: `iso--8859-2' ist kein gültiger Zeichensatz

    spricht ja für sich.)
    Garbage in, garbage out...


    Gruß, muzel

  • Funktioniert nicht.


    ISO-8859-1 Latin1 müsste die richtige sein. Passt aber nicht.

  • Wahrscheinlich handelt es sich bei dem Problem darum, dass die eingegebene Passphrase in ANSI-Kodierung an gpg übergeben wird, allerdings zum Verschlüsseln der privaten Schlüssels die Passphrase in UTF-8 übergeben wurde. Das ist immer dann der Fall, wenn die Schlüsselpaare unter Linux generiert wurden (wenn die Locale entsprechend gesetzt ist) und dann unter Windows in den Keymanager importiert werden. (Umgekehrt ist natürlich das gleiche Problem vorhanden.) Ein anderer Grund dafür kann die Schlüssel-Erstellung mit dem PGP-Desktop unter Windows sein, da dort die Passphrase immer als UTF-8 String interpretiert wird.
    Die Lösung für Dein Problem:
    Unter Windows die Passphrase ändern. Dabei allerdings für die alte Passphrase die Zeichen in UTF-8-Kodierung eingeben (Bsp. für 'ä': Tastenkombination alt-0195 alt-0164 wird zu "ä", UTF-8 Tabelle: http://www.utf8-zeichentabelle.de/, ASCII-Zeichen ganz normal). Dann einfach die neue Passphrase wie gewohnt eingeben.
    oder:
    Unter Linux die Passphrase zu einer Folge von ASCII-Zeichen ändern(a-z,A-z,0-1, wenige Sonderzeichen). Dann unter Windows importieren und wieder zurückändern (diesmal ganz normal).