deutsche Umlaute

  • Ich arbeite mit Thunderbird 2.0.0.14 (20080421) unter Windows XP.
    Häufig kommt es vor (allerdings nicht immer), dass bei eingehenden Mails die deutschen Umlaute (ä,ü,ö) nicht korrekt dargestellt werden, sondern durch 2 Sonderzeichen ersetzt werden. Dies geschieht sogar auch dann, wenn vom Absender ein ursprünglich von mir geschriebener Text (der bei mir natürlich völlig einwandfrei aussah) in der Antwort zitiert wird.


    Liegt das ausschließlich am Absender oder muss ich an meinen Einstellungen etwas ändern? Unter Extras/Einstellungen/Ansicht/Schriftarten und Codierung habe ich schon einiges ausprobiert, bisher aber ohne Erfolg.


    peter.mann

  • Hallo,

    Zitat

    Liegt das ausschließlich am Absender oder muss ich an meinen Einstellungen etwas ändern? Unter Extras/Einstellungen/Ansicht/Schriftarten und Codierung habe ich schon einiges ausprobiert, bisher aber ohne Erfolg.


    Das kann an beiden liegen.
    Wie sind denn deine Einstellungen dort?


    Lies:
    Beitrag
    3.1.1 Schriftarten und Zeichenkodierungen


    In Ergänzung dazu:
    Außerdem sollte unter Ansicht, Zeichenkodierung, "Automatisch bestimmen" auf "universell" stehen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi,
    ich habe jetzt das Häkchen bei "Standardzeichenkodierung auf alle eingehenden Mails anwenden" und der Option darunter entfernt: das war's wohl! Das Problem scheint erledigt.


    Herzlichen Dank für die Hilfe und Gruß!


    Peter Mann

  • Servus @all,


    ich arbeite mit der gleichen Konstellation und habe auch das gleiche Problem wie peter.mann, aber alle Topics hier im Forum und auch Tante Google helfen mir nicht weiter.


    "peter.mann" schrieb:

    Ich arbeite mit Thunderbird 2.0.0.14 (20080421) unter Windows XP.
    Häufig kommt es vor (allerdings nicht immer), dass bei eingehenden Mails die deutschen Umlaute (ä,ü,ö) nicht korrekt dargestellt werden, sondern durch 2 Sonderzeichen ersetzt werden. Dies geschieht sogar auch dann, wenn vom Absender ein ursprünglich von mir geschriebener Text (der bei mir natürlich völlig einwandfrei aussah) in der Antwort zitiert wird.


    Hab sämtliche auffindbare Tricks und Kniffe probiert und bin nun der Verzweiflung nahe :nixweiss:


    Habe alle Einstellungen wie empfohlen, also ISO-8859-15, keine Haken irgendwo drin, außer bei "Nachrichten erlauben...", Zeichenkodierung automatisch bestimmen steht auf universell.


    Was ich bislang feststellen konnte, waren das immer Mails mit UDF-8 im Header.
    Diese werden dann aber mit dem Zeichensatz Westlich (Windows-1252) dargestellt.
    Wenn ich manuell auf UDF-8 umstelle passt es.
    Kurioser Weise geht es automatisch, wenn ich die Mail in einen der Unterordner verschiebe.


    Hab auch schon probiert, dass Ganze zu erzwingen, also UDF-8 als Standard und darunter den Haken gesetzt. Händisch in der Konfig geändert, alles auf UDF-8 gesetzt und den Rest gelöscht. Hat TB überhaupt nicht interessiert. Nach Neustart alles beim Alten.


    Ist jetzt nix weltbewegendes, aber es nervt mich tierisch. :aerger:


    :help: Hat einer der Helden dieses Forums einen Tipp? :help:


    Ich danke Euch im Vorraus :flehan:
    Peter

  • Hallo,
    Helden sind wir hier alle nicht.

    Zitat

    Kurioser Weise geht es automatisch, wenn ich die Mail in einen der Unterordner verschiebe.


    Wie viele Mails hast du im Posteingangsordner bzw. in den Posteingangsordnern?
    Wie groß sind die?
    Größe nach dieser Anleitung anzeigen lassen:
    http://www.thunderbird-mail.de…n-.2FOrdnerliste_anpassen


    Also wie auch immer, die betr. Ordner leeren, den Index zurücksetzen und anschließend komprimieren.
    Den Index der Ordner zurücksetzen:" Rechtsklick auf den Ordner, Eigenschaften, Index wiederherstellen".
    Gruß
    P.S.: wenn in den betr. Mails im Quelltext der richtige Zeichensatz steht - in deinem Fall müsste dort beispielsweise stehen: "Content-Type: text/plain; charset=UTF-8" - dann müsste die Mail auch korrekt dargestellt werden, wenn "Automatisch bestimmen" auf "Universell" steht.

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Vielen Dank mrb!


    Konnte zwar jetzt nix mit der verlinkten Anleitung anfangen, aber der "Rechtsklick" war der Schlüssel.
    Ein Blick in die Eigenschaften von Posteingang ergab eine Standard-Zeichenkodierung "Westlich (Windows-1252)". Aha. Geändert in UTF-8 und schon geht's :zustimm:


    Alle anderen Ordner sind in ISO ...-15. Verstehe wer will, ich nicht, vor allem nicht, wer das wieder gemacht hat ;-)


    Ich hab aber mal vorsichtshalber komprimiert, das kann ja nicht schaden...


    Nochmals vielen Dank!!!
    Peter

  • Hallo,
    weiß der Geier, warum sich diese Einstellung öfter verstellt. DU bist nicht der einzige User, der damit Probleme hatte und alle schwören Stein und Bein, nie dort eine Änderung gemacht zu haben.
    Du hast jetzt dort keinen Haken gemacht, oder? Sonst würdest du die automatische Erkennung wieder abstellen.
    Mein Link bezog sich auf die Anzeigen der Ordnergröße, ungelesene Mails und Anzahl der Mails im Ordnerfenster. Für dich wäre interessant gewesen das Thema "Info-Spalten anzeigen lassen ".
    Das ist die einzige interne Möglichkeit, die Größe der Ordner anzeigen zu lassen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    ich hab mich etwas zu früh gefreut. Vom Regen in die Traufe... :wall:


    UTF-8 geht jetzt, somit auch die Mails aus Outlook und OE. Habe, wie beschrieben, per Rechtsklick auf den Posteingang --> Eigenschaften, diesen auf UTF-8 gesetzt.
    Hat aber mit der Konfig in den generellen Einstellungen nix zu tun. Stehen auf ISO...-15, und keine Haken drin.


    Allerdings hab ich jetzt Probleme mit ISO...-1. :evil: 
    Die Umlaute stehen da in einer grauen Raute mit einem weißen Fragezeichen drin.
    Die automatische Zeichenerkennung steht auf "universell", aber da müsste besser "autonom" stehen ;-) 
    So langsam hab ich keinen Bock mehr, zumal ich unter Ubuntu 7.10 exakt das gleiche Problem hab.


    Ach ja, um Deine Frage zu beantworten. Ich hab gefunden, was Du meinst. Leider gibt es anscheinend keine Summe. Sind rund 40 Unterordner, die jeweils im kB-Bereich gefüllt sind. Rund 500 Mails insgesamt und nochmal 500 in den gesendeten.
    Ich leg da großen Wert auf Übersichtlichkeit, was mir aber den Umstieg und Export in ein anderes Prog wesentlich erschwert...


    Gruß Peter

  • Hallo,
    nein nein, die Anzahl der Mails ist nicht so bedeutend, sondern die Größe der Ordner, nur daraus kann man evtl. Schlüsse ziehen.


    Poste bitte mal den Header des Quelltextes (strg+U) bis zum Beginn des Nachrichtentextes. Mache dabei private Namen unkenntlich.
    Ist eine Mail falsch deklariert, kann TB nämlich nur noch raten und stellt die Mails falsch dar.
    Das war z.B. jahrelang bei Mails von Amazon der Fall. Dagegen kann man praoktisch nichts machen außer die Mails nachträglich entsp. zu verändern.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw