Problem mit Zertifikatsimport

  • Hi @all,


    mit fiel heute folgendes auf:
    Bei einem völlig neuen Profil lassen sich keine Zertifikate importieren.
    Weder der Weg über Schlüsseldateien mit komplettem Zertifikatsbaum (=> "unbekannter Fehler ...") noch der manuelle Import der root-Zertifikate (ohne jegliche Meldung) gelingt.
    Gleiches Ergebnis auch beim Versuch des Imports von Nutzerzertifikaten.


    Bei einer manuellen Übernahme der relevanten Dateien in das neue Profil funktioniert die Nutzung der vorher importierten Zertifikate und Schlüssel wie gehabt - ein weiterer Import schlägt aber ebenfalls fehl.


    Im Menue taucht bei einem neuen Profil auch unter "Extras" der Eintrag "Zertifikats-Manager (Strg+Umschalt+S)" nicht mehr auf.


    Das ganze wurde auf zwei Rechnern unter openSUSE und TB Version 2.0.0.16 (20080720) völlig unabhängig voneinander festgestellt.


    Ist das nur ein Bug oder soll das der Tod von S/MIME mit X.509-Zertifikaten beim Thunderbird sein?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hi Peter, ich wünsche einen guten Morgen!


    Zitat


    Im Menue taucht bei einem neuen Profil auch unter "Extras" der Eintrag "Zertifikats-Manager (Strg+Umschalt+S)" nicht mehr auf.

    ist das nicht unter Extras>Einstellungen>Erweitert>Zertifikate


    *schleicht sich von dannen, da von der Materie so viel Ahnung habend, wie eine Kuh vom Melken*

  • Hi rum,


    danke für deine Antwort.
    Unter Linux sind die allgemeinen und die Kontoeinstellungen unter "Bearbeiten" beheimatet. Ist dort so üblich.
    Und zusätzlich (!) war bislang das Aufrufen des Zertifikatsmanagers auch noch direkt unter Extras möglich. Das und nur das ist jetzt verschwunden. Ist natürlich nicht problematisch, wenn nicht das "richtige" Problem nicht wäre.


    Aber wenn ich dich schon mal an der Strippe habe: könntest du mal testen, ob du auf der WinDOSe Zertifikate importieren kannst? (Dann würde mir nämlich gleich ein Wüüüürgaround einfallen: Virtuelle WinDOSe => dort TB installieren => Zertifikate importieren => die zwei relevanten Dateien nach Linux ziehen ... .)


    Diese Bitte gilt natürlich auch für alle kompetenten Windows-Nutzer, die mit X.509-Zertifikaten umgehen :-)


    MfG Peter (noch Urlauber ...)

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Ach Peter, ich von temporärer Alzheimer Geplagter vergaß, dass du das Glück hast, nicht mit der WinDOSe arbeiten zu müssen :redface:

    Zitat


    Aber wenn ich dich schon mal an der Strippe habe: könntest du mal testen, ob du auf der WinDOSe Zertifikate importieren kannst?

    Gerne! Äh....

    "Peter der Urlauber" schrieb:


    Diese Bitte gilt natürlich auch für alle kompetenten Windows-Nutzer, die mit X.509-Zertifikaten umgehen :-)

    aber hast du mal den letzten Satz meines Postings oben vergrößert, gelesen und verstanden? :mrgreen: *...duck und weg..*


    Also, wenn ich auf importieren gehe, kann ich ein Zertifikat auf meiner Festplatte suchen. Da ich keines habe, fällt mir das weitere Vorgehen nicht ganz so leicht. hmm, ich habe ja sogar ein Zertifikat von dir vom 28.03.2008 an gültig... :gruebel: :nixweiss:

  • Ok, nachdem ich nun mit Zertifikaten versorgt wurde und nach einigen Versuchen habe ich es jetzt geschafft und Peters Zertifikate in meinen TB geschleust.
    Dies nur zur Info, dass also zumindest unter WinDos das Ganze klappt.

  • "rum" schrieb:

    Dies nur zur Info, dass also zumindest unter WinDos das Ganze klappt.


    Hallo Zertifizierer! :)


    ja unter *Windelweich* geht's.


    Gut, daß ich gestern nicht gleich drauflos gepostet habe.
    Als ich abends dann meine SUSie animierte :D stellte ich wie vom Schlag getroffen fest:


    [IMG:http://srv025.pixpack.net/20080817163003148_yoeshiacvd.gif]


    bei den vorangegangenen Updates etc. ist mir wohl Thunderbird rausgeschlumpft!
    Sprich es läuft nur KMail bei der SUSie!
    {Ich will ja nicht nur verschiedene BS kennen lernen sondern eben auch verschiedene mail-clients! ;) }


    Jedoch bei KMail: *Extras* --> *Zertifikatsverwaltung* --> und schon wirft sich mir Kleopatra [*] in die Arme!!! :cool:
    Und sie verhüllt Nichts ~ sondern zeigt all ihre X.509-Zertifikate. :redface:


    Peter evtl. mußt Du mal intim mit der Dame sprechen, wenn schon TB sie ignoriert! :D


    greetings ... Vic


    [*] Die Dame heißt wirklich so - ist eine verbeugende Erinnerung an das ursprüngliche Aegypten-Projekt.
    (als Erläuterung für die Allgemeinheit ~ sonst fragt man sich: "Was will den der Peter mit der Kleo???" :mrgreen: )

  • Hi Vic~


    und vielen Dank für deine Antwort.
    Also ich habe jetzt drei Bestätigungen, dass die WinDOSe nicht betroffen ist (deine, die von rum und mein eigener Test mit dem virtuellen XP).


    Selbstverständlich sind in Kleopatra (*) alle meine Zertifikate drin. Das ist absolut nicht das Problem. Ich kann ja auch weiterhin mit Thunderbird S/MIME nutzen. Habe heute mehrere verschlüsselte und signierte Mails erhalten und gesendet. Das Problem ist nur, dass ich (unter Linux) keine neuen importieren kann. Weder pfx-Dateien noch Herausgeber- und Benutzerzertifikate.


    Ich würde noch nicht einmal etwas sagen, wenn das nur auf einer Maschine passieren würde, aber zeitgleich auf dem Desktop und dem Lappi... ?


    Heute habe ich unter XP neue Zertifikate (je eine Dummie-CA, ein Dummie-Nutzer und eine pfx-Datei für Dummie@xxxxx.de) importiert. => wie schon geschrieben, problemlos. Und die zwei Zertifikatsdateien habe ich dann einfach von der WinDOSe in ein Testprofil unter Linux transplantiert. Ergebnis: vollerErfolg. Sie funktionieren ... .


    Also warten wir einfach ein paar Tage. Manche Probleme lösen sich von allein (mit einem neuen Update).


    Wenn dein TB unter Linux wieder läuft, kannst du da mal einen Importversuch machen? => tnx!


    (*) Kleopatra hat ja genau so wenig wie der Kryptospeicher der WinDOSe mit Thunderbird zu tun. Wir benutzen da ja komplett etwas eigenes.
    Und: Die Dame ist mir schon sehr lange und sehr gut bekannt. Habe einige dicke Ordner mit ihrem Namen drauf in meinem Arbeitszimmer stehen ... .


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Ergänzung:


    Es ist auch nicht möglich, das alternative Kryptografie-Modul "FIPS" zu aktivieren. (FIPS = Federal Information Processing Standard. Dieser gibt u. A. Vorgaben für den Einsatz von kryptografischen Verfahren ... in Behörden. Nur mit diesem zertifizierten Modul darf TB dort eingesetzt werden.)


    Also, KEINERLEI Änderungen/Ergänzungen (Zertifikatsimport) am Kryptomodul möglich. Trotzdem funktioniert es mit den bereits importierten Zertifikaten. ????????????????



    Gibt es denn außer mir keine Linux+Thunderbird-Nutzer, die mal schnell irgend ein X.509-Zertifikat importieren könnten? Falls noch nie mit Zertifikaten gearbeitet und kein Zertifikat vorrätig - ich schicke gern eines.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Problem ist leider immer noch nicht geklärt ... .


    Folgende Fehlermeldung bringt die Fehlerkonsole:


    Fehler: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIX509CertDB.importCertsFromFile]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: chrome://pippki/content/certManager.js :: addCACerts :: line 448" data: no]


    Wie gesagt: frisch installierter Thunderbird, frisch angelegtes TB-Profil, sogar als root getestet.


    Leider bin ich "nur" Netzwerker und kein Programmierer :-(



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,


    ich teste es [natürlich! gerne] auch auf alle Fälle :!:


    Es wird aber {voraussichtlich} bis Anfang nächster Woche dauern.
    (... muß einfach zu viel Kram erledigen ...)


    MfG ... Vic

  • Hallo Peter,


    gibt es denn schon Neuigkeiten oder irgendwas 'Erhellendes' in der Sache :?:


    Also bei mir - SUSE 11 und ein neues Thunderbird 2.0.0.16 (beides quasi "frisch aus der Verpackung" auf einem unbefleckten System) - stellten sich die gleichen Fehler ein.


    Kann es sein, daß wir beide einfach "zu blöd" sind und das Naheliegende nicht sehen??? :gruebel:


    MfG ... Vic

  • na ja

    Zitat


    Kann es sein, daß wir beide einfach "zu blöd" sind ... :gruebel:

    unter Berücksichtigung Eurer bisherigen Aktivitäten im Forum im Allgemeinen und derer im Bereich "Verschlüsselung & digitale Unterschrift" im Besonderen, in Anbetracht der Erinnerung, afaiaatr (as far as i am able to remember), an diverse Postings unter erschwerten Bedingungen durch schlecht informierte User mit ausgeprägtem Selbstbewusstsein hinsichtlich ihres dann leider doch nicht vorhandenen (Halb-) Wissens bezüglich kryptologisch verfälschter Mails, sowie Eurer Anleitungen in der Anleitung, im Hinblick auf die Hoffnung auf weiterhin langjährige und erfolgreiche Hilfestellung für dem kryptologischen Wahnsinn verfallene paranoide Anti-M$´ler, ja, unter Berücksichtigung all dieser und von noch viel mehr Faktoren komme ich zu dem Schluss, dass Ihr jetzt erst mal nicht so hart mit Euch sein sollt und wir einfach davon ausgehen, das Mozilla da dran arbeitet... ;)

  • Tiefes Aufatmen .... !


    Zuerst einmal an dich, rum, meinen Dank für deine tröstenden Worte :-) Gingen mir runter wie Öl ... .


    Und das tiefe Aufatmen gilt dir, Vic~.
    Jetzt bin ich wirklich überzeugt, dass da ein Bug ist. Ich hatte einfach noch keine Zeit, ein frisches System aufzusetzen. Habe eben "nur" mit jeweils einem frischen Thunderbird+Profil getestet.
    Nun gilt es einfach zu warten. Irgendwann haben "sie" es gefixt.
    Und so lange gibt es ja die Krücke mit der WinDOSe.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo rum,


    :D - huija *das* war ein Satz! ;) 
    Ich danke für das in mich gesetzte Vertrauen! Möchte aber betonen, daß ich gerade im Bereich der Kryptographie meine man kann nicht gründlich genug vorgehen. Ich bin noch nicht zufrieden mit mir!


    Hallo Peter,


    ich hatte einem Freund ein frisches SUSE-System aufgesetzt und ihm dabei (klammheimlich) gleich Thunderbird mit "untergejubelt". ;)


    Ich teste diese Woche noch bei mir ausführlicher ~ leider bin ich bei S/MIME nicht so "fingerfertig" wie bei GPG. :redface:


    MfG ... Vic

  • Moin, *


    Ich habe mir (vor?)gestern erstmalig einen nagelneuen 2.0.0.16 auf meine SuSE 10.3 gezogen. (Zuvor hatte ich noch nie mit thunderbird zu tun, bin erst durch Peters Rat dazu gekommen, den mal zu testen) Und ich hatte keinerlei Probleme, die Zertifikate zu importieren...


    Ich bin über Bearbeiten --> Einstellungen --> Erweitert --> Zertifikate --> Zertifikate... gegangen und konnte völlig problemlos sowohl Zertifikate von Zertifizierungsstellen, anderen Benutzern als auch von mir selber importieren. No problemo! :D Ach so: Ja, das sind X.509-Zertifikate gewesen. :les:


    Peter, willst Du das mal nachvollziehen?


    Schönen Gruß!


    hssuhle

  • Hi hssuhle,


    und willkommen im Forum.
    Schön, dass wir uns hier wiedersehen :-)


    Unter 10.3 (und allen Vorversionen, unter denen ich Thunderbird betrieben habe) hat es auch immer problemlos funktioniert. Als ich mein 11.0 komplett neu aufgesetzt hatte, ging es auch. Nur nach einem Update eben nicht mehr. Auch das Update auf Kernel 2.6.25.16-0.1-pae brachte keine Veränderung.
    Nun, bald kommt 11.1 und da ich immer komplett neu installiere (bis auf /home, deshalb geht das immer so schnell und problemlos), habe ich wieder ein frisches System. Schaun wir mal ... .
    Und bis dahin importiere ich neue Zertifikate auf der WinDOSe und kopiere dann die beiden relevanten Dateien in mein Linux - und alle sind zufrieden. So viel Zeit habe ich :-)


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!