? statt ö, ü, ä [Erledigt]

  • Ich verwende Thunderbird Version 2.0.0.19.


    Betriebssystem Vista


    Problem: Ich verfasse ein E-mail mit den Buchstaben ä ö ü. Beim Schreiben werden diese ganz normal angezeigt (auch in anderen Programmen).
    Wenn ich aber dieses E-Mail versende liest der Empfänger (mehrere probiert, also jeder Empfänger) statt ü, ä oder Ö Fragezeichen.


    Die Schrifteinstellungen habe ich geprüft und sie sind eingestellt wie vorgeschrieben.


    Danke im Voraus

  • Hallo,
    mit Schriftarten hat das aber nichts zu tun, sondern mit den Zeichensätzen (TB sagt dazu Zeichenkodierungen).
    Überprüfe daher:
    Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten und Kodierung wird kein Haken gesetzt bei den unteren beiden Kästchen.
    "Nachrichten erlauben andere Schriftarten zu erlauben", sollte angehakt sein.
    Außerdem sollte im Hauptfenster unter Ansicht, Zeichenkodierung, "Automatisch bestimmen" auf "universell" stehen.
    Du hast für das Senden welchen Zeichensatz eingestellt?
    Wenn du die Mail an dich selbst versendest oder an jemand anderen außerdem dem von dir genannten, ist dann die Darstellung ebenfalls falsch?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für die Antwort,


    trotzdem ...


    Ich hab alle so eingestellt wie du gesagt hast.


    Habe an viele Leute und an mich selbst E-mails gesandt gleiches Ergebnis ...


    Wenn jemand mir ü ä ö und außerdem scharfes ß schickt wird das bei mir korrekt angezeigt, wenn ich dieses E-mail an den Absender zurücksende, werden diese Zeichen ebenfalls beim Empfänger umgewandelt.


    andere Sonderzeichen sind nicht betroffen, wie " $ & / \ () = >< *


    Also es sind nur diese Deutsch-spezifischen Buchstaben ö ü ä und ß betroffen.


    lG
    Danke

  • Hallo,
    bei an dich selbst gesandte Mails, die du wiederum beantwortet hast ebenfalls?


    Du hast auf universell gestellt?
    Welchen Zeichensatz (=Zeichenkodierung) hast du als Standard eingestellt?
    Unter Extras, Einstellungen, Verfassen, allgemein ist das zweite Kästchen von oben angehakt?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • ... Unter Extras, Einstellungen, Verfassen, allgemein ist das zweite Kästchen von oben angehakt?


    Das war´s DANKE.


    Wie hängt das eigentlich zusammen: ö ä ü und ß mit 8-bit/quoted printable ...


    Was merkwürdig ist (!!!) : mein Bruder hat das Programm auch, dieses Kästchen ist nicht angekreuzt bei ihm und trotzdem funktionierts mit öüäß, waruuuum ?


    Liebe Grüße und danke nochmal ...

  • Hallo,


    meine Frage könnte zu diesem Thema passen, hoffe ich. Deshalb hier meine Problembeschreibung:


    Ich erhalte gelegentlich Emails, die baltische Zeichen enthalten (also e, i, a usw. mit Häckchen, Punkten und Strichen darüber oder daran). Habe ich nun solch eine Mail, wähle ich unter Ansicht - Zeichencodierung: UTF-8. So ist die Zeichendarstellung dann erwartungsgemäß.
    Das Problem entsteht beim Drucken. Obwohl noch in der Druckvorschau die richtigen Zeichen dargestellt werden, stimmen sie auf dem Papier dann nicht mehr.
    Daß das Problem nicht am Drucker liegt, weil er solche Zeichen nicht beherrschen würde, habe ich überprüft. Es lassen sich z.B. baltische Webseiten fehlerfrei drucken (Browser: Firefox).
    An den Einstellungen unter Extras habe ich bisher vergeblich herumprobiert. Was sollte ich richtigerweise tun?


    Thunderbird-Version: 2.0.0.19
    Betriebssystem: WindowsXP Home


    Vielen Dank im Voraus !!

  • Zitat von "adhs"

    Was merkwürdig ist (!!!) : mein Bruder hat das Programm auch, dieses Kästchen ist nicht angekreuzt bei ihm und trotzdem funktionierts mit öüäß, waruuuum ?


    So sollte es eigentlich auch sein, da QP unter Umständen bei bestimmten Servern oder PC Probleme machen kann.
    Es hängt offensichtlich mit bestimmten Einstellungen Systemen der Empfänger/Versender zusammen.
    Wenn du darüber mehr erfahren möchtest, bitte googlen.
    Hier ein Hinweis, der dir vielleicht helfen könnte:
    http://de.wikipedia.org/wiki/Quoted-printable


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "salsalover"


    Ich erhalte gelegentlich Emails, die baltische Zeichen enthalten (also e, i, a usw. mit Häckchen, Punkten und Strichen darüber oder daran). Habe ich nun solch eine Mail, wähle ich unter Ansicht - Zeichencodierung: UTF-8. So ist die Zeichendarstellung dann erwartungsgemäß.


    Du hast die Tipps in meiner ersten Antwort überprüft?
    Besonders den zweiten Teil?
    Wen alles genau übereinstimmt, dann wurde die Mail vom Absenderprogramm nicht richtig deklariert.
    D.h. es wurde in UTF-8 geschrieben aber als bspw. ISO-1250 deklariert.
    Poste doch einfach mal eine Zeichensatzdeklarierung hier ins Forum.
    Öffne die Mail im Quelltext (strg+U) und kopiere ähnliche Teile wie diese hierher:


    Content-Type: text/plain;
    charset="iso-8859-1"
    Content-Transfer-Encoding: quoted-printable
    oder
    Content-Type: text/plain; charset=ISO-8859-15
    Content-Transfer-Encoding: 7bit
    oder
    Content-Type: text/html; charset=UTF-8
    Content-Transfer-Encoding: quoted-printable


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke "mrb" für die rasche Antwort!


    Ich fange hier einmal mit dem zweiten Teil Deiner Rückfrage an.
    Folgendes finde ich im Quelltext:
    =========================================
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_Part_2019716_5183837.1232458937261"


    ------=_Part_2019716_5183837.1232458937261
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: quoted-printable
    =========================================
    Die folgenden Zeile aus dem Email-Quelltext enthält ein paar der fraglichen baltischen Zeichen.
    =09=09=09Maza L=C4=81=C4=8Dpl=C4=93=C5=A1a iela 5


    Kannst Du daraus schon etwas entnehmen?


    Dann dies noch:
    Bei "Ansicht" - "Zeichenkodierung" - "Automatisch bestimmen" steht der Markierungspunkt bei "(Aus)". Wenn ich es ändere nach "Universell", dann sieht die Mail dem Quelltext sehr ähnlich, also die oben schon gezeigte Zeile hat dann dieses Aussehen:
    Maza L=C4= =81=C4=8Dpl=C4=93=C5=A1a iela 5


    Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten und Kodierung habe ich bei den unteren beiden Kästchen keine Haken gesetzt.
    "Nachrichten erlauben andere Schriftarten zu erlauben" ist angehakt.


    Und sowohl bei "Ausgehende Nachrichten" wie auch bei "Eingehende Nachrichten" habe ich "Unicode (UTF-8)" stehen.


    Ich freue mich auf Deine Meinung und Hinweise.
    ---------------------------------------------------------------------

  • Zitat von "mrb"


    So sollte es eigentlich auch sein, da QP unter Umständen bei bestimmten Servern oder PC Probleme machen kann.
    Es hängt offensichtlich mit bestimmten Einstellungen Systemen der Empfänger/Versender zusammen.


    Gruß


    Könnte es wirklich damit zusammenhängen, dass ich Win Vista und mein Bruder XP verwendet ??


    Gibts das, dass das Betriebssystem Einfluss auf das E-mail Programm hat und auf dessen Zeichencodierung?


    Grüße

  • Hallo,

    Zitat

    Könnte es wirklich damit zusammenhängen, dass ich Win Vista und mein Bruder XP verwendet ??


    Das halte ich für unwahrscheinlich.

    Zitat

    Gibts das, dass das Betriebssystem Einfluss auf das E-mail Programm hat und auf dessen Zeichencodierung?


    Ja, weil das Betriebssystem die Zeichenkodierungen kennen muss. Es gibt Systeme, denen ist beispielsweise UTF-8 unbekannt.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • salsalover ,

    Zitat

    Die folgenden Zeile aus dem Email-Quelltext enthält ein paar der fraglichen baltischen Zeichen.
    =09=09=09Maza L=C4=81=C4=8Dpl=C4=93=C5=A1a iela 5


    Das ist Teil des Nachrichtentextes oder des Betreffs?

    Zitat

    Dann dies noch:
    Bei "Ansicht" - "Zeichenkodierung" - "Automatisch bestimmen" steht der Markierungspunkt bei "(Aus)". Wenn ich es ändere nach "Universell", dann sieht die Mail dem Quelltext sehr ähnlich, also die oben schon gezeigte Zeile hat dann dieses Aussehen:
    Maza L=C4= =81=C4=8Dpl=C4=93=C5=A1a iela 5


    Das bedeutet, das TB nicht in der Lage ist, aufgrund der Deklarierung den Zeichensatz automatisch darzustellen.
    Wenn du auf "universell" stellst und dann die Mail noch einmal neu aufrufst, welcher Zeichensatz wird jetzt unter Ansicht, Zeichenkodierung angezeigt? Das ist der entscheidende Punkt. Den dort müsste der Zeichensatz stehen, der auch in der Deklarierung steht. D.h. die Anzeige der Zeichenkodierung wird je nach Mail anders ausfallen.
    Deine Einstellungen sind OK.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo "mrb",


    =09=09=09Maza L=C4=81=C4=8Dpl=C4=93=C5=A1a iela 5


    ist Nachrichtentext und soll so aussehen: [IMG:http://web2.vs170057.vserver.de/beispiel.jpg].


    Wenn ich auf "universell" stelle und die Mail noch einmal neu aufrufe, dann steht unter Ansicht, Zeichenkodierung "Westlich (Windows-1252)" und der betreffende Text sieht so aus: [IMG:http://web2.vs170057.vserver.de/beispiel_2.jpg]. Schalte ich hier von Westlich (Windows-1252) dann auf Unicode (UTF-8), dann stimmt das Schriftbild.


    Was kann man nun wohl noch tun, damit ich diese händische Korrektur nicht jedes Mal machen muß (wenn es in meinen Fällen überhaupt möglich ist)?


    Danke für Deine Geduld und Gruß!

  • hallo,
    das ist in der Tat merkwürdig, da ja UTF-8 richtig deklariert wurde.
    Könntest du mir so eine Mail als *eml (Datei, Speichern als, Datei) zu kommen lassen?
    Ich würde dir meine E-Mailadresse per PN posten.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"


    Könntest du mir so eine Mail als *eml (Datei, Speichern als, Datei) zu kommen lassen?
    Ich würde dir meine E-Mailadresse per PN posten.


    Hallo "mrb",


    ja, das möchte ich gerne tun.
    Was mich jetzt, nach dem Speichern als eml-Datei jedoch irritiert: eben diese eml-Datei wird von Thunderbird völlig richtig dargestellt. Selbst wenn ich dann bei "Ansicht" - "Zeichencodierung" andere Optionen wähle, also UTF-8 ersetze, bleiben die Zeichen, wie sie sein sollen. Deshalb wäre ich sehr dankbar, wenn Du das tatsächlich noch genauer unter die Lupe nehmen würdest.


    Besten Dank und Gruß

  • Hallo,
    ich habe nicht die geringsten Probleme mit den beiden auch nicht beim Drucken..
    Dann musst du es anders machen, könntest du die beiden Mails direkt an mich weiterleiten?
    Schaue ich aber in den Quelltext (strg+U), sind da schon nicht korrekte Zeichen.
    Z.B. Gr=C3=BC=C3=9Fen! (=Grüßen). Das könnte aber an der Kodierung quoted printable liegen.
    Die Mail an mich ist übrigens nicht in QP kodiert.
    Lies http://de.wikipedia.org/wiki/Quoted-Printable
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    mit der weitergeleiteten kann ich das Problem nachvollziehen.
    Die Ursache:
    der Quelltext (strg+U) ist OK.
    Deklarierung: charset=windows-1252


    Die ist auch OK.
    Nur die Mail ist in UTF-8 geschrieben. Wie soll TB jetzt aufgrund der falschen Deklarierung die Mail richtig darstellen?
    Der Fehler liegt entweder beim Absender oder beim versendenden oder beim empfangenden Mailserver.
    Hast du einen eigenen Mailserver?
    Auch können solche Probleme entstehen, wenn Mails auf einer Webseite versendet werden.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • salsalover ,


    was ich nicht verstehe, dass in der an mich gesendeten *.eml Datei die Deklarierung nicht mehr windows-1252 war, sondern - so wie es richtig wäre - UTF-8.
    Woran ich das erkenne? Einmal aus den Zeichensalat (hatte n wir schon öfter) und zum anderen aus dem Umkehrschluss: das ja nur UTF-8 funktioniert, ist die Deklarierung falsch.


    Ich habe das bei mir mehrfach versucht, die *.eml abzuspeichern und mit TB zu (und OE und WLM) zu lesen, immer mit Fehlern. Auch in der Druckervorschau immer falsch.


    Damit du eie richtig drucken kannst, gibt es meiner Meinung nach nur eine Lösung:
    die Deklarierung des Zeichensatzes in der Mail dauerhaft verändern.
    Also anstatt charset=windows-1252;
    charset=UTF-8, zu schreiben.
    Das geht nur mit dem Add-on TB Header Tools Extension .
    Nach der Installation das Tool unter Extras aufrufen dort "full source" klicken und die Änderung dort im Quelltext vornehmen.
    Das geht innerhalb von 20 Sekunden.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo "mrb",


    ganz herzlichen Dank für Deine Unterstützung. Ich denke, mein Problem ist nun gelöst.
    Nach ein paar zusätzlichen, eigenen Versuchen habe ich mir jetzt folgende Strategie zum Drucken solcher verunglückten Mails vorgenommen:


    "Datei" - "Speichern als..." - "Datei", also eine eml-Datei erzeugen. Dann gleich danach:
    "Datei" - "Datei öffnen...". Jetzt werden alle Zeichen richtig dargestellt. Dann:
    "Datei" - "Drucken...", und alles ist richtig auf dem Papier.


    Mehrere Tests zeigen bis jetzt, daß es funktioniert. Dein Hinweis, wenn auch aus einem anderen Grund, eine eml-Datei zu erzeugen, hat mir diese Möglichkeit eröffnet.


    Nochmals danke für Deine Hilfe!
    Viele Grüße,
    salsalover