IMAP: Ordnerstruktur "zerschossen"

Am 24.09.2018, werden in der Zeit zwischen 21:00 Uhr und 09:00 Uhr des folgenden Tages Wartungsarbeiten am Server durchgeführt. Daher wird die Webseite in dieser Zeit nur eingeschränkt erreichbar sein.
  • Guten Morgen und Hallo an das Forum.


    Ich hoffe, ich kann das Problem gut beschreiben. Es geht um meine IMAP-Ordner, welche nicht mehr richtig verwaltet werden. Wenn ich bei einem Konto einen neuen Ordner anlege, wird dieser jetzt jedesmal in einen zusätzlichen Ordner "imap.hostname" angelegt.


    [IMG:http://ramelow-online.de/Thunderbird/Folders-Broken.jpg]


    Wenn ich diese Ordner nun wieder löschen möchte, dann erhalte ich die Fehlermeldung


    "Thunderbird" schrieb:

    Der aktuelle Befehl war nicht erfolgreich. Der MailServer antwortete: Target mailbox doesn't allow inferior mailboxes.


    Ich möchte dieses Problem natürlich unbedingt beheben und hoffe jemand kennt dieses Problem bereits und kann mir helfen.


    Mein Dank ist Euch sicher ...
    Christian

  • Hallo und willkommen im Forum!
    Fehler unbekannt. Vermute aber einen Serverfehler.
    Entferne das Konto und richte es neu ein.
    Achte darauf, dass das Konto in deinem Profil im Ordner IMAP dort alles gelöscht ist, sonst musst du das erledigen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • allblue ,
    wobei ich mich allerdings frage, was man denn dort hereintun darf:

    Zitat

    Unterordner welche weitere Unterordner enthalten. Diese können jedoch keine E-Mails beherrbergen!


    Adressbücher, Akten, Rechnungen?
    Ach ja, deine Kristallkugel wieder repariert?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Nö, das ist etwas missverständlich ausgedrückt bei denen:


    Wenn ein Ordner Unterordner hat, können in dem Unterordner natürlich Mails liegen, nicht aber im Ordner selbst.

    Zitat

    Ach ja, deine Kristallkugel wieder repariert?


    Weil ich das mit all-inkl.com vermute? ;) Das Problem gab es schon mal, meine ich - daher kam ich drauf. Zudem habe ich selbst bei diesem Unternehmen meine Internet-Existenz liegen. ;)

  • Hallo allblue,
    jetzt ist alles geklärt.

    Zitat

    Wenn ein Ordner Unterordner hat, können in dem Unterordner natürlich Mails liegen, nicht aber im Ordner selbst.


    Woran man mal wieder sieht, dass man IMAP-Konten nicht unbedingt vergleichen kann.
    Gehört das alles zum IMAP-Protokoll?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Was weiß ich ... ? :nixweiss: :mrgreen:


    Zumindest habe ich das aber noch von keinem anderen Anbieter gehört.

  • "allblue" schrieb:

    Der Fragesteller hat versäumt zu erwähnen (was die entscheidende Info wäre), dass sein Hoster all-inkl.com ist und kennt die dortigen Gegebenheiten nicht:
    http://www.all-inkl.com/index.…b=thunderbird2imap-ordner


    Weiß aber nicht, ob ich richtig liege. ;)


    Wow! Ni schlecht! Ja stimmt. Ich bin bei All-Inkl.com.


    Allerdings kann ich weder den IMAP-Ordner noch den Unterordner löschen. Ich habe letztens den Thunderbird-Mail-Ordner aus der Grafik oben angelegt. Der übergeordnete IMAP-Ordner war bis zu diesem Zeitpunkt nicht vorhanden und wurde mit dem Thunderbird-Mail-Ordner zusammen angelegt.


    Ich werde dann wohl mal die Konten löschen und neu anlegen. Gibt es eine Möglichkeit die Filter zu exportieren, ich habe SEHR VIELE Ordner und daher auch SEHR VIELE Filter. Ich will die nicht noch einmal alle neu einrichten.

  • Sieh an ... ;)


    Tipp: Lösche den Ordner mal über das Webmail-System von all-inkl.com.


    Ich würde die Konten deshalb nicht löschen - zudem hast du ja hinterher dieselbe Ordnerstruktur, da diese ja auf dem Server besteht.

  • hehe. Das Webmail-System von All-Inkl.com
    http://webmail.all-inkl.com/index.php
    bietet mir grundsätzlich keine Ordnerstruktur an. Nur den Posteingang. Ich kann nur via IMAP auf die Ordnerstruktur zugreifen.


    Also werde ich All-Inkl.com kontaktieren müssen. Mal sehen, was die dazu sagen.


    Edit:


    Durh einen Test habe ich zumindest schonmal feststellen können, dass dieses Problem tatsächlich nur bei All-Inkl.com besteht. Meine Web.de Adresse ist nicht betroffen. Ordner kann ich da ganz selbstverständlich anlegen und wieder löschen.

  • Hallo,

    Zitat

    Durh einen Test habe ich zumindest schonmal feststellen können, dass dieses Problem tatsächlich nur bei All-Inkl.com besteht.


    Das hatte ich mir schon früher gedacht:

    Zitat

    Vermute aber einen Serverfehler.


    Ob das ein Fehler ist oder gewollt, das sei dahin gestellt. Darum wäre ich auch an einer Klärung interessiert.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • "Christian R." schrieb:

    hehe. Das Webmail-System von All-Inkl.com
    http://webmail.all-inkl.com/index.php
    bietet mir grundsätzlich keine Ordnerstruktur an. Nur den Posteingang. Ich kann nur via IMAP auf die Ordnerstruktur zugreifen.


    Seltsam, das kann und darf nicht sein und riecht nach POP:


    Bist du sicher, dass du du im Webmail-System unter "Mein Account" > Einstellungen als Servertyp überhaupt IMAP eingestellt hast? Standardmäßig steht das auf POP.


    Bei Umstellung auf IMAP und Relogin hast du dann alle "normalen" IMAP-Ordner.


    Das würde natürlich einiges erklären ...


    edit mrb :
    Wie gesagt, die oben verlinkte Erklärung und Unterscheidung kenne ich nur von all-inkl.com. Weiß nicht, ob es das woanders auch gibt.


    Das Problem von Christian hier scheint aber doch anders zu sein, da er auf der Webmail-Oberfläche keine Ordner vorfindet. Das kann eigentlich kein IMAP sein, siehe oben.

  • "allblue" schrieb:

    Seltsam, das kann und darf nicht sein und riecht nach POP:


    Bist du sicher, dass du du im Webmail-System unter "Mein Account" > Einstellungen als Servertyp überhaupt IMAP eingestellt hast? Standardmäßig steht das auf POP.


    Bei Umstellung auf IMAP und Relogin hast du dann alle "normalen" IMAP-Ordner.


    Oh man! Ich habe meine Domain nun schon seit zwei Jahren und mich immer wieder geärgert, dass die Webmail-Oberfläche keine Ordner anbietet. :wall: Und jetzt so ein Reinfall. :stupid: lol


    Also Danke. Jetzt sehe ich endlich meine Ordner im Webmailer.


    ---


    Ich konnte dem Problem nun soweit auf den Pelz rücken, dass ich die falschen Ordner im Webmailer gelöscht habe. Bei All-Inkl.com muss der Ordner rekursiv gelöscht werden, also beim untersten Ordner angefangen bis hoch zur Wurzel. Anschließend habe ich mein Thunderbird neu gestartet und die noch (unter Umständen) existierenden falschen Ordner gelöscht. Soweit auch alles i. O.


    Nach einem neuen (sicher ist sicher) Neustart von Thunderbird habe ich einen Testordner angelegt. Erster Erfolg im TB: Es wird kein IMAP-Ordner mehr angelegt. Soweit so gut. Nur löschen konnte ich den Testordner nicht.


    "Thunderbird" schrieb:

    Der aktuelle Befehl war nicht erfolgreich. Der MailServer antwortete: Target mailbox doesn't allow inferior mailboxes.


    Also vorerst ist ein Löschen nur über den Webmailer möglich. Dann den TB neu starten, damit die Ordnerstruktur neu eingelesen wird.


    Da Ihr bisher so gute Tips und auch Hinweise hattet, vielleicht fällt Euch für den letzten Schritt noch etwas ein? Ansonsten bleibt mir sicher nur der Kontakt zum Provider. Ich weiß, dass dieses Problem auftrat, nachdem mein USB-Stick, auf dem TB läuft, mitten im Betrieb ausfiel. Evtl. war gerade eine Anfrage an den Server in Arbeit und hat auf dem Server was zerschossen. Obwohl ich mir das nun wirklich nicht vorstellen kann.

  • Nachtrag:


    Das löschen der IMAP-Ordnerstruktur hat bisher nur bei einem Konto geklappt. Schon beim Zweiten wird ein neuer Ordner jedesmal wieder in einen IMAP-Ordner gepackt. :freak:


    Auf dem Webmail-System kann ich ganz normal arbeiten, also einen Ordner alegen und löschen. Der Name des IMAP-Ordners entspricht dem lokalen Ordner meines TB-Profils für das jeweilige Konto und wird im Profil auch unter dem Konto als neuer Ordner anglegt. Kann es evtl. doch ein Bug im TB sein? Das TB eventuell versucht ungefragt einen Ordner als Ordner für Ordner anzulegen?

  • OK. Ich habe testweise eine zweite Version von TB gestartet und ein Konto neu eingerichtet. Resultt: Die selben Probleme. Fazit: Also ist es definitiv ein Server-Problem und Sache des Providers. Da ich gleich in den Urlaub fahre, nächste Meldung in 1 1/2 Wochen. Bis dahin kann mir die Sache gestohlen bleiben. :D


    Ich bedanke mich bei Euch für Eure Hilfe. Viel Erfolg weiterhin.


    Christian

  • Bin nicht sicher, ob ich alles verstanden habe.


    Standardmäßig hat man - auch in TB - im IMAP-Konto auf gleicher Ebene die Ordner "Posteingang", "Entwürfe", "Gesendet", "Paperkorb" - evtl. noch "Vorlagen". Hier sollten auch die entsprechenden verschiedenen Ordner-Icons angezeigt werden. An diesen Ordnern sollte man keinesfalls rumwerkeln.


    Auf welcher Ebene legst du nun deinen zusätzlichen Ordner an? Direkt im IMAP-Konto oder als Unterordner? Welcher Typ von Ordner, Typ A oder B?