Anlage im Mailt. als Buchstaben Mix und hyroglypen [erl.]

  • Ich versende Zeichnungen als Anlage im Format " dxf ".
    Leider wird die Anlage in der MAIL als Buchstabenmix Angebzeigt .


    Es gibt einen Beitrag im Forom bei WORD Dokumenten das hat bei mir aber nicht geholfen.
    Anbei der Qultext:


    From - Sat Mar 21 08:42:18 2009
    X-Account-Key: account4
    X-UIDL: 1136470379.6934
    X-Mozilla-Status: 0001
    X-Mozilla-Status2: 10000000
    X-Mozilla-Keys:
    Return-Path: <XXXXXXXXXXXXX>
    Received: from mailin19.aul.t-online.de (mailin19.aul.t-online.de [172.20.27.51])
    by mhead502 with LMTP; Sat, 21 Mar 2009 08:42:11 +0100
    X-Sieve: CMU Sieve 2.3
    Received: from fepb01-svc.XXXXXXXXXXXXXXXXXX ([80.152.31.31]) by mailin19.aul.t-online.de
    with esmtp id 1LkvqG-1DPWZU0; Sat, 21 Mar 2009 08:42:04 +0100
    Received: from [91.41.143.81] by mail.wXXXXXXXXXXXXXXXXXXXXXXX
    id <XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX>
    for <XXXXXXXXXXXXXXXX>; Sat, 21 Mar 2009 08:41:56 +0100
    Message-ID: <4XXXXXXXXXXXXXXXXXXXXXXXXXXX>
    Date: Sat, 21 Mar 2009 08:41:55 +0100
    From: XXXXXXXXXXXXXXXXXXXXXXXXXXX
    User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
    MIME-Version: 1.0
    To: "XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    Subject: 55
    Content-Type: multipart/mixed; boundary="------------020207030502010809040509"
    X-TOI-SPAM: n;1;2009-03-21T07:42:11Z
    X-TOI-VIRUSSCAN: clean
    X-TOI-EXPURGATEID: 149288::090321084204-1C5FFBB0-82B637C0/2160847508-0/0-3
    X-TOI-SPAMCLASS: CLEAN, NORMAL
    X-TOI-MSGID: 0930673e-9a05-47ae-b0b1-aeba96d66944
    X-Seen: false
    X-ENVELOPE-TO: <XXXXXXXXXX>
    X-AntiVirus: checked (incoming) by AntiVir MailGuard (Version: 8.0.0.45; AVE: 8.2.0.120; VDF:
    7.1.2.195)
    X-Avira-Antispam: Version 7.0.4.6 on XXXXXXX (192.168.178.25) settings.db:7.0.4.6.3.2 (28-01-09
    10:21) global_words.db:7.0.4.6.0.1 (28-01-09 10:21) user_words.db:7.0.4.2.0.1 (01-09-08 17:17)
    X-Avira-ScanDate: 03/21/09 08:42:40
    X-Avira-SpamScore: ata: 0.000 bayes: 0.000 final: 0.000
    X-Avira-SpamLevel: No spam


    This is a multi-part message in MIME format.
    --------------020207030502010809040509
    Content-Type: text/plain; charset=ISO-8859-15; format=flowed
    Content-Transfer-Encoding: 8bit



    --

  • Hi mno2009,


    und willkommen im Forum (<== ja, so viel Zeit nehmen wir uns hier ...)


    Wo wird denn die Anlage "im Mail als Buchstabenmix angezeigt"?
    Vermutlich beim Empfänger.


    Fast alle Mailclients haben die nützliche Möglichkeit bestimmte Dateianhänge (reine Texte, aber auch einfache Bilder wie jpg u. einige andere) in einem eingebauten Betrachter direkt im Mailtext anzuzeigen. Die meisten Nutzer freuen sich darüber, weil sie diese Dateien (Anhänge) nicht immer extra öffnen müssen.


    Bestimmte Dateien sind in ihrer inneren Struktur auch "Textdateien", so zum Bsp. AutoCAD-Dateien. Nun, diese werden dann eben auch wie eine Textdatei angezeigt.


    Zum Glück kann man in den Einstellungen der Mailclients das eingebundene Anzeigen von Mailanhängen deaktivieren. Der Anhang wird aber immer ganz normal als Anhang übertragen.


    Nebenbei: Den "Buchstabenmix", welchen du in deinem Beitrag mitgesendet hast, ist der reine Mailheader. Den gibt es immer und der sagt zu deinem Problem nichts aus.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo,

    Zitat

    Den "Buchstabenmix", welchen du in deinem Beitrag mitgesendet hast, ist der reine Mailheader. Den gibt es immer und der sagt zu deinem Problem nichts aus.


    Genau. Es fehlen die für den Anhang notwendige Deklarierung und zumindest ein paar Reihen des in Text kodierten Anhangs. Und da bin ich sehr gespannt, wie die für diesen Dateityp aussieht.


    Die Deklarierung eines Anhangs sieht etwa so aus (bei einer PDF-Datei):


    --------------070107000703020702050709
    Content-Type: application/pdf;
    name="Flyer EDF Meeting.pdf"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
    filename="Flyer EDF Meeting.pdf"


    JVBERi0xLjMKJcfsj6IKNSAwIG9iago8PC9MZW5ndGggNiAwIFIvRmlsdGVyIC9GbGF0ZURl
    Y29kZT4+CnN0cmVhbQp4nOy9y6 usw.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • --------------020207030502010809040509
    Content-Type: text/plain;
    name="10 =?ISO-8859-15?Q?st=FCck_Hebel_blech_4mm_4301=2Edxf?="
    Content-Transfer-Encoding: 8bit
    Content-Disposition: attachment;
    filename*0*=ISO-8859-15''%31%30%20%73%74%FC%63%6B%20%48%65%62%65%6C%20%62;
    filename*1*=%6C%65%63%68%20%34%6D%6D%20%34%33%30%31%2E%64%78%66


    0
    SECTION
    2
    HEADER
    9
    $ACADVER
    1
    AC1015

  • Hallo,
    ja der Anhang ist nicht deklariert.
    Öffne deine Registry und schaue dort unter HKEY_CLASSES_ROOT nach der Endung.dxf.
    Ist diese dort nicht vorhanden (bei mir ist sie es nicht), wird sie TB ebenfalls unbekannt sein, weil TB sich mit den Mimetypes eben aus Windows versorgt. Wenn dort die Endung nicht verankert ist, woher soll TB sie dann kennen?
    Ein Workaround wäre vielleicht (muss man ausprobieren), die Endung umzubenennen, so dass sie von TB akzeptiert wird. pdf, txt, csv usw sind kein Problem.
    Versende dann so eine Testmail über "Später senden", damit sie in den Postausgang gelangt. Dort kannst du den Quelltext untersuchen. Wie eine richtige Deklarierung aussehen muss, hatte ich dir ja schon gepostet.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    Ergänzung: habe mal ein bisschen experimentiert und mehrere Datei umbenannt in *.fxd.
    Offensichtlich richtet sich TB auch nach der Struktur des Anhangs.
    Eine *.exe Datei hat dann korrekterweise eine solche Deklarierung:


    Content-Type: application/octet-stream;
    name="MIXER.fxd"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
    filename="MIXER.fxd"


    eine *.txt Datei eine solche:


    Content-Type: text/plain;
    name="Readme.fxd"
    Content-Transfer-Encoding: 7bit
    Content-Disposition: attachment;
    filename="Readme.fxd"


    Offensichtlich kann aber TB mit dem Inhalt des CAD-Formats nichts anfangen. Das wäre auch zuviel verlangt, von jedem Programm deren Formate analysieren zu können.


    Da mit leider keine Original *.fxd Datei zu Verfügung steht, kann ich es auch nicht testen.
    Auf jeden Fall - wie Peter Lehmann schon sagte - darf die Datei nicht eingebunden versendet werden.
    Deshalb sollte man vorsichtshalber eine Änderung in der Konfiguration (about:config) machen, damit
    TB die Mail nicht als inline deklariert.
    Ändere daher den Eintrag mail.content_disposition_type auf 1.
    Siehe http://www.thunderbird-mail.de…elle_manuelle_Anpassungen


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für eure Mühe.
    Den wert hatte ich schon auf "1" gesetzt
    "dxf" ist in der der Registery eingetragen
    In der registery bei "dxf" war ein Unterordner den ich jetz gelöscht habe
    und alles klappt wie gewünscht


    Nochmal DANK : : :top: