Add-ons lassen sich nicht installieren [erledigt]

  • Version 2.0.0.23
    OS: Windows Vista Business
    CPU: AMD Phenom X4+
    Hauptspeicher 4 GB


    Add-ons lassen sich nicht installieren. Wenn ich ein bereits bei der Grundinstallation installiertes Add-on anklicke, friert TB ein und ich komme nur mit dem Taskmanager wieder heraus. In der Fehlerkonsole stehen folgende Fehlermeldungen:


    Warnung: reference to undefined property this._IDToDirMap[id]
    Quelldatei: file:///C:/Program%20Files/Mozilla%20Thunderbird/components/nsExtensionManager.js
    Zeile: 1496


    Fehler: e.location.getItemLocation(e.id) has no properties
    Quelldatei: file:///C:/Program%20Files/Mozilla%20Thunderbird/components/nsExtensionManager.js
    Zeile: 4244


    Gruss - Sligo

  • Guten Morgen und willkommen im thunderbirdforum!


    Ich würde mein thunderbirdprofil sichern und dann thunderbird mal de- und dann neu installieren, denn offenbar ist irgendwas beschädigt. Das Profil wird zwar bei einer De- und Neuinstallation nicht angerührt, da Thunderbird streng trennt zwischen Daten- und Programmdateien, aber eine Sicherung des Profils empfiehlt sich einfach immer.


    Hilft das nicht, würde ich ein neues Profil zum Test erstellen, also Thunderbird mit dem Profilmanager starten, Startmenü ausführen Thunderbird.exe -p und dann schauen, ob sich in einem neu installierten Thunderbird in einem neuen Profil Erweiterungen installieren lassen.

  • "Rothaut" schrieb:

    Guten Morgen und willkommen im thunderbirdforum!


    Ich würde mein thunderbirdprofil sichern und dann thunderbird mal de- und dann neu installieren, denn offenbar ist irgendwas beschädigt. Das Profil wird zwar bei einer De- und Neuinstallation nicht angerührt, da Thunderbird streng trennt zwischen Daten- und Programmdateien, aber eine Sicherung des Profils empfiehlt sich einfach immer.


    Hilft das nicht, würde ich ein neues Profil zum Test erstellen, also Thunderbird mit dem Profilmanager starten, Startmenü ausführen Thunderbird.exe -p und dann schauen, ob sich in einem neu installierten Thunderbird in einem neuen Profil Erweiterungen installieren lassen.


    Ich habe TB neu installiert und ohne Profil gehen auch die Add-ons zu installieren. Auch funktionieren die Add-ons erst einmal auch nach dem Anlegen meiner Konten. Aber sobald ich einen Neustart von TB mache, kann ich die Add-ons nicht mehr aufrufen (friert wieder ein), ich kann kein neues Add-on installieren, es kommt immer folgende Fehlermeldung:
    -------
    Thunderbird konnte das Add-on von folgender Adresse nicht installieren:


    file:///D:/Installprog/Thunderbird%20Setup%202002.0.0.23/xpunge-0.3-tb.xpi


    Grund: bei der Installation ist ein unbekannter Fehler aufgetreten
    Schauen Sie in der Fehler-Konsole für weitere Informationen nach.
    -203
    -------
    Fehlermeldung in der Fehler-Konsole:


    Fehler: e.location.getItemLocation(e.id) has no properties
    Quelldatei: file:///C:/Program%20Files/Mozilla%20Thunderbird/components/nsExtensionManager.js
    Zeile: 4244
    -------
    Ich habe TB auf einem zweiten Rechner mit völlig identer Ausstattung zum Testen installiert - genau der gleiche Fehler.


    Ratlos!


    Gruss - Sligo

  • Hallo Sligo


    und willkommen im Thunderbird-Forum!


    Hast du TB mit dem Button "Herunterladen" oben auf dieser Site oder von sonst woher installiert?

    "Sligo" schrieb:

    Auch funktionieren die Add-ons erst einmal

    Welche Add-ons hast du denn installiert?
    Installiere noch mal neu und füge dann ein Add-on nach dem andern jeweils mit Neustart von TB ein und teste dazwischen immer wieder.



    Btw: bitte einfach auf QuickReply oder Antworten gehen und nicht den gesamten Beitrag zitieren, sonst ist das sehr unübersichtlich. Teilzitate kann man mit den Quote Button oder mit

    Code
    1. [quote]...[/quote]
    2. bzw
    3. [quote="name"]...[/quote] (ergibt: name hat geschrieben...) einfügen
  • "rum" schrieb:

    Hast du TB mit dem Button "Herunterladen" oben auf dieser Site oder von sonst woher installiert?


    ich hab's von http://www.mozilla-europe.org/de/products/thunderbird/


    "rum" schrieb:

    Welche Add-ons hast du denn installiert?


    mit der TB-Installation: talk back 2.0.0.9


    Sobald ich ein anderes Add-on installieren möchte, kommt der in der zweiten Nachricht beschriebene Fehler. Auch wenn ich in den Add-on auf "Einstellungen" oder auch einen anderen Button klicke, friert TB ein und nur der Taskmanager (oder manchmal nur der Resetknopf) helfen mir heraus.

    "rum" schrieb:

    Installiere noch mal neu und füge dann ein Add-on nach dem andern jeweils mit Neustart von TB ein und teste dazwischen immer wieder.


    Das habe ich bereits mehrmals getan.


    Vielleicht zusammenfassend:


    ich installiere TB in ein jungfräuliches System ;)
    ich installiere Add-ons
    die Add-ons lassen sich installieren
    ich richte ein Konto ein
    und von dem Augenblick an kommen die beschriebenen Fehler.


    Ohne die Add-ons anzuwenden, funktioniert TB problemlos, meine Standardinstallation hat 5 Konten und mein E-Mailverkehr hat keine Einschränkung. Entdeckt hatte ich den Fehler, als mir nach dem Umstieg von WinMail die Signaturen abgingen und ich das Add-on "Signatur-Switch" installieren wollte. Daraufhin habe ich auch andere Add-ons versucht, aber der Fehler war überall gleich.


    Sligo

  • Hmm, dann würde ich am ehesten auf einen Virenscanner tippen, der die Installation der *.js Scripte blockiert.

  • "rum" schrieb:

    Hmm, dann würde ich am ehesten auf einen Virenscanner tippen, der die Installation der *.js Scripte blockiert.


    Nein, nein - es lag schon am TB, Version 2.0.0.23, denn nach diversen Versuchen hatte ich mich entschlossen, die Version 3.0b4 zu versuchen (selbstverständlich nach einem Acronis-Backup) und damit waren alle meine Probleme gefixt. Jene Add-ons, welche Version-3 tauglich sind, lassen sich völlig problemlos installieren und deinstallieren. So vorallem das von mir besonders gewünschte "Signatur-Switch".


    Ich denke, ich werde der 3.0b4 trotz Vorbehalte vertrauen.


    Gruss Sligo

  • guten Morgen!


    Ich taue mich zu sagen, dass Du 3b4 vertrauen kannst, ich habe aufgrund der besseren Bedienbarkeit mit einem Screenreader schon seit 3b3 nur mehr 3erbetas und Nitghtlybuilts im einsatz, allerdings eine regelmäßige #Sicherung des Profils ist immer empfehlenswert, und ein Profil, das mal mit 3erversionen gelaufen ist, sollte nicht mehr mit 2erversionen angesteuert werden, da es da schon Probleme gibt.

  • "Rothaut" schrieb:

    guten Morgen!
    Ich taue mich zu sagen, dass Du 3b4 vertrauen kannst


    Vielen Dank! Es beruhigt mich.


    "Rothaut" schrieb:

    ein Profil, das mal mit 3erversionen gelaufen ist, sollte nicht mehr mit 2erversionen angesteuert werden, da es da schon Probleme gibt.


    Ich habe nicht vor, zu downgraden. TB verwende ich deshalb, weil ich zu unterschiedlichen Zeiten auf drei unterschiedlichen PC's mit unterschiedlichen MS-OS arbeite und immer alle E-Mails mitnehmen muß. Nachdem MS mit Win7 bei den Mailreadern dem Anwender wieder einmal ein völlig ungeeignetes Produkt auf's Aug' drücken will, war TB die entscheidende Wahl.


    Nochmals, vielen Dank für die Beruhigung und viele Grüsse, ebenfalls aus Wien - Sligo

  • Hi,


    grundsätzlich läuft ja die 3er Beta recht stabil, aber eine tägliche Sicherung ist das mindeste. :!:


    Wenn du IMAP hast, dann die Mails auch in lokale Ordnern kopieren und sichern, bei POP die Mails auf dem Server belassen. Eine Heute stabile Beta kann bei der nächsten Version eine Macke haben und wenn die versehentlich die Mailbox leert, kann das dumm ausgehen. Ein Löschbefehl im IMAP-Ordner wirkt auch auf dem Server...

    "rum" schrieb:

    Hmm, dann würde ich am ehesten auf einen Virenscanner tippen, der die Installation der *.js Scripte blockiert.

    das ist wohl eine sehr vage Annahme. Natürlich kann es sein, dass ein Script in TB 2.x anders aussieht als in TB 3.x und deshalb der Scanner momentan ruhig ist, aber wenn meine Vermutung richtig ist, dann geht das irgendwann schief.
    Antivirus-Software - Datenverlust droht!

  • "Sligo" schrieb:

    ...Nachdem MS mit Win7 bei den Mailreadern dem Anwender wieder einmal ein völlig ungeeignetes Produkt auf's Aug' drücken will, ...


    Hallo,


    - :lol: + :zustimm:

  • guten Abend miteinander"

    "Sligo" schrieb:

    :
    Ich habe nicht vor, zu downgraden. TB verwende ich deshalb, weil ich zu unterschiedlichen
    Zeiten auf drei unterschiedlichen PC's mit unterschiedlichen MS-OS arbeite und immer
    alle E-Mails mitnehmen muß. Nachdem MS mit Win7 bei den Mailreadern dem Anwender
    wieder einmal ein völlig ungeeignetes Produkt auf's Aug' drücken will, war TB die
    entscheidende Wahl.


    Da muss ich Billys Rasselbande ausnahmsweise mal in Schutz nehmen. Ich war vor 2 wochen in einem Vortag eines Microsoftlers über Windows 7, und der sagte, dass bei diesem OS Windowsmail nicht mehr standardmäßig dabei ist, man es sich aber runterladen kann oder für einen andern Mailer entscheiden.


    [OT]
    Tja und da fällt mir immer der ein: Liebe Mods, wenns zu gewagt ist, klpft mir eine auf die Finger und ich nehm ihn wieder raus:
    Windows Mail trifft auf seiner Reise durchs WWW eine Kuhflade. Die fragt ganzz erstaunt: Wer bist denn Du? Windowsmail ganz stolz: Ich bin ein inovativer, vielseitiger, userfreundlicher Mailklient.
    Ahso, meint die Kuhflade, dannn bin ich ab jetzt eine Sachertorte.
    *duck und weg*.[/OT]


    Edit: Ich habe mal deine despektierlichen Äußerungen auf "OT" gesetzt. ;)Mod. graba