Nach Upgrade auf ubuntu 9.10. Probleme mit Enigmail [erl.]

  • Hallo, ich hatte meine Frage dummerweise in einem Thema gestellt, das als gelöst markiert war, darum quote ich das hier in ein "ungelöstes" neues Thema:


    Edit: Um Doppelposting zu vermeiden, habe ich deinen 1. Beitrag in dem anderen Thread gelöscht.
    Mod. graba

  • Hallo elcheuter,


    Zitat von "elcheuter"

    die Datei secring.pgp ... ist doch mein geheimer Schlüssel, oder verstehe ich das die ganze Zeit falsch?


    Nein - das ist schon richtig!


    IMHO ist ein Ändern der Rechteverwaltung nicht nötig.


    Zitat von "elcheuter"

    Seltsamerweise kann ich Mails auch verschlüsseln, nur nicht entschlüsseln. Selbst die Mails, die ich erfolgreich verschlüsselt versendet habe, kann ich in meinem Postausgang nicht mehr entschlüsseln


    Nun zum Entschlüsseln benötigst Du ja die secrings. Scheinbar sind die für Dein GPG nicht auffindbar bzw. nutzbar.
    Gehe ich richtig in der Annahme, daß du auch nicht signieren kannst?


    *Leider* fällt mir momentan noch keine rechte Lösung für Dich ein!
    Überprüfe mal den Pfad zu den geheimen keys.
    Kannst Du denn gpg ohne enigmail nutzen?


    MfG ... Vic

  • Danke für die schnelle Antwort :zustimm:


    Stimmt, signieren kann ich auch nicht - dann wird mir angezeigt, meine Passphrase sei falsch...


    Was pgp ohne Enigmail angeht: Es tut mir leid, aber ich bin scheinbar echt zu blöd, herauszufinden, wie man das macht. Habe gegoogelt ohne Ende, aber klug bin ich nicht geworden - vielleicht Wald vor lauter Bäumen nicht gesehen oder so :nixweiss: Hast du vielleicht einen Link, mit dem ich mich klugmachen kann? Sorry!


    Ansonsten, falls das helfen könnte, die Fehlerkonsole von Enigmail gibt folgendes aus:

    Zitat

    Initializing Enigmail service ... EnigmailAgentPath=/usr/bin/gpg enigmail> /usr/bin/gpg --version --version --batch --no-tty --charset utf8 gpg (GnuPG) 1.4.9 Copyright (C) 2008 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law. Home: ~/.gnupg Unterstützte Verfahren: Ãff.Schlüssel: RSA, RSA-E, RSA-S, ELG-E, DSA Verschlü.: 3DES, CAST5, BLOWFISH, AES, AES192, AES256, TWOFISH Hash: MD5, SHA1, RIPEMD160, SHA256, SHA384, SHA512, SHA224 Komprimierung: nicht komprimiert, ZIP, ZLIB, BZIP2 enigmail> /usr/bin/gpg --charset utf8 --batch --no-tty --status-fd 2 -d --use-a gent


    hier dann die public keys der mailpartner


    gpg: Entschlüsselung fehlgeschlagen: Geheimer Schlüssel ist nicht vorhanden enigmail.js: Enigmail.decryptMessageEnd: Error in command execution

  • Hallo,


    in den Fehlermeldungen ist einmal der GPG-User-Agent an, einmal aus. Wie sieht den die Einstellung dazu aus? Falls der Haken bei "Zur Passphrasenverwaltung die GPG-Agent-Anwendung verwenden" gesetzt ist, mach ihn mal weg.


    Grüsse,
    Karla

  • Hallo Karla
    der Haken war nicht gesetzt. Hab ihn dann mal probeweise gesetzt, hat aber nichts geholfen.
    Grüße (und danke)

  • Zitat von "elcheuter"

    - dann wird mir angezeigt, meine Passphrase sei falsch...
    Was pgp ohne Enigmail angeht ... vielleicht einen Link, mit dem ich mich klugmachen kann? Sorry!


    Hallo elcheuter,


    Hhmmm ... evtl. stimmt Grundsätzliches bei Deiner Installation nicht - kann ja leicht passieren. ;)


    über: Anwendungen -> Zubehör -> Passwörter und Verschlüsselung kommst Du zu GPG und S/MIME.


    über: System -> Einstellungen -> Verschlüsselung und Schlüsselbünde kommst Du in die key-Verwaltung.
    Dort ist es ratsam einen Haken bei "Füge mich ..." (siehe roter Pfeil) zu setzen - dadurch wird stets auch mit dem *eigenen* key verschlüsselt.


    Das entspricht dem "zum Standard-key verschlüsseln". Ansonsten kannst Du von Dir Verschlüsseltes & Versendetes selbst nicht mehr lesen!


    Passwörter und Verschlüsselung läßt sich ( z.B. ) in Nautilus einbinden.
    Im Dateimanager eine beliebige, {unwichtige} Datei auswählen, mit der rechten Maustaste => Verschlüsseln [Signieren]
    Person auswählen für die die Datei verschlüsselt werden soll => OK
    [Beim Signieren das Kennwort für Deinen geheimen Schlüssel eingeben.]


    Die Text-Verschlüsselung kann auch in 'Gedit' via:
    Bearbeiten -> Einstellungen -> Plugins -> Text-Verschlüsselung angewählt werden.



    So kannst Du Dein GPG *ohne* enigmail testen. Dadurch sehen wir dann ob evtl. generell etwas nicht geht.


    Siehst Du denn unter Eigenschaften Deinen private-key so wie hier?




    Sind denn die verwendeten Schlüssel auch in der Verwaltung sichtbar?




    Wenn all das Abgefragte "o.k." ist, dann gehen mir langsam die Ideen aus! :gruebel:
    {Ich gehe davon aus, daß es mit einer früheren Version von Ubuntu ja geklappt hat ~ oder?}


    MfG ... Vic :hallo:

  • Hallo Vic~ :hallo:


    Zitat von "Vic~"


    Hallo elcheuter,


    Hhmmm ... evtl. stimmt Grundsätzliches bei Deiner Installation nicht - kann ja leicht passieren. ;)


    kann sein, aber ich hatte erst auf 9.10. upgegradet, bevor ich mir ein Herz gefasst habe und den Rechner komplett neu aufgesetzt haeb, um die leidige windowspartition loszuwerden, die ich bis dahin als dualboot hatte. und sowohl nach dem ugrade als auch jetzt geht enigmail nicht mehr - müsste also zweimal was mit der Installation schiefgegangen sein :nixweiss:


    Zitat von "Vic~"


    über: Anwendungen -> Zubehör -> Passwörter und Verschlüsselung kommst Du zu GPG und S/MIME.


    ja, das geht und da sind auch alle Schlüssel aufgeführt.


    Zitat von "Vic~"


    über: System -> Einstellungen -> Verschlüsselung und Schlüsselbünde kommst Du in die key-Verwaltung.


    nein, einen solchen Unterpunkt gibt es bei mir nicht. Das könnte es vielleicht sein!



    seltsam, weder bei gedit noch bei nautilus (also mit rechtsklick auf datei im dateimanager) gibt es bei mir eine solche option...das ist ja ominös.


    Bei allen früheren ubuntuversionen hat alles reibungslos funktioniert, ist absolut das erste Mal, dass ich mit Gnupg Probleme hab.


    Vielen vielen Dank und Grüße
    elch

  • Zitat von "elcheuter"

    ... weder bei gedit noch bei nautilus (also mit rechtsklick auf datei im dateimanager) gibt es bei mir eine solche option...


    Hallo elch,


    also dann stimmt IMHO etwas mit Deinen installierten Paketen nicht.
    Diese Optionen gibt es sogar bei einer (fixen) Life-CD.


    Leider läuft Ubuntu bei mir derzeit auf keinem Rechner { die liebe fehlende Zeit :rolleyes: }.
    Daher hoffe ich auf einen user bei dem *momentan* die aktuelle Version läuft & funktioniert!


    (Ich denke Dir ist klar, daß mit enigmail nichts klappen kann, wenn's schon mit Nautilus nicht geht.) :wall:


    Evtl. versuchst Du ja einfach mal die Pakete aus den Paketquellen neu zu instalen.


    MfG ... Vic :hallo:

  • Hallo Vic


    danke für die Antwort. Hier: http://wiki.ubuntuusers.de/Seahorse#Nautilus steht, dass seit 9.10. erst ein Plugin installiert werden muss, damit Nautilus das kann. Hab ich gemacht, klappt alles einwandfrei. Auch die Option "Verschlüsselung und Schlüsselbünde" ist jetzt unter System -> Einstellungen zu finden.


    Soweit alles gut. Nur eins funktioniert nach wie vor nicht: das Entschlüsseln von Mails :aerger: . Neuerdings werde ich noch nicht mal mehr nach der Passphrase gefragt, sondern gleich der Fehler angezeigt.


    Grüße und danke
    elch

  • Hi Elcheuter,


    installier auch mal das GPG2-Paket und den GPG-Agent aus den Paketquellen. Stell dann in den Enigmail-Einstellungen den Pfad zu GPG2 von Hand ein.


    Hast du Enigmail aus den Paketequellen installiert?


    Bei mir hat es, auch nach Installation auf 9.10, Probleme mit Enigmail gegeben.


    Gruß Ian

  • Hallo Ian


    danke für die Antwort! Offenbar steh ich auf dem Schlauch: Was ist das GPG2-Paket? Synaptic findet sowas nicht, und google behauptet auch, dass es das gar nicht gibt :(


    Enigmail und auch Thunderbird habe ich auf alle möglichen Arten installiert, deinstalliert, neu installiert. Aktuell aus den Paketquellen. Seltsam finde ich ja, dass auch wenn man unter Synaptic vollständig entfernen wählt, bei Neuinstallation schon alle Einstellungen, Mails etc. wieder da sind - irgendwie komisch.


    Grüße
    elch

  • Zitat von "elcheuter"


    danke für die Antwort! Offenbar steh ich auf dem Schlauch: Was ist das GPG2-Paket?


    Sorry, ich meinte gnupg und gnupg2
    dann in TB unter OpenPGP > Einstellungen > Allgemein > Dateien und Verzeichnisse
    anderer Pfad das Häckchen setzen und usr/bin/gpg2 einstellen

    Zitat von "elcheuter"

    Aktuell aus den Paketquellen.


    Bei mir hat die Variante TB/GnuPG/GnuPG2 aus den Paketquellen und Enigmal als Addon normal installiert (also nicht aus den Paketquellen) funktioniert

    Zitat von "elcheuter"

    Seltsam finde ich ja, dass auch wenn man unter Synaptic vollständig entfernen wählt, bei Neuinstallation schon alle Einstellungen, Mails etc. wieder da sind - irgendwie komisch.


    Das liegt daran dass alle Profildaten beim entfernen nicht gelöscht werden. Selbst bei vollständiger Entfernung. Deine Profildaten liegen immer in /home/DeinUsername/.mozilla-thunderbird/DeinTbProfil-Ordner.


    Gruß Ian

  • Hallo Ian


    hab ich alles gemacht. Einziger Unterschied zu zuvor: in der Fehlermeldung steht jetzt



    Kann doch nicht wahr sein...

  • Hi,


    ich hab die vorherigen Posts nicht komplett gelesen, daher die Frage.
    Hast du schon versucht die Sicherungskopien der Schlüssel neu zu laden. Nicht in TB sondern in Ubuntu unter Anwendungen > Zubehör > Passwörter und Verschlüsselung. Sie stehen dann auch in TB zur Verfügung.


    Gruß Ian

  • Ne, das hab ich noch nicht versucht. "Neu laden" bedeutet, alle zu löschen und neu zu importieren (von der Sicherungskopie aus)?


    Aber kann das echt die Lösung sein? Schließlich kann ich mit den Schlüsseln ja VERschlüsseln, nur eben nicht ENTschlüsseln.

  • kann es sein, dass der sender der email nur "an sich verschlüsselt" und darüber vergisst auch mit deinem schlüssel zu verschlüsseln. das ist mir am anfang mal passiert.


    kannst mir auch deine emailadresse mit zukommen lassen per pn. dann können wir das durchexerzieren.


    gruss ian

  • So, hab mir jetzt letztlich nen neuen Schlüssel gemacht, damit klappte alles auf Anhieb. Warum das mit dem alten nicht mehr ging weiß der Geier :aerger:


    Danke für die Hilfe!