Vom TB zum iPod eigene Bilder senden unmöglich [erledigt]

  • Wenn ich eine Mail im TB schreibe und mit einem Bild aus meinen eigenen Dateien versende, erscheint im iPod nur z.B. 3595. jpg und nicht das Bild. Das nützt dem Empfänger gar nichs.


    Vom OE aus klappt diese Aktion und das Bild erscheint gleich im iPod.
    So muss ich leider zeitweilig meinen Standardbrowser TB verlassen.


    Abgefunden habe ich mich schon damit, dass ich nicht vom TB- sondern nur aus dem OE, in dem ich leider kaum Adressen habe - mein Mail-Adressbuch zum iPod synchronisieren kann. So tippe ich alles von Hand ein
    Warum hängt Apple den TB so ab?
    Gruß Biggele

  • Hallo,
    gute Frage. Man müsste den Quelltext (strg+U) beider Mailklienten vergleichen und zwar im Postausgangsordner. Wenn du anstatt auf "Senden" auf Datei, "Später senden" gehst, gelangt die Mail direkt dort hin, wo man sie untersuchen kann.
    In OE muss strg+F3 drücken, um in den Quelltext zu gelangen.


    Virenscanner/Firewall vorhanden, die den TB-Profilordner abscannen??


    Und noch etwas: evtl. mag der iPod eine bestimmte Deklarierung nicht, die TB in den Mailheader schreibt. Nämlich diese:


    Code
    1. Content-Type: image/jpeg;
    2. name="crystal_ball_1.jpg"
    3. Content-Transfer-Encoding: base64
    4. Content-Disposition: inline; <------------
    5. Content-Disposition: attachment;
    6. filename="crystal_ball_1.jpg"


    Ergebnis nach Änderung der Konfiguration:


    Wie du siehst, fehlt jetzt der Eintrag "inline".


    Code
    1. Content-Type: image/jpeg;
    2. name="crystal_ball_1.jpg"
    3. Content-Transfer-Encoding: base64
    4. Content-Disposition: attachment;
    5. filename="crystal_ball_1.jpg"


    Das Problem tritt auf, wenn der empfangende Mailklient nicht TB ist und keine Möglichkeit hat, "inline"-Lesen abzuschalten. Das kann z.B. bei Outlook Express oder Lotus Notes auftreten.
    In TB kann man jeden Textanhang inline lesen oder auch abschalten durch Änderung unter Ansicht, "Anhänge eingebunden anzeigen".
    Alternativ kannst du aber deine Text-Dat Datei in ein Archiv stecken bspw. mit WinZip.
    Dann tritt dieses Problem nie mehr auf.


    Möchte man nicht "inline" senden, muss man folgende Änderung machen:
    about:config (Extras, Einstellungen, E rweitert, Allgemein, Konfiguration bearbeiten) aufrufen,
    in den Filter eintragen:
    disposition,
    diesen Eintrag:
    mail.content_disposition_type
    doppelklicken und den Wert von 0 auf 1 ändern.
    Neustart TB.



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"


    @ mrb,
    mit Deiner ausführlichen Erklärung und mit dem Vergleich der Codes hast Du mir sehr geholfen.
    Unter Ansicht /Anhänge eingebunden anzeigen/ habe ich den Haken entfernt. Also das Wort "inline" ist somit weg, denke ich.
    Nun klappt es plötzlich mit dem Bild senden aus der eigenen Datei.
    In about:config habe ich zunächst noch nichts verändert. Das kann ich ja dann immer noch als Joker obendrauf setzen. Ich möchte ja nicht alles "nicht eingebunden" versenden und habe es dann umständlicher, jedes Mal in about:config zu gehen.


    Also konnte der iPod wirklich nichts mit "inline" anfangen.
    Ich finde, er soll sich ruhig auch an den TB gewöhnen.


    Vielen Dank für die unsagbare Mühe, die Du mit mir hattest.
    Gruß Biggele

  • Hallo,
    vielen Dank für das Lob, aber so unsagbar war meine Mühe nicht. Ich habe alle Beispiele und Konfigurationsveränderung beim mir in einer Datenbank. Muss dann nur den Begleittext schreiben.


    Aber: mich wundert, dass Ansicht, "Anhänge eingebunden anzeigen" die Ursache sein soll.
    Vergiss nicht, dass TB nur intern damit eine andere Darstellung wählt und auch keinen Einfluss auf "inline" in der Deklarierung hat.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • @ mrb,
    also, ich werde das weiterhin beobachten und herumprobieren. Auf jeden Fall hat es mit dem Versenden aus meiner Bilddatei plötzlich funktioniert.
    Gruß Biggele