Dateiendungen verschwinden beim Speichern von Anhängen

  • Hallo!


    Ich lese schon länger hier im Forum mit und hab auch schon öfter Lösungen zu Probleme gefunden, diesmal aber leider nicht. Daher nun mein erstes Posting hier (-:


    Mein aktueller Thunderbid 2.0.0.23 unter Windows XP SP3 macht Probleme beim Speichern von Anhängen, teilweise werden die Dateiendungen "verschluckt".


    Folgende Fälle habe ich durchprobiert: In einer Mail ist im Anhang eine test.txt vorhanden. Die Endung wird vernünftigerweise immer angezeigt. Wenn ich nun


    - den Anhang doppelklicke und auf "Auf Diskette/Festplatte speichern" klicke, öffnet sich der "Speichern unter"-Dialog mit "test" oder "test.txt" als Dateiname und "Textdatei" als Dateityp. Auf Platte landet die Datei als test.txt. Abhängig von der Explorereinstellung ggf. auch mit versteckter Endung.


    - den Anhang rechtsklicke und auf "Speichern" klicke, wird der Dateityp nicht mehr richtig übergeben und das ganze hängt vom im Explorer angezeigten Namen ab. Im "Speicher unter"-Dialog steht bei Dateiname jetzt entweder "test.txt" oder "test" (zweiteres bei "bekannte Endungen ausblenden"). Der einzige auswählbare Dateityp ist "Alle Dateien". Thunderbird speichert die Datei dann jeweils auch als "test.txt" oder "test." auf Platte. Im letzten Fall _fehlt_ die Endung wirklich.



    Habe die Fehlerbeschreibung mehrfach im Web gefunden, aber keine Lösung. Thunderbird hab ich einmal komplett neu installiert, die mimeTypes.rdf auch gelöscht.


    Wer kann mir helfen?
    Vielen Dank!
    Ingo

  • Hallo, habe ich noch nie bemerkt, weil ich mir die Dateiendungen in Windows immer anzeigen lasse. Das würde ich als "Lösung" ;) auch empfehlen, zumal es ja nichts anderes zu geben scheint.

  • Hallo,


    du solltest dir immer alle Dateien, alle Ordner (auch Systemordner) und alle Dateiendungen anzeigen lassen. Ich gehe sogar noch einen Schritt weiter und lasse mir auch die Endungen *.lnk und *.pif anzeigen, welches nur über einen Eingriff in der Registry geht. Ansonsten ist ein System ein Sicherheitsrisiko, wenn die Originaleinstellungen beibehalten werden.


    Diese Einstellungen sollte sofort nach Installation eines neuen Systems gemacht werden. Um riskante Dateianhänge zu erkennen. Macht man das nicht und erhält einen Datei z.B: NewYork.jpg, und klick darauf, könnte man u.U. das System dann gleich wieder neu aufsetzen.
    Die wahre Dateiendung siehst du ja nicht: NewYork.jpg.exe


    Da die Suchfunktion in Windows ähnlich funktioniert und Systemdateien nicht findet, muss ebenfalls dementsprechend geändert werden.
    Siehe:
    http://freenet-homepage.de/rene-gad/invisible.html


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Zitat von "allblue"

    Hallo, habe ich noch nie bemerkt, weil ich mir die Dateiendungen in Windows immer anzeigen lasse. Das würde ich als "Lösung" ;) auch empfehlen, zumal es ja nichts anderes zu geben scheint.


    Doch, bis vor drei Tagen ging es ja noch so...
    Und wenn nicht, dann wäre es definitiv ein Bug...





    du solltest dir immer alle Dateien, alle Ordner (auch Systemordner) und alle Dateiendungen anzeigen lassen.


    Ja, ich kenne die Gründe gut und hab's auf allen _meinen_ Windows-Rechnern genau so. Ich mag es nicht, von meinem Rechner bevormundet zu werden... Die betroffene Maschine braucht aber leider nen hohen WAF.