Mehrere Fehler beim Umstieg auf TB 3.0.1

  • Hallo zusammen,


    ich habe hier schon einige Berichte über Probleme mit dem Umstieg/Update auf TB 3.0.1 gelesen, bei mir scheint irgendwie alles schiefgegangen zu sein. Immerhin sind meine E-Mails aber alle vorhanden, sofern ich das bisher überblicken konnte.


    Vorab die wesentlichen Systeminfos:


    • Windows XP Professional SP 3, alle Updates Stand 22. 01. 2010
    • Virenscanner: Avast! Freeware
    • Firewall: Sygate Personal
    • Umstieg von TB 2 auf TB 3.0.1
    • Installation und Update von TB als Administrator
    • Arbeiten mit TB als Nutzer mit eingeschränkten Rechten
    • ca. 70 (!) E-Mail-Konten, POP- und IMAP-Konten, keine Webmail-Konten


    Folgende Fehler treten bei mir seit dem Umstieg auf:


    • In unregelmäßigen Abständen fragt mich Thunderbird nach dem Masterpasswort, welches ich jedesmal korrekt eingebe. Bei welcher Aktion TB diese Frage stellt, konnte ich noch nicht erkennen.
    • TB startet beim Programmstart nicht automatisch die Abfrage der E-Mail-Postfächer, obwohl dies in den meisten Konten eingestellt ist ("Beim Starten auf neue Nachrichten prüfen") . Erst nach manuellem Start aller Konten geht's los.
    • Das Senden von E-Mails funktioniert nur direkt nach dem Start von TB; wenn vorher mit TB gearbeitet wurde (z. B. Mails gelöscht), dann erscheint das Hinweisfenster "Sende Nachricht..." und nichts passiert - die Nachricht wird nicht versandt.
    • Nach einer Weile Arbeit mit TB erscheinen plötzlich einige Ordner weniger (in der Ansicht "Gruppierte Orddner") bzw. einige Postfächer weniger (in der Ansicht "Alle Ordner"). Das geht dann solange weiter, bis keinerlei Ordner mehr angezeigt werden. Dann bleibt nur übrig, TB zu beenden und neuzustarten.
    • Irgendwann im Laufe einer TB-Sitzung erscheint in der Statuszeile "Suche Ordner...", das "Ich-bin-beschäftigt-"Kreissymbol rechts oben rennt und rennt, es hört nicht mehr auf.
    • Wenn ich aus den Gruppierten Ordnern E-Mails löschen möchte (z. B. aus dem Junkordner oder Papierkorb), dann löscht er immer nur die E-Mails, die zu dem Postfach gehören, welches gerade den Fokus hat - auch wenn ich alle E-Mails markiere.
    • Häufig kommt nach dem Beenden von TB und späterem, erneutem Aufrufen die Meldung, daß TB noch läuft.


    Das waren die dicksten Bugs, die ich bisher gefunden habe. Ein produktives Arbeiten ist mit TB 3.0.1 so nicht möglich.


    Folgende Lösungsmöglichkeiten habe ich nach Durchlesen der FAQ und des Forums bereits ausprobiert:


    • Globale Suche und Nachrichtenindizierung deaktiviert - keine Verbesserung
    • dem Virenscanner den Zugriff aufs TB-Profilverzeichnis verwehrt - keine Verbesserung
    • Virenscanner und Firewall deaktiviert - keine Verbesserung
    • Add-Ons deaktiviert (momentan nur Folderplane-Tools) - keine Verbesserung


    Ich bin mit meinem Latein am Ende und befürchte, daß ein Großteil der o. a. Fehler systembedingt sind. Ich würde mich freuen, wenn mich jemand vom Gegenteil überzeugt ... ;-)


    Danke & Grüße,


    Lagopus.

  • Willkommen im Form, und danke für den ausführlichen Bericht :)

    "Lagopus" schrieb:


    Umstieg von TB 2 auf TB 3.0.1


    Hast Du Dein Profil geupdatet?
    Oder ein neues Profil aufgebaut?


    Viele schwer reproduzierbare Probleme enstehen durch "alte" Profile, die einige verborgenen Tücken in sich haben. Was mich interessiert, was passiert, wenn Du mit einem neuen Profil auf 3.0.1 arbeitest. Siehe http://www.thunderbird-mail.de…3%B6schen,_ausw%C3%A4hlen

  • Hallo,


    der hier beschriebene Fall sieht mir an fast allen Punkten nach Verbindungsproblemen aus - kein direkter Fehler innerhalb Thunderbirds. Es könnte (indirekt) die sehr große Anzahl der Konten ein Problem sein. Man stelle sich 70 IMAP-Konten vor, die jeweils wieder vielleicht 20 Ordner pro Konto besitzen = 1400 IMAP-Ordner. Schuld könnten zu viele Idle-Verbindungen der IMAP-Ordner sein oder schlichtweg auch Thunderbirds Volltextsuche, die im Hintergrund versucht alles zu indizieren. Für Letzteres würde sprechen, wenn vorher mit Tb 2 alles funktioniert hat. Das Indizieren läuft meines Wissens auch asynchron ab, was bei so vielen IMAP-Ordnern vielleicht einfach zu viel ist. Avast lässt da auch nur eine begrenzte Zahl an Verbindungen zu, soweit ich mich erinnern kann (ich musste das auch mal in einer *.ini hochstellen).


    Gruß

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Hallo Amsterdammer,

    "Amsterdammer" schrieb:


    Hast Du Dein Profil geupdatet?
    Oder ein neues Profil aufgebaut?


    ich habe mein bestehendes Profil aus TB 2 übernommen.

    "Amsterdammer" schrieb:

    Viele schwer reproduzierbare Probleme enstehen durch "alte" Profile, die einige verborgenen Tücken in sich haben. Was mich interessiert, was passiert, wenn Du mit einem neuen Profil auf 3.0.1 arbeitest. Siehe http://www.thunderbird-mail.de…3%B6schen,_ausw%C3%A4hlen


    Ich habe soeben mal ein neues Profil erstellt und in selbigem eines meiner recht großen E-Mail-Konten angelegt, ein IMAP-Konto bei Web.de mit ca. 400 Nachrichten, darunter einige mit üppigen Anhängen. Es fällt schon auf, daß TB 3.0 trotz DSL 16.000 sehr lange braucht, bis alle anstehenden Arbeiten (ich nehme an Indizierung, Herunterladen aller E-Mails, etc.) abgeschlossen sind, aber mit nur einem E-Mail-Konto scheint TB 3 nun zu funktonieren.


    Soll ich also mal versuchen, meine ca. 70 Konten alle neu anzulegen? Das wäre natürlich machbar, aber recht zeitaufwendig. Oder gibt es eine andere Möglichkeit? Wie z. B. das "alte" Profil aus TB 2 irgendwie zu bereinigen?


    Auf jeden Fall schon mal danke für die Hilfe & Grüße,


    Lagopus.

  • Also einfach deine Konten auf POP umstellen :-):mrgreen:


    Imap mag wahrscheinlich das ewige hin und her synchronisieren nicht - dazu braucht man wohl ne fettere broad band Verbindung?


    Ich persönlich bin kein IMAP Fan, da ich hier nur Mobilnetz habe, und eine fette Festplatte mit viel Platz für alte EMails. Meine Mail gehört mir ;-)

  • ich finde ein Profil mit 70 Konten für den täglichen Gebrauch beachtenswert. Hast Du schon mal darüber nachgedacht, innerhalb von Thunderbird mit mehreren Profilen zu arbeiten?


    Ich selber habe drei Profile im Einsatz: eins mit "dienstlichen" Konten, eins mit "privaten" Konten, ein "Test" Konto. Der Umgang mit mehreren Profilen würde doch eine Verwaltung von 70 Mailkonten übersichtlicher gestalten, zudem es eine Erweiterung gibt, mit der man mehrere Profile einfach durch Mausklick verwalten kann:
    Profile Switcher


    Was Thunderbird 3 betrifft: durch die Einführung einer globalen Suche innerhalb des Programms wird es beim ersten Start immer eine Indexierung geben, die zunächst Ressourcen frisst. Dies glit insbesondere für IMAP, und besonders für Gmail-IMAP.


    Entwickler haben vor wenigen Tagen eine Wiki-Seite angelegt, um das Problem mit den Ressourcen, daß augenscheinlich nur bei wenigen auftritt, einzugrenzen. Diese Seite ist in Entwicklung, sie wird irgendwann Hinweise zu Diagnose und Abhilfen anbieten.

  • "Lagopus" schrieb:

    Oder gibt es eine andere Möglichkeit? Wie z. B. das "alte" Profil aus TB 2 irgendwie zu bereinigen?


    Die gibt es, aber das ist chirurgische Feinarbeit, wo einiges schief laufen kann, und einem Nutzer mit 70 Konten dies anzubieten, traue ich mich, ehrlich gesagt nicht. In jedem Fall solltest Du vorher eine 1:1 Kopie Deines gesamten Profilordner ablegen, offline gehen und dann fummeln wie hier beschrieben (Schriit 1, danach Schritt 3). Da geht es darum, wie man Profile von einem Thunderbird (hier 2.0) zu einem andere Thunderbird (hier 3.0) in Problemfällen manuell migriert. Bei dieser Fummelei geht alles verloren, außer die Konten mit Mails und das Adressbuch. Alle Erweiterungen, Themes, persönliche Einstellungen und Anpassungen, Filterregeln usw. sind danach futsch.


    Außerdem ist dieser Artikel alt, vielleicht können rum und Thunder , Autoren dieser Anleitung, auf Aktualität checken, mir fehlt da der Überblick.


    Eine Verteilung von 70 Konten auf mehrere Profile erscheint mir langfristig sinnvoller.

  • Hallo Amsterdammer,


    "Amsterdammer" schrieb:

    ich finde ein Profil mit 70 Konten für den täglichen Gebrauch beachtenswert. Hast Du schon mal darüber nachgedacht, innerhalb von Thunderbird mit mehreren Profilen zu arbeiten?


    ich selber habe drei Profile im Einsatz: eins mit "dienstlichen" Konten, eins mit "privaten" Konten, ein "Test" Konto. Der Umgang mit mehreren Profilen würde doch eine Verwaltung von 70 Mailkonten übersichtlicher gestalten, zudem es eine Erweiterung gibt, mit der man mehrere Profile einfach durch Mausklick verwalten kann:
    Profile Switcher


    ich habe bereits unter TB 2 mehrere Profile angelegt, die 70 E-Mail-Konten sind zu einer logischen Einheit gehörig und ich würde sie nur äußerst ungern nochmals weiter aufsplitten. Insgesamt habe ich ungefähr 300 Postfächer. Wie gesagt, unter TB 2 lief alles problemlos.


    Wie in meinem letzten Beitrag erwähnt, habe ich testweise ein paar meiner dicksten Konten in TB 3 in einem neuen Profil angelegt und stoße trotz jungfräulicher Installation erneut auf Probleme:


    • In der Statuszeile erscheint nach einiger Zeit "Suche Ordner..." und das "Ich-bin-beschäftigt-Symbol" oben rechts dreht sich auch nach Stunden noch. Die Postfächer sind nun nicht astronomisch groß (für meine Verhältnisse), maximal ca. 300 E-Mails und zudem alles POP3-Postfächer. Ich nehme an, daß die Meldung "Suche Ordner..." von der Indizierung der globalen Suche stammt und wohl ein Übersetzungsfehler ist; eigentlich ist damit "Durchsuche Ordner..." gemeint, oder irre ich mich?
    • Die manuell als Junk markierten Dateien werden nicht in den entsprechenden Ordner kopiert, obwohl ich die Einstellung ("Neue Junk-Nachrichten verschieben in:") entsprechend gemacht habe. Sie bleiben hartnäckig im Posteingang des Ordners kleben. In TB 2 wurden sie nach Markieren als Junk sofort in den entsprechend eingestellten Ordner verschoben - ist das jetzt nur bei mir so oder tritt dieser Fehler generell bei TB 3 auf?


    Mir kommt ein anderer Gedanke: Da ich auf dem Rechner, auf welchem TB läuft, auch einen SQL-Server laufen habe, frage ich mich, ob nicht vielleicht das der Grund für die Probleme sein könnte? Soviel ich verstanden habe ist SQLLite allerdings keine klassische Client-Server-Datenbank, sondern wird jeweils in das nutzende Programm compiliert, sodaß es wohl eher unwahrscheinlich ist, daß das der Grund für meine Probleme sein könnte. Aber der Ertrinkende klammert sich bekanntlich an den kleinsten Strohhalm ... ;-)


    "Amsterdammer" schrieb:

    Was Thunderbird 3 betrifft: durch die Einführung einer globalen Suche innerhalb des Programms wird es beim ersten Start immer eine Indexierung geben, die zunächst Ressourcen frisst. Dies glit insbesondere für IMAP, und besonders für Gmail-IMAP.


    Entwickler haben vor wenigen Tagen eine Wiki-Seite angelegt, um das Problem mit den Ressourcen, daß augenscheinlich nur bei wenigen auftritt, einzugrenzen. Diese Seite ist in Entwicklung, sie wird irgendwann Hinweise zu Diagnose und Abhilfen anbieten.


    Vielen Dank für die Infos, ich werde mal schauen, ob mir das weiterhilft.


    Grüße,


    Lagopus.

  • Hallo,


    die Textstelle "Ordner suchen..." kommt an zwei Stellen im Programm vor. Beide Meldungen werden im Zusammenhang mit IMAP-Ordnern/-Konten verwendet. Ob die Meldungen auch bei der Indizierung für die Volltextsuche auftreten können, kann ich nur vermuten. Allerdings hat der Indizierungsdienst dafür keine eigene passende Textstelle. Ich habe mir aber bei den IMAP-Meldungen die beiden Textstellen nochmals angesehen. Vermutlich muss es bei einer der beiden Textstellen tatsächlich "Ordner durchsuchen..." statt "Ordner suchen..." heißen. Die nächsten Programmversionen werden korrigiert sein. Ob nun aber im hier beschriebenen Fall die eine oder andere Meldung zur Anwendung kommt, kann ich nicht sagen.


    Nur aus Interesse (Thunderbird / die Netzwerk-/Internetverbindung müsste trotzdem funktionieren): Warum hat man so viele Konten, wenn dann nur rund 300 Mails in einem Konto sind?


    Gruß

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!

  • Hallo Thunder,

    "Thunder" schrieb:

    ...
    Nur aus Interesse (Thunderbird / die Netzwerk-/Internetverbindung müsste trotzdem funktionieren): Warum hat man so viele Konten, wenn dann nur rund 300 Mails in einem Konto sind?


    Die Frage hatte ich bereits erwartet ... ;-) Die Antwort ist recht simpel: Ich verwalte etliche Freemail-Konten, ein Teil davon ist nur geparkt und enthält (außer Spam natürlich) noch gar keine E-Mails, andere wiederum werden sporadisch genutzt, andere recht intensiv. Zudem habe ich natürlich auch noch meine privaten und dienstlichen Konten. All das ist mit separaten Profilen über TB organisiert.


    Nun habe ich testweise einen kleinen Teil der verwalteten Konten (nur POP3-Konten) in einem neuen Profil unter TB 3 angelegt, um zu überprüfen, woran das seltsame Verhalten von TB 3 liegen könnte und um auszuschließen, daß es an der schieren Menge oder an komplexen IMAP-Konten liegt. Daher nehme ich an, daß die zuletzt von mir genannten Fehler weder etwas mit meinen spezifischen Einstellungen noch mit der Größe der Konten zu tun haben, sondern wohl tatsächlich Bugs in TB 3 sind. Nachdem ich mir mal Bugzilla durchgeschaut habe, mußte ich feststellen, daß z. B. der Bug mit den nicht korrekt verschobenen manuell markierten Junk-Nachrichten offenbar schon öfter und auch bei Vorgängerversionen gemeldet wurde.


    Grüße,


    Lagopus.