IMAP Problem

  • Hallo,


    Thunderbird speichert unter IMAP nicht die gesendete Nachricht ab.


    Zitat

    Nachricht konnte nicht in den Ordner "Gesendet" kopiert werden. Nochmals versuchen?


    Das Problem tritt dann auf, wenn das TB Hauptfenster geschlossen wurde. Mir ist das nun bereits mehrfach beim E-Mail Schreiben passiert, dass ich etwas anderes nebenbei machen mußte, und dabei Platz auf dem Desktop schaffe. Beim Schließen des TB Hauptfensters erscheint keine (Fehler-)Meldung, obwohl man noch ein Fenster offen hat, in dem man gerade eine E-Mail verfaßt.


    Die E-Mail läßt anschließend noch normal verschicken (SMTP). Nur das Speichern über IMAP schlägt mit der obigen Meldung fehl. Die Möglichkeit lokal in Entwurf zu Speichern schlägt genauso fehl (bei einem IMAP Ordner). Der Text der Meldung ist auch falsch: Es wird wieder der Ordner "Gesendet" statt "Entwurf" genannt.


    Wäre schön, wenn entweder eine entsprechende Warnung (beim Versuch das Hauptfenster zu schließen) kommt, oder besser: die IMAP Verbindung gar nicht erst "gekappt" wird.


    Das Problem hatte ich nach meinem letzten TB Update häufiger. Heute habe ich dann mal probiert woran es lag. Früher wurden wohl keine neuen Top-Level Fenster für das Verfassen von E-Mails geöffnet, so dass man gar nicht in Versuchung kam, auf dem Desktop "aufzuräumen".


    System: TB 3.0.3 on WinXP SP3, dovecot on Debian/Lenny

  • Hallo lightme und willkommen im TB.Forum,


    ich kenne keine Lösung für Dich, aber vielleicht ein Workaround: MinimizeToTray Plus
    Wenn es Dir nur ums Aufräumen geht, dann ist das etwas für Dich. Es gibt noch verschiedene andere Versionen des AddOns, ich habe Dir hier meinen Favoriten vorgestellt, aber schau Dir auch mal die anderen an.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 64 Bit | Firefox 64 Bit | Avira Free Security Suite | Fritzbox 7490

  • Hallo und willkommen im Forum!

    Zitat

    Thunderbird speichert unter IMAP nicht die gesendete Nachricht ab.


    In den Konteneinstellungen, Kopien & Ordner gibt es unter "beim Senden Mails automatisch speichern", das Menü "anderer Ordner". Benutze dieses und gib den Ordner "gesendet" oder einen anderen im lokalen Ordner an.
    Besteht dann dein Problem noch weiter.
    Dieses Problem tritt fast nur bei IMAP auf und auch nur bei bestimmten Mailprovidern.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich bin mein eigener Mailprovider. ;-) dovecot auf Lenny ist der IMAP Server. logdovecot meldete keine Fehler. Offenbar versucht TB gar keine (oder eine falsche) Verbindung zum IMAP Server aufzubauen. Das Problem sollte somit recht einfach reproduzierbar sein. Ich kann auch notfalls mal ein tcpdump/wireshark anwerfen um zu gucken was der TB da macht, oder gerade nicht macht.


    btw: das speichern als lokale kopie, sowie Du das beschrieben hast, funktioniert.

  • Das Problem tritt dann auf, wenn sowohl TB als auch der Server gleichzeitig in den gleichen IMAP-Ordner abspeichern möchten.
    Du kannst ja mal testen, was passiert, wenn du in TB das Abspeichern von gesendeten Mails dieses Kontos ganz untersagst (Haken bei Kopie speichern unter entfernen).
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Sorry, das verstehe ich nicht. TB kann nie direkt in einen IMAP-Ordner schreiben, dass kann nur der IMAP Server.


    Ich habe jetzt mal Wireshark laufen lassen, und wie bereits vermutet, baut TB 3.0.3 in dem oben beschriebenen Szenario gar keine Verbindung zum IMAP-Server auf.


    Unter TB 2.0.0.23 habe ich das gleiche Szenario durchgespielt. Dort funktioniert alles problemlos.


    Ich denke, man kann nun mit ziemlicher Sicherheit davon ausgehen, dass es sich hier um einen Bug im TB 3.0.3 handelt.

  • Zitat

    TB kann nie direkt in einen IMAP-Ordner schreiben, dass kann nur der IMAP Server.


    Aber es gibt den Befehl dazu, oder? Der Server führt nur aus.
    Ich kann das weder bestätigen noch verneinen.
    Bei mir werden alle gesendeten Mail lokal abgespeichert und ich habe keinerlei Probleme mit meinen 6(!) IMAP-Konten.
    Frage doch auch einmal im englischen MozillaZine-Forum nach.
    http://forums.mozillazine.org/viewforum.php?f=39
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich würde das Problem gern von einer weiteren Person prüfen lassen bevor ich einen Bug Report schreibe. Es sind ja nur ein paar Klicks.

  • Mein Vorschlag war kein Bugreport. Du solltest eine Frage dort stellen.
    Bei bugzilla jedoch, musst du erst mal intensiv suchen, ob der Fehler nicht schon beschrieben wurde.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw