pdf anhänge

  • hallo liebe forummembers,


    ich habe das problem wenn ich pdfs anhänge, zeigt es beim empfänger und in meinem sent das pdf in merkwürdigen codes an
    beim kollegen funkt alles ganz normal wenn er versendet


    verwende thunderbird 3.0.4 auf osx 10.5.8, pop3 konto


    hat noch jemand das problem, und wie kann man es beheben


    herzlichen dank
    olli


    [IMG:http://transfer.balloonrecords.com/Bild1.png]

  • Hi Olli,


    und willkommen im Forum!
    Viele Mailprogramme bieten als gern genutzes Feature die Möglichkeit, bestimmte Dateitypen in einer integrierten Vorschaufunktion direkt im Textfenster anzuzeigen. Geeignete Dateitypen sind u.a. einfache (!) Bilder und Texte. Und ein .pdf wird wie auch Plotterdateien usw. als Textdukument erkannt und angezeigt ... .


    Lösung: Ansicht >> Anhänge eingebunden anzeigen deaktivieren.


    MfG Peter


    Eine Bitte noch: Das Benutzen der Shifttaste erleichtert uns das Lesen der Beiträge und erhöht auch unsere Bereitschaft zum Antworten.

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Danke für die Antwort!


    Jedoch werden diese merkwürdigen Zeichen (wenn Anhänge eingebunden anzeigen ein ist) beim Kollegen nicht so angezeigt....


    liegt das am PDF? oder woran?


    danke
    lg

  • Vermutung:


    Unser beider unixoiden Betriebssysteme kümmert es nicht, ob und welcher Suffix hinter dem Dateinamen steht. Im Gegensatz zur WinDOSe schaut das Betriebssystem in die Datei hinein und erkennt selbst, was es ist. Und ein pdf wird dann schnell als darstellbare Textdatei erkannt - wenn das natürlich auch wenig Sinn macht und es von nicht darstellbaren Zeichen nur so wimmelt.


    Könner der Konfiguration des TB sind bestimmt in der Lage, hier Anpassungen vorzunehmen. Ich gerate da an Grenzen ... .


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo zusammen.


    Ich kann das mit Unix-Versionen wiederlegen:
    Ich habe WinXP SP3, und das Problem schleicht sich schon seit diversen TB2.X bis zu aktuellen 3.1.6 (POP) durch:
    Mails die von diesem Client versand werden, zeigen bei eingebetter Ansicht der PDFs nur den besagten Quatsch an.
    Lade ich den Anhang herunter/Speichere ihn, merk man, dass die PDFs ok sind.
    Ich habe bei mehreren Empfängern Mails mit den selben PDFs von anderen Sendern geschickt: kein Problem mit der integrierten Anzeige.
    Was ist da los?
    Da ich bei Tante Google so einige ungelöste Theats zu diesem Topic gefunden habe, und das Problem unabhängig von MAC OS X liegt, frage ich mich, ob ein neuer Theats angebracht wäre.


    Vielen Dank und beste Grüße,
    Aranha

  • Hallo und willkommen im Forum!

    Zitat

    Da ich bei Tante Google so einige ungelöste Theats zu diesem Topic gefunden habe, und das Problem unabhängig von MAC OS X liegt, frage ich mich, ob ein neuer Theats angebracht wäre.


    Da ich noch nie in Windowssystemen dieses Problem hatte, muss ich dir widersprechen.
    Es muss sehr wohl mit anderen Mailklienten und Betriebssystemen zu tun haben.
    TB hat nämlich beim Versenden eine Eigenart, die andere Systeme/Mailprogramme u.U. nicht verstehen.
    Wenn du mal eine versendete Mail im Quelltext (Strg+U) untersuchst, stellst du in der Deklarierung des Anhangs einen Zusatz fest, nämlich diesen:


    Content-Type: application/pdf;
    name="2007_10rechnung_4.pdf"
    Content-Transfer-Encoding: base64
    Content-Disposition: inline;
    filename="2007_10rechnung_4.pdf"


    Um diesen zu vermeiden, sollte man ihn bei der Versendung an unbekannte Mailklienten/Betriebssysteme unterdrücken.


    Dazu in der erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten")
    den Eintrag mail.content_disposition_type auf 1 setzen.


    eine Garantie kann ich leider nicht dafür geben, da sicher auch noch andere Ursachen denkbar sein können.
    Ich weiß aber sicher, dass der Zusatz "inline" bei den Mailprogrammen Outlook Express und Windows Live Mail keinen Einfluss auf die korrekte Darstellung hat.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw