[solved] default-Webbrowser mit bestimmten Profil starten

  • THB 2.0.0, Linux Xfce4-Desktop


    Ich möchte gerne den Default-Browser für Links mit einer bestimmten Profil starten, auf der Konsole klappt es ohne weiteres. Eine Änderung in der Xfce-Einstellung für den Default-Browser brachte nichts.
    Es scheint auch näher zu liegen, die Änderung in der Thunderbird-Konfiguration vorzunehmen.
    Habe dazu in "about:config" eingetragen:


    Klappt aber alles nicht...
    In "about:config" wird eine geänderte Einstellung auch nicht wirklich übernommen, nach Neustart ist
    der Eintrag wieder "/usr/bin/seamonkey" - ohne Profiloption.


    Ausserdem sollte eine korrekte Änderung in "about:config" auch sofort funktionieren (meine ich), habe bisher aber keinen Eintrag hingekriegt, der funktioniert. Will sagen, es passiert dann garnichts mehr. Nur der Eintrag wie gehabt bewirkt ein Starten von Seamonkey im zuletzt benutzten Profil.


    Weiter unten in "about:config" kommt dann sinnigerweise:

    Code
    1. applications.rlogin ..... xterm -e rlogin %h


    Kann doch nicht sein, oder?
    Was mach ich denn falsch :eek:
    tom


    PS: Eine Alternative wäre, Seamonkey beizubringen, ohne Option statt mit dem zuletzt aufgerufenem mit dem 'default'-Profil zu starten...
    Das habe ich nun getan, durch ein Script, was Seamonkey aufruft:

    Code
    1. seamonkey -P default $1


    Den Pfad eingetragen in 'about:config', und siehe da, es klappt.
    Aber THB merkt es sich nicht...da hilft auch kein Eintrag in 'prefs.js', es ist zum Verzweifeln.
    Möchte mal wissen, woher THB seine Default-Browsereinstellung bezieht :freak:


    HAB'S! ..der Eintrag musste in der (von mir selbst angelegten :redface: ) "user.js" erfolgen...
    Es half allerdings nur der Eintrag von o.g. Script, nicht die Angabe der Option '-P'.
    tom