Problem beim beantworten von Mails

  • Hallo liebe Thunderbirdgemeinschaft,
    vielleicht kann mir von euch jemand helfen, oder weiß jemand einen Rat.


    Ich weiß auch nicht ob das Thema hier richtig ist, deshalb verzeiht falls es hier falsch ist.
    Ich nutze Thunderbird 3.0.4 Kontoart POP3 Betriebssystem Win XP SP2


    Also ich habe folgendes Problem.
    Ich habe eine Programm welches mit dem Betreff/Subjekt und Inhalt/Nachricht/Body einer Mail arbeitet. Damit diese Programm richtig arbeitet sind diese zwei Angaben das wichtigste, denn nur mit diesen Angaben kann dieses Programm seine arbeit verichten.


    Was hat das mit Thunderbird zu tun fragt Ihr jetzt sicher. ??? Eine ganze Menge werde es versuchen zu erklären.


    Also dieses Programm sendet z.B. eine Mail an ein bestimmtes POP3 Konto welches ich mit Thunderbird alle 2 min. abfrage.


    z.B. wird folgende Mail dann empfangen:


    An: xyz@xyz.de
    Von: egal
    Betreff: 12345678
    Nachricht: test


    Nun muß diese Mail von Thunderbird verarbeitet und beantwortet werden, da liegt dann nämlich auch schon das Problem, wovon ich eins dank des Forum lösen konnte.
    Doch das Hauptproblem besteht immer noch.


    Diese eingegangende Mail muß nun beantwortet werden zurück an das Programm von wo aus, die Mail stammt, nur mit dem unterschied das die Nachricht einen anderen Text enthalten soll, doch der Betreff nicht verändert werden darf, da das Empfängerprogramm sonst diese Mail nicht verarbeiten kann.


    z.B. Antwort Mail muß so aussehen:


    An: egal
    Von: xyz@xyz.de
    Betreff: 12345678
    Nachricht: hallo



    Alle Mailclients die ich kenne machen bei einer Antwort immer dieses Re: oder An: beim weiterleiten einer Mail Fw: vor dem eigentlichen Betreff, das heißt ja dann das der Betreff
    folgendermaßen aussehen würde in diesem Falle:


    Betreff: Re: 12345678 oder Betreff: An: 12345678


    Somit kann das Empfängerprogramm diese Mail zwar empfangen aber nicht verarbeiten,
    da der Betreff verändert wurde.
    Dank Thunderbird erster Mailclient der so was kann und dem
    Add on Clean Subject 0.4.2

    Kann ich nun eine Mail versenden in der die Betreffzeile genauso erhalten bleibt beim
    empfangen.


    1. Problem gelöst.


    Das können andere Mailclients noch lange nicht.


    Doch es wäre ja zu einfach wenn es nicht noch ein zweites Problem gäbe welches mir den Nerv raubt. :wall:


    Thunderbird ruft diese Mail ab und muss diese auch automatisch beantworten, an eine bestimmte Mailadresse.
    Des weiteren, werden die neuen Nachrichten unterschlich sein müssen.


    Kommt eine Mail mit der Nachricht: „test“ soll in der Antwortmail als Nachricht: „hallo“ stehen


    Kommt eine Mail mit der Nachricht: „test1“ soll in der Antwortmail als Nachricht: „ja“ stehen


    Diese mache ich über Filterfunktion die, die Mail auf Inhalt prüft und dann eine Aktion durchführen soll.
    Die Aktion soll lauten: Antworte mit Vorlage.


    Diese habe ich jedoch vorher erstellt und sieht folgendermaßen aus:


    An: egal
    Betreff: (bleibt in der Vorlage leer, denn es muß ja der Betreff aus der original Mail übernommen werden)
    Nachricht: hallo oder ja oder wie auch immer.


    Soweit so gut. Thunderbird empfängt die Nachrichten prüft Sie nach Inhalt.


    Kommt nun folgende Mail:


    An: xyz@xyz.de
    Von: egal
    Betreff: 12345678
    Nachricht: test


    Stellt Thunderbird fest das diese Mail den Inhalt als Nachricht : „test“ hat und weiß das diese Mail beantwortet werden muß mit: Antwort mit Vorlage


    Jetzt kommt das Problem so sieht die Antwort aus:


    An: egal
    Von: xyz@xyz.de
    Betreff: (was: 12345678) :wall:
    Nachricht: hallo


    Und wieder wurde der Betreff geändert, somit ist diese Antwort nichts wert,
    denn das Empfängerprogramm kann zwar mit dem Inhalt/Nachricht was anfangen,
    aber nichts mit dem Betreff.


    Wer weiß ob man dieses (was: ) irgendwie weg bekommt.


    Damit der Betreff wirklich so aussieht Betreff: 12345678
    wie in der empfangenden Mail.


    Bin für jeden Tip dankbar.
    Denn bekomme schaun graue Haare.


    :flehan: :flehan: :flehan: Vielen Dank im Voraus
    an alle die auch nur versuchen mir zu helfen eine Lösung zu finden. :flehan: :flehan: :flehan:


    Mit freundlichen Grüßen


    Martin Neuihaus

  • Zitat von "Rothaut"

    guten Abend und willkommen im Thunderbirdforum!


    Imho müsste das auch mit Clean Subject zu bewerkstelligen sein, aber ich bin im Umgang mit Regexdingern alles andere als sattelfest, aber mir hat der Autor in folgendem Thread sehr geholfen, vielleicht hilft das auch Dir weiter:
    praktischer Umgang mit Clean subject

    [quote="Rothaut"]guten Abend und willkommen im Thunderbirdforum!


    Also das Add-on Clean Subject habe ich ja schon installiert.
    Bei manueller Antwort funktioniert das auch wunderbar, dann wird der Betreff ohne Anhängsel übernommen,
    doch sobald ich das über die Filterfunktionen regel mit Antworten mit Vorlage funktioniert es nicht mehr.


    Habe schon zig Varianten getestet, doch leider immer ohne Erfolg.
    Oder ich mache da was falsch.


    mfg
    Martin

  • Zitat von "Rothaut"

    guten Abend und willkommen im Thunderbirdforum!


    Imho müsste das auch mit Clean Subject zu bewerkstelligen sein, aber ich bin im Umgang mit Regexdingern alles andere als sattelfest, aber mir hat der Autor in folgendem Thread sehr geholfen, vielleicht hilft das auch Dir weiter:
    praktischer Umgang mit Clean subject



    Es scheint mir so, das es sobald die die Regeln ins Spiel kommen nicht mehr geht bzw. mit Clean Subjekt nicht geht.


    Denn wenn ich Clean Subjekt einstelle und manuell über Antworten gehe dann funktioniert es tadellos,
    wenn ich nun jedoch über Filterregeln gehe und automatisch Antworte mit Vorlage über die Filterregeln funktioniert es nicht.


    Schade eigentlich.


    mfg


    Martin

  • Zitat von "graba"

    Hallo Martin,


    warum schreibst du einen 2. Beitrag mit quasi identischem Inhalt?

    Sorry das sollte nicht sein.


    Weiß jemand ob es eine andere Lösung gibt?


    Oder weiß jemand wo man einfach diese Zeichenketten (was: ) abstellen kann. In irgend einer config oder sonstiges.
    Denn irgendwo müssen diese Zeichen ja herkommen.


    mfg


    Martin