TB 3.1 RC1 - Schriftart beim Verfassen von Mails

  • Hallo,


    testweise habe ich TB 3.1 RC1 installiert. Was mir dabei sofort aufgefallen ist, ist eine "merkwürdige" Standardschriftart beim Verfassen von E-Mails. Ich verfasse meine Mails als Reintext-Nachrichten. Bei TB 3.0.x wurde keine deratige Schriftart verwendet. An den Einstellungen habe ich schon herumgespielt, ich bekomme es aber nicht hin, dass eine andere Schriftart - wie sie unter TB 3.0.x war - verwendet wird. Habt Ihr da eine Idee, wie ich das hinbekomme?


    EDIT: Gerade habe ich festgestellt, dass auch bei einigen empfangenen Mails diese Schriftart verwendet wird, bei anderen Mails ist widerum alles in Ordnung und sie werden so dargestellt, wie es früher auch unter TB 3.0.x gewesen . Auch das Lesen der Nachrichten erfolgt als Reintext.


    Hier ein Screenshot, in dem man die Schriftart sieht. Im Betreff ist alles normal, aber der Text der Mail gefällt mir nicht:



    Viele Grüße


    Vitos

    Einmal editiert, zuletzt von vitos77 ()

  • Moin,


    für das Erstellen der Nachrichten konnte ich die neue Schriftart inzwischen erfolgreich verbannen:



    Aber gibt es denn wirklich niemanden hier, der etwas dazu sagen kann, wie ich die nun standardmässig auch bei vielen eingehenden Mails die in meinem Beitrag oben dargestellte Schriftart verändern kann?


    Ich frage mich wirklich, was sich die Entwickler dabei gedacht, denn es sieht einfach nur grausam aus. Möglicherweise siehts ja bei höheren Auflösungen besser aus, mein Notebook kann allerdings max. 1280 x 800 und da wirkt die Größe und Art der Schriftart einfach nur furchtbar...


    Gruß


    Vitos

  • Hallo Graba,


    vielen Dank für den Link. Leider bekomme ich es für eingehende Nachrichten aber nicht wunschgemäß hin. Auch die Benachrichtigungsmail hier aus dem Forum, die eben kam, verwendet diese neue Schriftart.


    Unter Ansicht/Zeichenkodierung habe ich Unicode UTF8 eingestellt. Wenn ich z. B. westlich ISO 8859-1, oder 8859-15 nehme, so ist zwar die Schriftart in Ordnung, dann werden aber Zeichen wie ü, ö usw. nicht mehr richtig dargestellt.


    Sonst noch eine Idee?


    Grüße


    Vitos

  • Hallo Vitos,


    die Anzeigeschriftart kannst Du so ändern
    (Vorsichtshinweis lesen und beachten, Schritte unbedingt exakt einhalten und nichts Weiteres ändern!):


    1. Im Menü "Hilfe" den Eintrag "about:config" wählen. Fenster "about:config" öffnet sich.
    2. Dialog "Ich werde vorsichtig sein, versprochen!" bestätigen.
    3. Eingabe von "font.name.monospace.x" im Feld "Filter". Die Liste reduziert sich auf wenige Einträge.
    4. Einstellungsname "font.name.monospace.x-unicode" (befindet sich am Ende der Liste) markieren, dann rechte Maustaste klicken, "Zurücksetzen" wählen.
    5. Einstellungsname "font.name.monospace.x-western" (befindet sich in der Liste direkt darunter) markieren, dann rechte Maustaste klicken, "Zurücksetzen" wählen. Die Schriftart lautet nun wieder jeweils "Courier New" und wird sofort ohne Neustart umgesetzt.
    6. Fenster "about:config" schließen.


    Fertig.


    Es kann auch eine andere Schriftart gewählt werden, wenn bei Schritt 4 nicht "Zurücksetzen" sondern "Bearbeiten" gewählt oder statt der rechten Maustaste doppelt mit der linken Maustaste geklickt wird.
    Dies sollten jedoch wirklich nur erfahrene Nutzer ausführen, da die Schriftart bei "Wert" hier frei eingegeben werden (und vermutlich vorher auf dem System installiert sein) muß.


    Liest sich eventuell komplizierter, als es ist ... jedoch sollte unbedingt darauf geachtet werden, nichts Weiteres zu ändern, denn das ist keine "Spielwiese".


    Grüße,


    tb3tester

  • Hallo vitos,
    hättest du deine Frage im allgemeinen Forum gestellt, hätte ich sie dir schon längst beantwortet Ich schaue nämlich nie in dieses Unterforum.
    Ich installiere nie RC-Versionen und rate jedem User, dieses auch so zu handhaben, bzw- RC-Versionen nur zum Test aber nicht zum Gebrauch zu installieren. Es ist durchaus möglich, mehrere Versionen gleichzeitig zu benutzten.


    das von "tb3tester" vorgeschlagene Verfahren - welches ich bisher nicht kannte - würde ich erst dann versuchen anzuwenden, wenn es intern in TB keine andere Möglichkeit gibt.
    Das Verhalten bei deinem TB ist nicht normal und dürfte auf eine falsche Einstellung zurückzuführen sein.
    Überprüfe alle Ordner mit Rechtsklick, Eigenschaften, Allgemein, ob dort unterhalb "Standardzeichenkodierung" ein Haken gesetzt ist. Der sollte überall entfernt werden.
    Außerdem kontrolliere in der erweiterten Konfiguration ((Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten"), ob dort der Eintrag mailnews.force_charset_override auf false. Das sollte er.


    Was viele bei der Einstellung der Schriftarten übersehen ist, das dafür 3 Einstellungen gibt je nach Zeichenkodierung
    (Auswahl verschiedenen Zeichenkodierungen, "Andere Sprachen" und "Benutzerdefiniert").
    Ich beziehe mich dabei auf deinen 2. Screenshot.


    Du schriebst ja, dass du UTF-8 verwendest, deine Einstellung im Screenshot bezieht sich aber auf die Zeichenkodierung westlich und diese ist in deinem Fall unwirksam, weil du westlich ja nicht verwendest.
    Klicke also in dem Menü "Schriftarten für..." auf das Auswahldreieck und wähle "Andere Sprachen aus". Darunter fällt auch UTF-8. Wähle dort deine Einstellungen lt. Screenshot noch einmal aus und bestätige mit OK.
    Jetzt müsste deine Schriftart korrekt dargestellt werden.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw