HTML Mail wird nur dargestellt, wenn ich sie mit IMAP abrufe

Am 24.09.2018, werden in der Zeit zwischen 21:00 Uhr und 09:00 Uhr des folgenden Tages Wartungsarbeiten am Server durchgeführt. Daher wird die Webseite in dieser Zeit nur eingeschränkt erreichbar sein.
  • Hallo Forum,
    folgendes Problem: Ich lasse über ein PHP-Script (via Mailserver/SMTP) HTML-Mails an eines meiner Mailkonten versenden. Rufe ich dieses Konto mit IMAP ab, sieht die Mail einwandfrei aus. Rufe ich jedoch die selbe Mail von dem selben Konto mit POP3 ab, ist die Mail leer bzw es wird nichts angezeigt.
    Ich bin ratlos. Hat Jemand eine Erklärung oder einen Hinweis warum das so ist?


    Danke schon mal
    BJ


    _________________
    Thunderbird 3.1.1
    POP / IMAP
    Windows 7 64bit

  • Hallo BJ,


    und willkommen im Forum!
    Das erscheint mir genau so komisch wie dir ... .
    Wie sieht denn der Quelltext der via pop3 empfangenen Mail aus?
    Ist im pop3-Konto wirklich die Ansicht HTML eingestellt?
    Wie sendet dein PHP-Script? (pure HTML oder HTML + Text, in Verbindung mit vorheriger Frage zu sehen)


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Ich habe (nach stundenlager Suche natürlich) letztendlich eine Neuinstallation des TB ohne irgendwelche Add-ons zwei mal das Konto eingerichtet. Einmal mit Abruf via POP3 und einmal Abruf via IMAP. Das Ergebnis ist oben beschrieben. Da es gestern Nacht schon sehr spät war, konnte ich keinen Diff mehr über den Quelltext der empfangenen Mails mehr machen, das werde ich heute nachholen.
    Die Ansicht im POP3 Konto ist auf ORIGINAL HTML eingestellt, das passt also. In verschiedenen anderen Mailprogrammen (Outlook, Lotus, Webmail, sogar der Andoidmailer auf dem Handy) sieht die Mail in Ordnung aus, zwar hier und da mal ein kleiner Darstellungsfehler, aber durchaus noch okay.
    Ich würde mal behaupten, daß das Script pure HTML versendet, aber seht selbst:

  • Siehe meine PN.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • "bigjens" schrieb:

    Kann hier noch Jemand helfen?


    Hallo :)


    ja:

    "Peter_Lehmann" schrieb:

    Siehe meine PN.


    HTH
    Gruß Ingo

  • Dann will ich noch schnell darauf antworten, denn das was hinter den Kulissen ablief ist ja hier nicht zu sehen.


    Ich habe mir an eine Testadresse die per PHP-Script erzeugte Mail schicken lassen.
    Ergebnis: Weder im Textformat noch in der Klickibunti-Ansicht zeigt mein TB etwas an.


    Jetzt bin ich jemand, der sich nie ernsthaft mit html-Code (außer dem, was man für eine Primitiv-Webseite per Editor erstellt) und erst gar nicht für den Code einer Klickibunti-Mail interessiert hat. Also bin ich nicht derjenige, der dazu etwas verbindliches sagen könnte. Ich weiß nur, dass es für "html-Mails" keinen richtigen Standard gibt.


    Deshalb habe ich den TE angeregt, hier noch einmal nachzufragen. Wir haben doch garantiert Klickibunti-Experten im Forum, oder?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!