Wieder mal:"ß"-Darstellung

  • Hallo,


    ich habe mittels der Suche etliche Posts durchsucht, aber keine endgültige Lösung gefunden.
    Heute habe ich meinen Widerspruch bei Google-Streetview eingereicht und die Bestätigungsmail erhalten. Darin waren die "ß"-Zeichen wie in "Straße" folgendermaßen dargestellt: "Straße" (also "ß" für "ß"). Ich habe ISO 8859-15 eingestellt, aber es sind auch ISO 8859-1 und Unicode UTF-8 sowie natürlich "Automatisch bestimmen/Universell" vorhanden. Mit den erstgenannten zwei Codes ändert sich nichts, mit dem Unicode werden auch noch die Umlaute falsch dargestellt. Merkwürdiger Weise erscheint die Mail in meinem zweiten Mailprogramm "Mail" richtig, aber TB ist das bevorzugte Programm. In TB steht:

    Content-Type: multipart/alternative; boundary=001636e0b38214b68f048e053ea9


    Alle anderen Mails kommen richtig kodiert an.
    Wo kann ich noch nachschauen bzw. etwas ändern?


    Grüße
    raiSCH

  • Hallo,

    Zitat

    Ich habe ISO 8859-15 eingestellt, aber es sind auch ISO 8859-1 und Unicode UTF-8 sowie natürlich "Automatisch bestimmen/Universell" vorhanden


    Wo hast du das eingestellt?
    Deine Erläuterung lässt vermuten, dass du das unter Ansicht, Zeichenkodierung eingestellt hast.
    Das ist aber keine Einstellung (steht ja unter "Ansicht") sondern nur die Anzeige der gerade (nur) für diese Mail eingestellte Deklarierung, die man im Quelltext (strg+U) erkennen kann. Sie kann bei jeder Mail anders sein.
    Lies mal bitte diesen Thread und die Antwort von allblue:
    Schriftgröße
    Hier geht es zwar um die Schriftgröße, diese hat aber in diesem Fall auch etwa mit der Zeichenkodierung zu tun.


    Außerdem:
    überprüfe in der erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten"), ob der Eintrag mailnews.force_charset_override auch wirklich auf "false" steht, das sollte er unbedingt.
    Danach alle Ordner mit Rechtsklick auf diese --> Eigenschaften--> Allgemein überprüfen, ob dort ein Haken gesetzt ist. Falls ja, bitte entfernen.
    Klappt es jetzt?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    ich meinte mit "Einstellung" beides - meine Einstellungen oben in der Menüzeile in "Ansicht" und in "TB/Einstellungen/Ansicht/Erweitert". Hier ist "ISO 8859-15" für "Westlich" wie für "Andere Sprachen" eingestellt. Im Profilordner steht der entsprechende Eintrag unverändert auf "false". Bei den Ordnern ist unter "Eigenschaften/Allgemein/Standard..zuweisen" (das ist wohl gemeint) kein Haken gesetzt, und ISO 8859-15 ist angezeigt.


    Die entsprechende Mail bietet unverändert die kryptische Kodierung für das "ß", auch wenn ich mit "Ansicht" der Menüzeile die verschiedenen Kodierungen durchspiele. Wie gesagt, die anderen Mails sind alle richtig kodiert, und wenn früher mal eine Nachricht mit seltsamen Zeichen daherkam, konnte ich sie mit den drei angegebenen Kodierungen immer richtigstellen.


    OT - Noch etwas ist sehr merkwürdig: Die kurzzeitig auch in "Mails" von Mac erschienene Email ist dort jetzt verschwunden und steht nur noch in TB. Überhaupt erscheinen - wie gewünscht - die meisten Mails gleich in TB, aber manche auch noch (und meist zuerst) in "Mails". System habe ich noch keines dabei erkennen können, nur habe ich festgestellt, dass alle Mails meines Providers und viele Privatmitteilungen aus Foren (zuerst) auch dort erscheinen. Das ist zwar seltsam, aber es stört ja nicht weiter - Ende OT


    Viele Grüße
    raiSCH

  • Die vorgeschlagene Überprüfung hast du durchgeführt?
    Wenn eine Mail falsch deklariert ist (Quelltext (strg+U) also einen anderen oder gar keinen Zeichensatz deklariert, als er geschrieben wurde, muss TB passen.
    Welcher content-type steht dort?
    Etwa so o.ä.:
    Content-Type: text/plain; charset="utf-8"
    Content-Transfer-Encoding: 8bit


    Stimmt der dort angegebene Zeichensatz mit dem in TB unter Ansicht überein?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    ich weiß nicht genau, auf welche Angaben Du Dich beziehst; ich kopiere sie mal hierher:


    1. Content-Type: text/plain; charset=ISO-8859-1; format=flowed; delsp=yes
    Content-Transfer-Encoding: base64
    (Es folgt eine kryptscher langer Text)


    2. Content-Type: text/html; charset=ISO-8859-1
    Content-Transfer-Encoding: quoted-printable
    (Es folgt der Text der Email in einigermaßen lesbarer Form)


    Wie schon erwähnt, ist das "ß" auch bei Kodierung ISO 8859-1 in der "Ansicht" nicht richtig aufgelöst (kein Unterschied zu 8859-15). Warum das so ist, vermag ich nicht zu sagen.


    Gruß
    raiSCH

  • Ich meinte Folgendes:
    steht im Quelltext charset=ISO-8859-1, ist unter "Ansicht" der gleiche Zeichensatz oder ein anderer angehakt?


    Weiterhin schrieb ich:

    Zitat

    überprüfe in der erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten"), ob der Eintrag mailnews.force_charset_override auch wirklich auf "false" steht, das sollte er unbedingt.
    Danach alle Ordner mit Rechtsklick auf diese --> Eigenschaften--> Allgemein überprüfen, ob dort ein Haken gesetzt ist. Falls ja, bitte entfernen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    ich kann auf alle Fragen nur mit "ja" antworten. Die Ergebnisse stehen in meinem vorigen Post.


    Gruß raiSCH

  • Hast du mal versucht, bei dieser Mail unter Ansicht "UTF-8" einzustellen?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    wie ich ganz oben schon bemerkte, habe ich alle sinnvollen Varianten, die unter "Ansicht" stehen, durchprobiert - es ändert an der ß-Darstellung nichts. Bei Unicode UTF-8 werden zusätzlich alle Umlaute mit schwarz unterlegten Fragezeichen wiedergegeben!
    Mir ist schleierhaft, wie Google das kodiert hat (es handelt sich um das von Google bereitgestellte und von mir ausgefüllte Formular), und, wie gesagt, die sonstigen Mails erscheinen völlig korrekt.

    Einmal editiert, zuletzt von raiSCH ()

  • P. S.
    Ich hatte geschrieben, dass die Nachricht auch in "Mail" aufgetaucht, aber dann verschwunden ist. Ich habe sie (aus TB!) auch schon in einen anderen, externen Ordner abgespeichert, was ich vergessen hatte. Dort erscheint alles in der Kodierung von "Mail" (ich arbeitet ja mit einem Mac) und in richtiger Auflösung von "ß". Ich werde mal nachsehen, wie dort die Codierung eingestellt ist.


    P. S.2. in "Mail" ist "Automatisch" eingestellt (also erkennt das Programm wohl selbst die Codierung).

  • Du arbeitest mit verschiedenen Ordnereinstellungen?
    Warum?
    Der Standardzeichensatz sollte nie erzwungen werden, sonst raubst du TB die automatischen Erkennung der Zeichenkodierungen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    Zitat von "mrb"

    Du arbeitest mit verschiedenen Ordnereinstellungen?
    Warum?


    Das ist vielleicht ein Missverständnis: Ich habe die Mail "extern" gespeichert, weil sie ja juristisch relevant ist und ich verhindern möchte, dass sie bei einem Problem mit TB (wie beim Upgrade von TB 2 auf TB 3 schon einmal geschehen) verschwindet oder zumindest eine Zeitlang schwer greifbar ist; außerdem lege ich wichtige Mailinhalte dort ab, wo sie thematisch hingehören.

    Zitat von "mrb"

    Der Standardzeichensatz sollte nie erzwungen werden, sonst raubst du TB die automatischen Erkennung der Zeichenkodierungen.
    Gruß


    Den Satz verstehe ich nicht - wo habe ich was bei TB erzwungen, wenn ich in einem anderen Programm etwas einstelle?


    Gruß raiSCH

  • Hallo,
    dann hatte ich wohl deinen Satz

    Zitat

    P. S.2. in "Mail" ist "Automatisch" eingestellt (also erkennt das Programm wohl selbst die Codierung).


    missverstanden.
    Ich meinte: wenn du in TB in den Ordnereigenschaften/Allgemein, ganz unten bei "Standard allen Nachrichten zuweisen" einen Haken machst, TB nicht mehr den originalen Zeichensatz automatisch anzeigt.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    dann sind jetzt ja wohl alle Missverständnisse ausgeräumt, die Codierungsfrage ist aber nicht gelöst.
    Ich habe zwar die Mail richtig aufgelöst gespeichert, aber ich weiß nicht, mit welchem Zeichensatz das geschehen ist. Wie ich oben erwähnt habe, ist das eine Antwortmail auf die Formularausfüllung meinerseits, und dazwischen muss der Fehler aufgetreten sein. Mir ist auch aufgefallen, dass nur in den von mir ausgefüllten Teilen die merkwürdige ß-Codierung erscheint, während im normalen Bestätigungstext von Google das ß als ? (also vielleicht auch nur versehentliche Benutzung der Shift-Taste) auftaucht.
    Wenn die Sache nur auf diesen Fall beschränkt bleibt, dann man das ja auf sich beruhen lassen.


    Beste Grüße
    raiSCH

  • Hallo raisch,
    ich komme deswegen mit dem Problem nicht ganz zurecht, weil das "ß" alleine und alle Umlaute klappen, mir noch nie vorgekommen ist. Ob ISO-8955-1 oder -15 oder UTF-8, alle beinhalten es.
    Bei Google gab es mal ein Problem, weil es nur mit der Kodierung "quoted printable" umgehen konnte, nicht aber mit unkodierten Zeichensätzen (8bit).
    Dort aber waren auch Umlaute betroffen nicht nur das "ß".


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    ja, diesen isolierten Fehler (nur ß, und noch dazu nur in der Bestätigung des Formulareintrags - da aber leider gehäuft) finde ich auch sehr seltsam. Gibt es irgendein Konvertierungsprogramm o. ä., in dem man den falschen Zeichensatz ß für das ß eingeben kann und dann die Art der Konvertierung erfährt? Es ist Gott sei Dank ja kein dominierender Fehler, nur eben sehr ungewöhnlich.


    Gruß raiSCH